Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 02 Sep 2014, 23:25
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
Midnight Sun Pup 002 with 2.6.35.7 and 003 with 2.6.38.4
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 11 of 12 [168 Posts]   Goto page: Previous 1, 2, 3, ..., 9, 10, 11, 12 Next
Author Message
smokey01


Joined: 30 Dec 2006
Posts: 1806
Location: South Australia

PostPosted: Tue 26 Jul 2011, 16:47    Post subject:  

pemasu wrote:
Kernel source sfs for MNS 003 and Remix : http://www.smokey01.com/pemasu/Kernel_sources/kernel_src-2.6.38.4-lupe25.sfs

Sorry Smokey01. I have forgotten to make a link to the first page. Now it is done.
Once compiled there is unfortunately whole framework of other libs. I dont know good way to chase them. Best way I know is to download existing recent Nvidia pet and look what files and folders are inside. Then after installing the new Nvidia package you need to replace the stuff from your installment inside your puppy folders.

For ATI, I can compile the package inside ATI folder and get all the stuff neatly from the folder, but with Nvidia I cant do that. Nvidia fails at the beginning because I dont have Nvidia graphics.


Thanks I will try lupe25.

Packaging might be more difficult than I imagined. Bugger.

_________________
Puppy Software <-> Distros <-> Puppy Linux Tips
Back to top
View user's profile Send private message Visit poster's website 
smokey01


Joined: 30 Dec 2006
Posts: 1806
Location: South Australia

PostPosted: Tue 26 Jul 2011, 16:55    Post subject:  

smokey01 wrote:
pemasu wrote:
Kernel source sfs for MNS 003 and Remix : http://www.smokey01.com/pemasu/Kernel_sources/kernel_src-2.6.38.4-lupe25.sfs

Sorry Smokey01. I have forgotten to make a link to the first page. Now it is done.
Once compiled there is unfortunately whole framework of other libs. I dont know good way to chase them. Best way I know is to download existing recent Nvidia pet and look what files and folders are inside. Then after installing the new Nvidia package you need to replace the stuff from your installment inside your puppy folders.

For ATI, I can compile the package inside ATI folder and get all the stuff neatly from the folder, but with Nvidia I cant do that. Nvidia fails at the beginning because I dont have Nvidia graphics.


Thanks I will try lupe25.

Packaging might be more difficult than I imagined. Bugger.


Ok that worked fine. Now I need to try and work out what files to package.

BTW Skype video works now with this video driver. I'm not sure why it doesn't work with the vesa/default driver but I have experienced the same problems before.

Wed 27 Jul 2011 Operating System: Midnight Sun Pup-003 Linux 2.6.38
0.0 VGA compatible controller: nVidia Corporation GT216 [GeForce GT 220] (rev a2)
oem: NVIDIA product: GT216 Board - 0682vb02 Chip Rev

X Server: Xorg Driver: vesa
X.Org version: 1.7.6
dimensions: 1280x1024 pixels (382x313 millimeters)
depth of root window: 24 planes

direct rendering: Yes
server glx vendor string: NVIDIA Corporation
server glx version string: 1.4
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce GT 220/PCI/SSE2
OpenGL version string: 3.3.0 NVIDIA 270.41.06

Intel(R) Core(TM)2 Quad CPU Q9400
Core 0: 2665 1: 2665 2: 2665 3: 2665 MHz

...the above also recorded at '/tmp/root/report-video-glx'.


Thanks

_________________
Puppy Software <-> Distros <-> Puppy Linux Tips
Back to top
View user's profile Send private message Visit poster's website 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Tue 26 Jul 2011, 17:47    Post subject:  

Smokey01. Great that it worked. About that skype. I tested it also and I got video just fine, so I knew there wasnt anything generic problems. But Skype is difficult with video. Different webcams needs different things and also different initiations to work with skype so I didnt bother to post about my success.

By the way. You seem to have still xorg vesa driver. If there is nouveau.ko you need to delete it before nvidia drivers load correctly. Nouveau.ko reserves nvidia xorg driver otherwise.
Back to top
View user's profile Send private message 
live

Joined: 10 Feb 2010
Posts: 155

PostPosted: Wed 27 Jul 2011, 23:32    Post subject:  

Bug with

midnightsunpup-003.iso & midnightsunpup-002.iso

Working fine with Luci266 & Slacko 311.37

Details http://forums.partedmagic.com/viewtopic.php?f=3&t=1649
Back to top
View user's profile Send private message 
smokey01


Joined: 30 Dec 2006
Posts: 1806
Location: South Australia

PostPosted: Fri 29 Jul 2011, 04:58    Post subject:  

smokey01 wrote:
pemasu

BTW I still haven't got printing to work


I worked out the problem with printing. I had the samsung_unified-2.5.3.pet merged into a larger .sfs file along with a number of other pets.

As soon as I unmounted the large .sfs file and installed the samsung pet and configured printing it all worked as expected. It looks like some printing files don't work when inside a .sfs file.

_________________
Puppy Software <-> Distros <-> Puppy Linux Tips
Back to top
View user's profile Send private message Visit poster's website 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Fri 29 Jul 2011, 05:12    Post subject:  

Smokey01. Good news that you got printing working. Yes, printing and cups problems are not new. Installing browser from deb leads easily to non printing situation. Creating pet of that deb can lead success with printing.
Back to top
View user's profile Send private message 
Colonel Panic


Joined: 16 Sep 2006
Posts: 1511

PostPosted: Wed 24 Aug 2011, 04:17    Post subject:  

Back using Midnight Sun again, I think it's good. Well stocked with an attractive desktop wallpaper and default theme. It's definitely my favourite lupu-based Pup anyway. Thanks for producing it.

Cheers,

CP .

_________________
Stone Pentium IV (2.4 GHz), 2 GB of RAM, 160 GB hard drive running Puppy Slacko 5.9.3, Puppy EmSee v2.1, Puppy 4.31 Workhorse, Puppy Carolina 1.2, Puppy Legacy OS2 LTS and Puppy Upup Raring 3.9.9.2.
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Wed 24 Aug 2011, 11:50    Post subject:  

Thank you of the feedback. Yes, the wallpaper was taken at the beginning of my summer vacation. I rowed further to the lake and took many pics from the sundown. I was really pleased with that pic. And it was great start of the vacation.
Back to top
View user's profile Send private message 
smokey01


Joined: 30 Dec 2006
Posts: 1806
Location: South Australia

PostPosted: Thu 01 Sep 2011, 17:40    Post subject:  

pemasu I have just discovered something unusual and unwanted.

I just tried to backup a 2G SD card with photos direct to a DVD +R with Pburn 3.3.4.

The process seem to work fine but at the final stage of closing the disk the computer locked up solid.

The DVD is readable and all photos appears to have copied ok but I had to power down.

I though this was a bit unusual so I tried it a second time with exactly the same result.

Any ideas?

_________________
Puppy Software <-> Distros <-> Puppy Linux Tips
Back to top
View user's profile Send private message Visit poster's website 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Thu 01 Sep 2011, 18:03    Post subject:  

I believe MNS-002 misses the needed close app for dvd`s. Without it finalizing aka closing the dvd fails.

http://distro.ibiblio.org/quirky/pet_packages-common/close-dvd+rwtools-1.pet

Also, there is something else about Pburn here:
http://www.murga-linux.com/puppy/viewtopic.php?p=559554#559554
Back to top
View user's profile Send private message 
smokey01


Joined: 30 Dec 2006
Posts: 1806
Location: South Australia

PostPosted: Thu 01 Sep 2011, 18:30    Post subject:  

pemasu wrote:
I believe MNS-002 misses the needed close app for dvd`s. Without it finalizing aka closing the dvd fails.

Sorry mate I should have mentioned I'm using 003. I guess it has the same problem.

http://distro.ibiblio.org/quirky/pet_packages-common/close-dvd+rwtools-1.pet

Will this fix 003 too?

Also, there is something else about Pburn here:
http://www.murga-linux.com/puppy/viewtopic.php?p=559554#559554


Yes, just noticed that.

Thanks

_________________
Puppy Software <-> Distros <-> Puppy Linux Tips
Back to top
View user's profile Send private message Visit poster's website 
Colonel Panic


Joined: 16 Sep 2006
Posts: 1511

PostPosted: Fri 09 Sep 2011, 04:16    Post subject:  

Sorry, had to give up using Midnight. Firefox was grinding the hard drive for some reason (maybe it was running out of RAM and not picking up the swap).

I'd rather tell you than drift onto another Puppy without you knowing. I tend to hop around between Puppies quite a lot anyway (mainly because I love Puppy, the isos are small and CD-Rs are still cheap).

I've still got the Midnight CD-R if you want me to run any tests to figure out what's going wrong. It might just be my old machine; it wouldn't be the first time (I've had the same problem with Lighthouse 3.01 in the past).

Best,

CP .

_________________
Stone Pentium IV (2.4 GHz), 2 GB of RAM, 160 GB hard drive running Puppy Slacko 5.9.3, Puppy EmSee v2.1, Puppy 4.31 Workhorse, Puppy Carolina 1.2, Puppy Legacy OS2 LTS and Puppy Upup Raring 3.9.9.2.

Last edited by Colonel Panic on Fri 23 Sep 2011, 09:51; edited 1 time in total
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Fri 09 Sep 2011, 05:28    Post subject:  

Colonel Panic. Well, next Midnight Sun will be the product of newest woof and many stuff will be updated. Firefox will be the latest, Flashplayer will be newest and so on....

Every release is build of versions available at that time.

I think that debugging is not very useful...if you dont know anything spesific reason of some failure.
Of course xerrs.log might record spesific reasons but it has a lot info of normal behavior. So...it is sometimes like tracking needle from hay stack.
Also kernel 2.6.38.4 time is over now. I will use 2.6.39.3 now or newer in the future.

Dont use your time too much with debugging.

I havent forgotten Midnight Sun altogether. I just dont have time to support all my releases all the time.
Back to top
View user's profile Send private message 
smokey01


Joined: 30 Dec 2006
Posts: 1806
Location: South Australia

PostPosted: Sat 17 Sep 2011, 03:15    Post subject:  

Huston we have a problem.

When I started MidnightSunPup-003 this morning, X would not load. I tried XorgWizard a number of times using different video drivers to no avail.

This has been working well since it's release. The only thing I have changed is adding the DevX file with sfs_on_the_fly. I was doing a bit of coding and compiling, nothing startling and it was working fine.

Is there a known bug in this distro with sfs_on_the_fly?

What is the best way to delete the video information and have Xorgwizard start fresh, or is there a better way.

_________________
Puppy Software <-> Distros <-> Puppy Linux Tips
Back to top
View user's profile Send private message Visit poster's website 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Sat 17 Sep 2011, 03:37    Post subject:  

Smokey. Sorry to hear that you have problem with MNS. There should not be problem with sfs on the fly, I think I have used recent enough version with it.
I am sure I tested devx sfs loading on the fly, since I compile all the time.

To debug the problem. Only way is to start check log files. Xerrs.log is probably first to check what problems it logs. Use the method which is familiar for you in console state. There are several console text editors or just in console cat /tmp/xerrs.log or cat /tmp/xerrs.log | less
You need to try to start X of course first.

You might find errors of loading something or something other relevant....
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 11 of 12 [168 Posts]   Goto page: Previous 1, 2, 3, ..., 9, 10, 11, 12 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0858s ][ Queries: 12 (0.0062s) ][ GZIP on ]