Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 03 Aug 2015, 04:39
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Business
Money Manager Ex
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [15 Posts]  
Author Message
maximand

Joined: 27 Jun 2011
Posts: 8

PostPosted: Mon 27 Jun 2011, 11:11    Post subject:  Money Manager Ex
Subject description: Personal Finance Manager
 

Hi Everyone,

Please try new puppy package of Money Manager Ex
(http://sourceforge.net/projects/moneymanagerex/)

.pet package here:
http://www.mediafire.com/?49zqdmq85mg5vqp
libs if needed:
http://www.mediafire.com/?u48a47su4p83qco
Back to top
View user's profile Send private message 
maximand

Joined: 27 Jun 2011
Posts: 8

PostPosted: Mon 27 Jun 2011, 14:10    Post subject:  

Now on the project page:

http://sourceforge.net/projects/moneymanagerex/files/moneymanagerex/Development%20%28Unstable%29/
Back to top
View user's profile Send private message 
balaji.md

Joined: 15 Jun 2011
Posts: 29
Location: Australia

PostPosted: Thu 07 Jul 2011, 06:43    Post subject: Works well!  

Far quicker than Kmymoney. Much less confusion than gnucash. More intuitive than homebank.
Back to top
View user's profile Send private message 
balaji.md

Joined: 15 Jun 2011
Posts: 29
Location: Australia

PostPosted: Thu 07 Jul 2011, 23:35    Post subject: Issues  

It starts up with an error message (cannot set local=en-gb) but seems to work fine if that message is disregarded. I don't find an .rc file to edit.

Also, getting quotes from Australian stock exchange is not configured by default. I couldn't configure it manually either.

Thirdly, it would be nice if it shows current currency prices in a window (I realize that it gets rates from ECB but it doesn't show it up explicitly).
Back to top
View user's profile Send private message 
maximand

Joined: 27 Jun 2011
Posts: 8

PostPosted: Sat 09 Jul 2011, 16:58    Post subject: Re: Issues  

balaji.md wrote:


Also, getting quotes from Australian stock exchange is not configured by default. I couldn't configure it manually either.

try some suffix for your shares. Example for my shares are: AFLT.ME, SBER03.ME ...
balaji.md wrote:

Thirdly, it would be nice if it shows current currency prices in a window (I realize that it gets rates from ECB but it doesn't show it up explicitly).

To see exchange rates just create any account and past something to it. You will see result on homepage

Additionaly you can use Custom SQL report like this:
http://www.codelathe.com/forum/viewtopic.php?f=12&t=36&start=0

PS any suggetions and bugs please here: http://sourceforge.net/tracker/?group_id=163169&atid=826678
http://sourceforge.net/tracker/?group_id=163169&atid=826675
http://www.codelathe.com/forum/[/url]
Back to top
View user's profile Send private message 
balaji.md

Joined: 15 Jun 2011
Posts: 29
Location: Australia

PostPosted: Wed 13 Jul 2011, 06:17    Post subject: It's not getting it!  

Tried the suffixes (.ax) but not working for ASX. The exchange rate shows up if I add a test account with a different currency. Also, please tell me how to get rid of the "cannot set locale=en-gb" message at startup!
Back to top
View user's profile Send private message 
maximand

Joined: 27 Jun 2011
Posts: 8

PostPosted: Wed 13 Jul 2011, 13:23    Post subject: Re: It's not getting it!  

balaji.md wrote:
Tried the suffixes (.ax) but not working for ASX.


Why? http://finance.yahoo.com/echarts?s=ASX.AX

balaji.md wrote:
Also, please tell me how to get rid of the "cannot set locale=en-gb" message at startup!

I don't know but I think that if you add this locale to your system it should help.
Back to top
View user's profile Send private message 
maximand

Joined: 27 Jun 2011
Posts: 8

PostPosted: Thu 21 Jul 2011, 00:40    Post subject: Re: It's not getting it!  

maximand wrote:
balaji.md wrote:
Tried the suffixes (.ax) but not working for ASX.


Why? http://finance.yahoo.com/echarts?s=ASX.AX

balaji.md wrote:
Also, please tell me how to get rid of the "cannot set locale=en-gb" message at startup!

I don't know but I think that if you add this locale to your system it should help.


How to fix issue with en_GB locale:
http://www.codelathe.com/forum/viewtopic.php?f=5&t=1305

Try next:
#locale-gen
or
#chooselocale
Back to top
View user's profile Send private message 
maximand

Joined: 27 Jun 2011
Posts: 8

PostPosted: Tue 02 Aug 2011, 09:06    Post subject: Money Manager Ex  

New release already available.

http://www.codelathe.com/forum/viewtopic.php?f=3&t=1312&p=3587#p3587
Back to top
View user's profile Send private message 
maximand

Joined: 27 Jun 2011
Posts: 8

PostPosted: Sat 19 May 2012, 12:22    Post subject: MMEX 0.9.9.0
Subject description: MMEX 0.9.9.0 General Release
 

I am happy to announce that the release version of MMEX 0.9.9.0 is now available for general download.

To install the latest version, download the appropriate version for your system from the following sites:
Codelathe.com: http://www.codelathe.com/mmex/
Sourceforge.net: https://sourceforge.net/projects/moneymanagerex/files/moneymanagerex/Version%200.9.9.0/
Back to top
View user's profile Send private message 
hamoudoudou


Joined: 24 Jul 2014
Posts: 33
Location: rabat

PostPosted: Tue 28 Jul 2015, 22:02    Post subject: pet not found  

pet not found. PPM offers Kmymoney and homebank
Debian package here
Kmymoney.jpg
 Description   searching further...
 Filesize   55.35 KB
 Viewed   68 Time(s)

Kmymoney.jpg

Back to top
View user's profile Send private message 
Puppyt

Joined: 09 May 2008
Posts: 586
Location: Gatton, Queensland

PostPosted: Wed 29 Jul 2015, 02:21    Post subject:  

Hi hamoudoudou,
perhaps you might like to bump this into a REQUEST? I've been coping with MMEx's little quirks in v0.9.9 so was keen to try the v 1.1.0 dep you posted a link to. I'm using pemasu's Upup Precise 3.8.3. Unfortunately I had these dependencies called:
Code:
File /usr/bin/mmex has these missing library files:
 libwx_gtk2u_unofficial_aui-3.0.so.0
 libwx_gtk2u_unofficial_stc-3.0.so.0
 libwx_gtk2u_unofficial_webview-3.0.so.0
 ibwx_gtk2u_unofficial_html-3.0.so.0
 libwx_gtk2u_unofficial_qa-3.0.so.0
 libwx_gtk2u_unofficial_adv-3.0.so.0
 libwx_gtk2u_unofficial_core-3.0.so.0
 libwx_baseu_unofficial_net-3.0.so.0
 libwx_baseu_unofficial-3.0.so.0

And this from terminal:
Code:
# mmex
mmex: error while loading shared libraries: libwx_gtk2u_unofficial_aui-3.0.so.0: cannot open shared object file: No such file or directory

I don't know where to head to update my base to run the updated deb properly - I thought this might be a start http://www.murga-linux.com/puppy/viewtopic.php?t=95746 but I also see mention of SQLite, Lua functions also required... it would be great to see a pet made available - particularly as version 1.2.1 which is currently only avail in tar.gz for the non-commercial operating systems http://sourceforge.net/projects/moneymanagerex/files/moneymanagerex/Version_1.2.1/

EDIT: http://murga-linux.com/puppy/viewtopic.php?p=807277#807277 describes a similar attempt to get an earlier version going in FatDog. I don't know the outcome. Seems like a job for an expert in compiling Sad

UPDATE: Still trying to get it all working. Unofficial deb packages tracked down to here http://repos.codelite.org/wx3.0.2/ubuntu/pool/universe/w/wxwidgets3.0/

_________________
Toowoomba Linux Community
http://groups.google.com/group/toowoombalinux
Back to top
View user's profile Send private message Visit poster's website 
Puppyt

Joined: 09 May 2008
Posts: 586
Location: Gatton, Queensland

PostPosted: Wed 29 Jul 2015, 17:13    Post subject:
Subject description: Money Manager Ex MMEx v 1.2.1 plus dependencies
 

OK so I have v1.2.1 up and running, it retrieved my v0.9.9 files and imported new QIF files without any problems whatsoever. Still to correct the startup "'locale en_GB' cannot be set" error message but there's a workaround on the Money Manager Ex forums for that, I've always just ignored it previously.
My steps were:
Uninstall the previous MMEx deb (making sure I had backed up my working mmex directory);
Install libwxbase3.0-0-unofficial_3.0.0 (link above);
Install libwxgtk3.0-0-unofficial_3.0.0;
Install the mmex_1.1.0_i386 deb (in my pemasu Upup Precise 3.8.3); and,
Test from console "mmex" recieved a libwebkitgtk-1.0 error, so-
Updated my Precise PPM to
Install libwebkitgtk-1.0-common_1.8.3, with dependencies:
libgeoclue0_0.12.0; and,
libjavascriptcoregtk-1.0-0_1.8.3.
I think I tried to run it again from console at this point, and got another error that was solved by installing libwebkitgtk-1.0-0_1.8.3 (dunno why the 'common' libs installed above didn't cover it) . Bam! Up and running, both from console and startmenu entry, and resuming with the 'new' GUI which I haven't played with much. Looking forward to it. VERY handy software, makes tracking my expenditures almost fun Smile... (interestingly, the Tahrpup PPM I think was seeing the libwx* files that were needed, rather than via the MMEx support forums as Upup Precise didn't - but I haven't tried to complete an install in Tahrpup yet)

_________________
Toowoomba Linux Community
http://groups.google.com/group/toowoombalinux
Back to top
View user's profile Send private message Visit poster's website 
hamoudoudou


Joined: 24 Jul 2014
Posts: 33
Location: rabat

PostPosted: Thu 30 Jul 2015, 05:39    Post subject: Well !  

Very kind of you for the answer. I will do my best for success. I come back for progress in my installation. Thanks a lot
Back to top
View user's profile Send private message 
Puppyt

Joined: 09 May 2008
Posts: 586
Location: Gatton, Queensland

PostPosted: Thu 30 Jul 2015, 07:48    Post subject:  

Sure thing hamoudoudou - no problem. I made an error earlier though - I'm using v1.1.0 not 1.2.0, the later versions must be release candidates at this stage as the "check for updates" dialogue inside MMEx says 1.1.0 is the latest.
_________________
Toowoomba Linux Community
http://groups.google.com/group/toowoombalinux
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 1 of 1 [15 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Business
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0567s ][ Queries: 12 (0.0069s) ][ GZIP on ]