Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 01 Sep 2014, 20:05
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » System
Ymount 002
Post new topic   Reply to topic View previous topic :: View next topic
Page 4 of 7 [102 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6, 7 Next
Author Message
L18L

Joined: 19 Jun 2010
Posts: 2505
Location: Burghaslach, Germany somewhere also known as "Hosla"

PostPosted: Wed 10 Aug 2011, 14:20    Post subject: ymount
Subject description: hopefully last version before 1.0
 

Here is version 0.9

bugfixes
comeback of preferences
language switcher

Requires rox and yad

yad should run on all recent puppies (5xxx)
seaside wrote:
Here's a link for yad compiled for pup431
http://murga-linux.com/puppy/viewtopic.php?mode=attach&id=38895
in case anyone would like it.

Cheers,
s

Thanks seaside Smile


Edited 2011-09-11
Link to latest version provided always here:
http://www.murga-linux.com/puppy/viewtopic.php?p=557739
ymount-0.9.png
 Description   mount or unmount multiple partitions
 Filesize   29.01 KB
 Viewed   1089 Time(s)

ymount-0.9.png

ymount-0.9.pet
Description  mount or unmount multiple partitions
requires rox and yad
pet

 Download 
Filename  ymount-0.9.pet 
Filesize  13.05 KB 
Downloaded  361 Time(s) 

Last edited by L18L on Sun 11 Sep 2011, 09:09; edited 1 time in total
Back to top
View user's profile Send private message 
stu90


Joined: 25 Feb 2010
Posts: 1401
Location: England. Dell Inspiron 1501. Dpup

PostPosted: Sun 14 Aug 2011, 06:38    Post subject:  

Thanks for the 0.9 update L18L Smile
Back to top
View user's profile Send private message 
rodin.s

Joined: 22 Sep 2010
Posts: 338
Location: Ukraine

PostPosted: Fri 19 Aug 2011, 15:59    Post subject: Russian l10n  

I've translated pot-file into Russian. But is there a possibility to make yad buttons localized?
And the language name is Русский not Русские as it says in language select.
l10n_ru.tar.gz
Description  Russian l10n
gz

 Download 
Filename  l10n_ru.tar.gz 
Filesize  3.52 KB 
Downloaded  318 Time(s) 
Back to top
View user's profile Send private message 
Iguleder


Joined: 11 Aug 2009
Posts: 1889
Location: Israel, somewhere in the beautiful desert

PostPosted: Fri 19 Aug 2011, 16:04    Post subject:  

Wow, Pmount definitely should be kicked out in favor of Ymount Very Happy

Great work, L18L! I think it could be nice if I had a quick solution for partition mounting under Window Maker ... I'm seriously considering to learn how to write dockapps and make some dockapp that works with Ymount Smile

_________________
My homepage
Back to top
View user's profile Send private message Visit poster's website MSN Messenger 
ICQ Number 
Bert


Joined: 30 Jun 2006
Posts: 927

PostPosted: Fri 19 Aug 2011, 16:13    Post subject:  

Thanks for your translation rodin s.!

I believe L18L is actively looking into the problem.
It could even be not yad related... (?)

One question, does the Ukrainian locale work as it should?

Yes, L18L likes to add an "e" to the language name Wink
(in my Dutch case "Nederlands" becomes "Nederlandse" ...)

People like you and L18L give me the energy needed to keep believing one day Puppy will be globally understood. Cool

_________________



Last edited by Bert on Fri 19 Aug 2011, 16:29; edited 1 time in total
Back to top
View user's profile Send private message 
Bert


Joined: 30 Jun 2006
Posts: 927

PostPosted: Fri 19 Aug 2011, 16:27    Post subject:  

Iguleder wrote:
Wow, Pmount definitely should be kicked out in favor of Ymount Very Happy

Great work, L18L! I think it could be nice if I had a quick solution for partition mounting under Window Maker ... I'm seriously considering to learn how to write dockapps and make some dockapp that works with Ymount Smile


It's all your fault Igu, you started it Laughing L18L just made it extremely useful, usable and fool proof. And I'm 100% sure about the latter Wink

_________________


Back to top
View user's profile Send private message 
rodin.s

Joined: 22 Sep 2010
Posts: 338
Location: Ukraine

PostPosted: Fri 19 Aug 2011, 16:50    Post subject: Ukrainian yad buttons  

Ukrainian is the same. No localization.
Back to top
View user's profile Send private message 
Bert


Joined: 30 Jun 2006
Posts: 927

PostPosted: Fri 19 Aug 2011, 17:12    Post subject: Re: Ukrainian yad buttons  

rodin.s wrote:
Ukrainian is the same. No localization.

Below is a screenshot of Ymount in Dutch.

In the bottom task bar "Language" is translated ( "Taal"), but nothing else.
Is it correct to say L18L's yad translation is working just fine, but not the Gtk buttons?
ymount-scrn.jpg
 Description   
 Filesize   42.58 KB
 Viewed   413 Time(s)

ymount-scrn.jpg


_________________


Back to top
View user's profile Send private message 
L18L

Joined: 19 Jun 2010
Posts: 2505
Location: Burghaslach, Germany somewhere also known as "Hosla"

PostPosted: Sat 20 Aug 2011, 07:31    Post subject: ymount
Subject description: translation of gtk buttons
 

Iguleder,
thank you for your comment but ymount did not succed international quality control yet Laughing

rodin.s and Bert,
thank you for reporting.
I have corrected the language names in /usr/l0cal/ymount/lang_list
Code:
ru Русский
nl Nederlands

and added
Code:
slv Slovio
for sc0ttmann Smile

Now the gtk button texts:

Have you yad-NLS installed?
Please do it and/or confirm.
Of course there is no reason why you should do it (there are no translations to ru or nl in it) but this is the only difference in our systems I can see now.

yad-NLS is containing German translation
I have got everything correctly in other languages on my system while yad-NLS is installed and if I uninstall yad-NLS the button texts are English.

I cannot confuse the yad developer by using the term NLS. pet so please confirm that you have installed yad-NLS.pet

Thank you
with-yad-NLS.png
 Description   Russian with yad-NLS installed
 Filesize   30.25 KB
 Viewed   998 Time(s)

with-yad-NLS.png

Back to top
View user's profile Send private message 
Bert


Joined: 30 Jun 2006
Posts: 927

PostPosted: Sat 20 Aug 2011, 08:10    Post subject:  

Hi L18L,

First off, thanks for all your efforts trying to help us!

I installed yad-NLS (from Barry's blog). It made no difference.

I then moved the german yad.mo to the nl-LC_Messages. Only "language" button becomes "Sprache"...

I then changed my locale settings to German. Still no luck..

The only difference I can see now is that you are running Wary and I (and maybe rodin.s too?) am using Lucid.

Could that be the reason?
Thanks!

_________________


Back to top
View user's profile Send private message 
L18L

Joined: 19 Jun 2010
Posts: 2505
Location: Burghaslach, Germany somewhere also known as "Hosla"

PostPosted: Sat 20 Aug 2011, 08:22    Post subject: ymount
Subject description: gtk button text
 

Bert wrote:
... I (and maybe rodin.s too?) am using Lucid.

So I will test it in Lupu525 now (I have lang_packs converted to sfs)
Thank you Bert. Smile

Now in lupu525 (not lupq)
No yad-NLS installed
working correct
-> yad-NLS is not required
---------------------------------
Edited 2011-08-29
Now in wary514
yad-NLS is required to show gtk button text localized
---------------------------------
Bert, rodin.s,
are you using lupq or lupu Question
ymount_without_yad-NLS.png
 Description   in lupu525
 Filesize   25.87 KB
 Viewed   955 Time(s)

ymount_without_yad-NLS.png


Last edited by L18L on Mon 29 Aug 2011, 15:14; edited 1 time in total
Back to top
View user's profile Send private message 
Bert


Joined: 30 Jun 2006
Posts: 927

PostPosted: Sat 20 Aug 2011, 12:52    Post subject:  

L18L, I'm using Lupu, in fact Three Headed Dog (5.2.9)

I just tested Ymount localization In Wary, with and without yad-NLS, with and without utf-8..
No luck Sad

_________________


Back to top
View user's profile Send private message 
Bert


Joined: 30 Jun 2006
Posts: 927

PostPosted: Sat 20 Aug 2011, 12:54    Post subject:  

Hi again L18L,

What's the gtk20.mo you are using, or rather where did you get it from?
Thanks

_________________


Back to top
View user's profile Send private message 
rodin.s

Joined: 22 Sep 2010
Posts: 338
Location: Ukraine

PostPosted: Sat 20 Aug 2011, 15:13    Post subject: yad_NLS  

I'm using Wary-5.1.3. And installation of yad_NLS-0.12.4-w5.pet from Barry's blog helped. On clean system it doesn't work but on localized one it does.
I have the same result as on the picture above.
I've noticed on another yad application - urxvtset that NLS-pet somehow allows localization. urxvtset calls gcolor2 and without yad_NLS pet installed it is in English but with it installed it's in Russian.
Back to top
View user's profile Send private message 
Bert


Joined: 30 Jun 2006
Posts: 927

PostPosted: Sat 20 Aug 2011, 15:51    Post subject: Re: yad_NLS  

rodin.s wrote:
I'm using Wary-5.1.3. And installation of yad_NLS-0.12.4-w5.pet from Barry's blog helped. On clean system it doesn't work but on localized one it does.
I have the same result as on the picture above.

Thanks for your testing rodin.s!

So, the plot thickens..L18L is able to get full localization, without the need of yad-NLS and in your testing adding yad-NLS helped to get full translation of the buttons.

Did you add anything to /usr/share/locale/ru/LC_MESSAGES that wasn't part of the pristine Wary-5.1.3?

Thank you! I'm sure we'll find the solution. (What a great forum this is Cool )

_________________


Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 4 of 7 [102 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6, 7 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » System
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0809s ][ Queries: 12 (0.0051s) ][ GZIP on ]