Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 22 May 2018, 18:02
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
How to disable filesystem check when frugal install boots?
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [11 Posts]  
Author Message
Blazerboy65

Joined: 16 Jun 2011
Posts: 5

PostPosted: Thu 16 Jun 2011, 15:19    Post subject:  How to disable filesystem check when frugal install boots?  

I have been running puppy linux for several months now. Currently, I am running a frugal install of Lucid Puppy 520 on my netbook. My one pet peeve is that puppy runs a "filesystem check" at every boot. This increases the bootup time by at least 20 seconds. Is there anyway at all to disable this filesystem check, or at least reduce its frequency?
Back to top
View user's profile Send private message 
Karl Godt


Joined: 20 Jun 2010
Posts: 4208
Location: Kiel,Germany

PostPosted: Thu 16 Jun 2011, 16:03    Post subject:  

look for a file "fsckme.[err|flg]" somewhere [ on top ] level of the host partition or save-file . Normally /etc/rc.d/rc.shutdown should delete it .
Back to top
View user's profile Send private message 
Blazerboy65

Joined: 16 Jun 2011
Posts: 5

PostPosted: Thu 16 Jun 2011, 16:11    Post subject:  

Karl Godt wrote:
look for a file "fsckme.[err|flg]" somewhere [ on top ] level of the host partition or save-file . Normally /etc/rc.d/rc.shutdown should delete it .


I checked both the partition I did the frugal install on and the save file, but I didn't find such a file.
Back to top
View user's profile Send private message 
rjbrewer


Joined: 22 Jan 2008
Posts: 4421
Location: merriam, kansas

PostPosted: Thu 16 Jun 2011, 16:23    Post subject:  

Does it say it's doing a "file system check",

or "searching for files"?

_________________

Inspiron 700m, Pent.M 1.6Ghz, 1Gb ram.
Msi Wind U100, N270 1.6>2.0Ghz, 1.5Gb ram.
Eeepc 8g 701, 900Mhz, 1Gb ram.
Full installs

Back to top
View user's profile Send private message 
Karl Godt


Joined: 20 Jun 2010
Posts: 4208
Location: Kiel,Germany

PostPosted: Thu 16 Jun 2011, 16:24    Post subject:  

this code is 3/4 year old for puppy511 /init inside initrd.gz :

Code:
#100318 fix any improper shutdowns... fsckme.err format: sda7,ext3,[/pupsave.2fs] (see rc.shutdown)
 FSCKME=""
 [ -f /mnt/data/fsckme.err ] && FSCKME="`cat /mnt/data/fsckme.err | tr ',' ' ' | tr '\n' ' '`"
 rm -f /mnt/data/fsckme.err
 umntfunc /mnt/data
 [ "$FSCKME" ] && fsckme_func $FSCKME
done

fsckme_func() { #passed params: partition filesystem [pupsavefile]
 case $2 in
  ext2|ext3|ext4)
   e2fsck -y -f /dev/$1 >/tmp/chkret &
   echo -e "\\033[1;35m" >/dev/console #35=purple
   if [ "${1}" = "loop1" ];then
    echo -n " 'save file' filesystem check, please wait..." >/dev/console
   else
    echo -n " '${1}' filesystem check, please wait..." >/dev/console
   fi
   usleep 200000 #100604 TazOC gave me idea that delay before pidof is good.
   while [ "`pidof e2fsck`" != "" ];do
    sleep 1
    echo -n "." >/dev/console
   done
   echo -en "\\033[0;39m" >/dev/console
  ;;
 esac
 if [ $3 ];then
  #rc.shutdown has created /fsckme.err with this 3rd parameter.
  #this is a pupsave file, which has a ext2/3/4 f.s (based on .2fs, .3fs, .4fs ext)
  #this flag will be set for any prior improper shutdown. if have lots of installations
  #of puppy on the pc, the flag may not even be for this install of puppy, however, this is
  #the simplest implementation...
  PFSCK="yes"
 fi
}


However , there is additional code for encrypted save files ....
Back to top
View user's profile Send private message 
Blazerboy65

Joined: 16 Jun 2011
Posts: 5

PostPosted: Fri 17 Jun 2011, 02:24    Post subject:  

rjbrewer wrote:
Does it say it's doing a "file system check",

or "searching for files"?


It says "filesystem check", is there a way do make it do this less frequently?
Back to top
View user's profile Send private message 
p310don

Joined: 19 May 2009
Posts: 1174
Location: Brisbane, Australia

PostPosted: Fri 17 Jun 2011, 02:58    Post subject:  

If it runs a filesystem check at every boot, it sounds like it has the pfix=fsck optioni in the kernel parameter line of your menu.lst file.

Do you have grub as your bootloader, or grub4dos, or something different.

It seems that grub4dos puts the fsck argument in by default. This isn't necessarily a bad thing, but, if you want a faster boot time, it will have to go.

Find your menu.lst file in the grub boot directory. Open it, it might look something like this

Code:
title Eee 511 (sda6/puppy436)
  find --set-root --ignore-floppies /puppy436/initrd.gz
  kernel /puppy436/vmlinuz  pmedia=atahd psubdir=puppy436 pfix=fsck
  initrd /puppy436/initrd.gz


Note the pfix=fsck at the end of the line starting with kernel?

If yours has that, delete it, and you won't have a filesystem check on boot anymore.

Hope that helps

Paul
Back to top
View user's profile Send private message 
rhadon


Joined: 27 Mar 2008
Posts: 1293
Location: Germany

PostPosted: Fri 17 Jun 2011, 05:59    Post subject:  

The main question:

is it a 'save file' filesystem check or a 'sda2' filesystem check (it's sda2 for me, for you it's probably another partition)?

As far as I know, pfix=fsck checks only the save file. My save file is mostly 512MB. This takes about 2-3 secs (if I use this option) on an old Celeron Notebook. So, how big is your save file?

Another thought, newer Puppies like Lupu 5.20 initiate a complete file system check every time if improper shutdown. It's maybe annoying but reasonable.

So, how do you shut down?

Rolf

_________________
Ich verwende "frugal", und das ist gut so. Wink
Raspberry Pi without Puppy? No, thanks.
Back to top
View user's profile Send private message 
Blazerboy65

Joined: 16 Jun 2011
Posts: 5

PostPosted: Fri 17 Jun 2011, 12:40    Post subject:  

p310don wrote:
If it runs a filesystem check at every boot, it sounds like it has the pfix=fsck optioni in the kernel parameter line of your menu.lst file.

Do you have grub as your bootloader, or grub4dos, or something different.

It seems that grub4dos puts the fsck argument in by default. This isn't necessarily a bad thing, but, if you want a faster boot time, it will have to go.

Find your menu.lst file in the grub boot directory. Open it, it might look something like this

Code:
title Eee 511 (sda6/puppy436)
  find --set-root --ignore-floppies /puppy436/initrd.gz
  kernel /puppy436/vmlinuz  pmedia=atahd psubdir=puppy436 pfix=fsck
  initrd /puppy436/initrd.gz


Note the pfix=fsck at the end of the line starting with kernel?

If yours has that, delete it, and you won't have a filesystem check on boot anymore.

Hope that helps

Paul


Thank you p31odon, I think that should solve my problem, as I am in fact running Grub4DOS.
@rhadon:
I am using a 3.6GB personal save file on my windows partition, and I always make sure to shutdown correctly. I am not familiar with other puppy users' save file sizes, but I suspect the size of mine has something to do with it.
Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 10426
Location: Charleston S.C. USA

PostPosted: Fri 17 Jun 2011, 16:36    Post subject:  

A good idea would be to make another entry, in the menu.lst, for booting Puppy.
Make this one where it boots and does a file system check.
With a save file that big you have more chance of corruption.
Just do a duplicate copy of the normal boot entry, but put pfix=fsck at the end of the kernel line.
Makes a good backup boot option, that will fix most problems caused by corruption of files.
The title line can be anything.
Back to top
View user's profile Send private message 
Blazerboy65

Joined: 16 Jun 2011
Posts: 5

PostPosted: Sat 18 Jun 2011, 14:34    Post subject:  

bigpup wrote:
A good idea would be to make another entry, in the menu.lst, for booting Puppy.
Make this one where it boots and does a file system check.
With a save file that big you have more chance of corruption.
Just do a duplicate copy of the normal boot entry, but put pfix=fsck at the end of the kernel line.
Makes a good backup boot option, that will fix most problems caused by corruption of files.
The title line can be anything.


Thanks for the tip, not having and fsck at every boot is working wonders! I would like to thank everybody for their prompt responses and great help. My problem has been solved!
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [11 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0477s ][ Queries: 11 (0.0063s) ][ GZIP on ]