Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 26 Nov 2014, 16:23
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » REQUESTS
SABnzbd+ Binary Newsgrabber [FILLED]
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
chrome307


Joined: 15 Jan 2009
Posts: 713

PostPosted: Fri 13 May 2011, 08:55    Post_subject:  SABnzbd+ Binary Newsgrabber [FILLED]  

This is what I'm after:

CherryPy-3.2 rev2138 with patches

Thanks in advance Smile

Edited_time_total
Back to top
View user's profile Send_private_message 
GustavoYz


Joined: 07 Jul 2010
Posts: 897
Location: .ar

PostPosted: Mon 23 May 2011, 02:35    Post_subject:  

http://www.murga-linux.com/puppy/viewtopic.php?p=400130&sid=430bf7d0d93fe43af9ae3adf5f3b6c02 ?
_________________

Back to top
View user's profile Send_private_message 
chrome307


Joined: 15 Jan 2009
Posts: 713

PostPosted: Thu 26 May 2011, 05:55    Post_subject:  

Thank you for your reply and answer Smile

Unfortunately it doesn't solve my problem, I am trying to compile SABnzbd+ from source and it specifies that above build is the dependency required. However I have looked at the CherryPy site, and cannot locate the above build.

Guess I'm stuck Embarassed
Back to top
View user's profile Send_private_message 
p310don

Joined: 19 May 2009
Posts: 733
Location: Brisbane, Australia

PostPosted: Thu 26 May 2011, 06:47    Post_subject:  

chrome307,

are you still using 4.31? i got sab working fairly easily. when i get home i'll check what i did and help you out
Back to top
View user's profile Send_private_message 
chrome307


Joined: 15 Jan 2009
Posts: 713

PostPosted: Thu 26 May 2011, 07:48    Post_subject:  

Thank you that would be great Smile
Back to top
View user's profile Send_private_message 
p310don

Joined: 19 May 2009
Posts: 733
Location: Brisbane, Australia

PostPosted: Thu 26 May 2011, 09:11    Post_subject:  

Ok, this is what I did. I will start to mention that I did this in 5.2, not 4.31. I did try in 4.31 but got interrupted and didn't retry.

First thing, I downloaded and installed the devx for puppy.

4.31 here http://mirror.internode.on.net/pub/puppylinux/puppy-4.3.1/

5.2 here http://mirror.internode.on.net/pub/puppylinux/puppy-5.2/

Then all the source and dependencies for sabnzb

SABnzbd+ http://sabnzbd.org/download/

Cheetah http://pypi.python.org/pypi/Cheetah/2.4.4

yenc module http://sabnzbd.sourceforge.net/yenc-0.3.tar.gz

par2 http://www.murga-linux.com/puppy/viewtopic.php?search_id=1406948739&t=61382 actually your work chrome307!!

It is a few months since I did this so the order may need changing, but, I'm sure I started with the dependencies.

Cheetah first

Unzip the downloaded Cheetah-2.4.4.tar.gz then go into the directory where you unzipped it to and right click on a blank area in ROX filer, then click on window, then terminal here

In the terminal window type

Code:
python setup.py build


then

Code:
python setup.py install


That should take care of the cheetah dependency. Now go to the yenc module and follow the same process. Unzip the tar.gz go to that directory, right click, window, terminal here.

In the terminal window type

Code:
python setup.py build


then

Code:
python setup.py install


If I remember correctly, this one spat out an error, but it doesn't seem to matter anyway.

That is dependency two sorted.

Click on the par2.pet and it should install itself without any further interaction. Now the fun part. The actual program.

Unzip the SABnzbd+ tar.gz and go to that folder. Note, the cherrypy dependency is included in the download. I don't think you have to do anything with it, its just there.

Again, follow the same procedure to make this one, except the .py file is different. So, right click, window, terminal here...

Code:
python SABnzbd.py


That should be it done, your web browser should start itself and you'll be ready to download your nzbs.

Note, I don't know what I did, but, in the process of running through this myself to write this, its updated to the newest version for me, so thanks for making me do it!!

Hope that helps

Paul

Edited_time_total
Back to top
View user's profile Send_private_message 
chrome307


Joined: 15 Jan 2009
Posts: 713

PostPosted: Thu 26 May 2011, 09:30    Post_subject:  

Thank you ... Thank you .... Thank you Smile
Back to top
View user's profile Send_private_message 
p310don

Joined: 19 May 2009
Posts: 733
Location: Brisbane, Australia

PostPosted: Thu 26 May 2011, 09:37    Post_subject:  

do I take it you got it working? if so, maybe change the title to SABnzbd setup - if my instructions are correct
Back to top
View user's profile Send_private_message 
chrome307


Joined: 15 Jan 2009
Posts: 713

PostPosted: Thu 26 May 2011, 09:42    Post_subject:  

OOps ... sorry have done it just yet .... need to get back home to do this.

Thanks for the clear concise instructions, I very confident that it will work and will post later on once I have it up and running!!
Back to top
View user's profile Send_private_message 
p310don

Joined: 19 May 2009
Posts: 733
Location: Brisbane, Australia

PostPosted: Thu 26 May 2011, 09:47    Post_subject:  

Ok, look forward to hearing that you've gotten it going. I know you've been trying to do this for ages, and I know that I promised to help you out in January. Sorry for the slight delay, can you believe may is almost over already?!?
Back to top
View user's profile Send_private_message 
chrome307


Joined: 15 Jan 2009
Posts: 713

PostPosted: Fri 27 May 2011, 06:11    Post_subject:  

Yahoo!!

It works, compiled it ( used Lucid 5.25 ) as detailed in your steps, I did get some error messages, however you were right SABnzbd+ does start up and runs you through the setup wizard.

This is the error message:

Code:


You don't have the C version of NameMapper installed! I'm disabling Cheetah's useStackFrames option as it is painfully slow with the Python version of NameMapper. You should get a copy of Cheetah with the compiled C version of NameMapper.
  "\nYou don't have the C version of NameMapper installed! "



Just glad it's all sorted, I do like using PAN and it's lightweight and doesn't burden the OS, but SABnzbd+ offers more functionality.

Thank you again!! Smile
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » REQUESTS
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0626s ][ Queries: 11 (0.0034s) ][ GZIP on ]