Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 30 Aug 2014, 14:18
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
Lucid 525 Retro-2.6.30.5
Moderators: Flash, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 3 of 3 Posts_count   Goto page: Previous 1, 2, 3
Author Message
James C


Joined: 26 Mar 2009
Posts: 5722
Location: Kentucky

PostPosted: Thu 16 Jun 2011, 02:21    Post_subject:  

tallboy wrote:
Which repositories in the Puppy Packet Manager can be used for packet download? Are there issues with any packages in the puppy-lucid section because of the kernel change? Do we have to use spesific packages for the retro Lupu?

I have never really understood how all packages in all repositories in the PPM are backward compatible with a newer puppy, I don't know if that is a Linux policy matter? If all are not compatible, why are they listed?

What about the 'Extras for Puppy 4.3 with the 2.6.30.5 kernel', can those packages be used as is, or do they need some modifications?

Can I use the Firefox-3.6.6-Lucid from the puppy-lucid repository, or are there other more suited 3.6 versions?

I know these are newbie-questions, earlier I have just downloaded with PPM, and used what I found without thinking (yeah, yeah, I admit), and I have never had any problem with ditching a package that didn't work as intended!

Tallboy.


Probably most all regular Lucid packages should work in Lucid Retro except drivers.....because drivers are kernel dependant.That's why we disabled the drivers from downloading with Quickpet.
I've tested the regular Lucid browser downloads in Retro....Firefox, SeaMonkey, Opera and Chrome and they all work.
Other than the drivers (video,network,etc.) the regular Lucid pet packages should work though.
Any drivers for the 2.6.30.5 kernel should work fine since the kernel and included drivers are straight out of Puppy 4.31.
Back to top
View user's profile Send_private_message 
tallboy


Joined: 21 Sep 2010
Posts: 442
Location: Oslo, Norway

PostPosted: Thu 16 Jun 2011, 23:23    Post_subject:  

Thank you James C. I keep playing with my regular workhorse puppy dpup4.84beta4, and dpup-4.85 as well as 525 retro, all using the 2.6.30.5 kernel, great fun to compare!
I also test wary 5.12, lulpu_5.2.5 and sqzd_4.99.2. The leader in speed is wary_5.12, some apps is bang on the screen almost before the mouse is released, but the selection of dedicated packages is somewhat limited, though. The main thing is to have fun!

I have learnt to open any new program from console the first time, that way I always get feedback on missing libs or any other problems.

Tallboy.
Back to top
View user's profile Send_private_message 
Insomniacno1

Joined: 24 Jul 2009
Posts: 75

PostPosted: Fri 12 Aug 2011, 05:06    Post_subject:  

Hi James, I have a few small problems with your Retro puppy lupu-525-2.6.30.5.iso. I got it from http://puppylinuxnews.org/puplets/

No problem booting the LiveCD, but when trying to make a full install universal installer can't find the lupu-525.sfs file. This I figured out were because of the naming, you used "-" instead of what universal installer looks for "_". So I copied the files to a secondary partion and renamed the lupu-525.sfs to lupu_525.sfs. And pointed universal installer to this partion for the files. Now no problem installing.

The question here is, can I edit the ISO file and rename the lupu-525.sfs to lupu_525.sfs without having problem when booting the liveCD(don't feel like wasting a cd).

Or could you upload a reversed copy:)
---------------------------------------------------

Other probleme is to get OpenGL to work with my 16MB ATI Rage 128 Pro AGP 4x card. Could I lure you over to this thread to help:

http://murga-linux.com/puppy/viewtopic.php?p=552179#552179

-----------------------------------------------------------------------------
I also got some trouble with wine, so could I lure you over to this thread to help:

http://www.murga-linux.com/puppy/viewtopic.php?p=552298#552298

---------------------------------------------------------------------------------
And then there is some trouble with the keyboard layout for danish or any other than US keyboard. It would seem that no matter what you change the keyboard layout to, it saves but doesn't stick - next time you look its back to US keyboard. So could I lure you over to this thread to help:

http://www.murga-linux.com/puppy/viewtopic.php?p=552308#552308

I hope you can help with this, taking in mind that this is your distro so you know how its "stringed" together:) The reason for all these threads is the admin Flash thought that the thread would get too large if I collected every problem in 1 thread.

I chose your puplet because I'm trying to set up a pc with CNC/CAD and I need to have no restrictions and OpenGL. Any other distro I have tried (and I have tried allot - used 1 month already on this, having to change to another for one or another reason, usually caused by restrictions).

My friend who asked me to set this up for him is impatiently hanging over my shoulders to see if I'm done with this pc:)

With kind regards

Jan[/url]
Back to top
View user's profile Send_private_message 
James C


Joined: 26 Mar 2009
Posts: 5722
Location: Kentucky

PostPosted: Fri 12 Aug 2011, 17:26    Post_subject:  

Insomniacno1 wrote:

The question here is, can I edit the ISO file and rename the lupu-525.sfs to lupu_525.sfs without having problem when booting the liveCD(don't feel like wasting a cd).


Sorry to say,it's not that easy.Wish it was....simply renaming the sfs results in a non-booting cd.I tried. Laughing
There is a mismatch in the sfs naming between the sfs,the installer and the initrd.gz.....I'll try to upload a new iso this weekend.

Quote:
Other probleme is to get OpenGL to work with my 16MB ATI Rage 128 Pro AGP 4x card. Could I lure you over to this thread to help:


Since Lucid Retro has the kernel and drivers from Puppy 4.31 (2.6.30.5)
there should be some appropriate drivers floating around here in the forum.My boxes are mostly Nvidia but I'll see if I can find something to help.

Quote:
I also got some trouble with wine


I don't use Wine but a lot of forum members do,help should be forthcoming.

Quote:
And then there is some trouble with the keyboard layout for danish or any other than US keyboard. It would seem that no matter what you change the keyboard layout to, it saves but doesn't stick - next time you look its back to US keyboard. So could I lure you over to this thread to help:


Since the actual main sfs is untouched Lucid Puppy (except for the drivers and kernel modules) the procedure for changing the keyboard layout should be the same.I recall reading a number of posts about those problems in the regular Lucid threads.I'll see if I can find a way for the changes to be persistent.

Luckily there is a lot of knowledge on this forum....hopefully we can find some answers.
Back to top
View user's profile Send_private_message 
01micko


Joined: 11 Oct 2008
Posts: 7794
Location: qld

PostPosted: Sat 13 Aug 2011, 04:47    Post_subject:  

Insomniacno1

The X.org developers have more or less abandoned old AGP cards since xorg-7.4. All lucid based pups have xorg-7.5. Anything older than 5 or 6 years in an ATI or 7 or 8 years for an nvidia is pretty much unsupported. Wary or puppy 431 are the best chance at getting the old ATI working to full potential. That being said, I have found the open source radeon driver very good on my old radeon-9200 pro, with the Xorg_High driver. but that is a substantially more advanced card than the 16MB ATI Rage 128 Pro AGP 4x card.

HTH

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send_private_message Visit_website 
Insomniacno1

Joined: 24 Jul 2009
Posts: 75

PostPosted: Sat 13 Aug 2011, 07:16    Post_subject:  

01micko wrote:
Insomniacno1

The X.org developers have more or less abandoned old AGP cards since xorg-7.4. All lucid based pups have xorg-7.5. Anything older than 5 or 6 years in an ATI or 7 or 8 years for an nvidia is pretty much unsupported. Wary or puppy 431 are the best chance at getting the old ATI working to full potential. That being said, I have found the open source radeon driver very good on my old radeon-9200 pro, with the Xorg_High driver. but that is a substantially more advanced card than the 16MB ATI Rage 128 Pro AGP 4x card.

HTH


hi Micko, the retro version of 525 is using the 431 kernel:)

Jan
Back to top
View user's profile Send_private_message 
James C


Joined: 26 Mar 2009
Posts: 5722
Location: Kentucky

PostPosted: Sat 13 Aug 2011, 13:02    Post_subject:  

Insomniacno1 wrote:
01micko wrote:
Insomniacno1

The X.org developers have more or less abandoned old AGP cards since xorg-7.4. All lucid based pups have xorg-7.5. Anything older than 5 or 6 years in an ATI or 7 or 8 years for an nvidia is pretty much unsupported. Wary or puppy 431 are the best chance at getting the old ATI working to full potential. That being said, I have found the open source radeon driver very good on my old radeon-9200 pro, with the Xorg_High driver. but that is a substantially more advanced card than the 16MB ATI Rage 128 Pro AGP 4x card.

HTH


hi Micko, the retro version of 525 is using the 431 kernel:)

Jan


Lucid Retro does indeed have the 4.31 kernel (2.6.30.5) but it also has the newer Lucid xorg-7.5.
Back to top
View user's profile Send_private_message 
James C


Joined: 26 Mar 2009
Posts: 5722
Location: Kentucky

PostPosted: Sun 14 Aug 2011, 02:57    Post_subject:  

New upload in first post.


Lucid Retro 525-2.6.30.5-v4 now boots straight to the desktop and the full install bug is fixed.

Download link

http://www.smokey01.com/JamesC/uploads/lucid-retro-525-2.6.30.5-v4/lupu-525-2.6.30.5-v4.iso


md5

760e0e61fa24eb5f80d9c31a05d6b611 lupu-525-2.6.30.5-v4.iso
Back to top
View user's profile Send_private_message 
James C


Joined: 26 Mar 2009
Posts: 5722
Location: Kentucky

PostPosted: Tue 16 Aug 2011, 02:53    Post_subject:  

James C wrote:
New upload in first post.


Lucid Retro 525-2.6.30.5-v4 now boots straight to the desktop and the full install bug is fixed.

Download link

http://www.smokey01.com/JamesC/uploads/lucid-retro-525-2.6.30.5-v4/lupu-525-2.6.30.5-v4.iso


md5

760e0e61fa24eb5f80d9c31a05d6b611 lupu-525-2.6.30.5-v4.iso



I uploaded the incorrect iso....... the links and the iso are now correct.Sorry for any inconvenience to anyone who may have downloaded the wrong iso.
Back to top
View user's profile Send_private_message 
tallboy


Joined: 21 Sep 2010
Posts: 442
Location: Oslo, Norway

PostPosted: Sun 28 Aug 2011, 20:12    Post_subject:  

Thank you, James C

Olaf.
Back to top
View user's profile Send_private_message 
JackWagon

Joined: 17 Aug 2010
Posts: 43
Location: dead center, USA

PostPosted: Mon 19 Sep 2011, 16:39    Post_subject: 525 Retro-2.6.30.5  

Thank you James C

My Dell is liking this 525-2.6.30.5 hybrid. I’ve been crank’n on this retro for over a day now. The first pupsave I created will not boot back into, so I installed to a flash USB and created a save file from there. Even after updating the bios, this Dell still does not have the option to boot from a USB device. I made a Wakepup2 floppy boot disk to resolve that problem. (The CD boot picks up the USB created pupsave with no problems.)

specification:
Dell Optiplex GX260
Pentium 4- 2.53Ghz
512M (502 after video) 200 used
Intel 82845G/GE Brookdale (rev 01)VGA

Installed packages:

Lucid 525 instant update-001 (the largest of the 3 updates which is 001&002 combined I believe)

525 Xorg High

Firefox-6.0-lucid525 (updated to 6.02)

flashupdater-002

sfs_load-1.1-fixed (on-the-fly SFS loader)

PupSnap-1.62

Xchat

SFS: wine-1.3.6-i486 SFS-4.sfs

Summary- This is a good choice for the thousands of Dell GX260's that are now too slow for the latest commercial operating systems. Wink
Firefox 6 and everything I have tried is stable.
Thanks again James for your insight and contributions to this niche. 525/4.31 was the right choice for this project.
Any other suggestions/updates that can be made to improve this pup will be appreciated.

Jack W.
Back to top
View user's profile Send_private_message 
James C


Joined: 26 Mar 2009
Posts: 5722
Location: Kentucky

PostPosted: Tue 29 Nov 2011, 04:43    Post_subject: Re: 525 Retro-2.6.30.5  

JackWagon wrote:
Thank you James C

My Dell is liking this 525-2.6.30.5 hybrid. I’ve been crank’n on this retro for over a day now. The first pupsave I created will not boot back into, so I installed to a flash USB and created a save file from there. Even after updating the bios, this Dell still does not have the option to boot from a USB device. I made a Wakepup2 floppy boot disk to resolve that problem. (The CD boot picks up the USB created pupsave with no problems.)

specification:
Dell Optiplex GX260
Pentium 4- 2.53Ghz
512M (502 after video) 200 used
Intel 82845G/GE Brookdale (rev 01)VGA

Installed packages:

Lucid 525 instant update-001 (the largest of the 3 updates which is 001&002 combined I believe)

525 Xorg High

Firefox-6.0-lucid525 (updated to 6.02)

flashupdater-002

sfs_load-1.1-fixed (on-the-fly SFS loader)

PupSnap-1.62

Xchat

SFS: wine-1.3.6-i486 SFS-4.sfs

Summary- This is a good choice for the thousands of Dell GX260's that are now too slow for the latest commercial operating systems. Wink
Firefox 6 and everything I have tried is stable.
Thanks again James for your insight and contributions to this niche. 525/4.31 was the right choice for this project.
Any other suggestions/updates that can be made to improve this pup will be appreciated.

Jack W.


Glad to hear it's working well for you. Smile
Back to top
View user's profile Send_private_message 
Roy

Joined: 31 Dec 2008
Posts: 442

PostPosted: Sun 04 Dec 2011, 22:09    Post_subject:  

James C,

Downloaded a copy of your lupu-525-2.6.30.5-v4.iso last evening, checked the md5sum, and burned it to a multisession CD...

My copy would boot (puppy pfix=ram) straight to the desktop [but only one (?) icon], but then would freeze there. A hard shutdown and a second clean (... pfix=ram) boot using the f2 key for boot options gave me a more complete desktop, but only a 800x600 desktop instead of a 1024x768. Running xorgwizard froze everything again. Ctrl-Alt-Backspace would not even give a response.

Since I cannot confirm a good burn with a multisession disc (a closed session DAO-burned disc can be confirmed), may I ask if anyone else has experienced the same problem?

I am downloading your original .iso as I type this.

-Roy

Aopen Black Media P4, 2.8Ghz, 2Gb RAM, 40Gb HD
Back to top
View user's profile Send_private_message 
James C


Joined: 26 Mar 2009
Posts: 5722
Location: Kentucky

PostPosted: Mon 05 Dec 2011, 12:25    Post_subject:  

Roy wrote:
James C,

Downloaded a copy of your lupu-525-2.6.30.5-v4.iso last evening, checked the md5sum, and burned it to a multisession CD...

My copy would boot (puppy pfix=ram) straight to the desktop [but only one (?) icon], but then would freeze there. A hard shutdown and a second clean (... pfix=ram) boot using the f2 key for boot options gave me a more complete desktop, but only a 800x600 desktop instead of a 1024x768. Running xorgwizard froze everything again. Ctrl-Alt-Backspace would not even give a response.

Since I cannot confirm a good burn with a multisession disc (a closed session DAO-burned disc can be confirmed), may I ask if anyone else has experienced the same problem?

I am downloading your original .iso as I type this.

-Roy

Aopen Black Media P4, 2.8Ghz, 2Gb RAM, 40Gb HD


I'd suspect a bad burn. No one else has reported that problem and I've booted the cd on 10 or 12 different boxes...all straight to the desktop. Could possibly be a driver issue since Lucid Retro has the drivers from Puppy 431 but it works fine on all my test hardware.
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 3 of 3 Posts_count   Goto page: Previous 1, 2, 3
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1021s ][ Queries: 12 (0.0047s) ][ GZIP on ]