Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 19 Jun 2018, 02:47
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
No headphone volume in alsamixer, retrovol
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [14 Posts]  
Author Message
mantd

Joined: 15 Nov 2009
Posts: 7

PostPosted: Sat 07 May 2011, 17:29    Post subject:  No headphone volume in alsamixer, retrovol
Subject description: No headphone volume in alsamixer, retrovol
 

Hi,

I have an Asus A42n with a single combo jack running Lucid Puppy 5.25

I can't seem to get sound from my audio jack.

There is no volume slider for headphone in retrovol and alsamixer. The laptop speaker works fine. The problem is when i plug in my headphone i can't hear any sound thru my headphone and the laptop speaker is muted.

There is sound output thru the jack on ubuntu and windows though.

Below is the output of cat /proc/asound/card0/codec#@ |grep Codec
Codec: Realtek ALC259

Output for lscpi | grep Audio
00:14.2 Audio device: ATI Technologies SBx00 Azaliea (Intel_HDA) (rev 40)
01:05.1 Audio device: ATI Technologies Inc RS880 Audio Device [Radeon HD4200]

Appreciate if someone could help me out.

Thank you.
Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 10568
Location: Charleston S.C. USA

PostPosted: Sat 07 May 2011, 17:55    Post subject:  

Right click on the speaker in the task bar.
Choose full window.
Make sure headphone Jack sense is checked.

Not sure, but may also need to select Phone and adjust volume.
retrovol.jpg
 Description   
 Filesize   24.21 KB
 Viewed   1971 Time(s)

retrovol.jpg

Back to top
View user's profile Send private message 
mantd

Joined: 15 Nov 2009
Posts: 7

PostPosted: Sat 07 May 2011, 18:06    Post subject:  

Hi Bigpup,

Can't seem to find the item you mentioned in retrovol

Attached is my retrovol screenshot and my alsamixer.
alsamixer.png
 Description   
 Filesize   11.75 KB
 Viewed   798 Time(s)

alsamixer.png

vol.png
 Description   
 Filesize   12.45 KB
 Viewed   2011 Time(s)

vol.png

Back to top
View user's profile Send private message 
mantd

Joined: 15 Nov 2009
Posts: 7

PostPosted: Sat 07 May 2011, 18:11    Post subject:  

Is there a way to enable headphone sense ?

Thanks
Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 10568
Location: Charleston S.C. USA

PostPosted: Sat 07 May 2011, 18:28    Post subject:  

Right click on speaker in task bar.
Choose config window.
Select hardware tab.
Make sure it looks like this.
Everything in right list.
If stuff is in left list, move it over with the arrow keys.
Select apply.
Close window.
Right click on speaker.
Select full window.
Now you should see all the settings.
retrovol2.jpg
 Description   
 Filesize   28.83 KB
 Viewed   1999 Time(s)

retrovol2.jpg

Back to top
View user's profile Send private message 
mantd

Joined: 15 Nov 2009
Posts: 7

PostPosted: Sat 07 May 2011, 18:39    Post subject:  

Hi bigpup,

Thanks for the help.

Its not in my list .. maybe its my hardware configuration, driver or settings ?

Headphone sense is not in the list.
image-1.png
 Description   
 Filesize   39.22 KB
 Viewed   761 Time(s)

image-1.png

Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 10568
Location: Charleston S.C. USA

PostPosted: Sat 07 May 2011, 18:47    Post subject:  

If you have a normal Lucid Puppy 5.2.5 you should have this.
That is what I am using.
You can get a download of Retrovol from here:
http://www.murga-linux.com/puppy/viewtopic.php?t=50744

Seems like you do not have everything in Retrovol.

The way the config window works:
Under hardware tab
If everything is in right list- it will be an option in the Retrovol Full Window.
If anything is in left list- only those items will show in Retrovol Full Window.
Back to top
View user's profile Send private message 
mantd

Joined: 15 Nov 2009
Posts: 7

PostPosted: Sat 07 May 2011, 19:06    Post subject:  

Thanks for info bigpup , but i tried installling retrovol, reboot its still the same.

I've attached my alsa-info
Back to top
View user's profile Send private message 
mantd

Joined: 15 Nov 2009
Posts: 7

PostPosted: Sat 07 May 2011, 19:09    Post subject:  

post edited ..

Tried all the drivers to no avail on alsa config , none outputs to the headphone so still no volume slider on alsamixer, no headphone sense choice.

Solutions still eludes me ..

Last edited by mantd on Sun 08 May 2011, 13:50; edited 1 time in total
Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 10568
Location: Charleston S.C. USA

PostPosted: Sat 07 May 2011, 19:23    Post subject:  

Edit your last post. It is too wide.

Maybe run menu->setup-> Alsa Sound Wizard.
Maybe select a different audio controller. Could be causing this.
Back to top
View user's profile Send private message 
Pizzasgood


Joined: 04 May 2005
Posts: 6266
Location: Knoxville, TN, USA

PostPosted: Sun 08 May 2011, 14:46    Post subject:  

The lspci output makes it look like perhaps you have two audio chips. Maybe the default one Puppy is using isn't the one in charge of that output. You can adjust the levels on a second card by changing the settings in Retrovol under the "Hardware" tab, in the "Sound Card" line from hw:0 to hw:1. Or you can use alsamixer with the -c 1 switch:
Code:
alsamixer -c 1

(Remember, the first soundcard is 0, the second is 1, etc.)

That would let you change the settings, but it wouldn't cause any programs to actually send their sound data to the second card. To do that, you need to change the default soundcard for the system. If you edit /etc/asound.conf and add the following at the top, I think it will accomplish that:
Code:
pcm.!default {
   type   hw
   card   1
   device   0
}

Perhaps there is a GUI way to do that in Puppy's setup wizards, I do not know.

If that file already has anything in it before you edit it, back it up just in case. Also, any audio programs will probably need to be restarted after you make that change before the change kicks in for them. Note that it will not affect alsamixer and retrovol - you still have to do what I said earlier to have them let you control the other card.

I'm not sure whether this is the problem or not though.

_________________
Between depriving a man of one hour from his life and depriving him of his life there exists only a difference of degree. --Muad'Dib

Back to top
View user's profile Send private message Visit poster's website 
mantd

Joined: 15 Nov 2009
Posts: 7

PostPosted: Mon 09 May 2011, 22:44    Post subject:  

Hi,

Tried changing the soundcard to no avail. I found there is two audio hardware interface. on the retrovol hardware 1 there is only IEC958 and no sliders . on alsamixer its ATI RS690/780 HDMI stating S/PDIF (off). I doubt tht is the audio out.

Thanks for the help anyways.
Back to top
View user's profile Send private message 
danabnormal

Joined: 29 Mar 2010
Posts: 1

PostPosted: Wed 01 Jun 2011, 03:21    Post subject: Hi  

Hi, I have similar problem. I use ASUS K42F. No speaker volume on Puppy 5.2 and Puppy 5.2.5.
Back to top
View user's profile Send private message 
recobayu


Joined: 15 Sep 2010
Posts: 297
Location: indonesia

PostPosted: Wed 20 Jul 2011, 08:51    Post subject:  

danabnormal, not the speaker but headphone i think.
my laptop is asus a42f. dual core.
in wary and spup i got the headphone slider on alsamixer, but don't in lucid.
Sad
i don't know what happen with that.. maybe some library or what?
Confused
can anyone tell us?
actually i use both of wary and lucid now.
but i prefer use lucid because many support from ubuntu i get there, example my camera was detected very well with gucview, but don't in wary.
the appeareance of openbox n fbpanel also cool.
Very Happy
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [14 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1204s ][ Queries: 12 (0.0265s) ][ GZIP on ]