Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 24 Apr 2014, 08:15
All times are UTC - 4
 Forum index » House Training » Bugs ( Submit bugs )
Wary Puppy 5.1.4 - 29 August 2011
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 26 of 29 [425 Posts]   Goto page: Previous 1, 2, 3, ..., 24, 25, 26, 27, 28, 29 Next
Author Message
James C


Joined: 26 Mar 2009
Posts: 5453
Location: Kentucky

PostPosted: Wed 07 Sep 2011, 18:43    Post subject:  

Jades wrote:
James C wrote:
-Processor-
Name : AMD-K6(tm) 3D processor
Family, model, stepping : 5, 8, 12 (AMD K6-2)
Vendor : AuthenticAMD
-Configuration-
Cache Size : 64kb
Frequency : 501.12MHz


Is that a K6 2 500? Thought I had the only one left! Can you confirm whether you can play MP3s on that?


It is indeed a K6 2 500.I only pull it off the shelf for some occasional testing so I'll try to test some mp3's the next day or so.
Back to top
View user's profile Send private message 
Jades

Joined: 07 Aug 2010
Posts: 404
Location: Somewhere in Blighty.

PostPosted: Wed 07 Sep 2011, 18:56    Post subject:  

James C wrote:
Jades wrote:
Is that a K6 2 500? Thought I had the only one left! Can you confirm whether you can play MP3s on that?


It is indeed a K6 2 500.I only pull it off the shelf for some occasional testing so I'll try to test some mp3's the next day or so.


I use mine quite regularly, its main purpose is for running old Win98 and DOS games but Lupu 511 runs very well (and does play MP3s, its version of FFMPEG being 0.5.2) and I've been testing other versions of Puppy on it out of curiosity.

While Lupu eventually went i686+ only, in keeping with its remit as the bleeding-edge Puppy, Wary is more targetted at more... experienced machines and it'd be great if my K6 2 500 machine could be one of them. There appear to be very few other users of that CPU and Puppy, so it's reassuring that there is someone else out there testing. It may help to rule out the possibility that a problem is limited to my machine only, which to be honest is never far from my mind when I experience problems.

_________________
Zhaan - AMD K6 2 500, 512MB RAM, ATI Rage 128 VR. Full install Wary 5.5 HardInfo Report
Merlin - Pentium D 3.4GHz, 2GB RAM, Radeon X1650 Pro AGP. LiveCD of 5.25. HardInfo Report
Back to top
View user's profile Send private message Visit poster's website 
drblock2

Joined: 19 Jan 2009
Posts: 133

PostPosted: Fri 09 Sep 2011, 08:19    Post subject:
Subject description: Script for playing mp3 files
 

Those having problems playing mp3 files with applications based on ffmpeg can try the attached shell script.

It uses lame and aplay.

The business end of the script is in the line:
Code:
lame --decode "$file" - | aplay -twav


The rest is user interface and idiot proofing. In a pinch, you can play an mp3 file just by typing this line in a terminal window, substituting your mp3-file for "$file".
mp3play.gz
Description 
gz

 Download 
Filename  mp3play.gz 
Filesize  523 Bytes 
Downloaded  165 Time(s) 
Back to top
View user's profile Send private message 
James C


Joined: 26 Mar 2009
Posts: 5453
Location: Kentucky

PostPosted: Sun 11 Sep 2011, 02:55    Post subject:
Subject description: Problems playing MP3s on K6 2 500
 

Jades wrote:
Further to my previous post, I've now managed to install Wary 514 on my K6 2 500 machine and while the upgrade of the Live CD install's Warysave seems to have gone through without incident I'm still having the same problem with playing MP3 files as before. Pmusic loads with the file but doesn't play it and running FFMPEG from the command line generates an Illegal Instruction error.

Is the FFMPEG in Wary, Lupu and Slacko i686+ only? K6 2 500 is i586 according to both Puppy and HardInfo (see sig for report for Lupu 511 on that machine).

Madplay still plays MP3s and I've changed the Run Action in ROX so that Madplay is the default for those files.


Finally got the old K 6-2 box off the shelf.........MP3's and ogg files are both a no go here too.MPlayer won't even launch here either.
Back to top
View user's profile Send private message 
sc0ttman


Joined: 16 Sep 2009
Posts: 2368
Location: UK

PostPosted: Sun 11 Sep 2011, 13:27    Post subject:
Subject description: Problems playing MP3s on K6 2 500
 

James C wrote:
Jades wrote:
Further to my previous post, I've now managed to install Wary 514 on my K6 2 500 machine and while the upgrade of the Live CD install's Warysave seems to have gone through without incident I'm still having the same problem with playing MP3 files as before. Pmusic loads with the file but doesn't play it and running FFMPEG from the command line generates an Illegal Instruction error.

Is the FFMPEG in Wary, Lupu and Slacko i686+ only? K6 2 500 is i586 according to both Puppy and HardInfo (see sig for report for Lupu 511 on that machine).

Madplay still plays MP3s and I've changed the Run Action in ROX so that Madplay is the default for those files.


Finally got the old K 6-2 box off the shelf.........MP3's and ogg files are both a no go here too.MPlayer won't even launch here either.

Maybe MOCP, xhippo, mcplay or some other really lightweight audio player should be included (in the PPM, I guess)?

_________________
Akita Linux, VLC-GTK, Pup Search, Pup File Search
Back to top
View user's profile Send private message 
linuxcbon

Joined: 09 Aug 2007
Posts: 749

PostPosted: Mon 12 Sep 2011, 00:26    Post subject:  

When adding /sbin/udevd --daemon in rc.sysinit, got errors :
Code:
udevd[66]: SYSFS{}= will be removed in a future udev version, please use ATTR{}=

Replaced SYSFS with ATTR in /etc/udev/rules.d/ for TI_USB and WACOM.

Another error is in CUPS rules : %k is not reckognized, so removed it.
Back to top
View user's profile Send private message 
linuxcbon

Joined: 09 Aug 2007
Posts: 749

PostPosted: Mon 12 Sep 2011, 13:01    Post subject:  

re-edited
Should it be /usr/lib/xtables/ instead of /usr/libexec/xtables ?

pmount :
/usr/sbin/pmount: line 217: uniq: command not found
Back to top
View user's profile Send private message 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7047
Location: Perth, Western Australia

PostPosted: Thu 15 Sep 2011, 05:07    Post subject:
Subject description: Problems playing MP3s on K6 2 500
 

Jades wrote:
Further to my previous post, I've now managed to install Wary 514 on my K6 2 500 machine and while the upgrade of the Live CD install's Warysave seems to have gone through without incident I'm still having the same problem with playing MP3 files as before. Pmusic loads with the file but doesn't play it and running FFMPEG from the command line generates an Illegal Instruction error.

Is the FFMPEG in Wary, Lupu and Slacko i686+ only? K6 2 500 is i586 according to both Puppy and HardInfo (see sig for report for Lupu 511 on that machine).

Madplay still plays MP3s and I've changed the Run Action in ROX so that Madplay is the default for those files.


yes, ffmpeg was compiled for i686. I did that for performance reasons, but realise as this is Wary I should have compiled for i486/.586. This is on my to-do list to fix.

There were some posts on PETs for ffmpeg and mplayer that work in Wary and run on i586, but I don't recall the links. The posts were related to getting Wary running on the Gecko Edubook. The posts might have been on my blog.

_________________
http://bkhome.org/news/
Back to top
View user's profile Send private message Visit poster's website 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7047
Location: Perth, Western Australia

PostPosted: Thu 15 Sep 2011, 05:16    Post subject:  

linuxcbon wrote:
re-edited
Should it be /usr/lib/xtables/ instead of /usr/libexec/xtables ?

pmount :
/usr/sbin/pmount: line 217: uniq: command not found


# which uniq
/usr/bin/uniq

Regarding empty directories, some of those are needed. They get filled later, when an application runs, for example /etc/simple_network_setup gets used by SNS (Simple Network Setup).
/etc/belocs though, is not used.

linuxcbon,
Note, some of your earlier suggestions I will be looking at again a bit later.

_________________
http://bkhome.org/news/
Back to top
View user's profile Send private message Visit poster's website 
linuxcbon

Joined: 09 Aug 2007
Posts: 749

PostPosted: Thu 15 Sep 2011, 06:20    Post subject:  

Thanks, I am still testing.
Have a look at : http://www.spinics.net/lists/hotplug/msg05104.html
Back to top
View user's profile Send private message 
linuxcbon

Joined: 09 Aug 2007
Posts: 749

PostPosted: Thu 15 Sep 2011, 13:17    Post subject:  

Here are simple commands to remove the empty directories :
Code:
find /bin -type d -empty -delete
find /etc -type d -empty -delete
find /lib -type d -empty -delete
find /root -type d -empty -delete
find /sbin -type d -empty -delete
find /tmp -type d -empty -delete
find /usr -type d -empty -delete
find /var -type d -empty -delete
Back to top
View user's profile Send private message 
Jades

Joined: 07 Aug 2010
Posts: 404
Location: Somewhere in Blighty.

PostPosted: Fri 16 Sep 2011, 08:46    Post subject:
Subject description: Problems playing MP3s on K6 2 500
 

BarryK wrote:
yes, ffmpeg was compiled for i686. I did that for performance reasons, but realise as this is Wary I should have compiled for i486/.586. This is on my to-do list to fix.


Thanks for looking into it! Thanks also to James C for digging out his own K6 2 500 and confirming it wasn't just me. I've been testing Wary on mine because it's more the target market than the Pentium D, which is my family's main PC. Getting Lupu 52x and the recent Slacko to run on it at all was more of a curiosity thing.

BarryK wrote:
There were some posts on PETs for ffmpeg and mplayer that work in Wary and run on i586, but I don't recall the links. The posts were related to getting Wary running on the Gecko Edubook. The posts might have been on my blog.


I'll have a look. Someone send me the URL for an i486 FFMPEG and I downloaded it but haven't got round to testing it on that machine yet. I have a vague memory the file name said 2008 so it may be an older version.

_________________
Zhaan - AMD K6 2 500, 512MB RAM, ATI Rage 128 VR. Full install Wary 5.5 HardInfo Report
Merlin - Pentium D 3.4GHz, 2GB RAM, Radeon X1650 Pro AGP. LiveCD of 5.25. HardInfo Report
Back to top
View user's profile Send private message Visit poster's website 
linuxcbon

Joined: 09 Aug 2007
Posts: 749

PostPosted: Fri 16 Sep 2011, 16:56    Post subject:  

Code:
ldd /usr/lib/libpoppler-qt4.so
   libQtGui.so.4 => not found
   libQtXml.so.4 => not found
   libQtCore.so.4 => not found


Code:
# ffplay
libSDL-1.2.so.0: cannot open shared object file: No such file or directory
Back to top
View user's profile Send private message 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7047
Location: Perth, Western Australia

PostPosted: Sat 17 Sep 2011, 09:42    Post subject:  

I have uploaded Racy 5.1.99. This is the same as the next Wary except for Xorg 7.6 and 2.6.39.4 PAE kernel.

As it might (or might not) have a lot of different issues than the normal Wary, I started a separate thread for it:

http://murga-linux.com/puppy/viewtopic.php?t=71767

See also my blog announcement:

http://bkhome.org/blog/?viewDetailed=02481

_________________
http://bkhome.org/news/
Back to top
View user's profile Send private message Visit poster's website 
linuxcbon

Joined: 09 Aug 2007
Posts: 749

PostPosted: Sat 17 Sep 2011, 10:32    Post subject:  

Not wary related.
In page file:///usr/share/doc/home.htm
Some images link to /usr/share/doc/
Some others to /usr/local/lib/X11/pixmaps/
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 26 of 29 [425 Posts]   Goto page: Previous 1, 2, 3, ..., 24, 25, 26, 27, 28, 29 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Bugs ( Submit bugs )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0896s ][ Queries: 12 (0.0112s) ][ GZIP on ]