Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 24 Jul 2014, 09:18
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
Mouse Pointer Problem (it clicks everything constantly)
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [11 Posts]  
Author Message
Puppy_Zee

Joined: 25 Apr 2011
Posts: 4

PostPosted: Mon 25 Apr 2011, 10:33    Post subject:  Mouse Pointer Problem (it clicks everything constantly)  

Hello,

I have just recently installed (Lucid) Puppy Linux. I went for the frugal install.

Its my first time with Linux, it went pretty well, I got it connected to wireless and my epson printer/scanner easily enough.

I am now having problems with the pointer - it moves very sluggishly and if I move it over anything (icons) it clicks them automatically. (If I move over the word icon - it opens half a dozen new word documents in the time it takes me to move across the icon).

Sometimes rebooting fixes this problem - sometimes it doesnt.

Sometimes it starts ok - but will start up again later.

I tried running pupply linux from the live cd (as it seemed to work ok at first but I have only noticed it more recently) this made no difference.
It sounds as if the left click button has been jammed down - but as far as I can tell this is not the case.

This is on an old dell (inspiron 1300) laptop.

Any ideas?

Also I cant find how to access the "start" menu using the keyboard only.

Many thanks for any replies.
Back to top
View user's profile Send private message 
rjbrewer


Joined: 22 Jan 2008
Posts: 4422
Location: merriam, kansas

PostPosted: Mon 25 Apr 2011, 12:05    Post subject:  

Flsynclient is in the menu for adjusting touchpad, etc.

I use a little usb mouse on my 700m Dell.

Right click on background will open menu.

_________________

Inspiron 700m, Pent.M 1.6Ghz, 1Gb ram.
Msi Wind U100, N270 1.6>2.0Ghz, 1.5Gb ram.
Eeepc 8g 701, 900Mhz, 1Gb ram.
Full installs

Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 4984
Location: Charleston S.C. USA

PostPosted: Mon 25 Apr 2011, 12:08    Post subject:  

Try menu->setup->mouse/keyboard wizard.
Check settings for mouse.
Back to top
View user's profile Send private message 
Puppy_Zee

Joined: 25 Apr 2011
Posts: 4

PostPosted: Mon 25 Apr 2011, 13:49    Post subject:  

Thanks for those, didnt realise the menu was accessible by right clicking - thats quite nice.

Tried reinstalling puppy - made no difference, think it may possibly be hardware related - dont have any way to verify it right now though.

It is absolutely infuriating though - have decided to just pack it in.


Edit bought a usb mouse and that works fine, so it was presumably just a hardware issue. In the meantime though I have quite badly messed up my system - expect a question on partitioning in the next few days.
Back to top
View user's profile Send private message 
Valinote

Joined: 13 Dec 2010
Posts: 72

PostPosted: Fri 10 Jun 2011, 13:12    Post subject:  

I have the same annoying problem with the touchpad tap on my laptop. Is there a config file that can be modified so that I don't have to run FlSynClient and select/save the Touchpad Mode to "Tap Off" every time I reboot the computer?

-Steve D
Back to top
View user's profile Send private message 
muggins

Joined: 20 Jan 2006
Posts: 6673
Location: lisbon

PostPosted: Fri 10 Jun 2011, 19:13    Post subject:  

Pemasu has a pet to disable touchpads here.
Back to top
View user's profile Send private message 
DaveS


Joined: 09 Oct 2008
Posts: 3726
Location: UK

PostPosted: Sat 11 Jun 2011, 00:53    Post subject:  

This sounds like the 'clickfinger' bug and is dead easy to fix if it is. Just open the file /root/.flsynclient in a text editor by clicking on it, (it is a 'hidden' file, so set your filemanager to show hidden files), and look for the line that starts 'ClickFinger3 = ' Change the value to 'ClickFinger3 = 1'
Save, exit, re-boot. Hopefully, that will fix it.

_________________
Spup Frugal HD and USB
Root forever!
Back to top
View user's profile Send private message 
Valinote

Joined: 13 Dec 2010
Posts: 72

PostPosted: Sat 11 Jun 2011, 12:22    Post subject:  

Thanks for the quick response, guys.

Pemasu, since this is a laptop, and I don't want to have to use an external mouse. Therefore, I don't want to disable the touchpad. I just would like to turn off the ability to tap on the touchpad to emulate a left-click on a mouse.

DaveS, Clickfinger3 was already set to a value of one. And I don't see the value associated with that parameter change in the file in response to changing the Touchpad Mode via the FlSynClient gui. There are 3 available settings in the gui: ON, Off, Tap Off. It's the latter that I'm trying to make sticky.

-Steve D
Back to top
View user's profile Send private message 
Valinote

Joined: 13 Dec 2010
Posts: 72

PostPosted: Sat 11 Jun 2011, 13:37    Post subject:  

Ok. More info. If I set Touchpad Mode in the FlSynClient gui to Tap Off (that's what I want) and hit Save, the value for the TouchpadOff parameter in the .flSynclient file is 2. If I then change Touchpad Mode to ON and hit Save, then TouchpadOff changes to 0. Ah ha! Maybe I'm on to something. So you would think setting that value to 2 in the file would save my problem. But every time I reboot, even with TouchpadOff set to 2 in .flSynclient, the touchpad comes up with tap turned ON, and that is reflected in the gui; so I still have to change it manually. Could it be getting the powerup default value from another file?

-Steve D
Back to top
View user's profile Send private message 
Karl Godt


Joined: 20 Jun 2010
Posts: 3953
Location: Kiel,Germany

PostPosted: Sat 11 Jun 2011, 15:13    Post subject:  

What does the /etc/X11/xorg.conf look like ? I am guessing some input sections about keyboard,mouse,touchpad may be found there . Actually for example I had difficulties with the pointer of an usb mouse trying mouse protocol "Microsoft" , which is standard for old serial port mice , but for ps2/usb it must be "IMPS2" in my case . The documentation seems to be poor for it . I found "PS2,IMPS2,EXPS2,INTELLI" .
`grep` ing "-i touchpad" in xorg-server-1.7.7 source by debian throws out very little and most is in patches . The kernel driver "evdev" is mentioned there .

You can also try `modprobe -l | grep - E -i 'input|alp|syn|ps'` for a overview of available kernel drivers .
If you modprobe or change anything in files , X really has to be restarted .
Back to top
View user's profile Send private message Visit poster's website 
Valinote

Joined: 13 Dec 2010
Posts: 72

PostPosted: Sun 12 Jun 2011, 11:27    Post subject:  

Good tip, Karl! That was it!!

I found some abridged configuration of the touchpanel in the xorg.conf file. Just some of the main parameters to get it up and running I guess. The value I was looking for wasn't one of them, but I just added a line...

Option "TouchpadOff" "2"

and now the laptop boots up as desired, with the touchpad tap feature turned off.

Thanks so much for your suggestion... Cool

-Steve D
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [11 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0656s ][ Queries: 11 (0.0032s) ][ GZIP on ]