Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 24 Nov 2014, 05:45
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
EZ-Woof-525 - The Lucid 5.2.5 Build Environment
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 3 of 6 [80 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6 Next
Author Message
pemasu


Joined: 08 Jul 2009
Posts: 5465
Location: Finland

PostPosted: Sun 01 May 2011, 09:54    Post subject:  

http://www.murga-linux.com/puppy/viewtopic.php?p=517017#517017

That post might help. Not sure with lupe17. I havent tested with it, but that alsamixer fix worked with previous 2.6.38.2 kernel version. Lupe17 is newer 2.6.38.4 but probably the different /dev sound device location is the problem with that kernel also.

Last edited by pemasu on Sun 01 May 2011, 11:49; edited 1 time in total
Back to top
View user's profile Send private message 
puppyluvr


Joined: 06 Jan 2008
Posts: 3224
Location: Chickasha Oklahoma

PostPosted: Sun 01 May 2011, 11:38    Post subject:  

Very Happy Hello,
Leave it to me to forget to check the md5sum... Embarassed
Re-downloading... Cool

@EDIT:
I have D/L it twice more...
Each time I get a 411mb tarball, not 431mb as stated, and of course the md5sums dont match....
Weird thing is the 411mb tarballs matched md5`s thru 2 D/L`s, they were both the exact same thing...
What am I missing here???
Will try yet again, as I want this bad..LOL...
Jay...
@RE-EDIT...I give up...
Tried again, and as you can see, 411mb...


Will try wget and be back...(OK. so I didnt give up!) Cool

_________________
Close the Windows, and open your eyes, to a whole new world
http://puppylinuxstuff.meownplanet.net/puppyluvr/
Puppy Linux Users Group on Facebook

Puppy since 2.15CE...
Back to top
View user's profile Send private message Visit poster's website 
playdayz


Joined: 25 Apr 2008
Posts: 3789

PostPosted: Sun 01 May 2011, 13:46    Post subject:  

puppyluvr, I will start checking on this in a hour or so. I am wokring on Audacious 2.5.0 right now. One or two people have reported problems with the diddywahdiddy server--I will check that and put it on another server--but that will take a couple of hours. Sorry about the problem. Once it works it will be woof_gui that starts the process. I think you will enjoy playing with it once we get it right.
Back to top
View user's profile Send private message 
puppyluvr


Joined: 06 Jan 2008
Posts: 3224
Location: Chickasha Oklahoma

PostPosted: Sun 01 May 2011, 14:18    Post subject:  

Very Happy Hello,
Here is wget...

I saw 431003759 bytes and thought there it goes...but alas, that is still 411mb..Will let it finish and md5sum it anyhow...
Jay..

Oh, and bones wants a url to D/L Woof from..
Do you know a direct link for the Woof scripts, I cant seem to find one, and have not used Woof since before bones was involved......

_________________
Close the Windows, and open your eyes, to a whole new world
http://puppylinuxstuff.meownplanet.net/puppyluvr/
Puppy Linux Users Group on Facebook

Puppy since 2.15CE...
Back to top
View user's profile Send private message Visit poster's website 
playdayz


Joined: 25 Apr 2008
Posts: 3789

PostPosted: Sun 01 May 2011, 14:21    Post subject:  

Quote:
Oh, and bones wants a url to D/L Woof from..
Do you know a direct link for the Woof scripts, I cant seem to find one, and have not used Woof since before bones was involved......

The parts of Woof that you need are all included in EZ-Woof-525. Nothing else needs to be downloaded.
Back to top
View user's profile Send private message 
puppyluvr


Joined: 06 Jan 2008
Posts: 3224
Location: Chickasha Oklahoma

PostPosted: Sun 01 May 2011, 14:37    Post subject:  

Very Happy Hello,
Quote:
The parts of Woof that you need are all included in EZ-Woof-525.

I know, but am trying to D/L woof for other reasons...And I found the url in BK`s blog... Cool
Plus, when wget finishes, if the woof scripts are still missing, I will have them elsewhere....

What I`m doing is woofing 525 with the 2.6.38.2 kernel and some other stuff...

_________________
Close the Windows, and open your eyes, to a whole new world
http://puppylinuxstuff.meownplanet.net/puppyluvr/
Puppy Linux Users Group on Facebook

Puppy since 2.15CE...
Back to top
View user's profile Send private message Visit poster's website 
playdayz


Joined: 25 Apr 2008
Posts: 3789

PostPosted: Sun 01 May 2011, 14:56    Post subject:  

Quote:
I know, but am trying to D/L woof for other reasons...And I found the url in BK`s blog... Cool
Plus, when wget finishes, if the woof scripts are still missing, I will have them elsewhere....

I got it, I just wanted to make sure you knew the difference between Woof and EZ-Woof-525. I wouldn't recommend trying to mix them, not at all Wink

First, The download indicator does show 411MB, so that is OK. Second, I downloaded and got the same md5sum.



After confirming the md5sum, open a terminal in the folder that contains EZ-Woof-525 and extract. Right-click -> Window -> Terminal Here. Please do this instead of trying to use the Xarchive gui.

Code:
tar -xvf EZ-Woof-525.tgz


Then you will see



Upon opening the EZ-Woof-525 folder you will see



Click woof_gui to start and you will see the picture below. EZ-Woof-525 *only* uses the Specifications, Kernel and Build tabs.



Upon clicking the Kernel tab you will see the picture below. If you want to use a different kernel, all you need to do is to drag the kernel.pet into /packages-pet before you start woof-gui and it will show up under the Kernel tab.



After choosing a kernel, click Build--there are some more instructions in the first message in this thread.

Last edited by playdayz on Sun 01 May 2011, 15:23; edited 2 times in total
Back to top
View user's profile Send private message 
puppyluvr


Joined: 06 Jan 2008
Posts: 3224
Location: Chickasha Oklahoma

PostPosted: Sun 01 May 2011, 15:18    Post subject:  

Very Happy Hello,
Am wgetting it ATM..
Before, when I untarred it, all I got was the "packages-lupu" dir and the 3 package scripts.. No woof gui, no sandbox etc...
And yes, I almost always untar via the cli anyhow....
(Xarchive quite often freezes up with files bigger than 200 mb or so...)
Will get back when wget is done... Cool

Last edited by puppyluvr on Sun 01 May 2011, 15:27; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
playdayz


Joined: 25 Apr 2008
Posts: 3789

PostPosted: Sun 01 May 2011, 15:22    Post subject:  

Quote:
Before, when I untarred it, all I got was the "packages-lupu" dir and the 3 package scripts.. No woof gui, no sandbox etc...

Weird. Are you sure you have enough space? The EZ-Woof-525 folder takes 1.1GB. You might use /mnt/home or any other disk with at least 2GB of free space.
Back to top
View user's profile Send private message 
playdayz


Joined: 25 Apr 2008
Posts: 3789

PostPosted: Sun 01 May 2011, 15:25    Post subject:  

Quote:
I have tried using EZ-woof a couple of times now adding pemasu lupe-17 kernel - i keep running into the same problem, no audio or retrovol in tray and alsa sound wizard doesn't fix it.

Same when I have tried.

Quote:
What is the correct procedure to use in the kernel tab - i have the two tick boxes checked to remove exotic drivers, should these be left in?

You can experiment. The picture above shows the way it is done for Lucid 5.2.5.
Back to top
View user's profile Send private message 
puppyluvr


Joined: 06 Jan 2008
Posts: 3224
Location: Chickasha Oklahoma

PostPosted: Sun 01 May 2011, 15:42    Post subject:  

Very Happy Hello,
Partition has 2.8gb free space...after D/L the tarball...plenty of room...

Quote:
@no audio or retrovol in tray and alsa sound wizard doesn't fix it.

A known problem, but I cant ATM locate the posts concerning it, but i think it involves setting up alsa at boot...
@EDIT...see here about alsa:
http://www.murga-linux.com/puppy/viewtopic.php?p=517017#517017

Wget is @ 74%...I guess after 2gb today, my IP is "throttling" me..LOL

_________________
Close the Windows, and open your eyes, to a whole new world
http://puppylinuxstuff.meownplanet.net/puppyluvr/
Puppy Linux Users Group on Facebook

Puppy since 2.15CE...
Back to top
View user's profile Send private message Visit poster's website 
gcmartin

Joined: 14 Oct 2005
Posts: 4436
Location: Earth

PostPosted: Sun 01 May 2011, 16:11    Post subject: EZ Woof and ICE kernels  

playdayz wrote:
Quote:
I have tried using EZ-woof a couple of times now adding pemasu lupe-17 kernel - i keep running into the same problem, no audio or retrovol in tray and alsa sound wizard doesn't fix it.
Same when I have tried. ... .
Just a question for clarity: Does this mean that applications needing audio work and alsa config works, but, there is no tray icon. Do I understand this correctly?

Thanks in advance.

_________________
Get ACTIVE Create Circles; Do those good things which benefit people's needs!
We are all related ... Its time to show that we know this!
3 Different Puppy Search Engine or use DogPile
Back to top
View user's profile Send private message 
puppyluvr


Joined: 06 Jan 2008
Posts: 3224
Location: Chickasha Oklahoma

PostPosted: Sun 01 May 2011, 17:10    Post subject:  

Smile Hello,
Well, I finally got a md5sum match....Yea...
Woofed 5.25 with the 2.6.38.2 kernel, and I am posting from it now..

Commented out Openbox, and edited ect/windowmanager to jwm...
Still defaults to Openbox......LOL
Switched to jwm, working no problems..
No sound icons on tray, but alsa mixer works...
Forgot to do the ppm fix in sandbox3, so quickpet/ppm is broken ATM...
No puppy lucid entries, but `butu repo works fine...

Cool and fun....Gonna rewoof this again, to fix the bugs mentioned...
But other than the ppm, it is fully functional, and fast...
Posting from the "green" dillo ATM...

Well, gonna go do some tweaking before the rewoofing....
So easy and fast to make changes...
Great idea.... Cool

@EDIT:
OK, rewoofed it..
All is working now.. Cool
Alsa, Quickpet/PPM, ndiswrapper, programs, background, themes, retrovol, xcompmgr, transparency, etc....
If I redid it again, it would just be cosmetic...
Worked flawlessly...
Hmmm, what to test next... Cool

_________________
Close the Windows, and open your eyes, to a whole new world
http://puppylinuxstuff.meownplanet.net/puppyluvr/
Puppy Linux Users Group on Facebook

Puppy since 2.15CE...

Last edited by puppyluvr on Sun 01 May 2011, 20:58; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
playdayz


Joined: 25 Apr 2008
Posts: 3789

PostPosted: Sun 01 May 2011, 20:46    Post subject:  

Quote:
Not exactly. Some things are broken. For example: the firewall desktop calls rxvt and there is no rxvt. The default text editor is beaver and there is no beaver. At least they are not in the path.


I just built from a pristine EZ-Woof-525 and

1. Linux Firewall and firewallstate both ran as they should.

2. defaulttexteditor was set to geany and geany opened.

Did you compare your EZ-Woof-525.tgz with the md5sum in the first message of this thread? More likely, you changed something???? And that had unintended consequences???? You didn't add another Woof or anything did you, because there is a script somewhere that wants beaver to be default. You just 1) extracted, 2) started woof_gui, 3) chose the Kernel, and 4) selected Build????

If so, next time please watch the messages very closely as the Build script runs and post any anomalous looking stuff.
Back to top
View user's profile Send private message 
playdayz


Joined: 25 Apr 2008
Posts: 3789

PostPosted: Sun 01 May 2011, 20:49    Post subject:  

puppyluvr, A good day's work, I would say!

Quote:
Commented out Openbox, and edited ect/windowmanager to jwm...
Still defaults to Openbox......LOL


Yes, get used to the Woof way of doing things Wink Open DISTRO_PKGS_SPECS-ubuntu-lucid and replace no with yes in front of the fbpanel line and the openbox line. Be careful--the syntax must be exact--no typos! Look on the page 1 and page 2 discussion with tasmod for solution to a further problem. IMHO the easiest thing to do is to leave it like it is, and then boot openbox the first time, save, and then switch to jwm.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 3 of 6 [80 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1080s ][ Queries: 12 (0.0122s) ][ GZIP on ]