Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 19 Dec 2014, 11:19
All times are UTC - 4
 Forum index » House Training » HOWTO ( Solutions )
How to set up an FTDI USB to serial modem adaptor
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [3 Posts]  
Author Message
Eastern Counties


Joined: 31 Jan 2006
Posts: 142
Location: UK

PostPosted: Fri 10 Mar 2006, 13:20    Post subject:  How to set up an FTDI USB to serial modem adaptor  

How to set up an FTDI USB to serial modem adaptor

I should stress that I am a newbie and was only able to get my serial modem to work on a USB-only laptop with considerable guidance from forum members, especially Jonathon (jmarsden), Mark (MU) and jcoder24. What follows is a synopsis of the forum posts and tweaking I had to do to make the advice work for me. The whole process could probably be tidied up by somebody who knows what they are doing, but I hope that this will be of some help to others.

I used this method with Puppy 1.0.7 on a Toshiba laptop. I have a Sitecom modem and an FTDI chip based USB-serial adaptor.

The first stage is to install the usbserial module, which is included in Puppy 1.0.7, and the ftdi module, which is not.

1. Download the file ftdi_sio.o.tar.gz from
http://www.murga.org/~puppy/download.php?id=1871&sid=f7ed83af687b5c4f2743af28235c0306

2. Extract it with pupzip to /usr/lib/modules.

3. Puppy needs to install the usbserial and ftdi modules each time you boot, so open /.etc/rc.d/rc.local0 as a text file, and add these two lines immediately after the line #!/bin/sh:
insmod /lib/modules/2.4.29/usb/serial/usbserial.o.gz
insmod /usr/lib/modules/ftdi_sio.o

save and close. Make sure your modem is turned on and connected both to your computer and your phone line, and reboot.

6. Open a terminal and type dmesg and enter. The output should now include information about your FTDI adaptor, and give you the serial port assigned to it. In my case, this was ttyUSB0. If this information is missing, you could check that usbserial.o.gz and ftdi_sio.o are in the directories you entered in the /.etc/rc.d/rc.local0 file. If not, you will have to find them, edit /.etc/rc.d/rc.local0 again and reboot.

7. Check which directory ttyUSB0 sits in. In my case it was in /dev/usb.

8. Go to /usr/sbin/modem-wizard, and open the file as text.

9. Open Edit > Find and enter
BUTTONS=
as a search term, and on the first line it finds, change "ttyS4" to "ttyUSB0".

10. Return to the search facility and this time, look for
14)#
On the line after the one that is shown, change testmodem /dev/ttyS4 to testmodem /dev/usb/ttyUSB0. Save and close.

11. Run the Puppy modem wizard and (of course) select the 'ttyUSB0' button. Ignore any message about a modem not existing and click 'Save'.

12. Go to /dev and place your mouse over modem. This should show a symlink to /dev/usb/ttyUSB0.

13. Open GK Dial and enter relevant ISP data. For some reason, I could only get my modem to dialup if I selected the CHAP connection type.

14. Open the directory /.etc/ppp and check (and edit if necessary) the ISP data in the relevant files. In my case these were:
/.etc/ppp/chap-secrets
/.etc/ppp/chatscripts/<ISP name>CHAP
/.etc/ppp/peers/<ISP name>CHAP

One problem I encountered was that my dialling number was too long for the GK Dial GUI and had been truncated in /.etc/ppp/chatscripts/<ISP name>CHAP. Also, make sure the AT command is correct - I needed ATDT for tone dialling. Optional commands can be found on the web, e.g., http://www.modemhelp.net/basicatcommand.shtml

15. Save and close any files you have edited.

16. Open GK Dial, make sure that the server name you entered is shown in the selection box, and click 'Connect'. With any luck, you will be dialling up.

17. I have re-tried this procedure with a new pup002, and it worked, so hope it does for you.
Back to top
View user's profile Send private message 
Flash
Official Dog Handler


Joined: 04 May 2005
Posts: 11180
Location: Arizona USA

PostPosted: Fri 10 Mar 2006, 16:38    Post subject:  

Thanks for posting this. I hope it helps a lot of people. Smile
Back to top
View user's profile Send private message 
laserman

Joined: 18 Oct 2009
Posts: 22

PostPosted: Thu 17 Feb 2011, 13:16    Post subject:  

There may be a simple command I can run to get this done but I am not finding it. After reading the instructions (for an older pup), I have not been able to get my FTDI USB Terminal Node Controller to be recognized when connected.

I have a Terminal Node Controller that I use with amateur radio software, to communicate between the computer and radio. I am running Lucid 5.2. Under the Wine directory in dosdevices, I inserted a symbolic link to /dev/ttyUSB0 to reference the TNC as com3. When the software in Wine is initiated (which runs fine), it doesn't see the com port.

Typing dmesg shows that the FTDI USB device is recognized and assigns it to ttyUSB0.

In Wine, is there something that I have forgotten to set up?

John Rolling Eyes
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [3 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » HOWTO ( Solutions )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0516s ][ Queries: 11 (0.0031s) ][ GZIP on ]