Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 19 Jun 2018, 20:31
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Audio
Realtek ALC892 (Solved with weirdness)
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [4 Posts]  
Author Message

Joined: 23 Feb 2009
Posts: 37

PostPosted: Tue 12 Apr 2011, 17:35    Post subject:  Realtek ALC892 (Solved with weirdness)
Subject description: improper install

Hello folks,

Realtek ALC892 on Puppy 5.2.5 full install, MSI P67A-GD65 (B3) motherboard. At first it was not recognized.
Installed lupu_devx_525 and kernel source so I could install the new drivers from Realtek.

Now I have in /etc/modprobe.d alsa_cards.conf

alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel

/proc/asound/card0 shows codec#1 as Codec: Realtek ALC892
and card1 as Codec: Nvidia GPU 12 HDMI/DP which is correct.

Trouble is aplay -l no soundcards found.
Alsamixer no such device.
No volume controll in tray.

I have run alsaconf. I've tried adding options to alsa_cards.conf but they are gone on reboot. I may be adding bad options. Don't know.

I really only need the Realtek, the Nvidia would be gravy. Anybody see what I'm missing?


I've also tried adding to alsa.conf.
options snd-hda-intel model=6stack-dig 6-jack digital with SPDIF I/O
options snd-hda-intel model=auto auto-config reading BIOS
options snd-hda-intel model=auto
options snd-hda-intel model=Realtek ALC892

Last edited by jfh on Sun 24 Apr 2011, 22:44; edited 2 times in total
Back to top
View user's profile Send private message 

Joined: 23 Feb 2009
Posts: 37

PostPosted: Tue 12 Apr 2011, 23:50    Post subject: More info
Subject description: Debug output

Here is the debug output.

edit tried ossmix. bash: ossxmix: command not found

Well it didn't attach so:

# ./aadebug
ALSA Audio Debug v0.1.0 - Tue Apr 12 22:27:22 GMT-8 2011

Kernel ----------------------------------------------------
Linux puppypc #1 SMP Thu May 27 10:56:32 EST 2010 i686 GNU/Linux

Loaded Modules --------------------------------------------
snd_hda_codec_hdmi 16787 4
snd_hda_codec_realtek 206331 1
snd_hda_intel 16191 0
snd_hda_codec 52031 3 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_intel
snd_hwdep 3966 1 snd_hda_codec
snd_pcm_oss 27429 0
snd_mixer_oss 10267 1 snd_pcm_oss
snd_pcm 46566 4 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_pcm_oss
snd_seq_oss 19824 0
snd_seq_midi_event 3592 1 snd_seq_oss
snd_seq 33307 4 snd_seq_oss,snd_seq_midi_event
snd_timer 12110 2 snd_pcm,snd_seq
snd_seq_device 3821 2 snd_seq_oss,snd_seq
snd 34340 12 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_seq_oss,snd_seq,snd_timer,snd_seq_device
snd_page_alloc 4709 2 snd_hda_intel,snd_pcm

Modprobe Conf ---------------------------------------------
alias char-major-14-* soundcore
alias char-major-116-* snd
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss

Proc Asound -----------------------------------------------
Advanced Linux Sound Architecture Driver Version 1.0.24-5.16rc5.
Compiled on Apr 12 2011 for kernel (SMP).
0 [PCH ]: HDA-Intel - HDA Intel PCH
HDA Intel PCH at 0xfa600000 irq 33
1 [NVidia ]: HDA-Intel - HDA NVidia
HDA NVidia at 0xfa080000 irq 18
1: : sequencer
2: [ 0- 1]: digital audio playback
3: [ 0- 0]: digital audio playback
4: [ 0- 0]: digital audio capture
5: [ 0- 1]: hardware dependent
6: [ 0] : control
7: [ 1- 9]: digital audio playback
8: [ 1- 8]: digital audio playback
9: [ 1- 7]: digital audio playback
10: [ 1- 3]: digital audio playback
11: [ 1- 3]: hardware dependent
12: [ 1- 2]: hardware dependent
13: [ 1- 1]: hardware dependent
14: [ 1- 0]: hardware dependent
15: [ 1] : control
33: : timer
00-01: HDA Codec 1
01-03: HDA Codec 3
01-02: HDA Codec 2
01-01: HDA Codec 1
01-00: HDA Codec 0
00-00: ALC892 Analog : ALC892 Analog : playback 1 : capture 1
00-01: ALC892 Digital : ALC892 Digital : playback 1
01-03: HDMI 0 : HDMI 0 : playback 1
01-07: HDMI 0 : HDMI 0 : playback 1
01-08: HDMI 0 : HDMI 0 : playback 1
01-09: HDMI 0 : HDMI 0 : playback 1
Client info
cur clients : 2
peak clients : 2
max clients : 192

Client 0 : "System" [Kernel]
Port 0 : "Timer" (Rwe-)
Port 1 : "Announce" (R-e-)
Connecting To: 15:0
Client 15 : "OSS sequencer" [Kernel]
Port 0 : "Receiver" (-we-)
Connected From: 0:1

Dev Snd ---------------------------------------------------
controlC0 hwC2D3 midiC1D2 midiC3D1 pcmC0D4c pcmC1D3p pcmC2D3c pcmC3D2p
controlC1 hwC3D0 midiC1D3 midiC3D2 pcmC0D4p pcmC1D4c pcmC2D3p pcmC3D3c
controlC2 hwC3D1 midiC1D4 midiC3D3 pcmC0D5c pcmC1D4p pcmC2D4c pcmC3D3p
controlC3 hwC3D2 midiC1D5 midiC3D4 pcmC0D5p pcmC1D5c pcmC2D4p pcmC3D4c
hwC0D0 hwC3D3 midiC1D6 midiC3D5 pcmC0D6c pcmC1D5p pcmC2D5c pcmC3D4p
hwC0D1 midiC0D0 midiC1D7 midiC3D6 pcmC0D6p pcmC1D6c pcmC2D5p pcmC3D5c
hwC0D2 midiC0D1 midiC2D0 midiC3D7 pcmC0D7c pcmC1D6p pcmC2D6c pcmC3D5p
hwC0D3 midiC0D2 midiC2D1 pcmC0D0c pcmC0D7p pcmC1D7c pcmC2D6p pcmC3D6c
hwC1D0 midiC0D3 midiC2D2 pcmC0D0p pcmC1D0c pcmC1D7p pcmC2D7c pcmC3D6p
hwC1D1 midiC0D4 midiC2D3 pcmC0D1c pcmC1D0p pcmC2D0c pcmC2D7p pcmC3D7c
hwC1D2 midiC0D5 midiC2D4 pcmC0D1p pcmC1D1c pcmC2D0p pcmC3D0c pcmC3D7p
hwC1D3 midiC0D6 midiC2D5 pcmC0D2c pcmC1D1p pcmC2D1c pcmC3D0p seq
hwC2D0 midiC0D7 midiC2D6 pcmC0D2p pcmC1D2c pcmC2D1p pcmC3D1c timer
hwC2D1 midiC1D0 midiC2D7 pcmC0D3c pcmC1D2p pcmC2D2c pcmC3D1p
hwC2D2 midiC1D1 midiC3D0 pcmC0D3p pcmC1D3c pcmC2D2p pcmC3D2c

CPU -------------------------------------------------------
model name : Intel(R) Core(TM) i7-2600K CPU @ 3.40GHz
cpu MHz : 3392.280
model name : Intel(R) Core(TM) i7-2600K CPU @ 3.40GHz
cpu MHz : 3392.280
model name : Intel(R) Core(TM) i7-2600K CPU @ 3.40GHz
cpu MHz : 3392.280
model name : Intel(R) Core(TM) i7-2600K CPU @ 3.40GHz
cpu MHz : 3392.280

RAM -------------------------------------------------------
MemTotal: 3104160 kB
SwapTotal: 4192880 kB

Hardware --------------------------------------------------
00:00.0 Host bridge: Intel Corporation Device 0100 (rev 09)

Back to top
View user's profile Send private message 

Joined: 23 Feb 2009
Posts: 37

PostPosted: Wed 13 Apr 2011, 13:50    Post subject:  

OK. Could this be the problem?

Puppy shows:
snd 34340 12 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_seq_oss,snd_seq,snd_timer,snd_seq_device

Ubuntu shows:
snd 64181 13 snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device

Different modules. More interesting, Puppy alsa list
snd_hda_codec_hdmi, first and
snd_hda_codec_realtek,snd_hda_intel second.

Now to find out how that is generated or stored.
Back to top
View user's profile Send private message 

Joined: 23 Feb 2009
Posts: 37

PostPosted: Sun 24 Apr 2011, 22:43    Post subject: The Puppy Barked!  

Oh dancing with myself
Oh dancing with myself

Well I got it working, in a rather weird way. Also I forgot to mention earlier it works on every other distro I tried including two Windows flavors. I md5sumed the download, verified the burn and dd checked the burn. Even did it again with a new download.

I tried copying parts of working modprobe.d and alsa conf etc from other working distros including Quirky 142.

Installed the Realtek drivers and new alsa drivers, matching libs and utilities many times changing things keeping notes and reinstalling puppy.

I've read every audio file and script at least once trying to figure out why the last step was being blocked. Googled and googled. Nothing.

Tried compiling new kernels with newer hardware support, the newest stable and a patched one from Barrys's test page, compiled with and without the DOTconfig file, The ones without the DOTconfig file just locked up the puppy. Read the config file and found hardware dep turned off, turned it on and compiled again. Nothing.

Gave up again. Third time I think, I really wanted my puppy to bark. I'm running an i7 sandybridge. so I don't NEED Puppy, I just like it and spend more time here than on any other OS. He's a zippy puppy. ('Very Happy') I process audio and video so the fast machine.

Got to thinking. I had changed every variable except one. Puppy itself. I installed Quriky and proceeded to steal it's kernel and vmlinuz, rebooted. The Puppy barked! I had to change some other things to make everything else work.

I tried one more compile with the DOTconfig from Quirky to see if it was the config. Yeah too much time on my hands but I don't like fixing things and not knowing how. No bark. I haven't tried compiling in a different OS so I don't know if its some weirdness in the structure of 525 or what. If I decide to pursue this I.ll have to set up a test puppy, I'm tired of fixing the dual monitor setup.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [4 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Audio
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0546s ][ Queries: 11 (0.0125s) ][ GZIP on ]