Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 26 Nov 2014, 01:20
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
UnionFS Problems While Customizing Puppy
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count_1  
Author Message

Joined: 05 Mar 2006
Posts: 5

PostPosted: Sun 05 Mar 2006, 20:32    Post_subject:  UnionFS Problems While Customizing Puppy  

I was working on making a custom Puppy when I had this problem. The Puppy will be Developer Puppy or something. It will include the Java, gcc, and python compilers/interpreters, as well as a programming game I like called robocodeng. The game involves programming battle robots using Java, which is the reason I decided to make this CD. I still have all the files on my hard drive.
I looked through Puppy's startup scripts and found that, on startup, it loads usr_cram.fs, usr_devx.sfs, and usr_more.sfs (if found). I installed Java into a temporary loop filesystem, then made a squashfs- usr_more.sfs. Then I installed RobocodeNG into /usr/local/games/RobocodeNG and created a script in /usr/local/bin to launch it.
I cleared the loop filesystem (ext2) and moved robocode into it. Then I used unionfs to mount it and the current usr_more.sfs in a directory, then made a new squashfs. I moved the new squashfs to usr_ more.sfs (saving the old one) and rebooted.
Here's the problem: a directory is missing. In /.usr_more (where the actual file is mounted), the local/games/RobocodeNG directory shows up. When everything is unioned into /usr, the directory is missing, but the /usr/local/bin/robocodeng script is still there. Java is also still there.
I think this is a problem with unionfs. What did I do wrong?

PS: Oh, yeah. Earlier I tried to put RobocodeNG in usr_cram.fs. When I tried to boot Puppy again, it came up with a random assortment of colored pixels and a mouse pointer that wouldn't move. I restored the original usr_cram.fs and it seemed to work again.
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count_1  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

You cannot attach files in this forum
You can download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0452s ][ Queries: 11 (0.0099s) ][ GZIP on ]