Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 02 Sep 2015, 06:29
All times are UTC - 4
 Forum index » Taking the Puppy out for a walk » Suggestions
burniso2cd feature request
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [6 Posts]  
Author Message
jcoder24


Joined: 06 May 2005
Posts: 601
Location: Barbados

PostPosted: Fri 03 Mar 2006, 23:38    Post subject:  burniso2cd feature request  

I currently have an external usb cdrom that I was unable to use in puppy prior to MUT. Even the current version of pmount loads the correct modules but doesn't list the cdrom as a device that can be mounted.

Burniso2cd works fine for ide drives but for my usb cd burner it ejects the cd without burning although it says that the process was completed successfully. The command used when trying to burn my cd was cdrecord -data -eject -v speed=4 dev=ATAPI:/dev/scd0 /mnt/home/puppy-unleashed/puppy-1.0.8-mozilla.iso

My requests therefore are that burniso2cd:
1 Load drivers for external usb (and scsi cdrom) before starting (or this can be built into the cdwizard)
2 Test if to use atapi or scsi emulation before starting the burn process.
Back to top
View user's profile Send private message 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7456
Location: Perth, Western Australia

PostPosted: Sat 04 Mar 2006, 02:19    Post subject:  

I don't have a usb cd drive to test with, which is going to severely restrict what I can do.

But, can you determine a cdrecord executed from the commandline that does work?
What happens if you execute that command without the "ATAPI"?:
cdrecord -data -eject -v speed=4 dev=/dev/scd0 /mnt/home/puppy-unleashed/puppy-1.0.8-mozilla.iso

What do you get if you execute:
cdrecord -scanbus
Back to top
View user's profile Send private message Visit poster's website 
jcoder24


Joined: 06 May 2005
Posts: 601
Location: Barbados

PostPosted: Sat 04 Mar 2006, 09:17    Post subject:  

# cdrecord --scanbus
Cdrecord-Clone 2.01.01a03 (i686-pc-linux-gnu) Copyright (C) 1995-2005 Jörg Schilling
Linux sg driver version: 3.1.25
Using libscg version 'schily-0.8'.
scsibus0:
0,0,0 0) 'IOMEGA ' 'CDRW6402EXT-B ' 'OOX1' Removable CD-ROM
0,1,0 1) *
0,2,0 2) *
0,3,0 3) *
0,4,0 4) *
0,5,0 5) *
0,6,0 6) *
0,7,0 7) *

# cdrecord -data -blank=fast -eject -v speed=4 dev=/dev/scd0 /mnt/home/puppy-unleashed/puppy-1.0.8-mozilla.iso
cdrecord: No write mode specified.
cdrecord: Asuming -tao mode.
cdrecord: Future versions of cdrecord may have different drive dependent defaults.
cdrecord: Continuing in 5 seconds...
Cdrecord-Clone 2.01.01a03 (i686-pc-linux-gnu) Copyright (C) 1995-2005 Jörg Schilling
TOC Type: 1 = CD-ROM
scsidev: '/dev/scd0'
devname: '/dev/scd0'
scsibus: -2 target: -2 lun: -2
Warning: Open by 'devname' is unintentional and not supported.
cdrecord: Read-only file system. Cannot open '/dev/scd0'. Cannot open SCSI driver.
cdrecord: For possible targets try 'cdrecord -scanbus'.
cdrecord: For possible transport specifiers try 'cdrecord dev=help'.

# cdrecord -data -blank=fast -eject -v speed=4 dev=0,0,0 /mnt/home/puppy-unleashed/puppy-1.0.8-mozilla.iso
is the command that works for me, ie it behaves treats it like a scsi device.
Back to top
View user's profile Send private message 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7456
Location: Perth, Western Australia

PostPosted: Mon 06 Mar 2006, 04:17    Post subject:  

Thanks, I think you've given me enough info to fix burniso2cd.
Back to top
View user's profile Send private message Visit poster's website 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7456
Location: Perth, Western Australia

PostPosted: Mon 06 Mar 2006, 09:01    Post subject:  

Try this...
burniso2cd.gz
Description 
gz

 Download 
Filename  burniso2cd.gz 
Filesize  2.21 KB 
Downloaded  305 Time(s) 
Back to top
View user's profile Send private message Visit poster's website 
jcoder24


Joined: 06 May 2005
Posts: 601
Location: Barbados

PostPosted: Mon 06 Mar 2006, 19:12    Post subject:  

It now burns the iso successfully. However, I still have to run mut or pmount first so it can detect the ext. usb cdrom.

This is the output from running burniso2cd

Code:

Now executing:
 cdrecord  -data -eject -v speed=4 dev=ATAPI:0,0,0 /mnt/home/puppy-unleashed/puppy-1.0.8-mozilla.iso
...done
eject: unable to find or open device for: `0,0,0'


It stills ejects the cdrom although it complained.
burn2iso2.png
 Description   After running mut or pmount
 Filesize   8.55 KB
 Viewed   1738 Time(s)

burn2iso2.png

burn2iso1.png
 Description   Before running mut or pmount
 Filesize   8.09 KB
 Viewed   1761 Time(s)

burn2iso1.png

Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [6 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Taking the Puppy out for a walk » Suggestions
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0454s ][ Queries: 13 (0.0118s) ][ GZIP on ]