Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 21 Dec 2014, 14:08
All times are UTC - 4
 Forum index » Off-Topic Area » Programming
puppy and eclipse
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
thegreatwildbeast666

Joined: 02 Mar 2011
Posts: 1

PostPosted: Thu 03 Mar 2011, 13:06    Post_subject:  puppy and eclipse
Sub_title: i need a lot of help
 

Ok first of all I am completely new to Linux. Second of all my situation is kind of different. I have 3 pieces of hardware right now and that's all I have. I have a Droid x running on Verizon, an external 500g hard drive and a Sony laptop from 2003. I installed puppy on the laptop and it runs great! I love Linux even though I am just starting. Both hard drive and phone work as USB removable storage just fine but I would like more. Here are my goals :
To install Java / eclipse
To install android sdk
To tether my phone to my laptop vie USB.
To develop both Linux apps and droid apps.

I do not have a working wifi card for the laptop so tether must be via USB.
Here's what I downloaded :
Jdk-6u24-linux-i586-rpm.bin
Eclipse-sdk-3.6.2-linux-gtk.tar.gs

I extracted the contents of both and put it all in the same folder but eclipse only flashes the startup screen and then dies. I am sure that I did many things wrong. Any help on achieving my goals as far as install and tether would be awesome!!! Thank you so,much
Back to top
View user's profile Send_private_message 
GustavoYz


Joined: 07 Jul 2010
Posts: 897
Location: .ar

PostPosted: Thu 03 Mar 2011, 15:45    Post_subject:  

Java

Eclipse doesn't need installation if you alreadt have Jre.

_________________


Edited_time_total
Back to top
View user's profile Send_private_message 
jsssh

Joined: 03 Mar 2011
Posts: 4

PostPosted: Thu 03 Mar 2011, 17:12    Post_subject: puppy and eclipse  

I'm having the same problem.
The funny thing is that I had it working well just yesterday
using the .sfs files provided by TheAsterisk!

Here's how I got it working yesterday:
Download, extract these two
<http://www.silverdollarsolutions.com/PuppyLinux/asterisk/jdk-1.6u24-i586.sfs.zip>
<http://www.silverdollarsolutions.com/PuppyLinux/asterisk/eclipse_sdk-3.6.1.sfs.zip>

Because I have done a Full hard drive installation
of Puppy I had to follow the directions given here:
<http://puppylinux.com/development/compileapps.htm>
under the heading:
Full hard drive installation

The start of the (long) error log follows:

--------------- T H R E A D ---------------

Current thread (0x080c3c00): JavaThread "main" [_thread_in_native, id=8536, stack(0xbfee5000,0xbff35000)]

siginfo:si_signo=SIGSEGV: si_errno=0, si_code=1 (SEGV_MAPERR), si_addr=0xbff36000

Registers:
EAX=0xbff36000, EBX=0xb242dc7c, ECX=0xbff33084, EDX=0xb2843102
ESP=0xbff32010, EBP=0xbff32038, ESI=0x083b6588, EDI=0xbff33080
EIP=0xb23f0b18, CR2=0xbff36000, EFLAGS=0x00210282

Register to memory mapping:

EAX=0xbff36000
0xbff36000 is pointing to unknown location

EBX=0xb242dc7c
0xb242dc7c: <offset 0x84c7c> in /usr/lib/libxpcom_core.so at 0xb23a9000

[url][/url]
Back to top
View user's profile Send_private_message 
jsssh

Joined: 03 Mar 2011
Posts: 4

PostPosted: Thu 03 Mar 2011, 19:06    Post_subject: puppy and linux  

I think SeaMonkey browser does something funky with libxpcom_core.so
When I take SeaMonkey out Eclipse works fine
Shrug
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Off-Topic Area » Programming
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0450s ][ Queries: 11 (0.0035s) ][ GZIP on ]