Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 23 Aug 2019, 16:28
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
The Official Release of Lucid 5.25 (Lucid Five Twenty-Five)
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 62 of 129 [1925 Posts]   Goto page: Previous 1, 2, 3, ..., 60, 61, 62, 63, 64, ..., 127, 128, 129 Next
Author Message
playdayz


Joined: 25 Apr 2008
Posts: 3794

PostPosted: Sat 26 Mar 2011, 18:26    Post subject:  

Quote:
everything seems OK, except for one quirk in restoring my previous custom configuration from Puppy 5.2. I overwrote the stock PuppyPin and globicons in /root/Choices/ROX-Filer with the ones I backed up from 5.2, and restarted X; the positions and functions of the desktop icons I got were the same as I had in 5.2, but the non-standard icons themselves were not, even though my globicons file listed correct matches between the programs I wanted to run and the existing icons I wanted to display.

Hey Pa, Courtesy of 01micko we now have Desksetup Icon Templates under Desktop Settings, which will Save and load different desktop icon arrangements. It should be good for restoring icons after upgrading.
Back to top
View user's profile Send private message 
James C


Joined: 26 Mar 2009
Posts: 6734
Location: Kentucky

PostPosted: Sat 26 Mar 2011, 18:28    Post subject:  

playdayz wrote:
Quote:
everything seems OK, except for one quirk in restoring my previous custom configuration from Puppy 5.2. I overwrote the stock PuppyPin and globicons in /root/Choices/ROX-Filer with the ones I backed up from 5.2, and restarted X; the positions and functions of the desktop icons I got were the same as I had in 5.2, but the non-standard icons themselves were not, even though my globicons file listed correct matches between the programs I wanted to run and the existing icons I wanted to display.

Hey Pa, Courtesy of 01micko we now have Desksetup Icon Templates under Desktop Settings, which will Save and load different desktop icon arrangements. It should be good for restoring icons after upgrading.


Been working fine here when I do an upgrade test. Smile
Back to top
View user's profile Send private message 
majorfoo

Joined: 07 Mar 2011
Posts: 449
Location: Wish I knew

PostPosted: Sat 26 Mar 2011, 19:57    Post subject:  

playdayz wrote:


By all means. IMHO, the best way to contribute to that is to participate in the development of Puppy--a new one will be starting reasonably soon after the release of Lucid 5.2.1.

BTW, I have always found not being seen to be a pretty good defensive tactic Wink


i trust this means that you are not retiring and will be guiding us through another exciting version
Back to top
View user's profile Send private message 
playdayz


Joined: 25 Apr 2008
Posts: 3794

PostPosted: Sat 26 Mar 2011, 21:36    Post subject:  

Quote:
i trust this means that you are not retiring and will be guiding us through another exciting version

No, this is my swan song. I am looking forward to seeing what comes next.

I should have said " a new Puppy" will be starting soon....
Back to top
View user's profile Send private message 
cthisbear

Joined: 29 Jan 2006
Posts: 4424
Location: Sydney Australia

PostPosted: Sat 26 Mar 2011, 22:15    Post subject:  

I repeat the question.

Puppy Studio is configured to work on this monitor.

http://murga-linux.com/puppy/viewtopic.php?t=65136&start=720

What did he do to make it show up?

This might help newbies with black screens.

Chris.
Back to top
View user's profile Send private message 
rerwin


Joined: 24 Aug 2005
Posts: 1949
Location: Maine, USA

PostPosted: Sun 27 Mar 2011, 00:06    Post subject: Updated i915 black screen problem fix  

playdayz,
While working on the issue of updating to luci255, I discovered that the fix for the black screen on the problematic Intel 82845/i915 graphics controller is not staying in effect long enough, causing the problem to return after a successful bootup.

The cause is the "sundown" factor I included, to ensure the fix did not remain if the graphics card were removed. It expired after 30 seconds, on the assumption that is was needed only for initialization of the controller at bootup. But it appears to also be needed when X is restarted.

The included package changes the sundown technique so the the fix remains throughout each puppy session. Please include it in Luci before releasing 5.2.1. Otherwise, Luci can still be a problem for the affected users, only more randomly than with no fix for the problem.

EDIT: When I boot from the 257 CD, I do not see a problem with the black screen, even after the fix (an options statement for i915) is removed for the session. But it does occur consistently when I test the modem-modprobe package. So, something seems to trigger reloading of the i915 module during X-server restart, in that environment. Therefore, while it does not appear to be a problem in 257, it appears that it is possible that the module has to be reloaded, so needs the fix in place all the time -- I just can't see it in 257.

With that stated, I will understand if you choose to not include this corrected fix, at this late point in the release cycle. I can include it in the modem-modprobe package, if necessary, where it seems to be essential.

Another thing I have observed in my testing are error messages in /tmp/xerr.log related to the i915 DRI files:
Quote:
(EE) AIGLX error: dlopen of /usr/lib/dri/i915_dri.so failed (/usr/lib/dri/i915_dri.so: cannot open shared object file: No such file or directory)
(EE) AIGLX: reverting to software rendering
(EE) AIGLX error: dlopen of /usr/lib/dri/swrast_dri.so failed (/usr/lib/dri/swrast_dri.so: cannot open shared object file: No such file or directory)
(EE) GLX: could not load software renderer
The messages also occur with the original 257. Should those files be present? It would seem to defeat the purpose of including i915, if pieces are missing.

Thanks for all your effort with Luci.
Richard
i915_modeset0-0.2.pet
Description  Corrected fix for Intel 82845 graphics controllers experiencing a black screen lockup
on bootup or restart of X server.
pet

 Download 
Filename  i915_modeset0-0.2.pet 
Filesize  1.08 KB 
Downloaded  426 Time(s) 

Last edited by rerwin on Sun 27 Mar 2011, 00:45; edited 1 time in total
Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 12463
Location: S.C. USA

PostPosted: Sun 27 Mar 2011, 00:17    Post subject:  

Quote:
Has anyone heard bad things about Flashplayer 10.2.153?

Seems to work OK for me.
Downloaded and installed the version 10.2.153.1 one and it works OK.
Back to top
View user's profile Send private message 
Lobster
Official Crustacean


Joined: 04 May 2005
Posts: 15460
Location: Paradox Realm

PostPosted: Sun 27 Mar 2011, 00:38    Post subject:  

Both Lucid Xchat (PPM) and Pidgin (Quickpet) no longer go to the Puppy Linux IRC chat by default. They did previously in Luci betas, can we go back to this compromise of no longer having a chat icon? Cool
_________________
Raspberry Pi 4 to run Puppi
NEW Slackware Current ScPup 32 and 64bit
Back to top
View user's profile Send private message Visit poster's website 
James C


Joined: 26 Mar 2009
Posts: 6734
Location: Kentucky

PostPosted: Sun 27 Mar 2011, 00:44    Post subject:  

playdayz wrote:
Has anyone heard bad things about Flashplayer 10.2.153?


Have watched a bunch of videos with 10.2 r153 ......seems fine here too.Tested in Firefox 4.
Back to top
View user's profile Send private message 
playdayz


Joined: 25 Apr 2008
Posts: 3794

PostPosted: Sun 27 Mar 2011, 01:05    Post subject:  

Quote:
(EE) AIGLX error: dlopen of /usr/lib/dri/i915_dri.so failed (/usr/lib/dri/i915_dri.so: cannot open shared object file: No such file or directory)
(EE) AIGLX: reverting to software rendering
(EE) AIGLX error: dlopen of /usr/lib/dri/swrast_dri.so failed (/usr/lib/dri/swrast_dri.so: cannot open shared object file: No such file or directory)
(EE) GLX: could not load software renderer
The messages also occur with the original 257. Should those files be present

No worries here. This is expected behavior. The dri files are what is installed by Xorg_High. It seems to do no harm to set everything up for them though--this way there is no need to rewrite xorg.conf. The default state is basic graphics, then when Xorg_High is installed and is restarted there are the open source glx graphics.

And thanks for staying with the original puzzle.
Back to top
View user's profile Send private message 
Sage

Joined: 04 Oct 2005
Posts: 5480
Location: GB

PostPosted: Sun 27 Mar 2011, 02:35    Post subject:  

Glad to report everything working well, including FULL upgrade.
Please do not alter the initial status of firewall. Please don't pander to the tiny number who still want to duel(sic) boot with the Devil. Virii, trojans and worms don't just happen when you boot up, you have to do something stupid to capture them! ISP s run generalised firewalls, there's another configurable one in every router - how many does it take? Some folks (or their WAGS) just don't read/listen to good advice. In my day, only the girls (yes, they were girls then, hardly women yet) wrote and ran programs - what happened? Now they they just want to pick up another 'dozey PC when they run into a brickwall. We seem extra lucky with Jewel, but where are the others?
Anyone for Haiku?!
Back to top
View user's profile Send private message 
taichifu

Joined: 08 Dec 2006
Posts: 67

PostPosted: Sun 27 Mar 2011, 04:11    Post subject: Has to connect NIC on every bootup  

Problem with Lucid Puppy 5.2.1beta "256", did a full hard drive install everything went OK until a few days ago when I have to connect my ETH01, then on reboot I have to do the same never had this problem before.Is there a quick fix for this problem or is it a bug in this beta version. Ah! CUPS is a pain the Butt.
Otherwise all seems OK in this latest beta release.

Cheers
Back to top
View user's profile Send private message 
wuwei


Joined: 15 Sep 2007
Posts: 801
Location: formerly de; now in tranquility

PostPosted: Sun 27 Mar 2011, 04:49    Post subject:  

Quote:
Have watched a bunch of videos with 10.2 r153 ......seems fine here too.Tested in Firefox 4.


Confirmed.
FF4.0 with 10.2r153 plays fine.
Back to top
View user's profile Send private message 
Terryphi


Joined: 02 Jul 2008
Posts: 768
Location: West Wales, Britain.

PostPosted: Sun 27 Mar 2011, 05:54    Post subject:  

James C wrote:
playdayz wrote:
Has anyone heard bad things about Flashplayer 10.2.153?


Have watched a bunch of videos with 10.2 r153 ......seems fine here too.Tested in Firefox 4.


It also works fine with Opera 11.10 beta and Chromium browser 12.0.716.0.
Back to top
View user's profile Send private message 
Béèm


Joined: 21 Nov 2006
Posts: 11775
Location: Brussels IBM Thinkpad R40, 256MB, 20GB, WiFi ipw2100. Frugal Lin'N'Win

PostPosted: Sun 27 Mar 2011, 09:36    Post subject:  

Flashplayer 10.2.153 seems to work OK in SeaMonkey 2.0.13
_________________
Time savers:
Find packages in a snap and install using Puppy Package Manager (Menu).
Consult Wikka
Use peppyy's puppysearch
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 62 of 129 [1925 Posts]   Goto page: Previous 1, 2, 3, ..., 60, 61, 62, 63, 64, ..., 127, 128, 129 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1890s ][ Queries: 12 (0.0754s) ][ GZIP on ]