Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 28 Nov 2014, 22:45
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
The Official Release of Lucid 5.25 (Lucid Five Twenty-Five)
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 71 of 129 [1925 Posts]   Goto page: Previous 1, 2, 3, ..., 69, 70, 71, 72, 73, ..., 127, 128, 129 Next
Author Message
bigpup


Joined: 11 Oct 2009
Posts: 5402
Location: Charleston S.C. USA

PostPosted: Thu 31 Mar 2011, 00:04    Post subject:  

Fresh frugal install Lucid 522.
In browser installer.
Select Iron browser.
List of Iron browsers has programs other than Iron.
Iron browser installer.jpg
 Description   
 Filesize   19.87 KB
 Viewed   1096 Time(s)

Iron browser installer.jpg

Back to top
View user's profile Send private message 
01micko


Joined: 11 Oct 2008
Posts: 7841
Location: qld

PostPosted: Thu 31 Mar 2011, 01:01    Post subject:  

Hi bigpup

I can confirm and also fix....

BUT!

What annoys me is that we have hundreds of testers yet not one discovered this? It was introduced on 2101202.

Here's the comment I made in the quickpet script.

Quote:
GRABPET=`grep -i "$THEPET" $CONFFILE | cut -d '|' -f8|grep -i "$THEPET"` #changed from grep -iw call #20101202 bigpup


Ok, you can blame me, it's my code. But I just discovered a bug (and fix) reported here to do with rox being slow. The bug is in shino's countrywizard script. Again, an easy fix but how come no body found it until the twelfth hour?

I know I put in enough time trying to fix this stuff and do my best as do I'm sure shino and every other coder out there. This is in no way a spray toward you bigpup as you have been instrumental in finding bugs, but I'm sure as hell is down that you aren't the only one to see this.

I'll post playdayz the fixes but I'm sure he's a bit tired of all the "last minute" bugs surfacing when we hardly had a bug report in the preceding month! Rolling Eyes

(Don't mind me, jus' lettin' off some steeam )

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
James C


Joined: 26 Mar 2009
Posts: 5940
Location: Kentucky

PostPosted: Thu 31 Mar 2011, 01:10    Post subject:  

01micko wrote:

(Don't mind me, jus' lettin' off some steeam )


Chrome and Iron won't even run on my computers............ Laughing
Back to top
View user's profile Send private message 
James C


Joined: 26 Mar 2009
Posts: 5940
Location: Kentucky

PostPosted: Thu 31 Mar 2011, 01:14    Post subject:  

Still better than seeing this.....
default16.png
 Description   
 Filesize   1.6 KB
 Viewed   1100 Time(s)

default16.png

Back to top
View user's profile Send private message 
01micko


Joined: 11 Oct 2008
Posts: 7841
Location: qld

PostPosted: Thu 31 Mar 2011, 01:21    Post subject:  

James C wrote:
Still better than seeing this.....


Laughing

I don't use iron or chromium much either.. only time recently was in spup testing.

(ps, bigpup, check tour PMs)

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
Terryphi


Joined: 02 Jul 2008
Posts: 763
Location: West Wales, Britain.

PostPosted: Thu 31 Mar 2011, 01:32    Post subject:  

bigpup wrote:
Terryphi wrote:
Suddenly I find that Skype and retrovol are broken. I think that the broken retrovol crashes Skype when it is opened.

Here is the result when retrovol is run from terminal:

# retrovol
retrovol: hcontrol.c:573: snd_hctl_load: Assertion `hctl->count == 0' failed.
Aborted

Using the Alsa Sound Wizard I can select the correct driver and configure it but at the sound test I see this error at terminal:

Amixer: Mixer attach default error: No such file or directory

Consequently there is no sound volume.

LATER: Oh, and the retrovol tray icon has disappeared. I think we need something more retro than retrovol that works reliably!

If this is a frugal install of Puppy.
Run a file system check.
There is a chance the file system got corrupted.
Did you uninstall any audio programs before this happened?


Yes, it is a frugal install. No, I haven't uninstalled any audio programs. I have pfix=fsck in the menu.lst entry so there is a file system check at every boot.

The only thing I had done which may be relevant was try changing webcam usb port from front to back and similar for microphone connection. For various reasons I then changed back to front connections.
Back to top
View user's profile Send private message Visit poster's website 
mavrothal


Joined: 24 Aug 2009
Posts: 1810

PostPosted: Thu 31 Mar 2011, 02:07    Post subject:  

01micko wrote:

I know I put in enough time trying to fix this stuff and do my best as do I'm sure shino and every other coder out there. This is in no way a spray toward you bigpup as you have been instrumental in finding bugs, but I'm sure as hell is down that you aren't the only one to see this.

I do not really know if puppy 5.2.x is the end of the road but if not you may want to consider a bug tracker for the next release.
Combine it with a public git, cvs, bones, for sources and build scripts and you got a "professional" distro (in the sense that is really much easier to identify, track and correct problems).
Though I'm afraid this may not change "enthusiastic users" to "testers" Rolling Eyes

_________________
Kids all over the world go around with an XO laptop. They deserve one puppy (or many) too Very Happy
Back to top
View user's profile Send private message 
Sage

Joined: 04 Oct 2005
Posts: 4819
Location: GB

PostPosted: Thu 31 Mar 2011, 04:15    Post subject:  

Don't usually use .delta files to upgrade but thought I'd give it a spin this time around. The script doesn't seem to work for FULL installs. It asks for the old .iso. Doesn't exist in FULL - everything is decompressed!

So, I resorted to my usual method, liveCD, pfix=ram, etc.
Only the k/b setting remained at UK, all the other localisations returned to USA, except timezone = Peranjori. [Beats me why an Aussie distro defaults to USA!].
If we cannot have all Oz defaults, please can the initial settings panel display every time any changes are made?

re. the Chrome/Iron dispute, I gave up on both due to suspicion about Google data mining and Iron controversies + size.

That just leaves guy-on-a-bike to be added...
Back to top
View user's profile Send private message 
nooby

Joined: 29 Jun 2008
Posts: 10557
Location: SwedenEurope

PostPosted: Thu 31 Mar 2011, 05:58    Post subject:  

ooooh what is Iron controversies? Yes too big but in what way is Iron a controversy to us or anybody? Sorry if it derail.

One way to not get upset over bug found too close to a planned release would be to not set a fix date. Running update. It updates when one feel for it? Not a fix date. On the other hand one maybe need a date to get the enthusiasm kept on high enough motivation to get people engaged in the project?

I rather wish you put the release forwared some month or two to have time to include the shutdown choices that some of us want to be included.

To be able to just click on a sfs file to load and use it and then to click somewhere and it goes back outside of pupsave to be able to be reused again.

Such inclusiveness would be very good to have. Flexibility/Portable apps sort of.

I know too little. Only do it if you feel for it. Computing should be fun. I only suggest what could be fund to include Smile

_________________
I use Google Search on Puppy Forum
not an ideal solution though
Back to top
View user's profile Send private message 
Terryphi


Joined: 02 Jul 2008
Posts: 763
Location: West Wales, Britain.

PostPosted: Thu 31 Mar 2011, 06:10    Post subject:  

I resolved the Skype retrovol issue reported earlier in the thread by updating to 522 using a savefile from 520. For me Skype requires the firewall to be off to make a connection. Also, retrovol settings need quite a bit of tweaking because some that are needed are not available by default - most importantly the Input Source setting for the microphone!. This can of course be selected by right clicking on the volume icon on the tray and selecting Configure Window. However, this is far from user friendly. For safety after setting up to my satisfaction I deselected the Skype setting "Allow Skype to amend my mixer settings" in case it messed anything up. Inevitably, there is a bit of a trade off between settings for Skype and other programs.

Good news on the Chromium browser front. On initial testing My SFS of Chromium 12.0.716 works fine on my hardware. I suspect there may be a bug in the password manager (or its interaction with the exceptions feature) so I advise selecting the "Never save passwords" setting.

Opera 11.10 beta, as usual, works perfectly.

There is one small niggle, admittedly an obsession of mine, that locale settings are overwritten on upgrade. Barry has fixed this in Wary and it would be good to see it fixed in Lupu.

All in all, Lupu 522 is looking good for my needs. Thanks to all concerned. Smile
Back to top
View user's profile Send private message Visit poster's website 
Terryphi


Joined: 02 Jul 2008
Posts: 763
Location: West Wales, Britain.

PostPosted: Thu 31 Mar 2011, 06:18    Post subject:  

01micko wrote:
Hi bigpup

I can confirm and also fix....

BUT!

What annoys me is that we have hundreds of testers yet not one discovered this? It was introduced on 2101202.


Well to be very frank that is because some of us don't like the Quickpet feature and don't test it. Inevitably we only find the time to test the features we find useful and all Puppy variants have plenty of features we don't find useful so please don't be offended!
Back to top
View user's profile Send private message Visit poster's website 
Minnesota

Joined: 11 Sep 2008
Posts: 313

PostPosted: Thu 31 Mar 2011, 06:59    Post subject: Not a make or break  

01micko :

First and foremost! CONGRATULATIONS... five At a boys!!! YOU and the rest of the crew have done a bang up job in making this version of Puppy clean and efficient. You have catered to most of the request of users and testers in a very fast way.

SO don't let a few COSMETIC issues bother you. Years from now you can still find cosmetic issues. This Puppy RUNS... that is what is important. Perfect NEVER!

We who build anything from furniture to painting to software...always see the flaws.. but users not so much.

Step back a bit and congratulate yourselves... GOOD JOB!
Back to top
View user's profile Send private message 
Lobster
Official Crustacean


Joined: 04 May 2005
Posts: 15117
Location: Paradox Realm

PostPosted: Thu 31 Mar 2011, 07:01    Post subject:  

Quote:
GOOD JOB!

Well said - or shouted from the rooftops . . .

gonna do a fresh install of the 522
Just a report on stuff so far.

I tried using the CPU frequency tuning tool (under system) to
ensure Iplayer (uses flash) plays for longer than 15 minutes (did not help)

When playing (these are time consuming but fun tests)
videos (usually avi) in defaultmediaplayer, after about 50 mins
the sound makes a large continuous sound and the program locks -
have to do a ctrl + alt + backspace or x restart
VLC does not have this problem but is too large for Puppy
- we have to compromise and the current system is much better

'Business' (this is a woof error?) in ppm is still empty
- has been in every Lucid release

JWM I have been using in several of our latest test releases
and It has been working well Smile

_________________
Puppy WIKI
Back to top
View user's profile Send private message Visit poster's website 
tubeguy


Joined: 28 Aug 2009
Posts: 1332
Location: Park Ridge IL USA

PostPosted: Thu 31 Mar 2011, 07:08    Post subject: Re: Not a make or break  

Minnesota wrote:
01micko :

First and foremost! CONGRATULATIONS... five At a boys!!! YOU and the rest of the crew have done a bang up job in making this version of Puppy clean and efficient. You have catered to most of the request of users and testers in a very fast way.

SO don't let a few COSMETIC issues bother you. Years from now you can still find cosmetic issues. This Puppy RUNS... that is what is important. Perfect NEVER!

We who build anything from furniture to painting to software...always see the flaws.. but users not so much.

Step back a bit and congratulate yourselves... GOOD JOB!

Relevant: http://en.wikipedia.org/wiki/Perfect_is_the_enemy_of_good

_________________
MSI 970A-G46/AMD FX-8150/Plextor 128GB SSD/Corsair Vengeance 8GB: Tahr Pup 6
Back to top
View user's profile Send private message Visit poster's website 
ICPUG

Joined: 24 Jul 2005
Posts: 1290
Location: UK

PostPosted: Thu 31 Mar 2011, 08:04    Post subject:  

01micko wrote:
Hi bigpup

I can confirm and also fix....

BUT!

What annoys me is that we have hundreds of testers yet not one discovered this? It was introduced on 2101202.

Here's the comment I made in the quickpet script.

Quote:
GRABPET=`grep -i "$THEPET" $CONFFILE | cut -d '|' -f8|grep -i "$THEPET"` #changed from grep -iw call #20101202 bigpup


Ok, you can blame me, it's my code. But I just discovered a bug (and fix) reported here to do with rox being slow. The bug is in shino's countrywizard script. Again, an easy fix but how come no body found it until the twelfth hour?

...

I'll post playdayz the fixes but I'm sure he's a bit tired of all the "last minute" bugs surfacing when we hardly had a bug report in the preceding month! Rolling Eyes

(Don't mind me, jus' lettin' off some steeam )


I think 01micko is having a bad day!

If it helps we are all eternally grateful for what you, playdayz and the other devs do ...

The late reporting of bugs is probably due to a number of things. Here are 2.

Someone has already mentioned that many testers test only what they are interested in. I guess we don't have many interested in Chrome and Iron.

Seeing the rapid pace of development releases, even when it it just once a week, some users, who also want to have fun, will say they just cannot cope with the release schedule. They wait till the release candidate and then make last minute discoveries!
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 71 of 129 [1925 Posts]   Goto page: Previous 1, 2, 3, ..., 69, 70, 71, 72, 73, ..., 127, 128, 129 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1247s ][ Queries: 12 (0.0218s) ][ GZIP on ]