Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 29 Aug 2014, 14:10
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
lupu_devx_520 failed to install on puppy studio 3.3
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [13 Posts]  
Author Message
holala

Joined: 08 Feb 2011
Posts: 8

PostPosted: Thu 10 Feb 2011, 19:04    Post subject:  lupu_devx_520 failed to install on puppy studio 3.3  

after installing it with quickpet , it failes at the end of the installation with the message " error, lupu_devx_520 failed to install ..."

What is wrong in my setup and what can I do ?

Thanks,

Holala
Back to top
View user's profile Send private message 
Jim1911

Joined: 19 May 2008
Posts: 2455
Location: Texas, USA

PostPosted: Thu 10 Feb 2011, 19:17    Post subject:  

You need to provide more information about your installation ie. installation type (frugal or full hd), how many sfs files are you trying to boot? Then, maybe someone may be able to help.
Back to top
View user's profile Send private message 
holala

Joined: 08 Feb 2011
Posts: 8

PostPosted: Fri 11 Feb 2011, 15:05    Post subject:  

Here are some informations ....
Basic fresh full install on a PIII with 256 mo ram, no other sfs file, it can't be a more basic installation ... Just downloaded alsa-firmware on mediabuntu and other alsa-tools package on ubuntu lucid-lynx to connect my usb audio-card Tascam us224 ( it works ! ). But I need to compile rakarrack because a segmentation fault with the puppys studio's original program ...

Thanks for the help !

Holala
Back to top
View user's profile Send private message 
l0wt3ch
Guest


PostPosted: Fri 11 Feb 2011, 16:50    Post subject:  

Wait for 3.3 to be officially released.

Then write in and tell us if you still have that problem.
Back to top
PupGeek

Joined: 06 Sep 2009
Posts: 388

PostPosted: Sat 12 Feb 2011, 12:17    Post subject:  

sfs modules do not automatically load in a full install. in order to use it, you must either mount it and merge the directories, or, better yet, place it in a folder, write an AppRun script (thats right, make a roxapp) that will mount it and export all paths and make any necessary links and remove them after use. Being that you are attempting to install a devx module, I am assuming that you have some basic scripting knowledge, so I will not get into that here.
Back to top
View user's profile Send private message 
holala

Joined: 08 Feb 2011
Posts: 8

PostPosted: Sat 12 Feb 2011, 18:37    Post subject:  

I've created a /mnt/tempo directory and my first try to mount the sfs dev with :
mount -t squashfs -o loop /root/luppu_devx_520.sfs /mnt/tempo
give that :
wrong fs type, bad option, bad superblock ...
Back to top
View user's profile Send private message 
PupGeek

Joined: 06 Sep 2009
Posts: 388

PostPosted: Sun 13 Feb 2011, 10:32    Post subject:  

I hate that error, its so general. I got the same error when I tried to mount that sfs file in my puppy4.2, knowing it was the wrong version, and expecting it to error out... I just wanted to see what error it would give. I can't imagine it being a versioning issue, but It could be. I haven't tried puppy studio 3.3 enough yet to know for sure, so it may just need to use a squashfs 4.1 filesystem, or maybe not. My advice would be to load the cdrom in your drive, check the properties of the lupu_xxx.sfs file and see what version it is. if the versions of the two sfs's are the same, then the version is not the problem. Aside from that, I would not know what else it could be until I am able to try it out at home.
Back to top
View user's profile Send private message 
holala

Joined: 08 Feb 2011
Posts: 8

PostPosted: Sun 13 Feb 2011, 16:12    Post subject:  

cdrom puppy studio loaded, there's a lupu_520 sfs file ...

Arghh ... I'm lost in this strange puppy world !

Thanks for your help anyway !
Back to top
View user's profile Send private message 
PupGeek

Joined: 06 Sep 2009
Posts: 388

PostPosted: Sun 13 Feb 2011, 16:31    Post subject:  

Yes, there is supposed to be. What you need to do is right click on that file, select Properties, and at the bottom, it should provide a description of the file. In that description, it should say that is a squashfs and give the version number (i.e. 3.1, 4.0, etc...). That version number should be 4.0, but if it is a 4.1 (which I'm not sure is even available yet), then that would be the problem as the lupu_devx_520.sfs is a version 4.0 file.
Back to top
View user's profile Send private message 
holala

Joined: 08 Feb 2011
Posts: 8

PostPosted: Mon 14 Feb 2011, 18:47    Post subject:  

the two files : lupu_devx_520.sfs and lupu_520.sfs have the same version of squashfs file system : 4.0 ... maybe can i mount the devx.sfs on an other system, then copy all the files on a usb-key ... and merge them on the puppy studio system ...
Back to top
View user's profile Send private message 
Jim1911

Joined: 19 May 2008
Posts: 2455
Location: Texas, USA

PostPosted: Mon 14 Feb 2011, 20:19    Post subject:  

The Bootmanager does not work with a full hd installation. It only works for loading sfs files for a frugal installation. However, Lucid 5.2 has made the installation process very simple

Use Quickpet>Sfs Get and Click on the large button labeled GNU Compliler lupu_devx_520.sfs. It will download and convert the sfs to a pet file which is then installed on your full hd installation.

If you want to install additional sfs files that are not listed under tab Sfs Get, goto SFS>Sfs_grabber which will make the necessary conversion to a pet file so that it can be installed on a full hd installation.

If this procedure fails, give us complete information about what you were trying and what happened.
Back to top
View user's profile Send private message 
holala

Joined: 08 Feb 2011
Posts: 8

PostPosted: Tue 15 Feb 2011, 17:59    Post subject:  

ok, I will try a frugal install the next few days
Back to top
View user's profile Send private message 
holala

Joined: 08 Feb 2011
Posts: 8

PostPosted: Thu 17 Feb 2011, 18:40    Post subject:  

Finally, I discovered a lupu_devx_520.sfs in my root directory. ( I don't remember why i downloaded it ... ) I deleted it, reboot, downloaded again via quickpet->sfs the lupu_devx_520.sfs and installed it without any problem ...

I've just finished to compile "rakarrack" ( before I downloaded a fltk dev missing library in a ubuntu lucid lynx repository ) all seems OK ... but when I run it, I have immediately an "illegal instruction", as in the original puppy's rakarrack ... No luck !!!
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [13 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0616s ][ Queries: 11 (0.0038s) ][ GZIP on ]