Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 24 Oct 2014, 23:47
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Games
freeorion.sfs
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
666philb


Joined: 07 Feb 2010
Posts: 1776
Location: wales

PostPosted: Sun 30 Jan 2011, 08:45    Post_subject:  freeorion.sfs
Sub_title: turn-based space empire and galactic conquest
 

I don't know if this has already been posted on the forum.

FreeOrion is a free, open source, turn-based space empire and galactic conquest (4X) computer game being designed and built by the FreeOrion project. FreeOrion is inspired by the tradition of the Master of Orion games, but is not a clone or remake of that series or any other game.

Although the installer from the freeorion site works The game is 151mb's, which is why i made it into an .sfs. It should work with most modern puppies.
You will need opengl 2.0
this isn't working for some people with the xorg driver, as the opengl version is less than 2 which is required by openorion, see emils post below for how to check your version of opengl

Sickgut has kindly put the sfs on his server and it can be downloaded here....
http://www.thepussycatforest.info/linux/games/sfs4-lucid/freeorion_sfs4.sfs
MD5 efa77804c8117c9f51994032f596f33e

or a slower mirror here.....
http://uploadingit.com/d/4KALBQTEUAVGINWI

Alternatively, if the .sfs doesn't work for you can can download the original tar.gz ffrom here and run the 'setup.sh' file
http://sourceforge.net/projects/freeorion/files/FreeOrion/

Play guide here....http://www.freeorion.org/index.php/V0.4_Quick_Play_Guide

enjoy
666phil aka"MrFricks"

_________________
Tahrpup, built with trusty tahr packages http://murga-linux.com/puppy/viewtopic.php?t=93998
Quickpet_Precise, install popular apps quickly http://www.murga-linux.com/puppy/viewtopic.php?t=83642

Edited_time_total
Back to top
View user's profile Send_private_message 
ColdCactusKing

Joined: 29 Jan 2010
Posts: 10

PostPosted: Mon 07 Feb 2011, 18:33    Post_subject:  

Call me a newb but I downloaded the sfs and Im not sure what to do with it now...
Back to top
View user's profile Send_private_message 
666philb


Joined: 07 Feb 2010
Posts: 1776
Location: wales

PostPosted: Mon 07 Feb 2011, 18:48    Post_subject:  

hi coldcactusking

the sfs will only work if you have a frugal install (one with a save file). place the sfs in mnt/home then goto the 'menu' button, then select 'system' then select 'bootmanager config bootup', select the 'choose which sfs to load at bootup'. If you've placed the freeorion.sfs in mnt/home you should see it in the bootmanager window, highlight it and press add. This will then load everytime you boot, but won't take up space in your save file. you can remove it at anytime by going to the bootmanager, and moving it out of the load at start up window.

If you've got a full install, download the original tar.gz from the post above. click on it and extract it and run the 'setup.sh' file.

let me know if you have anymore problems

666philb

_________________
Tahrpup, built with trusty tahr packages http://murga-linux.com/puppy/viewtopic.php?t=93998
Quickpet_Precise, install popular apps quickly http://www.murga-linux.com/puppy/viewtopic.php?t=83642
Back to top
View user's profile Send_private_message 
ColdCactusKing

Joined: 29 Jan 2010
Posts: 10

PostPosted: Mon 07 Feb 2011, 19:03    Post_subject:  

Thank you I didnt realize that I needed a frugal install... But im downloading the source code and we shall see how things go thanks man!
Back to top
View user's profile Send_private_message 
ColdCactusKing

Joined: 29 Jan 2010
Posts: 10

PostPosted: Mon 07 Feb 2011, 23:35    Post_subject:  

Iv got it downloaded and installed but when I click on the icon in my menu nothing happens.... Im losing all faith in linux by the minute I cant seem to run anything besides pidgin and seamonkey... I click but nothing happens ever on anything im getting really pissed at this point...
Back to top
View user's profile Send_private_message 
666philb


Joined: 07 Feb 2010
Posts: 1776
Location: wales

PostPosted: Tue 08 Feb 2011, 13:38    Post_subject:  

Hi Coldcactusking,, can i ask what version of puppy you are using? also have you got your graphic cards drivers installed?

navigate to the folder with the game in, i think it's /usr/games/freeorion open a terminal there by right clicking in the window and selecting window/terminal here. and type

Code:
./freeorion
note that the name of your executable might be slightly different, for e.g. ./FreeOrion_1.2 or something. Make sure you type it exactly, including capitals. if there's are spaces in the name put it in quotes e.g. ./"freeorion 1.2" (and don't forget the fullstop at the start.)

this will run the game in the terminal and hopefully tell us what's missing

_________________
Tahrpup, built with trusty tahr packages http://murga-linux.com/puppy/viewtopic.php?t=93998
Quickpet_Precise, install popular apps quickly http://www.murga-linux.com/puppy/viewtopic.php?t=83642
Back to top
View user's profile Send_private_message 
ColdCactusKing

Joined: 29 Jan 2010
Posts: 10

PostPosted: Tue 08 Feb 2011, 14:16    Post_subject:  

Lucid Puppy 5.2 and yes my video drivers are installed all my drivers are set up I dont know what the issue is but I give up man thanks for your time though sorry it didnt work out... Im just gonna crawl back to windows and call it a day. I dont do much besides game anyway so Windows is my best bet.
Back to top
View user's profile Send_private_message 
666philb


Joined: 07 Feb 2010
Posts: 1776
Location: wales

PostPosted: Tue 08 Feb 2011, 15:06    Post_subject:  

Coldcactusking..... sorry to hear that! I understand that feeling well though, i found it difficult to start with on linux, when things that i wanted didn't immediately work, and having no idea how to solve the problem. It is a lot different to windows. My first use of linux was a year ago, Puppy was just something that i played with every now and again, but XP was my main OS. However over the year i started using puppy more and more, and now it's my main OS. I love it!.

I do feel pretty responsible though for you feeling that way as they were my pets that didn't work for you. What you probably don't know is that they were my first attempt at making pets and sfs's.(though they do actually work ....honest!!) The freeorion problem will be just one or two things needed that are in the PPM, Warzone2100 will be the same (presuming you downloaded the deps.pet as well)

i hope you don't give up on linux entirely

666philb

_________________
Tahrpup, built with trusty tahr packages http://murga-linux.com/puppy/viewtopic.php?t=93998
Quickpet_Precise, install popular apps quickly http://www.murga-linux.com/puppy/viewtopic.php?t=83642
Back to top
View user's profile Send_private_message 
ColdCactusKing

Joined: 29 Jan 2010
Posts: 10

PostPosted: Wed 09 Feb 2011, 04:16    Post_subject:  

I don't think you are in any responsible for the issues im having its not just your pet its any .pet or any source code or anything at all really. The problems im having are do to me not understanding what im doing. However I run it in the terminal and posted my results here [ http://www.murga-linux.com/puppy/viewtopic.php?t=64672 ] Hope this information is a little more useful. And also im sorry if my wording may seem a bit angry though this would make sense as I am a bit angry.. Rolling Eyes
Back to top
View user's profile Send_private_message 
666philb


Joined: 07 Feb 2010
Posts: 1776
Location: wales

PostPosted: Wed 09 Feb 2011, 15:25    Post_subject:  

Hi cold cactus king,

I just missed you in the puppylinux chat, didn't know you were there untill i saw the coldcactusking has left message.

Ah well, i would have told you this.....

Three options for you,

1. i'm downloading the freeorion tar.gz to run on a vanilla lupu520 puppy so i can see what deps you need(also so i can amend my post with the info) I will then tell you what they are, and also put them into a small pet for you. Problem is my internet is slow at the mo, so it won't be until later on or even tomorrow.

2. I've made the freeorion.sfs into a pet that you can install, i've tested and it works on a vanilla lupu520 with just my nvidia graphics drivers installed.
So you can either get the pet here http://dl.dropbox.com/u/19554672/freeorion.pet .

3...or if you're feeling adventurous and still have the sfs you downloaded, you can make it into a pet yourself (i should have thought of this)

make an empty folder called 'freeorion' . then clck on the freeorion sfs. it should say succesfully mounted. then copy all the contents of the sfs (if will be just a folder called usr) into the empty freeorion folder. then goto the directory where you can see your freeorion folder (up one) then right click in the window.. choose window then terminal here, type
Code:
dir2pet freeorion
it's then basically click ok to everything, then a gui comes up, click generate package, and after a few seconds your pet will appear!

as for warzone, i saw that you had problems, did you install the deps.pet from the post aswell?

cheers 666philb

_________________
Tahrpup, built with trusty tahr packages http://murga-linux.com/puppy/viewtopic.php?t=93998
Quickpet_Precise, install popular apps quickly http://www.murga-linux.com/puppy/viewtopic.php?t=83642
Back to top
View user's profile Send_private_message 
666philb


Joined: 07 Feb 2010
Posts: 1776
Location: wales

PostPosted: Thu 10 Feb 2011, 15:48    Post_subject:  

Well i download the tar.gz. then booted to a vanilla lucidpuppy520, installed just my nvidia graphics driver, installed the tar.gz, clicked on freeorion in the menu and it worked! no deps needed!

As to why it doesn't work on your lupu520, i can only think that you must have installed something which overwrote some of puppies core components, and then unistalled it, the unistall process removing the components all together, new and old.

Have you got a frugal install?, if so you can test this theory by booting with pfix ram, and trying freeorion then.
booting from cd.... press f2 (i think) for the boot menu. then type puppy pfix=ram
booting from grub on the grub menu, select your lucid puppy, and type the same as above

666philb

_________________
Tahrpup, built with trusty tahr packages http://murga-linux.com/puppy/viewtopic.php?t=93998
Quickpet_Precise, install popular apps quickly http://www.murga-linux.com/puppy/viewtopic.php?t=83642
Back to top
View user's profile Send_private_message 
emil

Joined: 10 Nov 2009
Posts: 618
Location: Austria

PostPosted: Sun 13 Feb 2011, 12:36    Post_subject:  

Hi 666phib,

i just tried your freeorion.sfs, but it didn't work in 5.11 and 5.20. I got
# ./freeorion
Following into my basedir
CWD: /usr/games/freeorion/application
libpython2.5.so.1.0 => not found
python2.5 missing. Using shipped version.
PYTHONHOME=python2.5
./freeorion: line 143: 23843 Segmentation fault ${FO_TRACE} ${FO_GDB_ARGS} ./freeorion --resource-dir ./default $@
#

beside that, the the symlink freeorion in /usr/bin is not working (it is absolute set to /mnt/sda3/...., it should be a relative symlink to ../games/freeorion/freeorion.

I load the original tarball and try to install it Very Happy
best
emil
Back to top
View user's profile Send_private_message Visit_website 
emil

Joined: 10 Nov 2009
Posts: 618
Location: Austria

PostPosted: Sun 13 Feb 2011, 13:07    Post_subject:  

Same negative result with the original tarball Confused !
I think it is because I - as recommneded by Quickpet - installed Xorg High.
But glxinfo gives just OpenGl version 1.4, whilst freeorion want minimum version 2.0.

Have others also experienced smth. similar? If yes, people should check their openGL version (with glxinfo in terminal) before download.

best Cool
emil
Back to top
View user's profile Send_private_message Visit_website 
666philb


Joined: 07 Feb 2010
Posts: 1776
Location: wales

PostPosted: Sun 13 Feb 2011, 15:09    Post_subject:  

emil

aaah! so that would be the problem then. Thankyou for posting, i'll add a note in the original post. it will save people a 150mb download. And thanks for pointing that symlink problem out, i'll fix that.

cheers

666philb

_________________
Tahrpup, built with trusty tahr packages http://murga-linux.com/puppy/viewtopic.php?t=93998
Quickpet_Precise, install popular apps quickly http://www.murga-linux.com/puppy/viewtopic.php?t=83642
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Games
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0773s ][ Queries: 11 (0.0034s) ][ GZIP on ]