Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 01 Jul 2015, 09:12
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Security/Privacy
TrueCrypt 7.0a
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
In the Doghouse

Joined: 03 Oct 2010
Posts: 6

PostPosted: Thu 27 Jan 2011, 16:46    Post_subject:  TrueCrypt 7.0a
Sub_title: .pet download fails - download from TrueCrypt.org has bad HELP

www.puppylinux.org/wikka/Truecrypt shows a Truecrypt-7.0a.pet download, but when clicked it just opens a web screen full of gibberish! Why can't I download the .pet?

So I downloaded Truecrypt 7.0a from the TrueCrypt.org web site, and installed. It runs well on my Lupu 510 install, except for the HELP menu items:

User's Guide, when clicked or Ctrl+H, RUNS GIMP!
All other HELP menu items, when clicked, RUN THE GEANY editor
Except that 'Legal Notices' and 'About' work properly

I have searched the web everywhere looking for solutions for the above - and can't find a single thing!

Any advice would be appreciated, cause TrueCrypt is an amazing software package.
Back to top
View user's profile Send_private_message 

Joined: 24 Sep 2009
Posts: 97

PostPosted: Thu 27 Jan 2011, 17:17    Post_subject:  

Right click on the link and save link target as... downloaded ok for me

Can't help with rest sorry
Back to top
View user's profile Send_private_message 
In the Doghouse

Joined: 03 Oct 2010
Posts: 6

PostPosted: Thu 27 Jan 2011, 21:35    Post_subject: TrueCrypt 7.0a
Sub_title: Inability to Download TrueCrypt .pet & TrueCrypt HELP Menu

Thanks to Mark for tip on downloading TrueCrypt .pet. For other .pets downloads, I have always been able to just left-click the download link to get the .pet package. The TrueCrypt .pet link, for reasons unknown to me, requires the right-click approach.

Because I was using Firefox with the InstaClick extension, which enables opening links in a new tab by using a single right-click, I was not seeing the normal right-click context menu, for downloading as Mark suggests. By disabling the InstaClick extension, I was finally able to download the TrueCrypt .pet and install it. Thanks again Mark.

BUT I STILL HAVE THE PROBLEM WITH THE TRUECRYPT HELP MENU, where HELP->User's Guide runs GIMP instead of showing the Guide, and the other Help menu items start the Geany editor instead of giving me TrueCrypt help. Found nothing about this on the TrueCrypt.org website. Has anyone else had this problem with the help menu? I am wondering if TrueCrypt for Linux has remnants of the Windows version, as far as the help menu is concerned? It seems sooo odd that /usr/bin/gimp and /usr/bin/geany would be executed by clicking items in the TrueCrypt Help menu?
Back to top
View user's profile Send_private_message 
In the Doghouse

Joined: 03 Oct 2010
Posts: 6

PostPosted: Mon 31 Jan 2011, 01:05    Post_subject: TrueCrypt Help menu
Sub_title: Most menu items on TrueCrypt Help menu don't work in Puppy

As stated previously, TrueCrypt Help menu User's Guide executes GIMP instead of epdfview; other Help menu items that should call up web pages, instead just run the text editor Geany, to an empty file.

Booted up in Ubuntu 9.10, amd same version of TrueCrypt. Executed the TrueCrypt GUI, and tried the Help menu. Guess what - in Ubuntu all the Help menu items are fully functional! Odd, since Puppy 5.10 is based on Ubuntu.

So why would Ubuntu run TrueCrypt perfectly, and while Puppy has a problem with the Help menu? Is it the JWM window manager? Or something to do with mimetypes in Puppy?

Any assistance would be appreciated.
Back to top
View user's profile Send_private_message 
In the Doghouse

Joined: 03 Oct 2010
Posts: 6

PostPosted: Fri 04 Mar 2011, 19:44    Post_subject: TrueCrypt Help menu - problems
Sub_title: Help Menu malfunctions in Puppy

Previously asked for assistance with TrueCrypt Help menu issues.

Have now solved these issues. Want to give solutions here so others do not waste their time on the same problems.

1. When the GIMP .sfs is attached to Puppy, then TrueCrypt Help-User's Guide request calls up GIMP, which tries to import the TrueCrypt User Guide.pdf as a postscript file.

SOLUTION-step 1: the /usr/share/applications/gimp.desktop file has a MimeType= statement that includes application/PDF; apparently Puppy looks here first to hand off the PDF, so GIMP grabs the PDF. The fix is to delete just the 'application/PDF;' phrase from the gimp.desktop file. Then the PDF will be handled by the default PDF viewer.

SOLUTION-step 2: the PDF was still not loading, because TrueCrypt was asking for, literally
"/usr/share/truecrypt/doc/TrueCrypt User Guide.pdf [trailing space]
The leading quote should not be there; nor should there be a trailing space.
This caused the PDF reader to not find the requested file. This can be resolved by adding this statement to ~/.config/rox.sourceforge.net/MIME-types/application_pdf:
#Remove " and trailing space from TrueCrypt help file request
MYFILE=`echo "$1" | sed 's/"//' | sed 's/ $//' `
Then change the exec statement that calls the PDF viewer to use "$MYFILE" instead of "$1". Other PDFs should continue to process normally, cause they do not have garbage before and after the PDF filenames.

2. When TrueCrypt Help calls, for instance, for Online Help, the geany editor is activated, with no file open, instead of the URL being passed to the default web browser as one would expect.

SOLUTION: the /usr/local/bin/defaulthandler script, that deals with these requests, is defective. (Sorry BK, but you do say right in your script that it needs more work!) The defaulthandler script fails to make provision for URL's. Make the simple changes authored by ozsouth:


Note that ozsouth was fixing the defaulthandler to deal with Foxit Reader calling URLs embedded in PDFs properly. Turns out the fix also cures the TrueCrypt Help problem.

I have requested TrueCrypt.org to fix linux User's Guide filename
(interestingly, works OK in Ubuntu 9.10)
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Security/Privacy
Jump to:  

You cannot attach files in this forum
You can download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0532s ][ Queries: 11 (0.0030s) ][ GZIP on ]