Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 01 Sep 2014, 23:06
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Utilities
Bleachbit
Post new topic   Reply to topic View previous topic :: View next topic
Page 2 of 4 [58 Posts]   Goto page: Previous 1, 2, 3, 4 Next
Author Message
sjsrikanth


Joined: 28 Mar 2011
Posts: 114
Location: Chennai, India

PostPosted: Sun 08 May 2011, 01:30    Post subject:  

This is the error Im getting! using puppy 5.25 usb install.
error.png
Description 
png

 Download 
Filename  error.png 
Filesize  306.02 KB 
Downloaded  829 Time(s) 
Back to top
View user's profile Send private message 
DPUP5520

Joined: 16 Feb 2011
Posts: 801

PostPosted: Sun 08 May 2011, 11:05    Post subject:  

Ok so I figured out it's a problem with wiping free disk space or doing any kind of deep scan which I don't use Bleachbit for which is why I never saw it and the error does happen with a frugal install to hd if theres not a lot of space left in the savefile. As for the error appearing in a frugal usb install it appears that puppy is incorrectly reporting the amount of ram that is left and therefore Bleachbit thinks that the pc/computer/laptop is out of memory and errors out.
_________________
PupRescue 2.5
Puppy Crypt 528
Back to top
View user's profile Send private message 
Digital_Dissident


Joined: 02 Mar 2010
Posts: 25
Location: U.S.- E. Coast

PostPosted: Tue 10 May 2011, 00:58    Post subject:  

DPUP5520 wrote:
To put it simply no Puppy does not include utlities that can do what bleachbit is designed to do.


Thank you for clarifying that.

Does Puppy automatically clear at least some of the saved logs and cache when they reach a certain size?

(This is just an honest and innocent inquiry; I do not mean to imply or suggest anything or make any point by it)

Quote:
Noone ever said that bleachbit was supposed to be used for secure deletion as it is no way suited for that,


I had simply suggested that the RAM full error being reported in this thread might be caused by running BleachBit with the wipe free disk space and/or wipe RAM options checked- a conclusion you yourself reached in your latest post.

My caution regarding the limitations of wiping free space (especially on solid state flash media but also on hard drives) was a general one and not aimed at BleachBit specifically, about which I never meant to imply anything one way or the other.

EDIT: I just noticed a thread in the security section here on the concern with solid-state drives that I had mentioned:

The security limitations of solid-state drives

Looks interesting.
Back to top
View user's profile Send private message 
DPUP5520

Joined: 16 Feb 2011
Posts: 801

PostPosted: Thu 23 Jun 2011, 12:48    Post subject:  

New version of bleachbit out. version 0.8.8 along wit some added extras.
bleachbit-0.8.8.pet
Description 
pet

 Download 
Filename  bleachbit-0.8.8.pet 
Filesize  349.49 KB 
Downloaded  1410 Time(s) 

_________________
PupRescue 2.5
Puppy Crypt 528

Last edited by DPUP5520 on Sun 26 Jun 2011, 13:59; edited 1 time in total
Back to top
View user's profile Send private message 
sjsrikanth


Joined: 28 Mar 2011
Posts: 114
Location: Chennai, India

PostPosted: Sat 25 Jun 2011, 22:17    Post subject:  

Hi Dpup5520

The 8.8 version doesnt seem to start.... 8.7 works great.


(puppy 5.2.5 ,frugal install in sda3,ext2 filesystem, openbox, python 2.6 lucid)
Back to top
View user's profile Send private message 
DPUP5520

Joined: 16 Feb 2011
Posts: 801

PostPosted: Sun 26 Jun 2011, 13:08    Post subject:  

I'll check it out and see what happened later today

Edit: Figured out the problem, I am fixing it now.

_________________
PupRescue 2.5
Puppy Crypt 528
Back to top
View user's profile Send private message 
DPUP5520

Joined: 16 Feb 2011
Posts: 801

PostPosted: Sun 26 Jun 2011, 13:59    Post subject:  

Fixed the problem with the 0.8.8 pet it is working fine now.
_________________
PupRescue 2.5
Puppy Crypt 528
Back to top
View user's profile Send private message 
sjsrikanth


Joined: 28 Mar 2011
Posts: 114
Location: Chennai, India

PostPosted: Sun 26 Jun 2011, 20:02    Post subject:  

Thank you Dpup5520 yes it does work. Wish it is pre-installed in the next puppy release!
Back to top
View user's profile Send private message 
DPUP5520

Joined: 16 Feb 2011
Posts: 801

PostPosted: Mon 27 Jun 2011, 09:37    Post subject:  

You could make a request to the devs or in the 5.3 developers/testers thread.
_________________
PupRescue 2.5
Puppy Crypt 528
Back to top
View user's profile Send private message 
PF-flyer

Joined: 08 Jun 2011
Posts: 71

PostPosted: Fri 08 Jul 2011, 14:50    Post subject: any success yet with Bleachbit in Lucid Pup 525?  

Bleachbit 8.8 for linux has versions for the following linux distros, but not puppy:

Debian 5 (Lenny)
Debian 6 (Squeeze)
Fedora 12 (Constantine)
Fedora 13 (Goddard)
Fedora 14 (Laughlin)
Fedora 15 (Lovelock)
Mandriva 2009.1
Mandriva 2010
Mandriva 2010.1
RHEL 6
SLE 11
Ubuntu 8.04 LTS (Hardy Heron)
Ubuntu 9.04 (Jaunty Jackalope)
Ubuntu 9.10 (Karmic Koala)
Ubuntu 10.04 (Lucid Lynx)
Ubuntu 10.10 (Maverick Meerkat)
Ubuntu 11.04 (Natty Narwhal)
openSUSE 11.3
openSUSE 11.4

Has anyone had success getting any of these to work in Lucid Puppy 525?
Back to top
View user's profile Send private message 
PF-flyer

Joined: 08 Jun 2011
Posts: 71

PostPosted: Fri 08 Jul 2011, 14:52    Post subject: download URL  

http://bleachbit.sourceforge.net/download/linux
Back to top
View user's profile Send private message 
PF-flyer

Joined: 08 Jun 2011
Posts: 71

PostPosted: Fri 08 Jul 2011, 15:03    Post subject: 8.8 running after installing python  

http://www.murga-linux.com/puppy/viewtopic.php?t=67222&sid=1e1308b5af10e63d4b8da175a8e6bb7b

After installing python 2.6 lucid, Bleachbit 8.8 works for me in LuPu525...
Back to top
View user's profile Send private message 
DPUP5520

Joined: 16 Feb 2011
Posts: 801

PostPosted: Fri 08 Jul 2011, 16:32    Post subject:  

bleachbit isn't compiled for puppy on their site but as new versions come out i try to keep up and compile all new versions from the source and yes all versions of bleachbit rely on python.
_________________
PupRescue 2.5
Puppy Crypt 528
Back to top
View user's profile Send private message 
jigglypuff

Joined: 16 Jun 2012
Posts: 5

PostPosted: Sun 17 Jun 2012, 11:42    Post subject:  

Hi does anybody know if there is a bleach bit pet for wary 5.3?.
Back to top
View user's profile Send private message 
Monsie


Joined: 01 Dec 2011
Posts: 633
Location: Kamloops BC Canada

PostPosted: Mon 01 Oct 2012, 04:42    Post subject: Bleachbit  

jigglypuff wrote:
Hi does anybody know if there is a bleach bit pet for wary 5.3?.


I did make a Pet for Wary 5.3 based on Bleachbit 0.9.3 Although the source code seemed to compile correctly, and without any errors, upon installing the Pet, I found that Bleachbit was missing several entries for cleaning purposes including SeaMonkey, Flash, and Java. So, I un-installed the package and will not be submitting it to the Forum. Maybe a future version will build properly.

Edit: UPDATE --BleachBit will build correctly with some adjustment... see my latest post.

That said, we are in luck because Bleachbit will still work in Puppy. Smile It turns out that Bleachbit is written in Python, and because Python is an interpretive language as the developer says, there is no need to compile the program as it is a complete package and will run as is --providing all dependencies are met, and for Bleachbit 0.9.3 in this case, Python 2.7 is required which you can get from over here.

To use Bleachbit, download the source code, extract it, then place it in a directory such as my-applications or opt for example, or to your own folder somewhere in the home directory.
Code:
cd /path/to/bleachbit
python bleachbit.py


The only advantage to creating a Pet for bleachbit would seem to be that one avoids having to use the terminal. Many people prefer a Pet over having to use the command line, but in this case, Bleachbit has a GUI once it starts, so it is fairly user friendly after all.

Monsie

_________________
My username is pronounced: "mun-see". Derived from my surname, it was my nickname throughout high school.

Last edited by Monsie on Sat 13 Oct 2012, 21:01; edited 2 times in total
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 2 of 4 [58 Posts]   Goto page: Previous 1, 2, 3, 4 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Utilities
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1026s ][ Queries: 12 (0.0333s) ][ GZIP on ]