Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 01 Sep 2014, 10:58
All times are UTC - 4
 Forum index » Advanced Topics » Cutting edge
Puppy2 Installer and USB tests; a bit long
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 2 of 2 [22 Posts]   Goto page: Previous 1, 2
Author Message
mkeienburg

Joined: 26 Mar 2006
Posts: 1

PostPosted: Sun 26 Mar 2006, 15:05    Post subject: Anyone tried install-mbr?  

Hi,

I also experienced the problem with a missing MBR on my CF-Card.

1. My solution:
I got around this by starting a Windows XP install on the card (which is attached to an IDE-CF adapter and is configured to be hda.) When the XP install discovered that 128 MB is not sufficient, it aborted. ... Aborted after it had completely restructured the CF with a new partition table and working MBR code. (Not a very clever move from XP to destroy the data on a device that is known to be too small - but I got my MBR.)

2. Another possible solution
which however I have not tried myself, might be the program install-mbr from http://www.chiark.greenend.org.uk/~neilt/ . This should create a working MBR on any device. install-mbr is included in Knoppix for example. The Debian package name is mbr: http://packages.qa.debian.org/m/mbr.html

Since my CF is working like a charm, I don't want to mess around with it. But someone whose bootdevice needs a MBR might try this. If incorporated into Puppy, install-mbr might be convenient alternative to dd'ing the MBR.

I'd like to hear of your experiences.

To budden: As I understand it, syslinux only affects the boot record of a partition. So it is quite normal, that you didn't get an error message after step 3. The boot code in the MBR is executed first and in turn runs the bootcode (created eg by syslinux) of the first active partition it finds. Anyone correct me please, if I got this wrong.

Martin
Back to top
View user's profile Send private message 
JustGreg

Joined: 24 May 2005
Posts: 668
Location: Connecticut USA

PostPosted: Sun 26 Mar 2006, 19:21    Post subject:  

Matin, thanks for the information. I will check the sites. I think that many flash (usb, compact, sd, etc.) devices come without a boot strap loader. Under the Users forum, I did a survey of devices and found that out. The manufacturers do not see them as being used that way. However, there are many ways to one in place. Your use of Windows XP is a new one to me. Windows XP installation process really does not care about the user data present. That is what made me to start looking at Linux, especially Puppy. The end user license agreement (EULA) for Windows XP is very scary. Microsoft errors which effect you are your problems and not theirs.
_________________
Enjoy life, Just Greg
Live Well, Laugh Often, Love Much
Back to top
View user's profile Send private message 
Mikrodots

Joined: 31 Mar 2006
Posts: 30
Location: Boston, MA USA

PostPosted: Mon 03 Apr 2006, 14:49    Post subject:  

I'm new to Puppy and Linux in general but I figured I'd throw my initial results up here on the chance they may be helpful.

I've got a SanDisk cruzer micro 256MB that will properly load and run Puppy installed from puppy-1.0.8r1-mozilla.iso CD. I do need to add acpi=off or else it will hang at "PCI: Using configuration type 1" .

For Puppy 2 I also needed to add acpi=off to the syslinux.cfg file and remove vga=785 to get it closer to booting.

Puppy 2 boot now hangs with this error:
Registering unionfs 1.0.14
ERROR, cannot find Puppy on usbflash boot media.
PUPMODE=1 PDEV=
Kernel panic: Attempted to kill init!

My syslunux.cfg file:
default vmlinuz root=/dev/ram0 initrd=initrd.gz acpi=off PMEDIA=usbflash

I used the defaults for all other selections during the USB install.

BTW the PC is a laptop:
Averatec 1000 series laptop
512MB RAM
Pentium M 733 1.1 GHZ
CD DVD CD/RW
1 NTFS partition on 80GB (I am not using the HDD for Puppy)
Laptop touch pad works as ps/2
Back to top
View user's profile Send private message Visit poster's website 
JustGreg

Joined: 24 May 2005
Posts: 668
Location: Connecticut USA

PostPosted: Mon 03 Apr 2006, 20:07    Post subject:  

I am not an expert on this. It sounds like the usb-storage modules are not completely loading and the flash device is not being found during the startup process. Are you seeing any error messages like insmod can not find usb-(some name).o.gz?
_________________
Enjoy life, Just Greg
Live Well, Laugh Often, Love Much
Back to top
View user's profile Send private message 
Guest
Guest


PostPosted: Thu 20 Apr 2006, 00:33    Post subject:  

I need a design for my website, who can do it?
Back to top
jim232777

Joined: 18 May 2006
Posts: 23
Location: SC, US

PostPosted: Thu 03 May 2007, 22:30    Post subject:  

Found this thread while trying to get a stick (as a matter of fact, a 512MB SanDisk cruzer mini) to boot. I had booted a 2.14 CD and run the universal installer script to set up the USB stick. I accepted the defaults and got no error messages, but it wouldn't boot. For others' info, this is how I got it to work.

1. I checked out the MBR, and it was OK, with c033 at the beginning.
2. I looked at the BIOS settings for my Dell Latitude D620, but there were no options to enable USB legacy support.
3. Finally, I looked at the partition table. This was the problem! The partition (created by SanDisk--I just reused it without reformatting it) was not marked bootable. Setting the bootable flag with gparted fixed everything, and the stick boots Puppy without a hitch.

(Incidentally, as partitioned by Sandiisk, gparted shows only one partition, sdb1 in my case. If I use pdisk to start cfdisk, cfdisk shows unused areas of 0.12 and 0.52 MB before and after (respectively) the 511.85 MB sdb1 partition. Next time I install, I think I'll get rid of these small, unused areas.)

Lesson: make sure your partition is flagged as bootable!

Jim
Back to top
View user's profile Send private message 
edoc


Joined: 07 Aug 2005
Posts: 4367
Location: Southeast Georgia, USA

PostPosted: Fri 04 May 2007, 08:44    Post subject:  

From what I just read on the Developer Forum 2.16a (Alpha), soon to be
a Final Release, has "perfected" USB Boot & Run with an autosave feature
as well.

Sure am looking forward to that!

_________________
Thanks! David
Home page: http://nevils-station.com
Don't google Search! http://duckduckgo.com
Puppy upup Raring 3992 & Lighthouse64-b602
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 2 of 2 [22 Posts]   Goto page: Previous 1, 2
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Cutting edge
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0646s ][ Queries: 12 (0.0100s) ][ GZIP on ]