Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 31 Jul 2014, 14:10
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
Running Puppy on an Aspire One 0751h
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 2 [18 Posts]   Goto page: 1, 2 Next
Author Message
yim


Joined: 01 Sep 2007
Posts: 167
Location: Blue Ridge Mtns

PostPosted: Sat 08 Jan 2011, 02:12    Post subject:  Running Puppy on an Aspire One 0751h
Subject description: How to install GMA500 (Poulsbo) driver?
 

Just wondering if anyone has successfully compiled the Poulsbo drivers for puppy, I'm using 5.2 , can't seem to get X at all other than with vesa and hate to admit it but even puppy is painfully slow and gittery when scrolling or moving of windows. This happens wether in 16 or 24 bit modes 16 is better but still not on par. Have had fair success when using PCLinux but I'd rather use puppy. @ the moment I have a hard drive install of Mint 9 fluxbox it works ok but slow.

I know this has been discussed somewhat here but haven't yet found a definitive answer to the GMA500 Poulsbo chipset. Surely I'm not the only one that has this complaint.

thanks for reading, all sugestions greatly appreciated

yim
Back to top
View user's profile Send private message 
yim


Joined: 01 Sep 2007
Posts: 167
Location: Blue Ridge Mtns

PostPosted: Sun 17 Apr 2011, 14:36    Post subject:  

just bumping this thread as it's been a couple months and no reply's.
thought something new has happend with poulsbo driver.

I'm assuming that puppy should absolutely fly on this machine it's dual core 1333mhz atom but this GMA500 is crapola, I hate to say. only one distro acutally runs fluid which is pclinuxos gnome. don't know why but the other desktops don't even with the correct drive just the gnome version. anyway if anyone has input of success please let me know.

puppys vesa and i810 both work but are very slow

thanks yim
Back to top
View user's profile Send private message 
Béèm


Joined: 21 Nov 2006
Posts: 11782
Location: Brussels IBM Thinkpad R40, 256MB, 20GB, WiFi ipw2100. Frugal Lin'N'Win

PostPosted: Sun 17 Apr 2011, 14:57    Post subject:  

I suppose you had a look at all the GMA500 post on the puppy forum?
You can do it with the puppy search link in my sig.

_________________
Time savers:
Find packages in a snap and install using Puppy Package Manager (Menu).
Consult Wikka
Use peppyy's puppysearch
Back to top
View user's profile Send private message 
yim


Joined: 01 Sep 2007
Posts: 167
Location: Blue Ridge Mtns

PostPosted: Sun 17 Apr 2011, 16:33    Post subject:  

yep had a look see, and nothing relevant to the native poulsbo drivers for GMA500, hince the reason I bumped thread. sometimes fixes come without a post though, just giving it a shot.

thanks for the interest

yim
Back to top
View user's profile Send private message 
Béèm


Joined: 21 Nov 2006
Posts: 11782
Location: Brussels IBM Thinkpad R40, 256MB, 20GB, WiFi ipw2100. Frugal Lin'N'Win

PostPosted: Sun 17 Apr 2011, 18:31    Post subject:  

I am sorry that you didn't find something relevant.
Apparently nobody here is able to help.
Maybe you could PM Barry Kauler directly.
Also there is a hardware video section in which you could post.
Then there is the bugs section i which you could post about 5.2 issues.

P.S. I had a good time in the autumn of 1972 riding on the blue ridge highway. It was in the WE where the color changes of the leaves were at the best, resulting in me not finding a place to sleep. All was booked and I had to spent the night in the car.

_________________
Time savers:
Find packages in a snap and install using Puppy Package Manager (Menu).
Consult Wikka
Use peppyy's puppysearch
Back to top
View user's profile Send private message 
rjbrewer


Joined: 22 Jan 2008
Posts: 4422
Location: merriam, kansas

PostPosted: Sun 17 Apr 2011, 18:57    Post subject:  

Another Linux os built especially for "Poulsbo".

http://pixielive.org/dotclear/index.php?tag/GMA500

I'm not familiar with it.

_________________

Inspiron 700m, Pent.M 1.6Ghz, 1Gb ram.
Msi Wind U100, N270 1.6>2.0Ghz, 1.5Gb ram.
Eeepc 8g 701, 900Mhz, 1Gb ram.
Full installs

Back to top
View user's profile Send private message 
tempestuous

Joined: 10 Jun 2005
Posts: 5218
Location: Australia

PostPosted: Wed 20 Apr 2011, 00:44    Post subject:  

The new pcb Xorg driver has just been made available for Puppy 5.1/5.2 here -
http://www.murga-linux.com/puppy/viewtopic.php?p=515093#515093
Back to top
View user's profile Send private message 
yim


Joined: 01 Sep 2007
Posts: 167
Location: Blue Ridge Mtns

PostPosted: Wed 20 Apr 2011, 07:53    Post subject:  

hey thanks tempestuous, I'll have a shot at this when I get home this evening

again thank you very much

yim
Back to top
View user's profile Send private message 
yim


Joined: 01 Sep 2007
Posts: 167
Location: Blue Ridge Mtns

PostPosted: Thu 21 Apr 2011, 20:34    Post subject:  

having a bit of trouble getting things to work , I am still messing around with the settings but restarting the xserver always defaults back to vesa and the screen is stretched in such a way that you can't make out the screen. But I'm still trying just letting you know that I'm giving it a go. will get back again soon
Back to top
View user's profile Send private message 
yim


Joined: 01 Sep 2007
Posts: 167
Location: Blue Ridge Mtns

PostPosted: Sat 02 Jul 2011, 16:38    Post subject:  

has anyone been successful with the pcb driver or is it psb confusing psb is whats in modules , hmmm

I've tried every combination I can think of to utilize this but no go so far

I'm up for ideas

yim
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Sat 02 Jul 2011, 16:44    Post subject:  

I remember seeing some mention of poulsbo when I compiled 2.6.38.4 kernel. And I included that named driver to the kernel. You could check IcePuppy builds or upcoming Midnight Sun Pup-003 or Polarpup.

sh-4.1# find /lib/modules -name poulsbo.ko
/lib/modules/2.6.38/kernel/drivers/gpu/stub/poulsbo.ko
Back to top
View user's profile Send private message 
Aitch


Joined: 04 Apr 2007
Posts: 6825
Location: Chatham, Kent, UK

PostPosted: Sat 02 Jul 2011, 17:07    Post subject:  

tempestuous to the rescue - linux framebuffer/uvesafb

http://www.murga-linux.com/puppy/viewtopic.php?t=67024

also see

http://www.murga-linux.com/puppy/viewtopic.php?p=515093#515093

http://www.murga-linux.com/puppy/viewtopic.php?t=67166

FYI https://wiki.archlinux.org/index.php/Uvesafb

Aitch Smile
Back to top
View user's profile Send private message 
yim


Joined: 01 Sep 2007
Posts: 167
Location: Blue Ridge Mtns

PostPosted: Sun 03 Jul 2011, 00:20    Post subject:  

i got the uvesafb driver to work and it was a lot better, but still not up to par, have to wait for naitive driver if it comes
on my pclinux hd install kernel updated along with xorg and the newer versions no longer support psb driver. guys and gals take my advice and don't buy a machine with the gma500 graphics you'll be kickin your own ars, trust me, this has had the worst performance of any machine I've owned

shame on intel

shame on acer

liked both until this crappy rig (AAO za3 0751h)

thanks for the help guys, I do appreciate it

yim
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Mon 04 Jul 2011, 06:35    Post subject:  

Midnight Sun Pup 003.
Code:
sh-4.1# modinfo poulsbo
filename:       /lib/modules/2.6.38/kernel/drivers/gpu/stub/poulsbo.ko
license:        GPL
description:    Poulsbo Stub Driver
author:         Lee, Chun-Yi <jlee@novell.com>
alias:          pci:v00008086d00008109sv*sd*bc*sc*i*
alias:          pci:v00008086d00008108sv*sd*bc*sc*i*
depends:        video
vermagic:       2.6.38 SMP preempt mod_unload modversions ATOM
sh-4.1#
Back to top
View user's profile Send private message 
yim


Joined: 01 Sep 2007
Posts: 167
Location: Blue Ridge Mtns

PostPosted: Tue 05 Jul 2011, 17:34    Post subject:  

pemesu

thank you very much for pointing this puplet out to me , I did download and try but unfortunately the video driver psb isn't in the xorg modules ,

I ran lsmod in terminal and it shows

video 9391 1 poulsbo

I check xorg.conf file and it shows the vesa driver is running, it works but this machine should run pretty good, and for puppy, well it should be a bad A$$. Very confused why it doesn't work well, no puppy I've tried yet runs very good, ok but not good by definition.

Midnightsun pup is a nice setup nontheless. and I thank you for trying to help me.

I got spoiled running pclinuxos gnome on this thing that was before they did all the updates, kernel and xorg. I mean for a full install of gnome it ran very fast and window movement was great smooth not herky jerky flash played well with about 80% cpu variable other distros are just not quite there and from what Ive gathered psb will no longer be supported. Oh well, if anyone has more suggestions, I'm game

thanks again

yim
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 2 [18 Posts]   Goto page: 1, 2 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0810s ][ Queries: 11 (0.0110s) ][ GZIP on ]