Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 21 Oct 2014, 16:08
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff)
How to use VPNs like AT&T agnclient & IBM mobility client?
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
damitowl

Joined: 15 Dec 2010
Posts: 1

PostPosted: Wed 15 Dec 2010, 06:06    Post_subject:  How to use VPNs like AT&T agnclient & IBM mobility client?
Sub_title: Trying to make .deb for VPNs into Puppy pets
 

Salutations Canine Comrades,

The idea and result of puppy linux is the coolest thing. I love it.

For several weeks I have been trying to get some VPN .deb packages working using things like undeb and the direct .deb install in 4.3.1 onwards. The two .deb files I have are for the AT&T Net Client often named agnclient and IBM's offering called ibm lotus mobility client (lmc).

The install in 4.3.1 and 5.1.1 looks to go OK and menu entries are added to Menu>Network. However, they do not seem to initiate. I ran the PPM dependency checker for both and it said there were no missing dependencies for drivers or other packages. I was surprised by that because in Ubuntu agnclient normally needs libss10.9.8, libcurl13 and tcl8.4. lmc usually needs libstdc++5. I cannot seem to locate a place where I can get these dependent packages for puppy. I have thought about using woof on ubuntu with these packages installed and working but woof looks complicated.

Does anyone have any ideas about how to go forwards with this one, please? If anyone can help, I can send the .deb files through.

Many thanks,

Damian (mainframe systems programmer gone linux feral)
Back to top
View user's profile Send_private_message 
Master_wrong

Joined: 19 Mar 2008
Posts: 456

PostPosted: Fri 04 Feb 2011, 21:13    Post_subject:  

http://packages.debian.org/search?suite=default&section=all&arch=any&searchon=names&keywords=libstdc%2B%2B5

you can get libstdc++5 from above site, convert the deb. package using deb2pet or something.

good luck

_________________
Cluster-Pup v.2-Puppy Beowulf Cluster
http://www.murga-linux.com/puppy/viewtopic.php?p=499199#499199
Back to top
View user's profile Send_private_message 
tempestuous

Joined: 10 Jun 2005
Posts: 5271
Location: Australia

PostPosted: Sat 05 Feb 2011, 02:44    Post_subject:  

Those are both quite specialised VPN solutions.
It might be easier to employ the more mainstream VPN solutions such as the Microsoft or Cisco implementations, since these are already tested and known to work with Puppy.

In any case, I had a look at agnclient and I see that it needs some modifications to make it Puppy-compatible.
The latest version appears to be the RPM available here
ftp://ftp.attglobal.net/pub/custom/ibm_linux/
I extracted the RPM, modified it, and repackaged as a dotpet, now attached.

Once installed, don't launch it from the menu, because we need to know if there are any errors or missing libraries reported.
First modify the configuration file, /etc/agnclient/agnclient.conf
to contain your VPN server details.
Now run the two start scripts, which I have located in /root/my-applications
as such:
Code:
/root/my-applications/agnclientd start
/root/my-applications/agnLogd start

In Puppy 5.1 I can run these start scripts without any errors. But of course, I have no valid VPN connection to test with.
There's a chance you may also need tcl, but wait and see.

Edited_time_total
Back to top
View user's profile Send_private_message 
tempestuous

Joined: 10 Jun 2005
Posts: 5271
Location: Australia

PostPosted: Wed 09 Feb 2011, 10:06    Post_subject:  

So, does it work?
Back to top
View user's profile Send_private_message 
tempestuous

Joined: 10 Jun 2005
Posts: 5271
Location: Australia

PostPosted: Thu 10 Feb 2011, 10:14    Post_subject:  

Very poor reporting.
Dotpet now removed.
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9200
Location: Stratford, Ontario

PostPosted: Thu 10 Feb 2011, 11:31    Post_subject:  

tempestuous wrote:
Very poor reporting.
Dotpet now removed.

I know the feeling. I once posted a scanner driver that was completely wrong. Yet it was downloaded a hundred times and no one ever reported a problem.

OTOH, this may be an indication of how large the unregistered Puppy community really is.
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff)
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0504s ][ Queries: 11 (0.0030s) ][ GZIP on ]