Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 18 Apr 2014, 15:04
All times are UTC - 4
 Forum index » House Training » Bugs ( Submit bugs )
Misc 5.1.1 bugs/regressions
Moderators: Flash, Ian, JohnMurga
Post new topic   This topic is locked: you cannot edit posts or make replies. View previous topic :: View next topic
Page 1 of 1 [2 Posts]  
Author Message
imnotrich

Joined: 02 Jun 2006
Posts: 44
Location: Northern California

PostPosted: Wed 20 Oct 2010, 10:10    Post subject:  Misc 5.1.1 bugs/regressions
Subject description: wifi, java, and xfprot oh my
 

So to get past the blank screen at boot up bug and keyboard issues I had to turn acpi off, and now I have a sort of functional live 5.1.1 running. But when I rebooted, the acpi=off setting was not saved in my .sfs. Where do I save this setting, if I don't use grub?

The wired network wizard pulls an IP just fine and i can bop around the internet, but wireless (realtek 8180/8185) refuses to connect in fact doesn't even see my wifi when scanning despite being 18 inches from the router or when I'm sitting on the sofa downstairs.

Worked perfectly in 4.3.1, but with 5.1.1 no joy. The proper module is loaded and just for grins I tried re-loading. Doubt it matters but I am running DD-WRT WPA2 with a visible SSID. Puppy repeatedly says no networks detected.

Yes, I did install the update 2 pet, didn't help.

Flash works great, but...the java install from quickpet only pretends to install. Browsers chrome and firefox don't call it when I go to the java test page, even though java is enabled in the browser.

I did a 4.3.1 install last year on the same laptop where I did not have this issue and java worked perfectly but this week (after installing a new hard drive in my laptop) 4.3.1 and sea monkey did the same thing with java. Java installs, but the browser doesn't use it even though java is enabled.

Perhaps off topic but xf-prot worked great after last year's install but a few weeks ago a 4.3.1 install attempt xf-prot bonks. It installs, but fails to run - "unable to determine version" error. And I don't even find xf-prot for 5.1.1.

This may be a clue regarding the wifi issue (or maybe it's a whole 'nother issue), but my old 4.3.1 install used to save wireless settings and autoconnect until one day that I tried to live boot 5.0 and something in the live cd overwrote my settings. After that, even though my ssid and wpa2 key were saved, Pup 4.3.1 would not auto connect. I thought live cd's were not supposed to make any changes unless you ask them to.

While we're at it, let's find out why Puppy is not recognizing usb flash drives when they're inserted - they should probably automount but regardless...the puppy "mounter" does not see them so I can't mount them manually.

I'm sure it's a bunch of something stupid that I'm missing, but I'm really tearing my hair out on this one. I really like the look of 5.1.1, can actually read the fonts without my bifocals, and both the generic and ati drivers work great (after I turn off acpi).

However, Puppy, like Ubuntu seems to have lost it's focus on "just works." Modern hardware (stuff made in the last 3-4 years) should not confuse a distro so. I fully understand the perils of using a bleeding edge distro, which Puppy seems to have become. Previously, every release (until 5) fixed more things than it broke and it was fun tinkering with the broken stuff. But I've got to admit, these 5's are frustrating me. If anyone's figured out any of the above issues I'd be grateful to hear your solution.
Back to top
View user's profile Send private message Visit poster's website Yahoo Messenger MSN Messenger 
Flash
Official Dog Handler


Joined: 04 May 2005
Posts: 10662
Location: Arizona USA

PostPosted: Wed 20 Oct 2010, 11:01    Post subject:  

Imnotrich, would you please post this in the Lucid Puppy bug thread? Thanks. Smile
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [2 Posts]  
Post new topic   This topic is locked: you cannot edit posts or make replies. View previous topic :: View next topic
 Forum index » House Training » Bugs ( Submit bugs )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0429s ][ Queries: 11 (0.0033s) ][ GZIP on ]