Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 24 Nov 2014, 10:11
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
Puppy Squeeze 009 Development
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 22 of 68 [1006 Posts]   Goto page: Previous 1, 2, 3, ..., 20, 21, 22, 23, 24, ..., 66, 67, 68 Next
Author Message
tubeguy


Joined: 28 Aug 2009
Posts: 1332
Location: Park Ridge IL USA

PostPosted: Sun 26 Sep 2010, 17:10    Post subject:  

Bert wrote:
Lobster wrote:
Thanks for 006
Here is a picture of an owl in a hat

Hi Lobster,

I'm afraid we can't see that picture.
Did you mean something like this:

Even after googling it, I have no idea what "an owl in a hat" means. Sounds good though Smile

I think he might be using a "thank you" meme. See something that makes you happy, respond with a happy/fun/cool/interesting/upbeat picture.

I could be wrong about his intention, but if I'm right, his execution was perfect.

Lobster, here is a picture of a cool kid:


_________________
MSI 970A-G46/AMD FX-8150/Plextor 128GB SSD/Corsair Vengeance 8GB: Tahr Pup 6
Back to top
View user's profile Send private message Visit poster's website 
dejan555


Joined: 30 Nov 2008
Posts: 2716
Location: Montenegro

PostPosted: Sun 26 Sep 2010, 17:40    Post subject:  

Debian's abiword in 006 has that bug where it crashes when you click Edit -> Preferences so I compiled this one:

http://puppy.b0x.me/software/squeeze/abiword/

NOTE: I didn't compile the plugins pet those are the ones that came with debian's abiword so I'm not sure if they are going to work with this pet but spellchecking works in main pet and I'm not really sure what those other plugins do anyway or if someone needs them. Main pet seems stable and working okay so please test.

_________________
Dpup 487 | Puppy Gallery | My photo gallery | mtPaint works
Back to top
View user's profile Send private message Visit poster's website MSN Messenger 
Béèm


Joined: 21 Nov 2006
Posts: 11782
Location: Brussels IBM Thinkpad R40, 256MB, 20GB, WiFi ipw2100. Frugal Lin'N'Win

PostPosted: Sun 26 Sep 2010, 17:51    Post subject: Re: no console in 004 and in 006  

Béèm wrote:
Annoying not to have a console in 004 (nor rxvt, urxvt, mrxvt) Crying or Very sad
Even terminal here doesn't work.
Never got an answer to this.
I still have the issue in 006.

_________________
Time savers:
Find packages in a snap and install using Puppy Package Manager (Menu).
Consult Wikka
Use peppyy's puppysearch
Back to top
View user's profile Send private message 
Bert


Joined: 30 Jun 2006
Posts: 975

PostPosted: Sun 26 Sep 2010, 18:07    Post subject: Re: no console in 004 and in 006  

Béèm wrote:
Béèm wrote:
Annoying not to have a console in 004 (nor rxvt, urxvt, mrxvt) Crying or Very sad
Even terminal here doesn't work.
Never got an answer to this.
I still have the issue in 006.


I believe gjuhasz found the source of this problem on page 18 of this thread:

Quote:
mrxvt

It disappears only if specific country localization is set (Desktop menu > chooselocale).
In my case, mrxvt became unavailable as soon as I set hu_HU. Fortunately, when I checked UTF-8 encoding, mrxvt returned.
Karl, maybe you selected de_DE@euro. In this case, mrxvt disappears, too. Tick UTF-8 or select de_DE.


I changed locale from nl.BE@euro to nl.BE and that made mrxvt available. This doesn't mean I like it...can't even paste into it.

_________________


Back to top
View user's profile Send private message 
Lobster
Official Crustacean


Joined: 04 May 2005
Posts: 15117
Location: Paradox Realm

PostPosted: Sun 26 Sep 2010, 18:52    Post subject:  

I do apologise if the invisible owl in a hat was not to your liking . . .
(Probably should have mentioned it was invisible) Embarassed

I am glad others have provided the more conventional and identical visible owl in a hat + cool kid.
It was indeed a thank you. Normal service is now resumed.

Puppy Linux
Visibly penguin

_________________
Puppy WIKI
Back to top
View user's profile Send private message Visit poster's website 
Karl Godt


Joined: 20 Jun 2010
Posts: 3972
Location: Kiel,Germany

PostPosted: Sun 26 Sep 2010, 19:09    Post subject:  

Which console ?

until now I had no severe problems but ...C+A+F2 ...C+A+F4 seems to work too

Ahh ... terminal seems to been gone from the Menu .. let`s see at /usr/share/applications ... seems to be not there

dpup-001 urxvt.dektop :
Code:
Encoding=UTF-8
Name=Urxvt terminal emulator
Icon=mini-sh.xpm
Comment=Urxvt terminal emulator
Exec=rxvt
Terminal=false
Type=Application
Categories=TerminalEmulator
GenericName=Urxvt
console+xconsole-dpup-006.png
 Description   
 Filesize   135.67 KB
 Viewed   914 Time(s)

console+xconsole-dpup-006.png

Back to top
View user's profile Send private message Visit poster's website 
tubeguy


Joined: 28 Aug 2009
Posts: 1332
Location: Park Ridge IL USA

PostPosted: Sun 26 Sep 2010, 19:11    Post subject:  

Running 006 frugal from clean install, JWM desktop count can't be changed from the menu. This showed up in xerrs:
Code:
/usr/local/jwmconfig2/virtualDesk: line 83: [: too many arguments
EXIT="abort"
EXIT="ok"


I edited .jwm/jwmrc-personal and that worked.

_________________
MSI 970A-G46/AMD FX-8150/Plextor 128GB SSD/Corsair Vengeance 8GB: Tahr Pup 6
Back to top
View user's profile Send private message Visit poster's website 
Karl Godt


Joined: 20 Jun 2010
Posts: 3972
Location: Kiel,Germany

PostPosted: Sun 26 Sep 2010, 19:18    Post subject: Yet another Cups-Conf  

After installing the ghostscript binary CUPS didn`t print here either but after killall cupsd and saving that cups.conf
Code:
#
# "$Id: cupsd.conf.in 7199 2008-01-08 00:16:30Z mike $"
#
#   Sample configuration file for the Common UNIX Printing System (CUPS)
#   scheduler.  See "man cupsd.conf" for a complete description of this
#   file.
#

# Log general information in error_log - change "info" to "debug" for
# troubleshooting...
LogLevel debug2

# Administrator user group...
# playdayz advised these two...
# SystemGroup root
SystemGroup lpadmin

# Only listen for connections from the local machine.
Listen localhost:631
Listen /var/run/cups/cups.sock

# Show shared printers on the local network.
Browsing On
BrowseOrder allow,deny
BrowseAllow all

# Default authentication type, when authentication is required...
# DefaultAuthType Basic
DefaultAuthType None

# Restrict access to the server...
#<Location />
#  Order deny,allow
#</Location>

# Restrict access to the admin pages...
#<Location /admin>
#  Order deny,allow
#</Location>

# Restrict access to configuration files...
<Location /admin/conf>
  AuthType None
#  Require user @SYSTEM
  Order allow,deny
</Location>
# Order deny,allow


# Set the default printer/job policies...
<Policy default>
  <Limit All>
    Order deny,allow
  </Limit>
</Policy>

#
# End of "$Id: cupsd.conf.in 7199 2008-01-08 00:16:30Z mike $".
#

#
# This is written by me to prove
#

cupsd or /etc/init.d/cups restart it prints now at 006 Smile
Back to top
View user's profile Send private message Visit poster's website 
Karl Godt


Joined: 20 Jun 2010
Posts: 3972
Location: Kiel,Germany

PostPosted: Sun 26 Sep 2010, 19:25    Post subject: Virtual Desktops  

/root/.jwm/jwmrc-theme :
Code:
<JWM>

<WindowStyle>
   <Font>DejaVu Sans-12</Font>
      <Width>3</Width>
    <Height>22</Height>
   <Active>
      <Text>white</Text>
      <Title>#757575:black</Title>
<!-- <Corner>black</Corner>  -->
          <Outline>black</Outline>
   </Active>
   <Inactive>
      <Text>#ADADAD</Text>
      <Title>#636363:#313131</Title>
<!-- <Corner>black</Corner> -->
          <Outline>black</Outline>
   </Inactive>
</WindowStyle>
      
<TaskListStyle>
    <Font>DejaVu Sans-12</Font>
   <Foreground>#E2E2E2</Foreground>
   <Background>#3F3F3F:#000000</Background>
   <ActiveForeground>white</ActiveForeground>
   <ActiveBackground>#212121:#3F3F3F</ActiveBackground>
</TaskListStyle>

<TrayStyle>
    <Font>DejaVu Sans-12</Font>
   <Foreground>#A2A2A2</Foreground>
   <Background>#181920</Background>
</TrayStyle>

<PagerStyle>
    <Font>DejaVu Sans-12</Font>
   <Outline>black</Outline>
   <!-- non-active programs: bg[NORMAL]-->
   <Foreground>#181920</Foreground>
   <!-- non-active desktops: bg[ACTIVE]-->
   <Background>#353746</Background>
   <!-- selected app/desktop bg[SELECTED]-->
   <ActiveForeground>#d5dcf6</ActiveForeground>
   <!-- frame of selected desktop...bg[SELECTED] -->
   <ActiveBackground>#1d2c53</ActiveBackground>
</PagerStyle>


<MenuStyle>
    <Font>DejaVu Sans-12</Font>
   <Foreground>#A5A5A5</Foreground>
   <Background>#181920</Background>
   <ActiveForeground>#E2E2E2</ActiveForeground>
   <ActiveBackground>#3F3F3F:#000000</ActiveBackground>
</MenuStyle>

</JWM>

to fix the virtualDesk line 83 complaints .

Note : Uncomment the lines with "Corner" - it is some .xml and no .sh
Back to top
View user's profile Send private message Visit poster's website 
tubeguy


Joined: 28 Aug 2009
Posts: 1332
Location: Park Ridge IL USA

PostPosted: Sun 26 Sep 2010, 20:01    Post subject:  

Tried to play an avi file from my Star Trek collection, gnome mplayer starts but doesn't play, got this in xerrs:
Code:
(firefox-bin:5976): libgnomevfs-WARNING **: Cannot load module `/usr/lib/gnome-vfs-2.0/modules/libfile.so' (libfam.so.0: cannot open shared object file: No such file or directory)


Edit: Quickpet VLC works fine.

_________________
MSI 970A-G46/AMD FX-8150/Plextor 128GB SSD/Corsair Vengeance 8GB: Tahr Pup 6

Last edited by tubeguy on Sun 26 Sep 2010, 21:42; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
Karl Godt


Joined: 20 Jun 2010
Posts: 3972
Location: Kiel,Germany

PostPosted: Sun 26 Sep 2010, 20:27    Post subject: mrxvt with start problems at several locale settings  

Quote:
mrxvt
It disappears only if specific country localization is set (Desktop menu > chooselocale).
In my case, mrxvt became unavailable as soon as I set hu_HU. Fortunately, when I checked UTF-8 encoding, mrxvt returned.
Karl, maybe you selected de_DE@euro. In this case, mrxvt disappears, too. Tick UTF-8 or select de_DE.
Page 18
Until now I hadn't have much time to play with locales

Mrxvt desn't like de_DE@Money ... de_DE works both checked/unchecked UTF-8 ... Changing the keyboard to deadkeys works, too .... really might be that thing Béèm is complaining about ....
What about Sakura ? it is 1-1.5 MB (3pkgs from debian repo) because at /usr/bin/*rxvt* are 4x 300 KB *rxvt*

Mrxvt doesn't disconnect `pgprs-shell` at mrxvt by Control+c after a while - only another mrxvt with `kill -s HUP pppd`... but perhaps the Internet gets patched dead at the moment .....
[ PrtSc- SysRq ] - key is working here too ... that is very nice ..!
Back to top
View user's profile Send private message Visit poster's website 
James C


Joined: 26 Mar 2009
Posts: 5932
Location: Kentucky

PostPosted: Mon 27 Sep 2010, 00:18    Post subject:  

Fresh frugal install of 006 on the old P3 test box. Luckily for me, Mrxvt was working out of the box.Went ahead and fixed the menu entry, just because. Smile
Most everything else is looking good so far.
Back to top
View user's profile Send private message 
DaveS


Joined: 09 Oct 2008
Posts: 3726
Location: UK

PostPosted: Mon 27 Sep 2010, 02:12    Post subject:  

dejan555 wrote:
Debian's abiword in 006 has that bug where it crashes when you click Edit -> Preferences so I compiled this one:

http://puppy.b0x.me/software/squeeze/abiword/

NOTE: I didn't compile the plugins pet those are the ones that came with debian's abiword so I'm not sure if they are going to work with this pet but spellchecking works in main pet and I'm not really sure what those other plugins do anyway or if someone needs them. Main pet seems stable and working okay so please test.


Seems ok dejan but it loads weird, as if screen position etc is not saved between use. Functions properly though.
I wish I could get printing to work but find Karls instructions too obscure. Working on it........

_________________
Spup Frugal HD and USB
Root forever!
Back to top
View user's profile Send private message 
dejan555


Joined: 30 Nov 2008
Posts: 2716
Location: Montenegro

PostPosted: Mon 27 Sep 2010, 02:18    Post subject: Re: mrxvt with start problems at several locale settings  

Karl Godt wrote:
because at /usr/bin/*rxvt* are 4x 300 KB *rxvt*


that's only one mrxvt, other 3 are symlinks

_________________
Dpup 487 | Puppy Gallery | My photo gallery | mtPaint works
Back to top
View user's profile Send private message Visit poster's website MSN Messenger 
Karl Godt


Joined: 20 Jun 2010
Posts: 3972
Location: Kiel,Germany

PostPosted: Mon 27 Sep 2010, 03:42    Post subject:  

Quote:
that's only one mrxvt, other 3 are symlinks

Nope :
# ls -lF /mnt/+mnt+home+dpup006+dpup-006.sfs/usr/bin/*xvt*
-rwxr-xr-x 4 root root 295728 2010-09-28 18:56 /mnt/+mnt+home+dpup006+dpup-006.sfs/usr/bin/mrxvt*
-rwxr-xr-x 4 root root 295728 2010-09-28 18:56 /mnt/+mnt+home+dpup006+dpup-006.sfs/usr/bin/mrxvt-full*
-rwxr-xr-x 4 root root 295728 2010-09-28 18:56 /mnt/+mnt+home+dpup006+dpup-006.sfs/usr/bin/rxvt*
-rwxr-xr-x 4 root root 295728 2010-09-28 18:56 /mnt/+mnt+home+dpup006+dpup-006.sfs/usr/bin/urxvt*
# file /mnt/+mnt+home+dpup006+dpup-006.sfs/usr/bin/*xvt*
/mnt/+mnt+home+dpup006+dpup-006.sfs/usr/bin/mrxvt: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), for GNU/Linux 2.6.18, dynamically linked (uses shared libs), stripped
/mnt/+mnt+home+dpup006+dpup-006.sfs/usr/bin/mrxvt-full: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), for GNU/Linux 2.6.18, dynamically linked (uses shared libs), stripped
/mnt/+mnt+home+dpup006+dpup-006.sfs/usr/bin/rxvt: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), for GNU/Linux 2.6.18, dynamically linked (uses shared libs), stripped
/mnt/+mnt+home+dpup006+dpup-006.sfs/usr/bin/urxvt: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), for GNU/Linux 2.6.18, dynamically linked (uses shared libs), stripped
# stat /mnt/+mnt+home+dpup006+dpup-006.sfs/usr/bin/*xvt*
File: `/mnt/+mnt+home+dpup006+dpup-006.sfs/usr/bin/mrxvt'
Size: 295728 Blocks: 578 IO Block: 1024 regular file
Device: 702h/1794d Inode: 2371 Links: 4
Access: (0755/-rwxr-xr-x) Uid: ( 0/ root) Gid: ( 0/ root)
Access: 2010-09-28 18:56:31.000000000 +0800
Modify: 2010-09-28 18:56:31.000000000 +0800
Change: 2010-09-28 18:56:31.000000000 +0800
File: `/mnt/+mnt+home+dpup006+dpup-006.sfs/usr/bin/mrxvt-full'
Size: 295728 Blocks: 578 IO Block: 1024 regular file
Device: 702h/1794d Inode: 2371 Links: 4
Access: (0755/-rwxr-xr-x) Uid: ( 0/ root) Gid: ( 0/ root)
Access: 2010-09-28 18:56:31.000000000 +0800
Modify: 2010-09-28 18:56:31.000000000 +0800
Change: 2010-09-28 18:56:31.000000000 +0800
File: `/mnt/+mnt+home+dpup006+dpup-006.sfs/usr/bin/rxvt'
Size: 295728 Blocks: 578 IO Block: 1024 regular file
Device: 702h/1794d Inode: 2371 Links: 4
Access: (0755/-rwxr-xr-x) Uid: ( 0/ root) Gid: ( 0/ root)
Access: 2010-09-28 18:56:31.000000000 +0800
Modify: 2010-09-28 18:56:31.000000000 +0800
Change: 2010-09-28 18:56:31.000000000 +0800
File: `/mnt/+mnt+home+dpup006+dpup-006.sfs/usr/bin/urxvt'
Size: 295728 Blocks: 578 IO Block: 1024 regular file
Device: 702h/1794d Inode: 2371 Links: 4
Access: (0755/-rwxr-xr-x) Uid: ( 0/ root) Gid: ( 0/ root)
Access: 2010-09-28 18:56:31.000000000 +0800
Modify: 2010-09-28 18:56:31.000000000 +0800
Change: 2010-09-28 18:56:31.000000000 +0800

geany at 005 is printing while abiword doesn`t prints : pdftoraster failed ..... perhaps a font thingy : abiword can adjust font but geany font and style ... and I had to use CUPS-PDF first today to get geany to print afterwards ... Epson is default and checked shared but the Headline says Not Shared Rolling Eyes Evil or Very Mad Twisted Evil Rolling Eyes
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 22 of 68 [1006 Posts]   Goto page: Previous 1, 2, 3, ..., 20, 21, 22, 23, 24, ..., 66, 67, 68 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1358s ][ Queries: 12 (0.0247s) ][ GZIP on ]