Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 24 Oct 2014, 14:20
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
Puppy Squeeze 009 Development
Moderators: Flash, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 21 of 68 Posts_count   Goto page: Previous 1, 2, 3, ..., 19, 20, 21, 22, 23, ..., 66, 67, 68 Next
Author Message
Iguleder


Joined: 11 Aug 2009
Posts: 1923
Location: Israel, somewhere in the beautiful desert

PostPosted: Sat 25 Sep 2010, 16:33    Post_subject:  

The 002 and 003 reports are not very useful.

We need to get it working on 004+, which use the Debian CUPS.

_________________
My homepage
Back to top
View user's profile Send_private_message Visit_website MSNM 
ICQ 
ajlec2000

Joined: 27 Jan 2007
Posts: 50

PostPosted: Sat 25 Sep 2010, 23:29    Post_subject: Photo Apps  

I am pleased to say that GIMP, ufraw, and gtkam installed with little difficulty.

The tray management in the JWM configuration does not work. This was the case in 004 as well as 005.

Frugal install on a Dell Inspiron 1501.
Back to top
View user's profile Send_private_message 
cinclus_cinclus

Joined: 22 Feb 2009
Posts: 59

PostPosted: Sun 26 Sep 2010, 06:04    Post_subject: Adding a new menu categoy?  

I have installed Office 97 (Word, Excel) under wine in Lucid Puppy 5.1.1.
The problem is that no menu entries are generated for Word or Excel.

The menu entries would be generated in the menu category "Other". But there is no such category in Puppy Squeeze 005 (or Puppy Lucid).

Question: how to add a new category "Other" in the Menu?
Back to top
View user's profile Send_private_message 
Karl Godt


Joined: 20 Jun 2010
Posts: 3972
Location: Kiel,Germany

PostPosted: Sun 26 Sep 2010, 06:40    Post_subject:  Cups is printing now  

dpup-004 and dpup-005 are printing also now !!!

1. problem was that /usr/share/ghostscript/..../Init was missing at all dpups .
2. problem had been the missing world read permission for /etc/cups/cupsd.conf to been shown at the CUPS-WEB-INTERFACE . Just check world read access and it still saves :
Code:
# Show troubleshooting information in error_log.
LogLevel debug
SystemGroup lpadmin
# Allow remote access
Port 631
Listen /var/run/cups/cups.sock
# Enable printer sharing and shared printers.
Browsing On
BrowseOrder allow,deny
BrowseAllow all
BrowseRemoteProtocols CUPS
BrowseAddress @LOCAL
BrowseLocalProtocols cups
DefaultAuthType None
<Location /admin/conf>
  AuthType None
  # Allow remote access to the configuration files...
  Order allow,deny
  Allow @LOCAL
</Location>
<Policy default>
  <Limit All>
    Order allow,deny
  </Limit>
</Policy>
# Allow shared printing and remote administration...
<Location />
  Order allow,deny
  Allow @LOCAL
</Location>
# Allow remote administration...
<Location /admin>
  Order allow,deny
  Allow @LOCAL
</Location>
MaxLogSize 5m
PreserveJobFiles Yes

3. problem is that cups needs some pdf-support ; the cups-error_log was complaining about libjbig2dec0_0.11-1_i386.deb and libopenjpeg2_1.3+dfsg-4_i386.deb
which I installed simply binarily from the debian-squeeze repository
http://packages.debian.org/squeeze/libjbig2dec0
http://packages.debian.org/squeeze/i386/libopenjpeg2
++ google search is sometimes better than debian search Laughing ++
(; luma-002 was missing libpoppler5 .... )
(4. problem was an unproper extension cord to the printer ""Unknown pending since"" Wink )
Back to top
View user's profile Send_private_message Visit_website 
Iguleder


Joined: 11 Aug 2009
Posts: 1923
Location: Israel, somewhere in the beautiful desert

PostPosted: Sun 26 Sep 2010, 06:48    Post_subject:  

No idea about the menu categories thing, actually Crying or Very sad

BUT, here I have some good news: I'm building an experimental 006.

New stuff:
- mplayer and GNOME-Mplayer replace gxine
- The gxine fix, in case some application needs Seamonkey's libraries
- Fixed the help page problem, fully working and integrated Seamonkey
- Pnethood replaces Gigolo Crying or Very sad
- Woof's xorgwizard and xwin - third attempt to fix the keyboard layouts problem
- EDIT: also the custom CUPS/ghostscript/X templates by playdayz; Karl Godt's report is very accurate, the two missing libraries are already in and I added the cupsd.conf to zzSqueeze_Utilities.

You can see all the custom dpup stuff (including PETs) here, including the Woof files used. The pet specs for all packages are listed in repo.txt.

ANOTHER EDIT: I'm really sorry if anyone feels ignored. I've been working for a week and had no spare time, I'm pretty sure I missed some replies. I'm trying to fix bugs in 006 and make it a bug-free 005, as much as possible. Let's hope keyboard layouts and CUPS work, after all we use the time-tested xorgwizard from Woof and the templates from Lupu, which worked.

01micko: your JWM uses /usr/etc instead of /etc, I'll make a new JWM probably.

_________________
My homepage
Back to top
View user's profile Send_private_message Visit_website MSNM 
ICQ 
dejan555


Joined: 30 Nov 2008
Posts: 2686
Location: Montenegro

PostPosted: Sun 26 Sep 2010, 07:57    Post_subject:  

Iguleder don't forget the gtkmoz symlink and .mrxvtrc Razz
_________________


Back to top
View user's profile Send_private_message Visit_website MSNM 
Iguleder


Joined: 11 Aug 2009
Posts: 1923
Location: Israel, somewhere in the beautiful desert

PostPosted: Sun 26 Sep 2010, 08:12    Post_subject:  

Added /root/.mrxvtrc and gtkmoz is already there, thanks Smile

EDIT: forgot to mention, I did some nice hack. Lupu runs the first-run wizard from xwin if I remember right, but I want to use the original Woof xwin so I can't replace it with a modified version from the zzSqueeze_Utilities pet, it will always replace the Woof xwin and I'll have to md5 it for each dpup release to make sure there are no changes in the Woof xwin.

I moved the first-run wizard to /root/Startup and added "rm /root/Startup/first-run.sh" to the end of it; now we get rid of the xwin update problem AND the first-run wizard runs only once, if you restart X to install some GPU drivers on your first dpup session, it won't appear again as in Lupu.

Yummy! Razz

_________________
My homepage

Edited_time_total
Back to top
View user's profile Send_private_message Visit_website MSNM 
ICQ 
01micko


Joined: 11 Oct 2008
Posts: 7835
Location: qld

PostPosted: Sun 26 Sep 2010, 08:16    Post_subject:  

Iguleder wrote:

01micko: your JWM uses /usr/etc instead of /etc, I'll make a new JWM probably.

Laughing it's a legacy thing Wink , it takes about 20 seconds to compile, but the important thing.. is BIDI working???

xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

I made a silly script that grabs e17 from SVN that works great in lupu.. (devx and deps are needed, but not too many Smile, it is HUGE [not compressed.. it's an SVN thing Rolling Eyes ] ) .. take a look in the 'desktop' forum in additional software. I'm sure it will work just as well in dpup, if not better Smile . I'll test it myself later. (you need a fast connection and a capable machine .. it is compiled on the fly Wink )

Cheers

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send_private_message Visit_website 
Iguleder


Joined: 11 Aug 2009
Posts: 1923
Location: Israel, somewhere in the beautiful desert

PostPosted: Sun 26 Sep 2010, 08:22    Post_subject:  

Nope, no BiDi. JWM always had this problem, I think we should check shinobar's i18n-and-BiDi-aware JWM, he posted a 493 recently.

Anyway, I have some interesting idea for 007, as 006 is mostly a bug-fix release - lxpanel/fbpanel/bmpanel with Openbox, available as a PET or a SFS. Kinda risky Laughing

_________________
My homepage
Back to top
View user's profile Send_private_message Visit_website MSNM 
ICQ 
Karl Godt


Joined: 20 Jun 2010
Posts: 3972
Location: Kiel,Germany

PostPosted: Sun 26 Sep 2010, 10:41    Post_subject:  

Fast as usual !

# uptime on dpup-005
06:30:03 up 5:06, load average: 0.06, 0.06, 0.09

to read and save a lot from the first 8 pages

also found the alien wallpaper on page 13

time to resize the personal save file ... Shocked
Back to top
View user's profile Send_private_message Visit_website 
Iguleder


Joined: 11 Aug 2009
Posts: 1923
Location: Israel, somewhere in the beautiful desert

PostPosted: Sun 26 Sep 2010, 11:16    Post_subject:  

Here's a Seamonkey 2.1 alpha 3 PET I made with my freshly written Seamonkey PET maker. 16 MB compared to the 14 MB of 2.0.8.

Made from the official binaries, nothing fancy, very snappy on 005.
smmaker-001.tar
Description 
tar

 Download 
Filename  smmaker-001.tar 
Filesize  20 KB 
Downloaded  329 Time(s) 

_________________
My homepage
Back to top
View user's profile Send_private_message Visit_website MSNM 
ICQ 
Lobster
Official Crustacean


Joined: 04 May 2005
Posts: 15117
Location: Paradox Realm

PostPosted: Sun 26 Sep 2010, 14:53    Post_subject:  

Thanks for 006
Here is a picture of an owl in a hat

_________________
Puppy WIKI
Back to top
View user's profile Send_private_message Visit_website 
DaveS


Joined: 09 Oct 2008
Posts: 3726
Location: UK

PostPosted: Sun 26 Sep 2010, 15:57    Post_subject:  

Geeeze Seamonkey is fast. 006 Printing however
Code:
/usr/lib/cups/filter/pstopdf failed

Was able to add printer though Smile

_________________
Spup Frugal HD and USB
Root forever!
Back to top
View user's profile Send_private_message 
Bert


Joined: 30 Jun 2006
Posts: 950

PostPosted: Sun 26 Sep 2010, 15:58    Post_subject:  

Lobster wrote:
Thanks for 006
Here is a picture of an owl in a hat

Hi Lobster,

I'm afraid we can't see that picture.
Did you mean something like this:

Even after googling it, I have no idea what "an owl in a hat" means. Sounds good though Smile

_________________


Back to top
View user's profile Send_private_message 
Karl Godt


Joined: 20 Jun 2010
Posts: 3972
Location: Kiel,Germany

PostPosted: Sun 26 Sep 2010, 16:54    Post_subject:  

http://www.murga-linux.com/puppy/viewtopic.php?p=453765#453765 ( page 20 last post )

/usr/share/ghostscript/8.71/Resource/Init/* ( 60 Items )
still missing .... Laughing

http://packages.debian.org/squeeze/ghostscript

started frugal as usual : Monitor Probed Fine ... Barks Fine ... both WELCOME PAGES FINE ... pgprs-shell -connect FINE SeaMonkey FINE .... CUPS-WEB-INTERFACE OK. .... after installing ghostscript/ .... /Init CUPS-PDF FINE .... Printer is pending but needs perhaps pupsave-file first or faster swap-DMA ....

Posting from your latest Seamonkey, Iguleder and it runs FINE on 005 ATM because the linkcode you posted didnot create -s links but hardlinks and playing around with links I deleted the .../seamonkey/lib*.so ... Smile
Embarassed Razz Shocked Cool Laughing
Back to top
View user's profile Send_private_message Visit_website 
Display_posts:   Sort by:   
Page 21 of 68 Posts_count   Goto page: Previous 1, 2, 3, ..., 19, 20, 21, 22, 23, ..., 66, 67, 68 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1024s ][ Queries: 12 (0.0165s) ][ GZIP on ]