(OLD) (ARCHIVED) Puppy Linux Discussion Forum Forum Index (OLD) (ARCHIVED) Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info

This forum can also be accessed as http://oldforum.puppylinux.com
It is now read-only and serves only as archives.

Please register over the NEW forum
and continue your work there. Thank you.

 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups    
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 01 Oct 2020, 04:41
All times are UTC - 4
 Forum index » House Training » Bugs ( Submit bugs )
Lucid Puppy 5.1.1 Bugs, Fixes, & Feedback
Moderators: Flash, Ian, JohnMurga
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies. View previous topic :: View next topic
Page 10 of 11 [155 Posts]   Goto page: Previous 1, 2, 3, ..., 8, 9, 10, 11 Next
Author Message

Joined: 07 Jan 2010
Posts: 29
Location: uk

PostPosted: Fri 26 Nov 2010, 09:32    Post subject:  

here's my experience of 5.1.1
first off all loaded fine and the first thing was to get touchpad tapping and scrolling working, tapping worked out of the box edge scrolling would not, then I thought I'd configure for my country (keyboard etc), so when I'd finished that scrolling worked tapping didn't, every time I ticked the box enable touchpad tapping, closed and reopened the mouse properties box, touchpad tapping tick in the box was gone.
All this became redundant after a couple of reboots as on boot up always get "kernel panic can't sync (something, sorry can't remember) tried 5.1.0 same kernel panic message, tried different memory stick, different machine, checked md5sum same evey time
Now happily back with 4.3.1 Very Happy
Back to top
View user's profile Send private message 

Joined: 03 Feb 2009
Posts: 20
Location: Alberta, Canada

PostPosted: Sat 27 Nov 2010, 01:09    Post subject: Oops!
Subject description: Bad shutdown recovery

Oops, I started a new topic (Bad Shutdown Recovery) that should have gone here. Full install accidental shutdown recovery apparently only works with EXt2, it just blew by on this ext3 formatted full install.

Back to top
View user's profile Send private message 

Joined: 01 Apr 2007
Posts: 100

PostPosted: Fri 03 Dec 2010, 13:37    Post subject: Arguments erased during "panel item" copy
Subject description: argument field entries are not carried over to the copy of a panel item.

Lucid Puppy 5.1 and 5.2 (241).
Dell Desktop
When an item, already displaying on the panel, is duplicated as a second copy on the panel, the Argument field's contents do not get copied to the new copy.
To test:
1. Enter some value into the Argument field of any of the items on a panel (after opening the item with the "Edit item" option.).
2. Drag that item, using your mouse, to an empty location on the panel, and drop it there.
3. Do an "Edit item" on the newly created icon.
4. Observe that the argument field is empty (should have had the value entered in "1", above.)


Back to top
View user's profile Send private message 

Joined: 03 Feb 2009
Posts: 20
Location: Alberta, Canada

PostPosted: Fri 03 Dec 2010, 14:58    Post subject:    

I think I am getting the hang of it !@#$%^&*()+Confused><
This is getting off topic.
Back to top
View user's profile Send private message 

Joined: 17 May 2009
Posts: 367
Location: Q8

PostPosted: Sat 04 Dec 2010, 03:28    Post subject:  

Last night i installed xfce4 and every thing was good but i uninstalled xfce4 and went back on JWM ,so far so good ?
Bad news is that now i cant reboot ,shutoff or restart x server from the menu.
The only way to reboot or shutoff is by the terminal.

Full install lupu 511,firefox, on a PIII Toshiba Satellite laptop,RAM is 192MB.
Back to top
View user's profile Send private message 

Joined: 16 Jun 2006
Posts: 2307
Location: Wyoming, USA

PostPosted: Sun 05 Dec 2010, 20:58    Post subject:  

I must have tried 5.1.1 on 2 dozen or more machines and never saw that Paul. (many of those with the same usb key installation). What filesystem is on the key? I usually use ext2. I know many prefer FAT for windows compatibility. Filesystem may not even be the problem. Some things have been changed in the init script since 431. If can you try another key, let us know if it still happens.

I suspect, as you apparently do, that it is hardware-dependent. It does have ext2 on it. It is a Patriot Rage 8GB drive, supposedly the fastest flash drive available.

I went into the icon manager and told it to redraw the drive icons, but that didn't do anything.

This is an annoyance, but not very important. I'd rather dig into Puppy Package Manager which needs attention and is very important.
Back to top
View user's profile Send private message 

Joined: 10 Nov 2009
Posts: 631
Location: Austria

PostPosted: Wed 08 Dec 2010, 08:40    Post subject: Xgamma-gui
Subject description: smoother change of Gamma Values

It is a nice feature to have the possibility to calibrate the RGB channels of the screen. xgamma-gui is the frontend for the programm xgamma which provides this feature. In puppy quickset it is called from Menu/Setup/Setup-Wizard/Xorg-Video-Wizard

However the version of the xgamma-gui included in 511 is buggy. This stems from a difference of the values provided by the gui-spinboxes and the required parameters from the xgamma program.

xgamma takes 3 parameters (floating point). Each of this parameters ranges from
0.1 (darkest) over 1.0 (default) to 10.0 (brightest)

xgamma-gui is build with spinboxes which range from
0 (should be the minimum) over 100 (default) to 200 (should be maximimum).

The values are simply cut from a string and fed to the xgamma program, so this gives some quirks for small values (less the 3 digits). The spinboxes are also linear, whereas the input to xgamma covers an exponential range (physiological features always follow exponential/logharitmic measures).

I tried to reimplemt the gui using the following simple transformation:
x--> y: y=10^(x/100)

whereas x denotes the linear spinbox values and y denotes the values need by xgamma

This allows spinnboxes which have a minimum at -100 (darkest), 0 (default) and +100 (brightest). The following graph shows the functional relation:

#Written by PANZERKOPF
#100215 hacked by BK
#101207 hacked by EW

# this is a Xdialog frontend for the xgamma program - setting colour calibration for the screen
# It is using the 3 RGB channels
# xgamma uses a logharithmic scale for the gamma values (0.1 - darkest, 1.0 - default, 10.0 - brightest) -> Y Values
# The GUI uses a linear scale (going from -100 - darkest, 0.0 - default, +100 - brightest) -> X Values
# The transformation is given by Y=10^(X/100)
# the calculation has to be performed with bc,
# to use decimal values in the exponent the equation must be rewritten Y = exp ( X/100 * log (10))
# or, setting the precision to 3 decimal points using bc command: Y=$(echo "e( "$X"/100 * l(10))" | bc -l)
# The reverse transformation is XRED=$(echo "scale:0; 100 * l($YRED) / l(10)" | bc -l)

TITLE="Monitor Gamma calibration"
BACKTITLE='Set percentage value for each colour,\nor adjust equally if only want to adjust\nbrightness of screen'

if [ "`which xgamma`" = "" ]; then
 Xdialog --title "${TITLE}" --msgbox "xgamma not found." 0 0

#get current settings (for startup)
YGAMMA=$((xgamma) 2>&1)

#transform y-->x values to get the current values;
XRED=$(echo "scale=3; 100 * l("$YRED") / l(10)" | bc -l)
XRED=$(echo "scale=0; "$XRED"/1" | bc -l) # cut decimals
XGREEN=$(echo "scale=3; 100 * l("$YGREEN") / l(10)" | bc -l)
XGREEN=$(echo "scale=0; "$XGREEN"/1" | bc -l) # cut decimals
XBLUE=$(echo "scale=3; 100 * l("$YBLUE") / l(10)" | bc -l)
XBLUE=$(echo "scale=0; "$XBLUE"/1" | bc -l) # cut decimals


while [ "${EXCODE}" = "0" ]; do

 XDGOUT=`Xdialog  --left --backtitle "${BACKTITLE}" --title "${TITLE}" --stdout --buttons-style "text" --icon "/usr/share/images/xgamma-gui.xpm" --ok-label "Apply" --cancel-label "Exit" \
--3spinsbox "" 0 0 "-100" "100" "$XRED" "Red" "-100" "100" "$XGREEN" "Green" "-100" "100" "$XBLUE" "Blue"`
 # get exit code
 # only remember the output XDGOUT if "Apply" was pressed.
 if [ "${EXCODE}" = "0" ]; then
 # substitute >space< for >/<, otherways there are problems to parse the string properly
 XGAMMA=$(echo $XGAMMA| sed 's:/: :g')
 # cut in pieces (parse) and assign
 set -- ${XGAMMA// / }
 # make transformation x-->y
 YRED=$(echo "scale=3; e( "$XRED"/100 * l(10))" | bc -l)
 YGREEN=$(echo "scale=3; e( "$XGREEN"/100 * l(10))" | bc -l)
 YBLUE=$(echo "scale=3; e( "$XBLUE"/100 * l(10))" | bc -l)
 #apply gamma values
 xgamma -rgamma ${YRED} -ggamma ${YGREEN} -bgamma ${YBLUE}

# if default values we dont need xgamma at startup, so remove the file. This saves time in .xinitrc
if [ "$XGAMMA" = "0 0 0" ]; then
   rm -f $HOME/.xgamma-gamma

# else ask if we want to save the current values and create a startup calibration file
Xdialog --yesno "Save current configuration?" 0 0
if [ ${?} -eq 0 ]; then
  echo -n "xgamma -rgamma $YRED -ggamma $YGREEN -bgamma $YBLUE"' &' > $HOME/.xgamma-gamma
  #...xgamma is executed in /root/.xinitrc
  echo "Saved" 


download at http://boxen.math.washington.edu/home/emil/stuff/xgamma-gui-log.sh

If you want to test it just run the script.

If you want to replace the built in xgamma-gui, just rename the script (to xgamma-gui)and place it in /usr/sbin (and make it executeable).

Doing the necessary calculations was a bit tricky using the "bc" program, but I think it works fine. It is also my 2nd script so there is surly room for improvements. I would especially like to see "instant" changes, i.e the gama values change while spinning the values in the dialog box. If anybody has an idea how to achieve that ( a clue might by that xdialog has an option where it writes the values to stdout each n milliseconds).

kind regards
Back to top
View user's profile Send private message Visit poster's website 

Joined: 06 Oct 2006
Posts: 133
Location: Cologne, Germany &/or Perth, Australia

PostPosted: Mon 13 Dec 2010, 19:24    Post subject: Ralink rt61pci ndiswrapper problems  

I've got a WIFI issue that as far as I can find out is not the fault of the puppy team (phew), but is bound to frustrate a lot of puppy users.
Network Wizard or Simple Network Setup made no difference.

I've got a D-Link pci card that needs the rt61pci driver.
The serialmonkey totally free GPL driver on most distros
goes but drops connections often for me, as the signal strength is low.

Go ndiswrapper.....ah not this time.
Previous puppies worked okay. This time nidiswrapper gives me errors on the win-xp .INF file with "invalid module".
I worked out it could no longer make the connection to the rt61.sys file.
None of the wizards work all stopping at the ndiswrapper error, so I did it manually:

Okay I copied that rt61.sys across to where ndiswrapper has its stuff (/etc/ndiswrapper/netrt61g/) and then in a console:
ndiswrapper -l
Now it seemes to work (apart from the "Depreciated config file" errors, but only if I do this to turn off the native driver
rmmod rt61pci

A few other conficts and errors came up. It's still not reliable. It hangs sometimes.

But then.. if you need it, the native rt61pci works kind of okay, if you install RutilT as it seems to help restore a dropped connection saving redoing all that setup in the wizards again.

For more reliability I tried to compile Ralinks own drivers.
- failure - "CFLAGS was changed in....Makefile. Fix it to use EXTRA_CFLAGS"
Seems other users on other distros have had similar problems trying to do the same. Ralinks drivers have been historically hard to compile.

All this is a dis to ndiswrapper developers and to Ralink for not keeping up with newer kernels or making robust code.

What to learn from this?
I don't know. Perhaps a little more debugging help in the network scripts?
A friendly "It's not puppy's fault: ndiswrapper said "#####" Try getting help on the puppy forum."

It would be a shame to loose lots of frustrated users because they can't get on the net. The network wizard scripts are great and tough.
A don't give up "this could be a way out" answer instead of a dead end no answers and the user's "Now What" frustration might keep the spirit going when underlying problems from non puppy sources mess it all up.
Back to top
View user's profile Send private message 

Joined: 26 May 2008
Posts: 1599
Location: Austin, TX, USA

PostPosted: Tue 14 Dec 2010, 21:57    Post subject:  

Here's a fun one: I was bragging about Puppy 5.1.1 and showing to a Linux newbie. Then I got clicky and cocky and was showing how to change the desktop.

I clicked on JWM configuration and clicked on "Or apply current gtk theme to JWM" and my tray/panel dissappeared!

They didn't need it, it was just a save file on their computer and I think we found a solution but I don't know for sure since I don't have access to it right now...ps: it had nothing to do with autohide as that was selected as off...weird.. Confused
Back to top
View user's profile Send private message Visit poster's website 

Joined: 16 Jun 2006
Posts: 2307
Location: Wyoming, USA

PostPosted: Thu 23 Dec 2010, 14:27    Post subject:  

I have a problem that shows up if I leave Puppy running overnight. The sound on a youtube turns to garbage, really weird noises, sounds like someone hammering on a pipe. However, "aplay /usr/share/audio/2barks.au" still works.

When I first boot I have no problem. It seems to work all day no problem, just goes bad overnight when the machine is idle. And, if I get this problem, and run through the alsawizard again, the problem goes away.

I see this sa me thing on completely different machines (although they may both be using snd_hda_intel).

I found that if I do "/etc/init.d/alsa stop" and then "/etc/init.d/alsa start", it fixes the bad noises.

Last edited by PaulBx1 on Sun 26 Dec 2010, 16:59; edited 1 time in total
Back to top
View user's profile Send private message 

Joined: 11 Aug 2008
Posts: 374
Location: Melbourne, Aus

PostPosted: Thu 23 Dec 2010, 17:43    Post subject: Multimedia Troubles
Subject description: (almost) Nothing seems to work

I re-installed Lucid 5.1.1 Frugal the other day, but now have no multi-media programs working. Gnome Mplayer opens up, but won't play any audio or video files.

VLC won't even open up.

SMplayer starts, but I keep getting this message:
"MPlayer has finished unexpectedly. Exit code: 127"

The fact that nothing is working suggests to me there is a problem in my setup, not just with the software itself. But I'm not sure where to look.

any suggestions will be gratefully received.


I have discovered that PMusic and Pcd - CD Audio Player do work. But still none of the others.

Dell Latitude D630 running Puppy 5.2.8 frugal, Macpup 525 frugal (if I can get it working again. Sadly, I couldn't get it fixed Confused )
Precise Puppy 5.4 live DVD
Precise 5.7.3 on USB

Last edited by bones01 on Thu 23 Dec 2010, 18:28; edited 1 time in total
Back to top
View user's profile Send private message 

Joined: 16 Jun 2006
Posts: 2307
Location: Wyoming, USA

PostPosted: Thu 23 Dec 2010, 18:02    Post subject:  

I see a strange thing with Rox. If I am in certain directories, such as /tmp and sometimes /root, I get at the top of the window the note "(Scanning)" about every 2 seconds. Very irritating...
Back to top
View user's profile Send private message 

Joined: 03 Apr 2007
Posts: 3425
Location: Oregon

PostPosted: Sat 01 Jan 2011, 13:30    Post subject:
Subject description: Memorex DVD +R capacity problem

I bought some memorex DVD +R disks with a rated capacity of 4.37 gigs.
In Puppy 5.11, the disks are reported as only having 2.20 gigs capacity.
In Windows Vista, the full capacity is seen.
So my question is does Puppy need an updated driver for the DVDrw/CDrw drive?

BTW, I discovered this after burning the large LightHouse G iso as an image to the DVD and even though Puppy is supposed to leave the session open on the DVD, it closed the session as well as not seeing the full capacity of the disk.

Back to top
View user's profile Send private message 

Joined: 18 Nov 2007
Posts: 250
Location: NZ

PostPosted: Sun 02 Jan 2011, 19:04    Post subject:  

Hi all,

On my Toshiba nb200, it finds all network interfaces, and sound from the speakers works.

After adding "options snd-hda-intel model=auto" to /etc/modprobe.d/alsa-base.conf also the internal speakers work.

However, the whole thing will freeze after anything from a few seconds to a minute if there is no mouse or keyboard activity. This means that for example right now typing this the cursor will stop blinking and the animated emoticons on the left will stop being animated after some time. More annoyingly music and video experience the same problem. Making Lupu for my purposes unusable. When I move the mouse everything resumes as normal. (For example if I left it frozen for 5 seconds and move the mouse my song playing resumes 5 seconds from where it froze.)

The same problem happens in all fluppy versions. I believe it is a kernel problem because when I moved the kernel from fluppy into puppy 4.3.1 the same problem appeared.

I really hope someone can figure this one out. I don't think that it's a puppy problem though.

An expert is just a beginner with experience.
Shamelessly representing TdeM!
Back to top
View user's profile Send private message Visit poster's website 

Joined: 08 Jul 2009
Posts: 5485
Location: Finland

PostPosted: Sun 09 Jan 2011, 09:51    Post subject:  

I made package of laptop goodies for Lucid 5.2. Package consists of Frisbee wireless unofficial, acpid-1.0.10-1, acpitool, xbindkeys, xbindkeys-config, vattery-ibam and Iguleder`s ppower. The original usage was in woof build Lucid 5.1.1 based derivative, so this laptop-001.pet should work in both Lucid 5.1.1 and Lucid 5.2.

Scripts are mostly from Fluppy 010. Thank you Jemimah. Frisbee script is from 4.1.2011 frisbeefix-2.pet, other Frisbee stuff is from Fluppy 010 and connectwizard update is done by me.

These addons enable more laptop buttons and Fn keys. Shutdown button shuts down, Zz button suspends to ram, PrtSc button launches mtPaint-snapshot, Multimedia keys play, stop, previous and forward uses and launches deadbeef, if you have it installed. My Luci compiled Deadbeef-0.4.4 is also in this post.

Frisbee is added to the connect wizard, not made as default like in smil99`s pet. Frisbee is still at beta phase and Jemimah hasnt made official pet of it yet.

Rfkill seems to shutdown and enable my wireless with wireless button, but Tempestuous rfkill kernel module update might be useful for some laptop users:

Vattery-ibam stuff gives you new battery menu-tray icon. The precision of ibam is somewhat questionable, but vattery gives you verbose warnings. The battery percentage in which the warnings comes, you can edit yourself in /root/.config/vattery. Just modify warning=15 and critical=5 values.

If you have enabled your cpu frequency scaling, the ppower menu-tray icon gives you possibility to change between cpu frequencies. This works better in Lucid 5.2 cause of better cpu frequency scaling app.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 10 of 11 [155 Posts]   Goto page: Previous 1, 2, 3, ..., 8, 9, 10, 11 Next
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies. View previous topic :: View next topic
 Forum index » House Training » Bugs ( Submit bugs )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1678s ][ Queries: 12 (0.0952s) ][ GZIP on ]