Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 22 Oct 2017, 22:39
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Drivers
Drivers for Puppy 5.1-5.2.8 with 2.6.33.2 kernel
Post new topic   Reply to topic View previous topic :: View next topic
Page 13 of 14 [201 Posts]   Goto page: Previous 1, 2, 3, ..., 11, 12, 13, 14 Next
Author Message
tempestuous

Joined: 10 Jun 2005
Posts: 5468
Location: Australia

PostPosted: Mon 02 Jun 2014, 00:22    Post subject:  

June 2014
I just compiled and uploaded the Realtek 8188eu USB wifi driver -
www.smokey01.com/tempestuous/8188eu-rev382-k2.6.33.2.pet

Known supported wifi dongles:
TP-Link TL-WN723N v3
TP-Link TL-WN725N v2
Back to top
View user's profile Send private message 
tempestuous

Joined: 10 Jun 2005
Posts: 5468
Location: Australia

PostPosted: Sat 28 Jun 2014, 22:57    Post subject:  

JUNE 2014
Here is the dm9601 USB-LAN driver, updated to include 8 new device ID's, which I have taken from the latest version of the driver from recent 3.x kernels.
dm9601-updated-k2.6.33.2.pet
Description  for Puppy 5.1/5.2.x
pet

 Download 
Filename  dm9601-updated-k2.6.33.2.pet 
Filesize  5.38 KB 
Downloaded  377 Time(s) 
Back to top
View user's profile Send private message 
Griot


Joined: 12 Sep 2014
Posts: 131
Location: Serbia

PostPosted: Mon 15 Sep 2014, 18:14    Post subject:  

tempestuous wrote:
There's a range of Creative Labs/E-MU sound cards supported by the snd-emu10k1 ALSA driver already in Puppy,
but several of these cards require firmware as well. I'm uncertain about all the models involved, but certainly the well-known E-MU 0404 PCI card requires this firmware.

Note: the E-MU 0404 USB is a completely different animal, which uses the generic snd-usb-audio ALSA driver.

After installing this dotpet, reboot. Then run the ALSA Wizard.


Hi all, this is my first post on the forum. Looks like I have a problem configuring Creative sound card. After initial setup, Retrovol tray icon and menu entry both disappeared. I'm new to Linux but i guess it's related to this script (/root/startup):

#!/bin/sh

#exec retrovol -hide ${BGOPT} #BGOPT is exported from /usr/sbin/delayedrun.

#retrovol 0.10, -bg option no longer needed...
exec retrovol -hide

Experienced advice would be much appreciated. Cheers!

Edit: Excuse me for posting in this topic but I couldn't find much in other (ancient) threads. My PC runs Puppy Precise 5.7.1. (Kernel 3.9.11, PAE, i686), Frugal install on HDD.

Edit 2: Disabling onboard sound within BIOS solved my problem. Wink
Back to top
View user's profile Send private message 
Pelo

Joined: 10 Sep 2011
Posts: 12591
Location: Mer méditerrannée (1 kms°)

PostPosted: Fri 06 Nov 2015, 20:33    Post subject: RTL8192CU driver for wireless dongle  

RTL8192CU driver for wireless dongle
You can easily improve wireless connection of your laptop with a dongle for a few pennies, or dollars (or 10 euros).
rcrsn51 has compiled drivers for you, kernel 2.6.33.2 here, click please
How-to video by Pelo, cliquer SVP
rtw-usb-drv.jpg
 Description   
 Filesize   46.7 KB
 Viewed   502 Time(s)

rtw-usb-drv.jpg


_________________
Passenger Pelo ! don't ask him to repair the aircraft. Don't use him as a demining dog .... pleeease.
Back to top
View user's profile Send private message Yahoo Messenger 
James186282


Joined: 08 Sep 2009
Posts: 254
Location: Minnesota

PostPosted: Tue 27 Dec 2016, 15:53    Post subject:  

tempestuous wrote:
Here is the USB 3.0 Linux driver, which was not enabled in the standard Puppy 5.1.x kernel.
The driver is called xhci
I have also included the upgraded isp1760 USB driver, which is apparently USB 3.0 compatible, though very few Puppy users will ever use this driver because the relevant interface is found on embedded devices.
After installing this dotpet, reboot, and the xhci driver should automatically load for any compatible interface detected at boot up.


Got it and it worked on install of my AMD64 machine running Tahr 64 but after the first reboot it didn't work. If I modinfro it doesn't appear. *Also it seems to have installed in an older Linux versions subdirectory. dmsg reports finding the PCI card fine.

dmsg starts signaling errors after finding the hardware.
xhci_hcd 0000:01:00.0: Timeout while waiting for setup address command
xhci_hcd 0000:01:00.0: Stopped the command ring failed, maybe the host is dead

and these...
Abort command ring failed
HC died; cleaning up
Timeout while waiting for setup address command
Abort the command ring, but the xHCI is dead

Should I be trying to add this to the drivers that Puppy installs? *And what is the proper way to do that? Or is this a 32 versus 64 bit problem? Any help super most appreciated.

_________________
Science is what we understand well enough to explain to a computer.
Art is everything else we do.
Donald Knuth
Back to top
View user's profile Send private message 
tempestuous

Joined: 10 Jun 2005
Posts: 5468
Location: Australia

PostPosted: Sat 21 Jan 2017, 06:30    Post subject:  

Compatibility, or otherwise, of the drivers posted in this forum thread can be seen from the title of the thread, but for a clearer explanation, please read the very first sentence in the very first post -
http://www.murga-linux.com/puppy/viewtopic.php?p=443984#443984
Back to top
View user's profile Send private message 
issac99289928

Joined: 19 Jan 2016
Posts: 10

PostPosted: Mon 21 Aug 2017, 05:05    Post subject:  

I cannot find any pet with rt3070 again .need help. thanks.
Back to top
View user's profile Send private message 
perdido


Joined: 09 Dec 2013
Posts: 643
Location: Altair IV , Just north of Eeyore Junction.

PostPosted: Mon 21 Aug 2017, 05:12    Post subject:  

issac99289928 wrote:
I cannot find any pet with rt3070 again .need help. thanks.


Looks like this one maybe?
http://www.murga-linux.com/puppy/viewtopic.php?p=513360#513360

Edit: Looks like the driver is missing in that thread/post, there are no links anymore??
Edit: The rt3070sta-v2.3.0.1-k2.6.33.2.pet seems to be MIA
Can't even find it on the wayback machine! What kind of witchcraft is this???

.
Back to top
View user's profile Send private message 
perdido


Joined: 09 Dec 2013
Posts: 643
Location: Altair IV , Just north of Eeyore Junction.

PostPosted: Mon 21 Aug 2017, 06:08    Post subject:  

Found it Razz

[url]h̶t̶t̶p̶s̶:̶/̶/̶w̶e̶b̶.̶a̶r̶c̶h̶i̶v̶e̶.̶o̶r̶g̶/̶w̶e̶b̶/̶2̶0̶1̶5̶0̶4̶0̶6̶0̶1̶2̶9̶5̶1̶/̶h̶t̶t̶p̶:̶/̶/̶p̶u̶p̶p̶y̶l̶i̶n̶u̶x̶s̶t̶u̶f̶f̶.̶m̶e̶o̶w̶n̶p̶l̶a̶n̶e̶t̶.̶n̶e̶t̶:̶8̶0̶/̶a̶a̶r̶f̶/̶p̶e̶t̶s̶-̶s̶c̶r̶i̶p̶t̶s̶-̶z̶i̶p̶s̶/̶r̶t̶3̶3̶7̶0̶s̶t̶a̶-̶v̶2̶.̶4̶.̶0̶.̶1̶-̶k̶2̶.̶6̶.̶3̶3̶.̶2̶.̶p̶e̶t̶[/url]

Now lets hope it works Exclamation

Edit: did not work so removed pet attachment due to corruption

Last edited by perdido on Mon 21 Aug 2017, 08:36; edited 3 times in total
Back to top
View user's profile Send private message 
issac99289928

Joined: 19 Jan 2016
Posts: 10

PostPosted: Mon 21 Aug 2017, 07:38    Post subject:  

hi Perdido ,rt3370sta-v2.4.0.1-k2.6.33.2.pet seems corrupt .It could not be installed .
Back to top
View user's profile Send private message 
issac99289928

Joined: 19 Jan 2016
Posts: 10

PostPosted: Mon 21 Aug 2017, 07:51    Post subject:  

hi Perdido , after checking with winhex ,rt3370sta-v2.4.0.1-k2.6.33.2.pet is a html . not a pet file.
Back to top
View user's profile Send private message 
perdido


Joined: 09 Dec 2013
Posts: 643
Location: Altair IV , Just north of Eeyore Junction.

PostPosted: Mon 21 Aug 2017, 07:54    Post subject:  

issac99289928 wrote:
hi Perdido ,rt3370sta-v2.4.0.1-k2.6.33.2.pet seems corrupt .It could not be installed .


Hello Isaac,

That was the only one I could find so far. Darn!.

I should have looked at it after I got it from archive.org, looks like it gave me the web page named as a pet Confused

I will remove that from the post.

We need some more help here!

.

_________________
.
Back to top
View user's profile Send private message 
perdido


Joined: 09 Dec 2013
Posts: 643
Location: Altair IV , Just north of Eeyore Junction.

PostPosted: Mon 21 Aug 2017, 08:17    Post subject:  

OK, with much thanks to ally the archiver!

Here is the link to the RT3370 pet, it is a pet this time lol
https://archive.org/download/RussoodlessPuppyLinuxStuff-aarf/rt3370sta-v2.4.0.1-k2.6.33.2.pet

The pet is too big to attach to the page, must be why it went missing, probably due to space limits on murga.
It is a real pet this time.

Have found where ally archived Russoodle's whole site :
https://archive.org/search.php?query=subject%3A%22Russoodle%27s%22

Hope that this one works, Isaac!

.
Back to top
View user's profile Send private message 
ally


Joined: 19 May 2012
Posts: 1535
Location: lincoln, uk

PostPosted: Mon 21 Aug 2017, 10:25    Post subject:  

Smile
Back to top
View user's profile Send private message Visit poster's website 
issac99289928

Joined: 19 Jan 2016
Posts: 10

PostPosted: Mon 21 Aug 2017, 10:49    Post subject:  

Hello perdido ,rt3370sta-v2.4.0.1-k2.6.33.2.pet does not work on my adapter .anyway thanks for your effort.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 13 of 14 [201 Posts]   Goto page: Previous 1, 2, 3, ..., 11, 12, 13, 14 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Drivers
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0722s ][ Queries: 12 (0.0150s) ][ GZIP on ]