Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 21 Dec 2014, 19:26
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » REQUESTS
Perl 5.12.1 as a pet
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
Q5sys


Joined: 11 Dec 2008
Posts: 1074

PostPosted: Tue 13 Jul 2010, 18:25    Post_subject:  Perl 5.12.1 as a pet
Sub_title: not the whole thing
 

I've already gone and compiled the whole thing, but its rather large, due to the fact that when I compiled it was the entire enviroment. Im looking for a trimmed package with just the good stuff needed for running programs and none of the excess fluff. Someone made such a package for 5.8.8. Was wondering if someone out there in puppyland could be generous to do so for the latest stable version as well.
_________________



Back to top
View user's profile Send_private_message Visit_website 
Q5sys


Joined: 11 Dec 2008
Posts: 1074

PostPosted: Mon 19 Jul 2010, 15:21    Post_subject:  

anyone able? One of you uber skilled people should be able to crank it out in no time... My attempt was 59Mb, I know it can be trimmed down ALOT more than that.
_________________



Back to top
View user's profile Send_private_message Visit_website 
Q5sys


Joined: 11 Dec 2008
Posts: 1074

PostPosted: Tue 27 Jul 2010, 16:35    Post_subject:  

bumping back to the top
_________________



Back to top
View user's profile Send_private_message Visit_website 
sc0ttman


Joined: 16 Sep 2009
Posts: 2387
Location: UK

PostPosted: Sat 03 Mar 2012, 07:56    Post_subject:  

BUMP...

I'd be very interested in having a PERL install that actually works!
Sure Puppy includes the bare minimum, but it's missing so much..

Maybe Lupu is better than T2 pups, but...

- CPAN does not work right, cos locale.pm, cpan.pm, Lib.pm, etc are missing (and most of their deps)..
- also missing is MakeMaker and its deps,
- many other important cpan modules are missing
- Luckily the 'perl_base' pkg from ubuntu contains many of these files..

So in short, I want the *minimal* PERL stuff required to do the following:

- compile Snes9x-gtk (and other apps that need intltools PERL deps)
- add new cpan modules, using cpan in the console!
- use MakeMaker

If no one has such a working PERL pkg,
I will be building my own PERL, based on the w5c version, I think..
Or the lupu/ubuntu pkgs...

_________________
Akita Linux, VLC-GTK, Pup Search, Pup File Search
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » REQUESTS
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0422s ][ Queries: 11 (0.0043s) ][ GZIP on ]