Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 19 Apr 2014, 11:48
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Video
kdrives-1.4.2 (Xvesa etc...)
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [7 Posts]  
Author Message
technosaurus


Joined: 18 May 2008
Posts: 4134

PostPosted: Sat 26 Jun 2010, 19:29    Post subject:  kdrives-1.4.2 (Xvesa etc...)  

I think xorgserver-1.4.2 is the last version that will build without libpciaccess, so I built the kdrives from that (most are familiar with Xvesa, which is just one of the kdrives) ... if you are having trouble with xorg but still want some hardware specific acceleration, then try one of these.

I've tested Xvesa only. All xecutables are stripped and upx'd, so do NOT strip them again or they will be rendered useless.

_________________
Web Programming - Pet Packaging 100 & 101

Last edited by technosaurus on Mon 10 Sep 2012, 23:41; edited 2 times in total
Back to top
View user's profile Send private message 
technosaurus


Joined: 18 May 2008
Posts: 4134

PostPosted: Sat 26 Jun 2010, 19:30    Post subject:  

Here is Xvesa and Xfbdev
_________________
Web Programming - Pet Packaging 100 & 101
Back to top
View user's profile Send private message 
joe-roberts

Joined: 18 Feb 2008
Posts: 3

PostPosted: Mon 03 Jan 2011, 12:44    Post subject:  

Sorry for the dumb question, but how do you use these? What are the compatibility issues, such as puppy version, or kernel version, or Xorg version if any.

Thanks.
Back to top
View user's profile Send private message 
technosaurus


Joined: 18 May 2008
Posts: 4134

PostPosted: Mon 03 Jan 2011, 13:41    Post subject:  

I use a laptop with intel graphics that only takes Xvesa, so I can't say for sure, but my first attempt at a hack would be to simply rename the corresponding executable (depends on your video card) to Xvesa and see if xorgwizard takes care of it when you select Xvesa.
_________________
Web Programming - Pet Packaging 100 & 101
Back to top
View user's profile Send private message 
Karl Godt


Joined: 20 Jun 2010
Posts: 3860
Location: Kiel,Germany

PostPosted: Thu 02 Jun 2011, 13:36    Post subject:  

Hi technosaurus !

I was running only Xorg nv & vesa x=800 to 1600 before and was able to get the pre-installed Xvesa to work without any problems so far on MacpupOpera2pup431 .
Then I tried the pre-installed on MacpupFoxy3pup-430 and have a blank black screen .

Now I installed your Xvesa driver on a luci-218/pup-511 full install which has no Xvesa pre-installed and despite the wierd code of xorgwizard,xwin,delayedrun,.xinitrc it booted to functional desktop . Smile

Unfortunately I can't get the mouse to work . In Opera2 /dev/mouse is linked to /dev/psaux and still works .

I have compared /etc,/var,/tmp files , elspci-l,lsmod etcetera , and if somewhere there would be the solution , I couln't find it .

Does anybody know if there are workarounds for black screens and input-ware ?

I also miss the Cntl+Alt+F[1-12]|BackSpace possibilities of Xorg to switch|exit to console. Do they exist for Xvesa ?
Back to top
View user's profile Send private message Visit poster's website 
Karl Godt


Joined: 20 Jun 2010
Posts: 3860
Location: Kiel,Germany

PostPosted: Tue 07 Jun 2011, 12:38    Post subject:  

Yes , also Xvesa normally switches to the prompts defined @/etc/inittab
with ALT+CONTROL+F[1-9]*

I have compiled Xorg-7.1.1 = xserver-1.1.1 from debian etch sources @MacPupF3

and Xvesa works fine @MacPupF3 @xwin [enlightenment_start&jwm]

I used the configure options

"--enable-xgl --enable-xglx --enable-xegl --enable-kdrive --enable-multibuffer --enable-glx-tls --enable-install-libxf86config --enable-builddocs"

and "strip" became 192KB bigger than the original Xvesa
and "strip && upx -9" it became 544KB in size .

This also boots into jwm @puppy5 with mouse and switching to terminals , but even compiled @puppy5 it does not work with gtk&gtk-dialog apps . The only things that were working had been "rxvt" and "xmessage" .

I also recognized , that many defaults of the configure options had changed from 1.1.1 to 1.4.2

If time permits , I will compile later xorgs @puppy5 , to see , how they would work .

I must say , that latest </X11/extensions/panoramiXext.h>
contains code as
Quote:

extern Status XPanoramiXGetScreenSize (
Display * /* dpy */,
Drawable /* drawable */,
int /* screen_num */,
XPanoramiXInfo * /* panoramiX_info */
);

which forced running make -k to compile the kdrives but Xorg itself did not compile .
Back to top
View user's profile Send private message Visit poster's website 
technosaurus


Joined: 18 May 2008
Posts: 4134

PostPosted: Tue 07 Jun 2011, 15:05    Post subject:    

http://murga-linux.com/puppy/viewtopic.php?t=62145
My latest static uclibc compile is really tiny and will still work even if x11 and libc are broken ... but then you'd need other static X-apps too.

_________________
Web Programming - Pet Packaging 100 & 101
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [7 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Video
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0474s ][ Queries: 11 (0.0051s) ][ GZIP on ]