Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 18 Dec 2014, 23:20
All times are UTC - 4
 Forum index » Off-Topic Area » Programming
Problem with Puppy and Android-SDK
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [3 Posts]  
Author Message
rhadon


Joined: 27 Mar 2008
Posts: 1293
Location: Germany

PostPosted: Thu 20 May 2010, 06:41    Post subject:  Problem with Puppy and Android-SDK
Subject description: adb doesn't find my Motorola Milestone
 

HI,
I want to tether my Milestone and found an easy instruction for Ubuntu. There it works fine. It requires Android-SDK on the laptop and azilink on the phone.
I think I isolated the problem: Adb doesn't find my USB-connected Milestone.

Then in both OS (Ubuntu 8.04 and Lucid Puppy ) I installed only ANDROID-SDK, copied adb to /usr/bin and copied 91-android.rules to /etc/udev/rules.d/.

91-android.rules:
Code:
SUBSYSTEM=="usb", ATTRS(idVendor)=="22b8", SYMLINK+="android_adb", MODE="0666", OWNER="root"

Running adb devices starts the daemon but gives an empty device list in Puppy.
I hope you can smile about my stupidity and one can easily point me to the right direction.

~ Rolf

_________________
Ich verwende "frugal", und das ist gut so. Wink
Raspberry Pi without Puppy? No, thanks.
Back to top
View user's profile Send private message 
weffy

Joined: 30 Mar 2006
Posts: 34

PostPosted: Sun 15 Aug 2010, 17:51    Post subject:  

Did you ever figure this out? I'm having the same problem. I have a rooted Nexus One and I need adb working to modify the device. Adb seems to have installed correctly - it just doesn't recognize my phone. I saw in my research that using lsusb will list the device's ID which you would plug into the script you listed for 91-android.rules. But lsusb is 'command not found'. Maybe I need to be in a certain directory. Or there might be a different command to use.

I saw on the internet for my device a vendor ID of '18d1' but that still doesn't work. I'll keep working on it.
Back to top
View user's profile Send private message 
weffy

Joined: 30 Mar 2006
Posts: 34

PostPosted: Mon 30 Aug 2010, 08:14    Post subject:  

Here's where I'm at.

According to this http://developer.android.com/guide/developing/tools/adb.html , adb sets up a server and is bound to port 5037 where it listens for communication from the phone. I can't remember what the command was, but I verified that adb is doing this. So it appears that the phone is not able to connect to that port to communicate with the adb server. I don't have a firewall installed.

The phone has 3 modes with which it can connect to the computer - as a mass storage device, as a modem and a debugging mode to connect to adb. The first 2 work flawlessly.

I'm not sure what is keeping Puppy(Lucid 510, frugal install) from seeing the device in debugging mode and allowing it to communicate to port 5037. It may be a udev rules issue or lack of correct kernel module or some other protocol issue. Looking at Pupscan, with the phone in modem mode, the loaded kernel module is rndis_host. In debugging mode there is no loaded kernel module.

Some one with more knowledge than I have of the pup event backend, could probably figure this out. Any ideas welcome!
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [3 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Off-Topic Area » Programming
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0475s ][ Queries: 11 (0.0051s) ][ GZIP on ]