Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 30 Oct 2014, 12:26
All times are UTC - 4
 Forum index » Taking the Puppy out for a walk » Announcements
Official 4.3.2
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 30 of 31 Posts_count   Goto page: Previous 1, 2, 3, ..., 28, 29, 30, 31 Next
Author Message
sindi

Joined: 16 Aug 2009
Posts: 395

PostPosted: Mon 13 Jan 2014, 12:15    Post_subject: Puppy 4.3.2 vs 4.3.1-retro with fb on the same computer
Sub_title: Do not mix the two (different kernels)
 

I am online with 4.3.2-plus (Seamonkey 2 - flashblock much appreciated at the murga-linux site, also the puppy bookmarks). DELL D600.

I seem to have a default 500MB filespace. I usually choose 32MB and then use shared browsers from outside the file system because I have lots of operating systems on a 10GB hard drive and that saves space.

Seamonkey just updated two of my addons automatically.
(Which means 4.3.2 was not quite up to date).

Flash is 10.0 (chosen for its size?). I read that 10.2 or later uses less memory. 10.1 uses more memory than 10.3 in my tests. 10.0 is 10 MB, 10.3 12.5 MB filesize.

Boots with lilo. I had to add pfix=ram so it would not use the pupsave.2fs file on my computer, which is from puppy 4.3.1-retro (older 2.6.21.7 kernel). Without this pfix, it wanted to update my 4.3.1 installation and would have messed things up because of the different kernels. I prefer the older kernel because it calls my ide drives hda not sda, and my hardware is 2003 or earlier. Retro kernel has worked on all but one (900MHz Toshiba laptop) computer.

I won't make a save file because in 4.3.1 I am using framebuffer console (much nicer-looking text than rxvt provides) and when booting I cannot see what is happening early enough to choose between pupsave files and it gets stuck on a black screen. If I knew enough I would change things so 4.3.2 looked for a differently named save file.

I will install to a different computer (without retro 4.3.1) and continue testing, after reading the 29 pages of discussion. Thanks to everyone who contributed to this version.
Back to top
View user's profile Send_private_message 
sindi

Joined: 16 Aug 2009
Posts: 395

PostPosted: Mon 13 Jan 2014, 12:27    Post_subject: 4.3.2 v3plus vs updated-glibc version  

The V3 plus version that I successfully downloaded has glibc 2.6.1 and flash 10.0.

Is the version with glibc 2.10 and flash 10.3 and newer libjpeg built from V3 plus or the original V3?
Back to top
View user's profile Send_private_message 
darry1966

Joined: 26 Feb 2012
Posts: 488
Location: New Zealand

PostPosted: Mon 13 Jan 2014, 14:23    Post_subject: Re: 4.3.2 v3plus vs updated-glibc version  

sindi wrote:
The V3 plus version that I successfully downloaded has glibc 2.6.1 and flash 10.0.

Is the version with glibc 2.10 and flash 10.3 and newer libjpeg built from V3 plus or the original V3?


Been having a little bit of fun with this Pup and woofy and decided to produce an updated iso with regards to glibc to 2.10/and added gtkdialog 4 etc anyway download from here and read the notes in text form also from here

To beto 2.10 honest I only Updated the following

glibc 2.10 and glibc locales
gtkdialog4
flashplayer 10.3.183.90
libjpeg’s 7 and 8
libtiff4.3.9.4-5

libstc++6_4.4.5-8
menumaker
Left original Seamonkey which updates to latest

So the rest is pretty original as abiword for example is 2.8 so this is still a good choice for old kit and the dbus libraries are already setup. So well done and thanks Ttuuxxx.

http://sourceforge.net/projects/dazsbarebonespups/files/4.32v3%20Updated%20with%20glibc%202.10/

Edited_time_total
Back to top
View user's profile Send_private_message 
sindi

Joined: 16 Aug 2009
Posts: 395

PostPosted: Mon 13 Jan 2014, 14:56    Post_subject: which 4.3.2 is which  

I had already read what you kindly copied over again. I cannot tell
whether the 'pup' you updated with newer glibc and flash is 'V3 plus'
which I just downloaded, or the official V3 version at archive.org.

I am guessing the latter. I know how to update glibc and other libraries
manually.

(I just also checked lamia site, with opera, and all the puppy files I
checked are 404 not found though they are all listed in the index).

Is there some way other than in the middle of booting to instruct
puppy which pupsave.2fs file to load? I can point it at the sfs file.
I can't see the choices when I boot with framebuffer console - what
normally appears onscreen simply does not show up at that point in the
boot process.
Back to top
View user's profile Send_private_message 
ally


Joined: 19 May 2012
Posts: 856
Location: lincoln

PostPosted: Mon 13 Jan 2014, 17:37    Post_subject:  

darry's version is called '4.3.2.V3_updated.iso' on archive.org and is here:

http://archive.org/download/4.3.2.V3/4.3.2.V3_updated.iso

the original is here:

http://ia601705.us.archive.org/30/items/4.3.2.V3/4.3.2.V3.iso

and 'plus' is here:

http://ia601708.us.archive.org/7/items/432V3plus/432-v3plus.iso

Smile
Back to top
View user's profile Send_private_message Visit_website 
darry1966

Joined: 26 Feb 2012
Posts: 488
Location: New Zealand

PostPosted: Mon 13 Jan 2014, 18:43    Post_subject:  

thanks ally I tried to get links to work as you have done and couldn't lost hair tearing it out trying to understand how to do it.
Back to top
View user's profile Send_private_message 
Fossil

Joined: 13 Dec 2005
Posts: 627
Location: Gloucestershire, UK.

PostPosted: Mon 13 Jan 2014, 19:57    Post_subject:  

darry1966,
A quick 'How-To'

It's a three stage process to post a 'live' URL.
Assuming you have already copied the website address into memory.

ONE. Look up to the last rectangular box directly above the text box, the upper right, showing an underscored capitalized URL. Click on it.
This will appear [url]

TWO. Paste website address from memory to alongside the [url] tag.
For instance [url] http://murga-linux.com/puppy/index.php

THREE. Having done that. Go back up to the rectangle containing the URL. Click it again, the end tag will appear.
The result will look like this (once posted, to those viewing your website address, the square-bracketed url's will be invisible ). [url]http://murga-linux.com/puppy/index.php [/url]

The website will now be 'live' and clickable.
Back to top
View user's profile Send_private_message 
darry1966

Joined: 26 Feb 2012
Posts: 488
Location: New Zealand

PostPosted: Mon 13 Jan 2014, 22:14    Post_subject:  

Thanks Mr Fossil for taking the time to explain this.

http://sourceforge.net/projects/dazsbarebonespups/files/4.32v3%20Updated%20with%20glibc%202.10/

Edited_times_total
Back to top
View user's profile Send_private_message 
Makoto


Joined: 03 Sep 2009
Posts: 1799
Location: Out wandering... maybe.

PostPosted: Mon 13 Jan 2014, 23:44    Post_subject:  

An easy way to do it is to enter the URL text first, highlight it, and then press the URL tag button. The editor will wrap both tags around the text. Smile
_________________
[ Puppy 4.3.1 JP, Frugal install | 1GB RAM | 1.3GB swap ] * My Pidgin Builds for Puppy 4.3.1+
In memory of our beloved American Eskimo puppy (1995-2010) and black Lab puppy (1997-2011).
Back to top
View user's profile Send_private_message 
starhawk

Joined: 22 Nov 2010
Posts: 2984
Location: Everybody knows this is nowhere...

PostPosted: Tue 14 Jan 2014, 23:20    Post_subject:  

sindi, do you still need 432v3? I don't think I have the updated version.
_________________
Loving X-Slacko 2.1!
Custom Build: HP MOCA-AR + Core2Duo T7200 + 4gb RAM + 256gb SSD
...just needs a pretty case Wink
Back to top
View user's profile Send_private_message 
sindi

Joined: 16 Aug 2009
Posts: 395

PostPosted: Thu 16 Jan 2014, 09:25    Post_subject: Forks of puppy 4.3.2v3  

Thanks starhawk - all three links are now listed clearly in one place.

V3 seems to have forked to Plus (a bunch of things changed but not glibc) and Updated (mainly newer glibc). I will attempt to combine the two sets of improvements unless someone more skilled can do that and post the result. I found a glibc 2.11.3 deb package.

4.3.2 is much appreciated. Wary is not useful on this 2003 laptop because cpufreq cannot be used as in Puppy 4 to keep the BIOS from fixing cpu speed at 600MHz instead of ranging up to 1.6GHz.

A little wire on motherboard is supposed to sense another wire in DELL OEM psu and if either breaks you can no longer either charge the battery or run at full speed - presumably a scheme to make you buy DELL's expensive psu.

Wary also won't work with loadlin, and has to be in sda1 (or maybe just the first 8GB) to work with lilo, unlike puppy 4.
Back to top
View user's profile Send_private_message 
sindi

Joined: 16 Aug 2009
Posts: 395

PostPosted: Sun 19 Jan 2014, 15:24    Post_subject: updated glibc and standalone youtube-dl
Sub_title: Youtube-dl needs glibc 2.7 or later
 

There is a standalone youtube-dl that works with puppy 5's and also with a puppy 4.1.2
with updated glibc (from 2.6.1), that requires glibc 2.7 or later. I suggest updating
the 'plus' version to glibc 2.10 or later. Opera 12.10 requires 2.8 or later.
Youtube-dl lets you download a video as mp4 and play it with mplayer, using far less
memory and cpu than a graphical browser and flash, and thus play youtube on computer
that won't run Puppy 5 (with the gtk-youtube-viewer) or is too slow/low-ram for flash
plus graphical browser.
Back to top
View user's profile Send_private_message 
darry1966

Joined: 26 Feb 2012
Posts: 488
Location: New Zealand

PostPosted: Tue 21 Jan 2014, 17:50    Post_subject: Re: updated glibc and standalone youtube-dl
Sub_title: Youtube-dl needs glibc 2.7 or later
 

sindi wrote:
There is a standalone youtube-dl that works with puppy 5's and also with a puppy 4.1.2
with updated glibc (from 2.6.1), that requires glibc 2.7 or later. I suggest updating
the 'plus' version to glibc 2.10 or later. Opera 12.10 requires 2.8 or later.
Youtube-dl lets you download a video as mp4 and play it with mplayer, using far less
memory and cpu than a graphical browser and flash, and thus play youtube on computer
that won't run Puppy 5 (with the gtk-youtube-viewer) or is too slow/low-ram for flash
plus graphical browser.


Ok here is an updated as requested 432v3plus only things you need to do is install the ffmpeg update included in the folder, edit desktop browse icon to exec seamonkey and copy xmms lib file to usr/lib once downloaded. Has glibc2.11 and working vlc from wary plus required QT and xine instructions are in the folder.
Lbstd6c++6 also in folder and menumaker.


https://sourceforge.net/projects/dazsbarebonespups/files/v32v3plusglibc2.11/
Back to top
View user's profile Send_private_message 
sindi

Joined: 16 Aug 2009
Posts: 395

PostPosted: Tue 21 Jan 2014, 20:48    Post_subject: Re v3 updated plus  

So now we have a V3, a V3-plus with glibc 2.6 and flash 10.0, a V3-updated with glibc 2.10 and flash 10.3, and the latest is, if I understood correctly:

updated-plus with glibc 2.11, flash 10.3 (?), and the pieces needed to manually update ffmpeg, and xmms, and to add vlc from wary with QT libraries

What do I edit in the initrd.gz or sfs so puppy 4.3.2 will create and look for a save file with a name different from 4.3.1? I will test this out without a save file and then install to a different computer without 4.3.1 on it.

How do I update perl to 5.10 so I can use gtk-youtube-viewer for Puppy 5 with this nicely updated 4.3.2? (It may also need the newer glibc and gtk).
Back to top
View user's profile Send_private_message 
sindi

Joined: 16 Aug 2009
Posts: 395

PostPosted: Tue 21 Jan 2014, 21:00    Post_subject: Puppy 4.3..2 v3 plus updated much larger  

Darry's 'old' plus iso is about 115MB and the updated one (without the pets and libraries to be downloaded and added separately) about 185MB. The deb glibc 2.11 update package is under 4MB. What is the additional 65MB? (Maybe I got something confused).

Thanks for granting my wish for a new improved 4.3.2.
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 30 of 31 Posts_count   Goto page: Previous 1, 2, 3, ..., 28, 29, 30, 31 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Taking the Puppy out for a walk » Announcements
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0856s ][ Queries: 12 (0.0043s) ][ GZIP on ]