Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 30 Oct 2014, 10:32
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Video
How to get more than 800x600 resolution in Xorg?
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
kitsumimaru

Joined: 08 Mar 2010
Posts: 3

PostPosted: Mon 08 Mar 2010, 05:24    Post_subject:  How to get more than 800x600 resolution in Xorg?
Sub_title: 1024x600 in Vesa but video playback is poor
 

Hello, I am a complete newbie to linux, and have installed (successfully) puppy 4 on my netbook.

Everything seems to work beautifully and I'm loving the ten second boot time!

(here comes the inevitable 'but')

But, I am having massive headaches enabling/installing my videocard.
I have trawled through the forums here but I am not at all savvy with half of the terminology used, and was wondering if anyone could (please!) help to guide me through this problem?


I have tried to follow some of the guides :
http://murga-linux.com/puppy/viewtopic.php?t=22933&start=15

This being the one which seemed to have the most answers, unfortunately I cannot download Kirk's pet so I cannot test whether it works, and am now utterly confused as to how to get my screen working in xorg at a resolution higher than 800x600

I'm currently using the vesa mode at 1024x600 and it looks spiffy, but the video playback looks very poor, pease help me!

Thankyou in advance,

Kit
Back to top
View user's profile Send_private_message 
L18L

Joined: 19 Jun 2010
Posts: 2530
Location: Moved from Hosla to www.eussenheim.de

PostPosted: Tue 31 Aug 2010, 14:09    Post_subject: unichrome  

Quote:
xorg at a resolution higher than 800x600

I am in a similiar situation.
My mini-ITX Via VB7002G box has openchrome graphic chip.
Xorg resolution not higher than 1024x768
I use xvesa 1920x1080.

Until last week I have been thinking that unichrome is the bad guy.
But I have tried Xorg in another distro and there unichrome was working in 1920x1080, they use Xorg-7.5.
Back to top
View user's profile Send_private_message 
jemimah


Joined: 26 Aug 2009
Posts: 4309
Location: Tampa, FL

PostPosted: Tue 31 Aug 2010, 17:49    Post_subject:  

You should try Fluppy. It's a bugfixed Puppy4 with newer drivers, included an updated Xorg.
Back to top
View user's profile Send_private_message Visit_website 
L18L

Joined: 19 Jun 2010
Posts: 2530
Location: Moved from Hosla to www.eussenheim.de

PostPosted: Wed 01 Sep 2010, 11:48    Post_subject:
Sub_title: xorg
 

Quote:
You should try Fluppy.

thank you, jemimah
I will try it. Wait a moment, or 2
Back to top
View user's profile Send_private_message 
L18L

Joined: 19 Jun 2010
Posts: 2530
Location: Moved from Hosla to www.eussenheim.de

PostPosted: Wed 01 Sep 2010, 12:37    Post_subject:
Sub_title: Xorg unichrome on VB7002G
 

posting from freshly installed fluppy004
from Xorg.0.log
Quote:
(II) CHROME(0): ViaValidMode: Validating 1920x1080 (Clock: 172900)
(II) CHROME(0): ViaFirstCRTCModeValid
(II) CHROME(0): ViaSecondCRTCModeValid
(II) CHROME(0): Not using default mode "1920x1080" (exceeds panel dimensions)

"exceeds panel dimensions" is a lie Embarassed
1024x768 only Sad
xorg_log.bz2
Description  contains Xorg.0.log
bz2

 Download 
Filename  xorg_log.bz2 
Filesize  8.18 KB 
Downloaded  521 Time(s) 
Back to top
View user's profile Send_private_message 
G0XAN

Joined: 08 May 2009
Posts: 31
Location: Brighton, UK

PostPosted: Mon 28 Mar 2011, 16:59    Post_subject:  

From the comment in Barry's blog, this topic doesn't seem to be resolved yet: http://bkhome.org/blog/?viewDetailed=02197

Maybe this will help?

I have recently acquired an old 5.25" SBC with a VIA chipset. It seemed an ideal candidate for resurrection with Puppy. Sure enough, it all started up OK, but I could not get it to work at more than 640 x 480 resolution.
Googling didn't throw up anything useful, then I had a "Eureka!" moment...

The video on this particular board is part of the Northbridge chip, and essentially an "S3 Twister". It supports both LCD and CRT displays. The BIOS defaults to "CRT + LCD" but I am only using the CRT interface (15-pin D-type VGA connector) to an LCD monitor. The LCD interface is designed to drive an LCD panel directly.

Setting the BIOS to "CRT" (so disabling the LCD interface) magically allowed Puppy to run at the full 1280 x 1024 resolution of the monitor Smile

Maybe this will work for someone else? I don't exactly understand why the LCD setting limited the resolution of the display; Xorg wizard offered all the resolutions, just that whatever was selected, it only displayed at 640 x 480...

_________________
Gary
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Hardware » Video
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0667s ][ Queries: 12 (0.0170s) ][ GZIP on ]