Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 24 Nov 2014, 13:59
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Documents
Updated Abiword-2.8.2 plus all plugins, locales and docs
Post new topic   Reply to topic View previous topic :: View next topic
Page 2 of 3 [39 Posts]   Goto page: Previous 1, 2, 3 Next
Author Message
MisterDog

Joined: 19 Feb 2010
Posts: 1

PostPosted: Tue 23 Feb 2010, 19:17    Post subject:  

Great compile!

I too am waiting for the version with spellchecking.
Back to top
View user's profile Send private message 
jemimah


Joined: 26 Aug 2009
Posts: 4309
Location: Tampa, FL

PostPosted: Wed 24 Feb 2010, 17:39    Post subject:  

technosaurus wrote:

By the way if you set up a symlink from mtpaint to gimp, the paint editor plugin works using mtpaint.


Also many menu items on the tools menu won't work unless you symlink firefox to defaultbrowser.

And the collaborate plugin has no options in the configuration combobox; not sure what it needs.
Back to top
View user's profile Send private message Visit poster's website 
technosaurus


Joined: 18 May 2008
Posts: 4378

PostPosted: Wed 24 Feb 2010, 18:27    Post subject:  

I have never used abicollab so not sure either - it may require an additional backend or something for networking
_________________
Web Programming - Pet Packaging 100 & 101
Back to top
View user's profile Send private message 
charlie6


Joined: 30 Jun 2008
Posts: 1020
Location: South of Belgium

PostPosted: Sun 07 Mar 2010, 06:55    Post subject:  

Hi Technosaurus,
many thanks keeping efforts in issuing abiword updates !
Hoping to install the above abiword-2.8.2-i486.pet on turbopup-v.0.1-Xtrem (which is derivated from puppy 4.20 - here http://www.murga-linux.com/puppy/viewtopic.php?t=40477), I got this error message:
Code:

# abiword
abiword: symbol lookup error: abiword: undefined symbol: gtk_adjustment_configure

I do not know how to fix this.
Any help would be appreciated.
Thanks in advance
cheers, Charlie

edited: got exactly the same message trying installing it on Puppy 4.1.2 (k.2.6.25.16)
Could the gtk-version be inappropriate for both puppy 4.1.2 and Turbopup (Puppy4.20)?
note: on both installations, I have made the symlink
Code:
ln -s /usr/lib/libgoffice-0.6.so.6.0.3 /usr/lib/libgoffice-0.8.so.8
Back to top
View user's profile Send private message 
technosaurus


Joined: 18 May 2008
Posts: 4378

PostPosted: Tue 09 Mar 2010, 18:27    Post subject:  

You will need at least the updated glib and updated gtk, probably pango, cairo, enchant and libpixman as well - you can compile abiword on those older platforms and get ~90% functionality, but there is a bug in the plugin window and some other minor issues if you do.


Note: if you update those libs and remaster the size will grow quite large because the older libraries do not get overwritten. You can safely delete them and/or replace them with symlinks to the new ones.

_________________
Web Programming - Pet Packaging 100 & 101
Back to top
View user's profile Send private message 
UberNoob


Joined: 23 Jan 2010
Posts: 33
Location: Potsdam NY USA

PostPosted: Thu 08 Apr 2010, 06:15    Post subject: Spelling  

I was wondering if spell check is included now in the current .pet so I can re-install.
_________________
Follow the misadventures of "Timmy and his new puppy"
http://puppylinuxnoob.blogspot.com/
About My Puppy: 4.3.1 FULL on a DELL INSPIRON B130
Back to top
View user's profile Send private message 
ttuuxxx


Joined: 05 May 2007
Posts: 10843
Location: Ontario Canada,Sydney Australia

PostPosted: Thu 08 Apr 2010, 06:19    Post subject: Re: Spelling  

UberNoob wrote:
I was wondering if spell check is included now in the current .pet so I can re-install.

I'm using it 4.3.2 spellcheck works if you add the dictionary and link it to enchant, there's a pet I made for it, you can find it in the 4.3.2 thread
ttuuxxx

_________________
http://audio.online-convert.com/ <-- excellent site
http://samples.mplayerhq.hu/A-codecs/ <-- Codec Test Files
http://html5games.com/ <-- excellent HTML5 games Smile
Back to top
View user's profile Send private message Visit poster's website 
Anniekin


Joined: 24 Feb 2009
Posts: 188

PostPosted: Thu 08 Apr 2010, 21:46    Post subject:  

Hi ttuuxx,

Could you be a little more specific particularly in how to
    add the dictionary and
    add it to enchant
?
Back to top
View user's profile Send private message 
ttuuxxx


Joined: 05 May 2007
Posts: 10843
Location: Ontario Canada,Sydney Australia

PostPosted: Thu 08 Apr 2010, 22:54    Post subject:  

Anniekin wrote:
Hi ttuuxx,

Could you be a little more specific particularly in how to
    add the dictionary and
    add it to enchant
?


Install this Smile
ttuuxxx
Spellcheck-abiword.pet
Description 
pet

 Download 
Filename  Spellcheck-abiword.pet 
Filesize  741.5 KB 
Downloaded  700 Time(s) 

_________________
http://audio.online-convert.com/ <-- excellent site
http://samples.mplayerhq.hu/A-codecs/ <-- Codec Test Files
http://html5games.com/ <-- excellent HTML5 games Smile
Back to top
View user's profile Send private message Visit poster's website 
Anniekin


Joined: 24 Feb 2009
Posts: 188

PostPosted: Fri 09 Apr 2010, 01:20    Post subject:  

hrmm...

seems a no go in 4.3.1...
Back to top
View user's profile Send private message 
technosaurus


Joined: 18 May 2008
Posts: 4378

PostPosted: Fri 09 Apr 2010, 09:31    Post subject:  

what does running it from the command line return?

I'm guessing that you need the updated glib, enchant or hunspell

_________________
Web Programming - Pet Packaging 100 & 101
Back to top
View user's profile Send private message 
chrismt


Joined: 21 Apr 2010
Posts: 255

PostPosted: Mon 26 Apr 2010, 03:10    Post subject: Missing Lib  

I installed this Abiword on my Puppy 4.3.1

But Libgoffice - 0.8.so.8 is missing

Where can I get this?

Regards
Back to top
View user's profile Send private message 
ttuuxxx


Joined: 05 May 2007
Posts: 10843
Location: Ontario Canada,Sydney Australia

PostPosted: Mon 26 Apr 2010, 03:23    Post subject: Re: Missing Lib  

chrismt wrote:
I installed this Abiword on my Puppy 4.3.1

But Libgoffice - 0.8.so.8 is missing

Where can I get this?

Regards


You can find the goffoice 8 at this gnumeric link
http://www.murga-linux.com/puppy/viewtopic.php?t=52510&sid=875de41b81246635fe59d7a63877444e
ttuuxxx

_________________
http://audio.online-convert.com/ <-- excellent site
http://samples.mplayerhq.hu/A-codecs/ <-- Codec Test Files
http://html5games.com/ <-- excellent HTML5 games Smile
Back to top
View user's profile Send private message Visit poster's website 
chrismt


Joined: 21 Apr 2010
Posts: 255

PostPosted: Mon 26 Apr 2010, 04:09    Post subject:  

It worked!
Back to top
View user's profile Send private message 
Barkingmad

Joined: 21 Nov 2008
Posts: 121

PostPosted: Thu 04 Aug 2011, 11:21    Post subject:
Subject description: Libgoffice probs on 4.31
 

Help, am I going mad

I have tried this Abiword on one of Zigbert's Puppy "Stardust" puplets (I'm afrade I can't remember which of them it is - he released several) and it works fine after installing the "libgoffice" pet linked to by ttuuxxx.

EDIT I think it must be Stardust 007 -- there are some of my posts in the announcement thread for that one.

I have now tried it in a "plain vanilla" 4.3.1 install using the same downloaded files via a pen drive and have problems - terminal output below.

Quote:
abiword: symbol lookup error: usr/lib/libgoffice-0.8.so.8: undefined symbol: g-dgettext


I have tried: rebooting, uninstalling then reinstalling with pet-get and even copying the "libgoffice" files from the working install via pendrive but all give the same error.

This install of 4.3.1 is an update over 4.1.1 -- I haven't yet tried Abiword in a live boot in ram.

I hope this is enough to start some ideas.

Thanks
Will
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 2 of 3 [39 Posts]   Goto page: Previous 1, 2, 3 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Documents
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0759s ][ Queries: 12 (0.0043s) ][ GZIP on ]