Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 24 Apr 2014, 12:47
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Application Request - Kvirc
Moderators: deshlab, Flash, GuestToo, Ian, JohnMurga, Lobster
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [6 Posts]  
Author Message
Q5sys


Joined: 11 Dec 2008
Posts: 1046

PostPosted: Sat 13 Feb 2010, 19:38    Post subject:  Application Request - Kvirc
Subject description: can someone make a .pet?
 

Sorry if this isnt the place for this request (Mods, if you want to move this somwhere else, feel free)

I have tried and failed at compiling any of the 4.0 series of kvirc. I have run both (4.0rc1 and 4.0rc2)on my win box and my fedora box, and have never had a single issue, however Im unable to compile it on puppy. Is there anyway one of you master compilers can step in and help me out? I have been working on this ever since the first RC came out, and have failed every time.

ive even tried grabing the deb version and using deb2pet, and the same with the rpm release; but i still meet with failure.

Is there someone out there that can save me from torment? lol

source code link - ftp://ftp.kvirc.de/pub/kvirc/snapshots/source/

Last edited by Q5sys on Sun 21 Feb 2010, 16:31; edited 1 time in total
Back to top
View user's profile Send private message 
Q5sys


Joined: 11 Dec 2008
Posts: 1046

PostPosted: Sun 21 Feb 2010, 16:30    Post subject:  

Anyone?
Back to top
View user's profile Send private message 
GrumpyWolfe


Joined: 26 Nov 2006
Posts: 496

PostPosted: Mon 22 Feb 2010, 20:57    Post subject:  

Hi Q5sys

I just looked at what is needed for kviirc and the biggest problem you will have is that is uses a lot of the kde libs and file support and will take a lot I believe to get it to run on puppy with jwm. There is some kde puppys out there that may be able to run it.

_________________
Live and Let Live

Acer Aspire One N450 1.66GHz

MyWolfe at Sourceforge
MyWolfe Blog
MyWolfe Groups
Back to top
View user's profile Send private message Visit poster's website 
Q5sys


Joined: 11 Dec 2008
Posts: 1046

PostPosted: Mon 22 Feb 2010, 23:44    Post subject:  

GrumpyWolfe wrote:
Hi Q5sys

I just looked at what is needed for kviirc and the biggest problem you will have is that is uses a lot of the kde libs and file support and will take a lot I believe to get it to run on puppy with jwm. There is some kde puppys out there that may be able to run it.


Oh yea, forgot about that in my first post, somewhere I've got a tar.gz with the required libs. I'll have to find it and then upload it so its avail, if someone is able to compile it for me.
Also KDE is no longer required for v4.
As for the rest... here is the info from a gentoo ebuild showing the dependancies
Code:
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/net-irc/kvirc/kvirc-9999.ebuild,v 1.24 2010/01/11 10:36:41 arfrever Exp $
EAPI="2"
inherit cmake-utils multilib python subversion
DESCRIPTION="Advanced IRC Client"
HOMEPAGE="http://www.kvirc.net/"
SRC_URI=""
ESVN_REPO_URI="https://svn.kvirc.de/svn/trunk/kvirc"
ESVN_PROJECT="kvirc"
LICENSE="kvirc"
SLOT="4"
KEYWORDS=""
IUSE="audiofile +crypt dcc_video +dcc_voice debug doc gsm +ipc ipv6 kde +nls oss +perl +phonon profile +python +qt-dbus qt-webkit +ssl theora +transparency"
RDEPEND="
>=dev-libs/crypto++-5.6.0-r1
sys-libs/zlib
x11-libs/libX11
>=x11-libs/qt-core-4.5
>=x11-libs/qt-gui-4.5
>=x11-libs/qt-sql-4.5
dcc_video? (
media-libs/libv4l
theora? ( media-libs/libogg media-libs/libtheora )
)
kde? ( >=kde-base/kdelibs-4 )
oss? ( audiofile? ( media-libs/audiofile ) )
perl? ( dev-lang/perl )
phonon? ( || ( media-sound/phonon >=x11-libs/qt-phonon-4.5 ) )
python? ( dev-lang/python )
qt-dbus? ( >=x11-libs/qt-dbus-4.5 )
qt-webkit? ( >=x11-libs/qt-webkit-4.5 )
ssl? ( dev-libs/openssl )"
DEPEND="${RDEPEND}
>=dev-util/cmake-2.6.4
dev-util/pkgconfig
x11-proto/scrnsaverproto
nls? ( sys-devel/gettext )
doc? ( app-doc/doxygen )"
RDEPEND="${RDEPEND}
gsm? ( media-sound/gsm )"
DOCS="ChangeLog TODO"
pkg_setup() {
if use audiofile && ! use oss; then
die "USE=\"audiofile\" requires USE=\"oss\""
fi
if use theora && ! use dcc_video; then
die "USE=\"theora\" requires USE=\"dcc_video\""
fi
if use python; then
python_set_active_version 2
fi
}
src_prepare() {
subversion_wc_info
VERSIO_PRAESENS="${ESVN_WC_REVISION}"
elog "Setting revision number to ${VERSIO_PRAESENS}"
sed -e "/#define KVI_DEFAULT_FRAME_CAPTION/s/KVI_VERSION/& \" r${VERSIO_PRAESENS}\"/" -i src/kvirc/ui/kvi_frame.cpp || die "Failed to set revision number"
}
src_configure() {
local libdir="$(get_libdir)"
local mycmakeargs="
-DCMAKE_INSTALL_PREFIX=/usr
-DCOEXISTENCE=1
-DLIB_SUFFIX=${libdir#lib}
-DMANUAL_REVISION=${VERSIO_PRAESENS}
-DUSE_ENV_FLAGS=1
-DVERBOSE=1
-DWANT_NO_EMBEDDED_CODE=1
$(cmake-utils_use_want audiofile AUDIOFILE)
$(cmake-utils_use_want crypt CRYPT)
$(cmake-utils_use_want dcc_video DCC_VIDEO)
$(cmake-utils_use_want dcc_voice DCC_VOICE)
$(cmake-utils_use_want debug DEBUG)
$(cmake-utils_use_want doc DOXYGEN)
$(cmake-utils_use_want gsm GSM)
$(cmake-utils_use_want ipc IPC)
$(cmake-utils_use_want ipv6 IPV6)
$(cmake-utils_use_want kde KDE4)
$(cmake-utils_use_want nls GETTEXT)
$(cmake-utils_use_want oss OSS)
$(cmake-utils_use_want perl PERL)
$(cmake-utils_use_want phonon PHONON)
$(cmake-utils_use_want profile MEMORY_PROFILE)
$(cmake-utils_use_want python PYTHON)
$(cmake-utils_use_want qt-dbus QTDBUS)
$(cmake-utils_use_want qt-webkit QTWEBKIT)
$(cmake-utils_use_want ssl OPENSSL)
$(cmake-utils_use_want theora OGG_THEORA)
$(cmake-utils_use_want transparency TRANSPARENCY)"
cmake-utils_src_configure
}
Back to top
View user's profile Send private message 
GrumpyWolfe


Joined: 26 Nov 2006
Posts: 496

PostPosted: Tue 23 Feb 2010, 23:38    Post subject:  

Hi Q5sys

I have a pet of Kvirv-3.4.2, but I must warn you that it will install a file libc.so.6 that over write a core file of puppylinux. If you uninstall puppy will no longer be stable. And you may have to delete your save file to get the system running right.

Kvirc-3.4.2
http://mywolfe.googlecode.com/files/Kvirc-3.4.2.pet

Hope this will hold ya over the 4 is still in sid at debain and I was unable to compile it from source.

_________________
Live and Let Live

Acer Aspire One N450 1.66GHz

MyWolfe at Sourceforge
MyWolfe Blog
MyWolfe Groups
Back to top
View user's profile Send private message Visit poster's website 
Q5sys


Joined: 11 Dec 2008
Posts: 1046

PostPosted: Wed 24 Feb 2010, 04:48    Post subject:  

GrumpyWolfe wrote:
Hi Q5sys

I have a pet of Kvirv-3.4.2, but I must warn you that it will install a file libc.so.6 that over write a core file of puppylinux. If you uninstall puppy will no longer be stable. And you may have to delete your save file to get the system running right.

Kvirc-3.4.2
http://mywolfe.googlecode.com/files/Kvirc-3.4.2.pet

Hope this will hold ya over the 4 is still in sid at debain and I was unable to compile it from source.


Thanks so much, for your help and effort in this. Kvirc has been my client of choice for a long time. And it happens to be one of those things that compromising on is almost intollerable. And actually... its whats been keeping me tied to Fedora. So thanks for your help.

I'll make a backup copy of libc.so.6, so if I happen to uninstall it, I'll have it. Though to be honest, I cant imagine a reason I'd uninstall it other than to upgrade to 4.0 at some point later in time.

Thanks again! Smile
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [6 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0581s ][ Queries: 11 (0.0047s) ][ GZIP on ]