Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 21 Oct 2014, 22:06
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
Hard Disk Install - Success and Failures
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
linbie

Joined: 09 Jan 2010
Posts: 63

PostPosted: Sat 09 Jan 2010, 01:27    Post_subject:  Hard Disk Install - Success and Failures
Sub_title: Step by Step Attemp at Hard Disk Installation
 

Long post but hopefully helpful.

This is a step by step run down of my attempts to install puppy on my hard disk. It takes in instructions from many sources (mostly these
forums) and describes my failures with various methods and some reasons for those failures. In addition it may answer some questions
being posed on various threads.

Yes there is a happy ending (sort of).

THE STORY BEGINS


Complete Linux newbie - never tried Linux before apart from using an eeePC once.

Task at hand - try Linux on an old tired laptop.

System:

Dell Inspiron 2500
CPU: Intel Celeron 900Mhz
Ram: 128 MB
HDD: 20Gb (12Gb free)
Operating System: Windows XP (Home) - No updates or patches
CD/DVD: Internal (player only - no recording)
Modem: Internal dial up
Wireless: None
USB: 2 ports (USB 1, not USB 2)

No previous tinkering with laptop etc - essentially as it came from Dell (1999) with some basic applications loaded.

Trials:

Found old Ubantu 9.0 live disc on an old computer magazine

Set laptop to boot from CD

Screen says loading Ubantu - system freezes (forgot to read the minimum system requirements before trying!)

Google for answers - find Puppy Linux

Download and burn Pupply Linux Live CD

Try again - Success!!

Main applications work and load quickly, interface nice and clean.

Insert old USB wireless adapter and run connect wizard. After some fiddling and a couple of reboots I did connect to the wireless LAN
although the collention was unstable.

At this point I should have noticed something on the desktop but was not looking and did not pay attention. Thinking about it I would not have understood it even if I did notice - see below.

Switch off - did not create personal save file.


Time to load Linux to hard drive! (keeping Win XP)


Read lots of information on these forums and decide to use single application detailed here.

Download application and run in Windows XP - loads smoothly.

Reboot - Two choices appear. Select puppy linux

ERROR 15 - No file found

Read some more and rename all files in puppy431 folder (created by the installer) to non capital letters and change PUPPY_431.SFS to puppy-431.sfs

Try Again!

ERROR 15 - No file found.

Uninstall and reinstall using download from mirror site (assuming the primary download was somehow corrupted). Followed the two steps
above i.e booting before and after file name changes still error 15 - no file found.

Uninstall.

Try manual frugal install using the files on liveCD and instructions from lin'N'win.

Carefully followed all instructions (step by step). (I changed puppy421 to puppy431 as this was a new version and I stored the files in the folder named puppy431)

I changed the file names to non capital and PUPPY_431.SFS to puppy-431.sfs as there appear to be concensus on these forums that this was the right thing to do.

Downloaded "grldr" and "menu.lst"

Added the following to the menu.lst using notepad

title puppy Linux 4.3.1
kernel (hd0,0)/puppy431/vmlinuz PMEDIA=idehd PDEV=sdal psubdir=puppy431 psubOK=TRUE
initrd (hd0,0)/puppy431/initrd.gz
boot

Accessed boot.ini and added c:\grldr="Puppy Linux" to the last line (This was actually already there I assume from my initial attempts using the one click application)



Reboot

Two choices - select puppy linux

Screen reads:


kernel (hd0,0)/puppy431/vmlinuz PMEDIA=idehd PDEV=sdal psubdir=puppy431 psubOK=TRUE

ERROR 21 - no file found

Review (and re-review) entire process - no mistakes. Even tried without changing file names to lower case.

Continued ERROR 21.

Than noticed the following:

lil'N'win gives an example of what the boot.ini file should look like (reporoduced below)

[bootloader]
timeout=30
default=multi(0) disk(0) rdisk(0) partition(1)\WINDOWS
[operating systems]
default=multi(0) disk(0) rdisk(0) partition(1)\WINDOWS="Microsoft Windows XP Home Edition" /fastdetect
c:\grldr="Puppy Linux"

This is what my boot.ini file looked like

[bootloader]
timeout=30
default=multi(0) disk(0) rdisk(0) partition(2)\WINDOWS
[operating systems]
default=multi(0) disk(0) rdisk(0) partition(2)\WINDOWS="Microsoft Windows XP Home Edition" /fastdetect
c:\grldr="Puppy Linux"

Notice the partition(2).

As stated before the laptop had not been tinkered with in any way. At the time I had no idea about partitions or how to work with them.

I changed my boot.ini to partition(1) as stated in the lin'N'win instructions.

As you can guess - NOTHING LOADED

Boot using liveCD and change boot.ini back to partition(2) - Windows XP back and loads

At this point I figured out that for what ever reason I have two partitions on my disk and that windows and puppy are loaded partition 2 and the instructions for booting are pointing to partition 1 and hence it can't find the files.

After some more googling and reading I changed my menu.lst to read as follows - (as a rush of blood I did try (hd0,2) before fully reading about partitions and correct syntax.)

title puppy Linux 4.3.1
kernel (hd0,1)/puppy431/vmlinuz PMEDIA=idehd PDEV=sdal psubdir=puppy431 psubOK=TRUE
initrd (hd0,1)/puppy431/initrd.gz
boot

Reboot:

Gets a little a further but now shows:

puppy-431.sfs - file not found (along with a few more bits and pieces). This aspect is discussed here (existing forum thread). The concencus on the forums appear to be a problem with the kernel and that an older kernel maybe the answer.

I was a little disappointed especially given the fact that the liveCD appear to load and function.

Frustrated I uninstalled the lot and decided to give the universal installer on the liveCD (along with lil'N'win instructions) to try a semi-automated install.

Process went smoothly enough and I changed my menu.lst file as follows- as per the instructions on the hard puppy site


title Puppy Linux 4.3.1
rootnoverify (hd0,1)
kernel /puppy431/vmlinuz pmedia=idehd psubdir=puppy431
initrd /puppy431/initrd.gz

Reboot:

Starts to load than

ERROR 24 - Unknown command

Cheaked my menu.lst file

Near the bottom there were three other lines

rootnoverify (hd0,5)
c****** + 1 (***** = can't recall what this was)
boot

Seem to have been added by the universal installer


Following on from lil'N'win I changed menu.lst to:

rootnoverify (hd0,1) (I kept this from the instructions on hard puppy page)
title puppy Linux 4.3.1
kernel (hd0,1)/puppy431/vmlinuz PMEDIA=idehd PDEV=sdal psubdir=puppy431 psubOK=TRUE
initrd (hd0,1)/puppy431/initrd.gz
boot


Reboot:

Two options:

Windows XP
Puppy Linux

Select Puppy

SUCCESS - Puppy boots from the hard drive.

Play around a little bit to personalise and make a personal save file during shut down. The system hangs and does not shutdown fully.

Reboot

Major meltdown - lots of red and orange writing. Last line reads paused for 60 seconds

After 60 seconds - more red and orange writing and the system halts!

Try booting from LiveCD - Same meltdown

Boot into Windows and remove the personal save file using windows explorer

Reboot:

Puppy boots from hard drive but all personal settings lost.



Questions/Lessons learned

Have a look at how the vendor has set up the system! Dell had made two partitions on the hard disk one 30MB and the remainder 19GB. The 30MB partition contains some security message as a text file.

The one touch application will not work unless windows/puppy are in partition 1

The application may not work at all as manual installation of files did not work (? copying files using windows alters some attributes so that it cannot be read/found during the boot process)

Avoid copying files from live CD to hard disk using Windows - instead boot into puppy with liveCD and use puppy to copy files onto the hard drive. Not sure if this is essential as some people have not had a problem according to the forum posts but maybe this is related to wether Windows XP has been updated (mine was not).

Why am I having problems with a personal save file?
Back to top
View user's profile Send_private_message 
8-bit


Joined: 03 Apr 2007
Posts: 3382
Location: Oregon

PostPosted: Sat 09 Jan 2010, 03:39    Post_subject:  

It sounds like the pupsave file was corrupted on making it on shutdown or reboot. You might try adding "acpi=force" to the end of the kernel line in your menu.lst file. That might help in getting Puppy to poweroff.
Try different options.
You can find them by booting the CD and pressing F1 or F2 to see the boot options available to you.
Back to top
View user's profile Send_private_message 
linbie

Joined: 09 Jan 2010
Posts: 63

PostPosted: Sat 09 Jan 2010, 22:29    Post_subject: Personal Save File  

During shutdown saved the personal file onto a USB drive and then used windows to copy it onto the puppy431 folde. Works well now - much faster boot up
Back to top
View user's profile Send_private_message 
ICPUG

Joined: 24 Jul 2005
Posts: 1290
Location: UK

PostPosted: Mon 11 Jan 2010, 09:34    Post_subject:  

Hi limbie,

I wrote the Ln'N'Win instructions but I don't frequent here at the weekend so I was not here to help you!

Full marks for getting a working Puppy dual boot. However, there are a couple of points remaining with your menu.lst.

PDEV should be PDEV1

BUT it is a good job you did not get this right as ...

sda1 should be sda2

because PDEV was wrong it was ignored so the other error was not found. In this case two wrongs maker a right!

Finally, I don't think psubOK=TRUE has any effect with Puppy 4.3.1 so it is not really necessary. Doesn't cause a problem if it is there though.

Good luck with using Puppy!
Back to top
View user's profile Send_private_message 
Bruce B


Joined: 18 May 2005
Posts: 11130
Location: The Peoples Republic of California

PostPosted: Tue 12 Jan 2010, 07:01    Post_subject: Re: Hard Disk Install - Success and Failures
Sub_title: Step by Step Attemp at Hard Disk Installation
 

linbie wrote:

Why am I having problems with a personal save file?


Excellent post!

I do it different than the orthodox way and maybe this will help. I build the
pup_save.2fs file FIRST, not on shutdown. Why? The reason is because I convert
Puppy to use an ext3 format. For this reason it's much easier to make my own
pup_save files. The problem being is Puppy, if it makes the file on shutdown will
make an ext2 format.

Here is how to make pup_save first:

1) delete the existing puppy431/pup_save.2fs file

2) when running Linux do this for a 512 mb file

cd to the puppy431 directory
dd if=/dev/zero of=pup_save.2fs bs=1M count=512
mkfs.ext2 pup_save.2fs
(answer yes to the warning)

-----

When Puppy boots it would (should) locate the file you made and use it. I will
(should) populate the empty file.

Good luck

_________________
New! Puppy Linux Links Page
Back to top
View user's profile Send_private_message 
trapster


Joined: 28 Nov 2005
Posts: 2006
Location: Maine, USA

PostPosted: Tue 12 Jan 2010, 07:40    Post_subject:  

@ Bruce B

Bruce,

Interesting!
Where in here are you telling it to use .ext3?

Quote:
cd to the puppy431 directory
dd if=/dev/zero of=pup_save.2fs bs=1M count=512
mkfs.ext2 pup_save.2fs (answer yes to the warning)


I do like the idea of creating the save file before shutdown.

Is there a way to convert existing .ext2 save files to .ext3?

_________________
trapster
Maine, USA

Asus eeepc 1005HA PU1X-BK
Frugal install: Puppeee4.31 + 1.0, Puppy4.10 + Lupu52
Currently using Slacko AND lupu52 w/ fluxbox
Back to top
View user's profile Send_private_message Visit_website 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0794s ][ Queries: 11 (0.0052s) ][ GZIP on ]