Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 17 Aug 2019, 22:54
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Java 1.06 rev.17 SFS
Moderators: deshlab, Flash, GuestToo, Ian, JohnMurga, Lobster
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [6 Posts]  
Author Message
futurnet

Joined: 31 Jan 2009
Posts: 62
Location: Italy

PostPosted: Tue 29 Dec 2009, 09:31    Post subject:  Java 1.06 rev.17 SFS  

http://www.mediafire.com/download.php?3jvmmzn2tlg


This is the latest java version just configurated to work in seamonkey.
I did a SFS version because is about 35Mb.
I tested it in puppy 4.31 and seamonkey 2.0
Back to top
View user's profile Send private message 
Dingo


Joined: 11 Dec 2007
Posts: 1439
Location: somewhere at the end of rainbow...

PostPosted: Fri 01 Jan 2010, 15:09    Post subject: java sfs sfs3 version  

your sfs is in sfs4, I added a version in sfs3 format usable by older puppies
http://puppylover.netsons.org/dokupuppy/programs:java

Dear futurnet

thanks for your effort, however, next time you will make an sfs package, please, take in in mind puppy is different (ands better) than Ubuntu & company

Ubuntu shuts down older repositories
Ubuntu tries to port users to use even the last (even crappy build)
Ubuntu does not supports its same older versions
Ubuntu does not loves really its users

Puppy loves its users
Puppy supports even all its versions
packages are almost all usable by different puppy version

So, when you make a sfs 4 version, you must think to create also sfs3 for puppy using a kernel older than 2.6.28.xx otherwise we act as dumb ubuntian users

_________________
replace .co.cc with .info to get access to stuff I posted in forum
dropbox 2GB free
OpenOffice for Puppy Linux
Back to top
View user's profile Send private message Visit poster's website 
futurnet

Joined: 31 Jan 2009
Posts: 62
Location: Italy

PostPosted: Sat 16 Jan 2010, 09:29    Post subject:  

Yes Dingo, you right, its my fault to forget about older puppy users, and i am agree with you about different philosophy from ubuntu world.
Back to top
View user's profile Send private message 
Dingo


Joined: 11 Dec 2007
Posts: 1439
Location: somewhere at the end of rainbow...

PostPosted: Sat 16 Jan 2010, 13:53    Post subject:  

Yes, only thing you needs to remember is that for Puppy Linux 3.xx series compatibility, sfs v3 built for Older puppies (3.xx-4.2.xx series) must be in 3.0 squashfs version

You can do what I can do: copy, from a working puppy linux 3.xx squashfs from /usr/bin/mksquashfs put whatever you want

start puppy linux 4.3.xx

rename your mksquashfs got from puppy linux 3.xx in mksquashfs3, then copy in /usr/sbin/ and overwritre current mksquashfs3 or, if you prefer, you can aver call mksquashfs3 with fill path, so, assuming you have a usb external drive inserted and mounted with mksquashfs3 you can type /mnt/path-to...mksquashfs3/...

_________________
replace .co.cc with .info to get access to stuff I posted in forum
dropbox 2GB free
OpenOffice for Puppy Linux
Back to top
View user's profile Send private message Visit poster's website 
futurnet

Joined: 31 Jan 2009
Posts: 62
Location: Italy

PostPosted: Sat 16 Jan 2010, 16:22    Post subject:  

hmm.. Dingo, in puppy 4 into menu utility there is a program called SFSconvert and I used to it confert SFS3 in SFS4, but I know that is possible also convert from SFS4 to SFS3. I wrong?
Back to top
View user's profile Send private message 
Dingo


Joined: 11 Dec 2007
Posts: 1439
Location: somewhere at the end of rainbow...

PostPosted: Sat 16 Jan 2010, 17:08    Post subject:  

futurnet wrote:
hmm.. Dingo, in puppy 4 into menu utility there is a program called SFSconvert and I used to it confert SFS3 in SFS4, but I know that is possible also convert from SFS4 to SFS3. I wrong?

I fear conversion is performed via mksquashfs3 included in puppy 4.3.1 producing sfs v. 3.1 (not 3.0) so they are not compatible with 3.xx series, you can try and then view properties of converted files; must be written version 3.0 to be compatible with older puppies

kernels newer than 2.6.21.7 (kernel of puppy linux 3.xx series) like 2.6.25.xx (puppy 4.2.xx series is based on) can read 3.0 squashfilesystem version, so, producing v . 3.0 is better than producing 3.1 version, because are compatible with 3.xx and 4.xx series, while 3.1 is only compatible with 4..2xx series

I'm very disappointed kernels higher than 2.6.29.xx does not have support for 3.xx squashfilesystem this costrains to make a double efforet in producing sfs packages

mksquashf3 included in puppy 3.01 attached

_________________
replace .co.cc with .info to get access to stuff I posted in forum
dropbox 2GB free
OpenOffice for Puppy Linux
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 1 of 1 [6 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1445s ][ Queries: 11 (0.0521s) ][ GZIP on ]