Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 26 Oct 2014, 04:06
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
keyboard in pupy Linux: "@" not working
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
comedix

Joined: 10 May 2005
Posts: 8
Location: belgium

PostPosted: Sun 01 Jan 2006, 05:33    Post_subject:  keyboard in pupy Linux: "@" not working  

dear puppy fans,

Some time ago I stopped using puppy because of the small annoyments I had. One that is irrating is the fact that I could type the "@" like in email adresses like "info@test.be".
I using a belgian keyboard setup (the second option when selecting a keyboard latin azerty)
To write the "@" I have to press "ALT GR" (next to the spacebar) and the combined key "2--@" . When I press that , screen just jumps away and ofcourse no "@" has been written.

Can anybody help me with this?
Back to top
View user's profile Send_private_message Visit_website 
Lobster
Official Crustacean


Joined: 04 May 2005
Posts: 15117
Location: Paradox Realm

PostPosted: Sun 01 Jan 2006, 05:48    Post_subject:  

Cool I am only helping you because Belgians make the best chocolate in the world (high praise from a half Swiss like me)

- actually I would probably help even if you were a US Republican
Wink

Try this in Puppy Tardis (107)
Click on setup
choose the first wizard "change mouse and keyboard"
choose keyboard layout for your country
The second option is be-latin1 is that the one?

then I suppose reboot

If this works - good - let us know Smile

_________________
Puppy WIKI
Back to top
View user's profile Send_private_message Visit_website 
comedix

Joined: 10 May 2005
Posts: 8
Location: belgium

PostPosted: Mon 02 Jan 2006, 05:33    Post_subject: solved  

lobyster,

it seems to be solved : I selected 'french' instead of Be-latin1' and it works now.
(although I don't speak french!)

greetings

indeed , we have the best chocolats and french fries (who are belgian ofcourse).
Back to top
View user's profile Send_private_message Visit_website 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Mon 02 Jan 2006, 06:01    Post_subject:  

Comedix, if you installed french, look in an editor in the file /root/.Xmodmap
(that is a hidden file. In the file-open dialog of the editor hit "." and then "TAB" to see it).

There you will find something like
keycode 24 = q Q at

Install the belgium keyboardlayout again.
Now you have a new /root/.Xmodmap, insert here the line from the french one.
To activate the change, restart X or type in a console "xmodmap /root/.Xmodmap".

Mark
Back to top
View user's profile Send_private_message Visit_website 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0441s ][ Queries: 11 (0.0053s) ][ GZIP on ]