Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 24 Nov 2014, 01:22
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Utilities
Hot Backup for Frugal Pups Updated 2011-10-1
Post new topic   Reply to topic View previous topic :: View next topic
Page 2 of 6 [88 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6 Next
Author Message
8-bit


Joined: 03 Apr 2007
Posts: 3393
Location: Oregon

PostPosted: Sat 06 Mar 2010, 16:19    Post subject:  

One thing that would be nice to have added to your script just after the line that clears the temporary file of the word "Done" after it is displayed for 4 seconds would be to add a line
Code:
xmessage "Pupsave backup completed"
.
That way if I am away from the PC and have missed the "Done" message, I know the backup has completed.
Back to top
View user's profile Send private message 
abushcrafter


Joined: 30 Oct 2009
Posts: 1447
Location: England

PostPosted: Sat 06 Mar 2010, 18:23    Post subject:  

8-bit wrote:
One thing that would be nice to have added to your script just after the line that clears the temporary file of the word "Done" after it is displayed for 4 seconds would be to add a line
Code:
xmessage "Pupsave backup completed"
.
That way if I am away from the PC and have missed the "Done" message, I know the backup has completed.


+1
Back to top
View user's profile Send private message Visit poster's website 
don922

Joined: 19 Jan 2008
Posts: 380
Location: The land of 14" monitors

PostPosted: Wed 26 May 2010, 05:54    Post subject: How to make it work ???????
Subject description: (Fixed)
 

Puppy 4.12 frugal install

Downloaded and extracted hotbkp.tar.gz to ~/my-applications. This resulted in one file named Pupsave-backup in ~/my-applications.

There is no menu entries and when I click on the file nothing happens.

In the console
Code:
[~]/root/my-applications/Pupsave-backup
/root/my-applications/Pupsave-backup: line 204: unexpected EOF while looking for matching `)'
/root/my-applications/Pupsave-backup: line 316: syntax error: unexpected end of file


line 204: export PUPSAVE_HOT_BKP=$(cat <<EOV | sed -e 's/#.*//' # allow comments in gui
line 316: is blank

Any idea what is wrong? How is it fixed?

Fixed by downgrading bash to version 3.00.16(1) it had been upgraded to version 4.0.10(1).

Some dumb-dumb didn't pay attention to the 1st line of the 1st post or didn't remember upgrading bash...........Duh Embarassed Embarassed Embarassed

_________________
Don -- Thailand


Last edited by don922 on Fri 23 Sep 2011, 01:00; edited 1 time in total
Back to top
View user's profile Send private message 
Baldlygo


Joined: 21 Mar 2011
Posts: 67
Location: Le Dorat, France

PostPosted: Thu 22 Sep 2011, 08:25    Post subject: Hot Backup  

Just tried this hotbkp on my lupu520. It starts the gui OK and sees the right save file but then just stays there without showing any more info or allow any other clicks.

I do have Bash 3.00.16. Could my problem relate to me upgrading to gtkdialog3-0.7.20-patriot-e-1.pet ? (which I did to get lameSMBxplorer-0.2.3a.pet to work)

Paul

_________________
Lucid 5.20 - my preferred OS on old Dell Inspiron 8000 & Toshiba Tecra M5
Back to top
View user's profile Send private message Visit poster's website 
2byte

Joined: 09 Oct 2006
Posts: 357

PostPosted: Thu 22 Sep 2011, 09:05    Post subject:  

Hello Baldygo

The utility was built for official 4x series pups and many things have changed since then. I'll take a look at upgrading it for 5x series, but no promises.

I do not recommend downgrading bash or gtkdialog in order to use this utility!

_________________

Back to top
View user's profile Send private message 
Baldlygo


Joined: 21 Mar 2011
Posts: 67
Location: Le Dorat, France

PostPosted: Thu 22 Sep 2011, 09:18    Post subject: Hot Backup  

Thanks for quick reply Zbyte - I will be very keen to use it if you do upgrade.

Paul

_________________
Lucid 5.20 - my preferred OS on old Dell Inspiron 8000 & Toshiba Tecra M5
Back to top
View user's profile Send private message Visit poster's website 
8-bit


Joined: 03 Apr 2007
Posts: 3393
Location: Oregon

PostPosted: Thu 22 Sep 2011, 09:44    Post subject:  

Baldygo,
I run Puppy Lucid 520 with half of creation installed.
I do not understand why you say you had to upgrade gtkdialog3 as the Patriot version is already in by default.
Are you sure you have not installed a Pet of the development gtkdialog?

Also, Pupsave-backup works just fine for me.
Remember to save outside of your lupusave file though.


I will check on that to see.
I am back from running Pupsave-backup with the latest gtkdialog.
It works just fine.
So it must be something else you have installed that is causing problems or just maybe you got a bad download of hotbackup.
Try downloading and installing it again.
Back to top
View user's profile Send private message 
Baldlygo


Joined: 21 Mar 2011
Posts: 67
Location: Le Dorat, France

PostPosted: Thu 22 Sep 2011, 10:42    Post subject: Hot Backup - Gtkdialog  

8-bit - I could not get lameSMBxplorer-0.2.3a to work and the console told me that gtkdialog3-0.7.20 was required. I found the gtkdialog3-07.20-patriot-e-1.pet, installed it and the xplorer and mount worked ok.

Please can you tell me how I can find "the latest gtkdialog" as a pet or how I can install it?

Paul

_________________
Lucid 5.20 - my preferred OS on old Dell Inspiron 8000 & Toshiba Tecra M5
Back to top
View user's profile Send private message Visit poster's website 
8-bit


Joined: 03 Apr 2007
Posts: 3393
Location: Oregon

PostPosted: Thu 22 Sep 2011, 13:28    Post subject:  

Where did you find that gtkdialog3.pet?
I want to check with your pet of it as I still do not think gtkdialog3 is the problem.

I just downloaded the beta version of lameSMBexplorer that you did and it works fine with gtkdialog3 that comes with Puppy Lucid 520.
So it sounds like your problem is somewhere else.
As to the latest version of gtkdialog, check with 01micko as it is a compiled binary file.
But as I said, I cannot seem to duplicate your problem with the applications and the only difference I can see is the strange version of gtkdialog3 you installed.
Back to top
View user's profile Send private message 
Baldlygo


Joined: 21 Mar 2011
Posts: 67
Location: Le Dorat, France

PostPosted: Thu 22 Sep 2011, 14:06    Post subject: Version of gtkdialog  

8-bit wrote:
Where did you find that gtkdialog3.pet?
I want to check with your pet of it as I still do not think gtkdialog3 is the problem.

http://bkhome.org/blog/?viewDetailed=01264 is where I found the pet which solved my previous problem.

Paul

_________________
Lucid 5.20 - my preferred OS on old Dell Inspiron 8000 & Toshiba Tecra M5
Back to top
View user's profile Send private message Visit poster's website 
8-bit


Joined: 03 Apr 2007
Posts: 3393
Location: Oregon

PostPosted: Thu 22 Sep 2011, 18:44    Post subject:  

I have now run both Pupsave-Backup and lameSMBxplorer-0.2.3a on Puppy Lucid 520. Both ran fine with the version of gtkdialog3 that is included in Lucid 520 without installing anything additional.
In the case of lameSMBxplorer, it found my only network share so I assume it works.
And Pupsave-Backup created a pupsave backup just fine in /mnt/home.
Also, as I was saying, make doubly sure you select an area outside of your lupusave/pupsave file as you cannot back up your pupsave to your pupsave with any form of success.

Anyway, I would uninstall the gtkdialog3 PET you got from Barry's site and try again with the one that is part of Lucid.
Also remember that the lameSMBxplorer you installed is in beta and feedback from users is requested as to problems you may encounter.
Have you tried starting it from a terminal/rxvt/urxvt to see if any error messages appear?
Back to top
View user's profile Send private message 
Baldlygo


Joined: 21 Mar 2011
Posts: 67
Location: Le Dorat, France

PostPosted: Fri 23 Sep 2011, 06:44    Post subject: Hot Backup - Gtkdialog  

I've removed the Gtkdialog pet and lameSMBxplorer version with packetmanager. Then loaded an older version of lameSMBxplorer and that works ok for my network Linkstation.

When I run Pupsave-backup from the console it shows the gui ok - with savefile details but will not let me change anything. (eg location). When I quit the gui disappears but the console tells me it is repeatedly trying to cat a tmp file which does not exist.

I have run in ram and used a simple copy to a usb drive - which did not take too long and maybe is the simplest way to backup my 1G savefile.

Paul

_________________
Lucid 5.20 - my preferred OS on old Dell Inspiron 8000 & Toshiba Tecra M5
Back to top
View user's profile Send private message Visit poster's website 
8-bit


Joined: 03 Apr 2007
Posts: 3393
Location: Oregon

PostPosted: Fri 23 Sep 2011, 14:48    Post subject:
Subject description: Getting Pupsave-backup to work
 

I am curious as to why you are having problems.
In the first window that shows information, are you able to click on the folder icon and does it open a selection window?
Mine, when I start it looks like the attached jpg file. Pay attention to MB required and make sure it is less than MB available on xxxx.
If the destination does not have room, it will not work.
pupsave-backup.jpg
 Description   My opening screen for Pupsave-backup.
 Filesize   34.68 KB
 Viewed   731 Time(s)

pupsave-backup.jpg

Back to top
View user's profile Send private message 
Baldlygo


Joined: 21 Mar 2011
Posts: 67
Location: Le Dorat, France

PostPosted: Sat 24 Sep 2011, 08:01    Post subject:  Hot Backup  

Well now it appears to be working for me Very Happy
May be I did not wait long enough for the folders to show. Also I seemed to have the cat problem Quiting without running backup. Then it would not run a second time without reboot. I'll have another look at that when my first backup is completed.

Thanks again - Paul
workinghotbck.jpeg
 Description   In progress as I post
 Filesize   22.23 KB
 Viewed   826 Time(s)

workinghotbck.jpeg


_________________
Lucid 5.20 - my preferred OS on old Dell Inspiron 8000 & Toshiba Tecra M5
Back to top
View user's profile Send private message Visit poster's website 
8-bit


Joined: 03 Apr 2007
Posts: 3393
Location: Oregon

PostPosted: Sat 24 Sep 2011, 12:41    Post subject:  

Your backed up lupusave file will have date and time appended to the file name. To restore to a backup, you would copy it to your frugal subdirectory using something like
"cp [location of backup]/lupusave.3fs.BKP-11.10.24.09.38 /mnt/home/[puppy directory]/lupusave.3fs".
I would recommend doing this with Puppy booted with pfix=ram added temporarily to the kernel line.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 2 of 6 [88 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Utilities
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0836s ][ Queries: 12 (0.0067s) ][ GZIP on ]