Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 09 Apr 2020, 19:45
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
I'm seriously frustrated with xscreensaver..
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [10 Posts]  
Author Message
jason.b.c


Joined: 08 Feb 2006
Posts: 758
Location: Marshfield,MO

PostPosted: Thu 26 Nov 2009, 17:24    Post subject:  I'm seriously frustrated with xscreensaver..
Subject description: How do you make it run as "nobody"..?
 

i don't understand this...!

i attached a screen shot...


I had xscreensaver running just fine and dandy , then i wanted to change to a differant gtk ( or was it a jwm ) theme , so i did - and now "xscreensaver-demo" (why is it called "demo"..? ) Will Not Run Anymore..., why?


i have un/re-installed it already , i have deleted the config file 3 or four times so it could be rewriten ... dosen't help..


How do i run xscreensaver as "nobody".....???? Confused

_________________
Puppy is Awesome..!!!!

Back to top
View user's profile Send private message Visit poster's website AIM Address Yahoo Messenger 
gposil


Joined: 06 Apr 2009
Posts: 1305
Location: Stanthorpe (The Granite Belt), QLD, Australia

PostPosted: Thu 26 Nov 2009, 19:59    Post subject:  

All you need do is launch xscreensaver-demo is use the script below to launch it..(Comes from Dpup, which has Xscreensaver as standard)

Quote:
#!/bin/bash
cd /
chmod 777 root
su nobody -c xscreensaver-demo
#exit
cd /
chmod 755 root


save the script as ssconfig or whatever and make it executable.

Cheers

_________________
Dpup Home
Back to top
View user's profile Send private message Visit poster's website MSN Messenger 
jason.b.c


Joined: 08 Feb 2006
Posts: 758
Location: Marshfield,MO

PostPosted: Fri 27 Nov 2009, 18:11    Post subject:  

gposil wrote:
All you need do is launch xscreensaver-demo is use the script below to launch it..(Comes from Dpup, which has Xscreensaver as standard)

Quote:
#!/bin/bash
cd /
chmod 777 root
su nobody -c xscreensaver-demo
#exit
cd /
chmod 755 root


save the script as ssconfig or whatever and make it executable.

Cheers



Alrighty , i will try this and post back soon as i can...


Thank You

_________________
Puppy is Awesome..!!!!

Back to top
View user's profile Send private message Visit poster's website AIM Address Yahoo Messenger 
jason.b.c


Joined: 08 Feb 2006
Posts: 758
Location: Marshfield,MO

PostPosted: Sat 28 Nov 2009, 03:44    Post subject:  

where should i save it...?
_________________
Puppy is Awesome..!!!!

Back to top
View user's profile Send private message Visit poster's website AIM Address Yahoo Messenger 
gposil


Joined: 06 Apr 2009
Posts: 1305
Location: Stanthorpe (The Granite Belt), QLD, Australia

PostPosted: Sat 28 Nov 2009, 04:04    Post subject:  

The best place is /usr/sbin, and then you can create a shortcut to it if you want...In Dpup it has a shortcut in the taskbar with Show Desktop etc.
_________________
Dpup Home
Back to top
View user's profile Send private message Visit poster's website MSN Messenger 
jason.b.c


Joined: 08 Feb 2006
Posts: 758
Location: Marshfield,MO

PostPosted: Sat 28 Nov 2009, 14:05    Post subject:  

gposil wrote:
The best place is /usr/sbin, and then you can create a shortcut to it if you want...In Dpup it has a shortcut in the taskbar with Show Desktop etc.


oh ok , i get it - so it'll show up in the menu , right?

_________________
Puppy is Awesome..!!!!

Back to top
View user's profile Send private message Visit poster's website AIM Address Yahoo Messenger 
jason.b.c


Joined: 08 Feb 2006
Posts: 758
Location: Marshfield,MO

PostPosted: Tue 01 Dec 2009, 14:43    Post subject:  

hhmm

ok new problem..

i've followed the previous instruction above which happens to work out pretty good , when i click the executable the xscreensaver dialog ( whatever it's called ) box window thing appears only this time it looks differant ( like it is running as a differant user , which i guess it would be LOL ) , but after setting up my chosen saver and all other settings and then clicking the close button ,the saver dosen't come on after the preset time limit ....


If i open the terminal and type xscreensaver ( and not "xscreensaver-demo" ) the dialog will come up , if i then minimize that window and the terminal too ( just to have them outta the way ) the saver will run fine , but the terminal has to remain open ...!


so my question is........ how could i get xscreensaver to run (at startup mind you) like it's being launched from the terminal without actually being launched from terminal..? because i've tried a few other ways and i'm rather stumped and confused at this point....


Thanks...... Very Happy

_________________
Puppy is Awesome..!!!!

Back to top
View user's profile Send private message Visit poster's website AIM Address Yahoo Messenger 
jason.b.c


Joined: 08 Feb 2006
Posts: 758
Location: Marshfield,MO

PostPosted: Tue 01 Dec 2009, 22:39    Post subject:  

bump
_________________
Puppy is Awesome..!!!!

Back to top
View user's profile Send private message Visit poster's website AIM Address Yahoo Messenger 
gposil


Joined: 06 Apr 2009
Posts: 1305
Location: Stanthorpe (The Granite Belt), QLD, Australia

PostPosted: Tue 01 Dec 2009, 22:52    Post subject:  

Jason,

In the /root/Startup folder put the following in a file called xscr and make it executable.

Quote:
#!/bin/bash
xscreensaver -no-splash &


Now everytime Puppy starts, the screensaver will be running in the background.........

Cheers

_________________
Dpup Home
Back to top
View user's profile Send private message Visit poster's website MSN Messenger 
jason.b.c


Joined: 08 Feb 2006
Posts: 758
Location: Marshfield,MO

PostPosted: Mon 07 Dec 2009, 12:35    Post subject:  

gposil wrote:
Jason,

In the /root/Startup folder put the following in a file called xscr and make it executable.

Quote:
#!/bin/bash
xscreensaver -no-splash &


Now everytime Puppy starts, the screensaver will be running in the background.........

Cheers



you are good.. Wink

Thank You ........

_________________
Puppy is Awesome..!!!!

Back to top
View user's profile Send private message Visit poster's website AIM Address Yahoo Messenger 
Display posts from previous:   Sort by:   
Page 1 of 1 [10 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0407s ][ Queries: 11 (0.0062s) ][ GZIP on ]