Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info

READ-ONLY-MODE: PLEASE DO NOT POST NEW STUFF!
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile       

The time now is Mon 10 Aug 2020, 02:00
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Networking » Wireless
Re-boot loses my Windows XP Driver Setting via ndiswrapper
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [5 Posts]  
Author Message
wtall

Joined: 01 Feb 2009
Posts: 4

PostPosted: Thu 12 Nov 2009, 00:28    Post subject:  Re-boot loses my Windows XP Driver Setting via ndiswrapper
Subject description: Want to define driver precedence using the setup icon so a Windows XP (via ndiswrapper) PMCIA Wirele
 

Hi All,

I hope someone can help.

Objeective: Want to define driver precedence using the setup icon so a Windows XP (via ndiswrapper) PMCIA Wireless driver is used instead of the generic rt61pci driver.

Puppy Variant: 4.3.1

Harware Profile: Laptop: Dell Lattitude C640, 1.70Gz, 512MB

Wireless Card: DWA-610 Dlink PMCIA

Driver I want to use: Windows Driver which I have saved onto a linux partition

Detailed Description of Issue:

Instead of the generic linux driver (rt61pci) driver which comes with Puppy (which works fine, but seems to struggle when the signal strength is a bit low...loses connectivity and never automatically recovers...) I am using the Windows XP Driver netrt61g (via ndiswrapper) that supports the wireless card with far greater success (extremely stable). I have no problem configuring puppy to do this thanks to the Wireless Wizard and the option to use a Windows Driver via ndiswrapper.

The problem is when when I re-boot the machine, Puppy Linux defaults back to the generic linux driver (rt61pci).

I believe one can use the (destkop) 'Setup' option to define driver start-up order by loading drivers, black-listing them and/or by assigning a precedence of one driver over another.


Now I've tried using this setup feature, specifically the 'precedence' option, using a few variations, but none of them work.

Syntax: (module1:module2) where, module 2 takes precendence over module1.

eg: rt61pci:netrt61g
rt61pci:ndsiwrapper

But each time I re-boot, Puppy keeps reverting to the generic driver and not the Windows (via ndiswrapper) one.

Help anyone?
Back to top
View user's profile Send private message 
8-bit


Joined: 03 Apr 2007
Posts: 3425
Location: Oregon

PostPosted: Thu 12 Nov 2009, 11:38    Post subject:  

I do not know if this would work, but with Psearch, do a search for that driver.
I just did and it is showing up.
Try going to the directory containing rt61pci.ko and renaming it to something like blacklist-rt61pci.ko.
You might also have to rename the directory containing it.
This is just a thought.
If the driver is not found, it will not be loaded.
Back to top
View user's profile Send private message 
wtall

Joined: 01 Feb 2009
Posts: 4

PostPosted: Thu 12 Nov 2009, 17:52    Post subject:  

8-bit wrote:
I do not know if this would work, but with Psearch, do a search for that driver.
I just did and it is showing up.
Try going to the directory containing rt61pci.ko and renaming it to something like blacklist-rt61pci.ko.
You might also have to rename the directory containing it.
This is just a thought.
If the driver is not found, it will not be loaded.


Thanks for that. I assume you mean do a Psearch for the default linux driver that rt61pci that is being automatically loaded? I'll try it tonight . That should allow me to rename it so (ala blacklist) so it is no longer loaded up. Still leaves me with the issue of making Puppy see the Windows driver automatically on re-boot (instead of me having to use the Network Wizard and ndiswrapper option to manually load it up).

Ta.
Back to top
View user's profile Send private message 
wtall

Joined: 01 Feb 2009
Posts: 4

PostPosted: Sat 14 Nov 2009, 02:20    Post subject:  

THANK YOU. It worked. Thank you very much for the advice. Very much appreciated. I believe this issue may be considered closed.



To summarize, I did as you suggested (listed below) after I had configured, using the network wizard, to use a Windows Driver (via ndiswrapper) to drive my d-link PMCIA wireless card:

1. After doing a search I located the default linux driver rt61pci in /lib/modules/2.6.30.5/kernel/drivers/net/wireless/rt2x00/rt61pci.ko
2. I renamed the file (via 'mv') to blacklist-rt61pci.ko
3. Re-booted my machine.
4. Puppy loaded up the Windows Driver (via ndiswrapper) instead of the default linux rt61pci

Fantastic. I was worried on point 4 as I didn't know if puppy would know which Windows driver to load up, but it must pick the information up fro the saved configuration information that concludes with original network wizard efforts.

Smile

Thanks!
Back to top
View user's profile Send private message 
8-bit


Joined: 03 Apr 2007
Posts: 3425
Location: Oregon

PostPosted: Sat 14 Nov 2009, 02:56    Post subject:  

If it continues to work, please edit your original post and add "SOLVED" to the title line.
Glad that worked for you.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [5 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Networking » Wireless
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0652s ][ Queries: 11 (0.0274s) ][ GZIP on ]