Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 20 Oct 2014, 22:49
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Go-OpenOffice SFS 3.1.1
Moderators: deshlab, Flash, GuestToo, Ian, JohnMurga, Lobster
Post new topic   Reply to topic View previous topic :: View next topic
Page 2 of 2 [29 Posts]   Goto page: Previous 1, 2
Author Message
mikeb


Joined: 23 Nov 2006
Posts: 8342

PostPosted: Mon 30 Nov 2009, 12:50    Post subject:  

For those who pulled out their remaining hair trying to get a british english dictionary that is supposed to be but often isn't included and is not available from OO site and if you like you thesarus in british english too then go here and be relieved of the stress
http://www.weeklywhinge.com/?p=69

phew

mike
Back to top
View user's profile Send private message 
jduffy


Joined: 12 Dec 2009
Posts: 12

PostPosted: Sat 12 Dec 2009, 14:02    Post subject: Nice...  

I actually got this to work. I found some Office icons on line and installed a US dictionary. Fun stuff.

I'm new as all get out to Puppy Linux but I'm getting the hang of it.

I've been looking for a way to edit the Menu so I can make a link to Office but no luck yet.
Back to top
View user's profile Send private message 
charlie6


Joined: 30 Jun 2008
Posts: 1015
Location: South of Belgium

PostPosted: Sat 19 Dec 2009, 05:17    Post subject:
Subject description: go-OpenOffice unable to open .doc files
 

Hi,
on latest puppy 431 small frugal instal:
Go-Openoffice ( go-00432.sfs ) writer freezes when opening the attached .doc (tar.gz compressed...to 811K...do not kow if it is to big?) document. This has been reproduced also on 2 different installations of go-oo-3.1.1-sfs3.sfs on puppy4.1.2 (using the sfs3 version). As also with another .doc file written on a different PC.

Problem: opening the attached fileX.doc causes Go-Openoffice to freeze. Same behaviour with other .doc files.
I need to kill the process and also to open PProcess to end swriter.
Installing java jre1.6.0.17 does not help.

(those .doc files are produced from microsoft office suite - no problem reading them on windows XP).
Abiword can open them even if the characters looks «quirky» - using the preview gets it ...readable!

This does not happen with an earlier version of OpenOffice (i.e. OO3-DE-US-FR-NL-IT_411.sfs ): the attached document gets opened normaly.

Thanks for any help.

Cheers, Charlie

Here are the comments from the console (just the beginning!)
Code:
# soffice
javaldx: Could not find a Java Runtime Environment!
# *** glibc detected *** /opt/openoffice.org3/program/soffice.bin: malloc(): mem                                                              ory corruption: 0x08d13798 ***
======= Backtrace: =========
/lib/libc.so.6[0xb7d6840e]
/lib/libc.so.6[0xb7d69db9]
/lib/libc.so.6(__libc_malloc+0x75)[0xb7d6b174]
/opt/openoffice.org3/program/../basis-link/ure-link/lib/libuno_sal.so.3(rtl_allo                                                              cateMemory+0x1a)[0xb7f7a6b6]
/opt/openoffice.org3/program/soffice.bin(__gxx_personality_v0+0x1f5)[0x8048dcd]
/opt/openoffice.org3/program/soffice.bin(_Znaj+0x26)[0x8048e56]
/opt/openoffice.org3/program/../basis-link/program/libsvlli.so[0xb77c8c77]
/opt/openoffice.org/basis3.1/program/libmswordli.so[0xadf09ce2]
/opt/openoffice.org/basis3.1/program/libmswordli.so[0xadf0ff28]
/opt/openoffice.org/basis3.1/program/libmswordli.so[0xadf10527]
/opt/openoffice.org/basis3.1/program/libmswordli.so[0xadf106f5]
/opt/openoffice.org/basis3.1/program/libmswordli.so[0xadf13bf0]
....
fileX.tar.gz
Description 
gz

 Download 
Filename  fileX.tar.gz 
Filesize  810.61 KB 
Downloaded  679 Time(s) 
Back to top
View user's profile Send private message 
mikeb


Joined: 23 Nov 2006
Posts: 8342

PostPosted: Sat 19 Dec 2009, 11:26    Post subject:  

Yes confirmed this is a problem.
I also tested on windows with the same version of Go Office and the document opened normally.
I re-saved from there under another name and Go Office on puppy still crashed with that.
My first thought was of a locale/language/unicode problem.(when opened said language unknown)
Its not a java problem...I tested with and without.

Since this sfs was apparently built direct from the Go Office linux package perhaps a they need informing along with a copy of the file as this is quite a serious issue.

Abiword did open it but its handling and doc output is not very standard..ie document only but no file header/footers....the header of the document from GO is the same as the original.


mike
Back to top
View user's profile Send private message 
mikeb


Joined: 23 Nov 2006
Posts: 8342

PostPosted: Sat 19 Dec 2009, 15:56    Post subject:  

In addition I tried another french language document and it opened ok.
The test document had language unknown...could be a factor

mike
Back to top
View user's profile Send private message 
mikeb


Joined: 23 Nov 2006
Posts: 8342

PostPosted: Fri 15 Jan 2010, 17:45    Post subject:  

Ok I finally investigated this.
The freezing was due to the embedded jpg images.
Basically they appear to be malformed...ie the endings are incorrect....on windows go-office it copes with that but on linux it does not.
If I extracted the embedded image with a hex editor it only partly displayed if re-imported...windows itself was unable to thumbnail it at all.
If I did the same with a good .doc and embedded jpg ie extract with a hex editor , the extracted image displayed 100%.
Examining the images showed header info that is normally at the start of the file was also present at the end so the source of these images is in question.

Hope that throws some light on the subject.

mike
Back to top
View user's profile Send private message 
jpeps

Joined: 31 May 2008
Posts: 3220

PostPosted: Sun 24 Jan 2010, 06:11    Post subject:  

go-oo works nicely network printing with my DD-WRT firmware. I tried several versions of OO, and all failed.
Back to top
View user's profile Send private message 
omskates


Joined: 03 Sep 2009
Posts: 257
Location: TriCities, WA

PostPosted: Wed 27 Jan 2010, 20:06    Post subject:  

I can't seem to get go-00432.sfs to show up in /opt with Puppy 4.31 I do have it set to load at boot and also tried renaming to go-00432-431.sfs
Mounted or unmounted, the sfs doesn't show up as an application no matter what its name is. I must be missing something.

***OK downloading from a different source now to make sure format is correct. Will post results if anyone interested.
Back to top
View user's profile Send private message 
mikeb


Joined: 23 Nov 2006
Posts: 8342

PostPosted: Wed 27 Jan 2010, 20:57    Post subject:  

My only encounter with the boot manager is either use the naming convention or select whats boots but do not mix the two....as you see it works well


mike
Back to top
View user's profile Send private message 
omskates


Joined: 03 Sep 2009
Posts: 257
Location: TriCities, WA

PostPosted: Thu 28 Jan 2010, 05:05    Post subject:  

Yes, loading sfs files with boot manager has worked very well for me. I may need to start over with this one and follow necessary steps with the correct download. Thanks Smile
Back to top
View user's profile Send private message 
axel


Joined: 17 Oct 2008
Posts: 40
Location: Germany / Herrenberg

PostPosted: Mon 22 Feb 2010, 05:27    Post subject: OO installed with p pack manger / can't even create document  

I hope to find help here.
Have installed (on full installation 4.3.1) openoffice-cutdown3-2.2.0.. Got a heap of missing dependencies - and surprisingly at the end a message
"No missing dependencies"

I can't even create a tiny test document. When trying to save the file OO freezes. Have to kill it via process manager.

Have installed afterwards jre-6 / help / missings / mozilla / pyno
with no succes whatsoever.
Any advice ??
openoffice_missing_dependencies.jpg
 Description   
 Filesize   109.84 KB
 Viewed   673 Time(s)

openoffice_missing_dependencies.jpg

Back to top
View user's profile Send private message 
axel


Joined: 17 Oct 2008
Posts: 40
Location: Germany / Herrenberg

PostPosted: Mon 22 Feb 2010, 06:04    Post subject: OO hangs when trying to save a tiny .ods file  

oooh dear - I realized that I'm in the wrong thread. Did only realize some minutes ago that all conversation is about Go-OpenOffice SFS 3.1.1
sorry
Back to top
View user's profile Send private message 
axel


Joined: 17 Oct 2008
Posts: 40
Location: Germany / Herrenberg

PostPosted: Mon 22 Feb 2010, 07:37    Post subject: OO hangs when trying to save a tiny .ods file  

oooh dear - I realized that I'm in the wrong thread. Did only realize some minutes ago that all conversation is about Go-OpenOffice SFS 3.1.1
sorry
Back to top
View user's profile Send private message 
steve_s


Joined: 26 May 2008
Posts: 1545
Location: Austin, TX, USA

PostPosted: Wed 13 Jul 2011, 14:33    Post subject: Re: missing dictionary  

wuwei wrote:
Thanks playdayz.

I tried the sfs3 version in 421 and it works fine, except for one strange quirk:
When opening Writer a message comes up and reports "dict-fr.oxt does not exist". When opening Writer again, it opens without this message. Installing the French dictionary does not help any.

Any ideas how and where to get rid of this annoyance?


Did you get a fix for this wuwei/playdayz? I have exactly this same issue...
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 2 of 2 [29 Posts]   Goto page: Previous 1, 2
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0773s ][ Queries: 12 (0.0059s) ][ GZIP on ]