Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 01 Oct 2014, 12:36
All times are UTC - 4
 Forum index » House Training » Bugs ( Submit bugs )
Problem with tar (solved) (D'oh!)
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
Sit Heel Speak


Joined: 30 Mar 2006
Posts: 2595
Location: downwind

PostPosted: Mon 26 Oct 2009, 14:33    Post_subject:  Problem with tar (solved) (D'oh!)
Sub_title: One does have to specify output filename...
 

Not sure if this is a bug, or my own ignorance. Clues are welcome.

This problem manifests on Puppies 4.12, 4.21, and 4.30 (prebuilt .iso). Underlying filesystem is ext3.

I am trying to tar a 60M source directory, using

tar -c gcc-4.4.1-source-patched-SHS

The source code in this directory is good enough that gcc compiles cleanly from it, and the gcc created from it works OK.

After about two minutes, there is a brief burst of beeps from the internal speaker.

Another burst, at four minutes.

At five minutes, beeping becomes continuous, but beeping stops at the eight-minute point.

At the 13-minute point, the rxvt screen starts filling up with a repeated pattern and so I kill the process.

The pattern is

;2c1;2c1;2c1;2c1;2c1;2c1;2c1;2c1;2c1;2c1;2c1;2c1;2c1;2c1;2c1;2c1;2c1;2c1

Attempting to tar the smaller (2M) directory freetype-2.3.11 starts producing the same pattern and then tar hangs.

Rudy Puppy 2.14 finishes the 60M tar without emitting any beeps, the END OF (FILE? ARCHIVE? I forget) message appears, and it returns to the command prompt, but then dumps a half-a-screenful of the same pattern, and there is no .tar archive created.

***edited: hmm, let me try Rudy again...I don't recall whether the ;2c1 pattern is dumped before, or after, the prompt returns. Will try it again and check back here in 20 minutes.***

Giving it

tar -c --ignore-command-errors gcc-4.4.1-source-patched-SHS

makes no difference.

Help?

Edited_time_total
Back to top
View user's profile Send_private_message 
technosaurus


Joined: 18 May 2008
Posts: 4351

PostPosted: Mon 26 Oct 2009, 14:39    Post_subject:  

Code:
which tar


should it not be?:

tar -c{y,z}f mytarball.tar.{b,g}z the_directory_I_want_to_tarballize

I think you just have to specify the tarball name? Different than all of the compression programs that simply add their suffix

the y and z are only if you want bzip or gzip compression respectively - they can be removed if you just want a tarball to do a diff against or whatever... if you have tar-1.22 or later and xz you can do a tar.xz by using 'J' instead of 'y' or 'z' .... not that you would want to but you can use 'Z' to just use compress

to untar

tar -x{j,J,y,z,Z} mytarball.tar.{bz2,xz,bz,gz,Z}

I am on a win32 machine right now so instead of relying on my memory maybe check me with:

Code:
tar --help

_________________
Web Programming - Pet Packaging 100 & 101

Edited_time_total
Back to top
View user's profile Send_private_message 
Sit Heel Speak


Joined: 30 Mar 2006
Posts: 2595
Location: downwind

PostPosted: Mon 26 Oct 2009, 14:51    Post_subject:  

(ahem)...of course (thunks head) ...

I was thinking, one can just name the directory, and tar will create a .tar archive of the same name.

Now to see if I can get gftp to oblige me...
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Bugs ( Submit bugs )
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0550s ][ Queries: 11 (0.0142s) ][ GZIP on ]