Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 04 Jun 2020, 19:58
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Networking » Wireless
wireless / wifi cards confirmed to work in puppy
Post new topic   Reply to topic View previous topic :: View next topic
Page 7 of 10 [140 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6, 7, 8, 9, 10 Next
Author Message

Joined: 23 Dec 2011
Posts: 130
Location: The Little Red Dot

PostPosted: Tue 27 Dec 2011, 05:53    Post subject: DLink DWL-G630 wireless pcmcia adapter
Subject description: no modem available

My wireless pcmcia adapter,DLink DWL-G630, is not detected(no modem available),didn't even show in hardinfo.I'm running Classic Pup214X-TOP9 frugal installed on my Acer Travelmate notebook(since 2002),cpu 1.6GHz,512MB RAM,ALI chipset motherboard,80GB harddisk. Really hope you guys can help me to get it working as I'm about to give up as most of the Puppy Linux distros didn't work properly for this notebook(usually screen and touchpad no tapping,wireless networking problems) except Classic Pup214X-TOP9 and Quickset Wary511(this one works well,including the wireless networking) but I kind of like 214X better.
Edited: My wireless pcmcia adapter is now detected after I followed tempestuous' advice to update the rt61.sys driver, except that I'm still unable to establish a wpa connection,probably due to my ISP max 6 connections limitation;however blinky network status info showed that it was connected with sent and receive packets,just that the web pages won't load. Wonder whether it has anything to do with the wpa_supplicant.
Latest: It works after I changed wpa2 to wpa+tkip encryption on wlan0 configuration in Puppy,now my wireless wpa connection established.

Last edited by PenguinPupLin on Mon 09 Jan 2012, 08:20; edited 2 times in total
Back to top
View user's profile Send private message 

Joined: 15 Dec 2009
Posts: 2955
Location: USA

PostPosted: Mon 02 Jan 2012, 17:41    Post subject:  

Two reports:

PCMCIA Trendnet TEW-441PC (11g card) works in Lupu 5.25 (Retro)

USB Trendnet TEW-424UB works under 5.20 and 5.28 (I believe I tested both, I'm sure that I tested the former -- I didn't yet try it under 5.25, but would guess it works).

Add swapfile
WellMinded Search
PuppyLinux.US Search
Back to top
View user's profile Send private message 

Joined: 11 Jul 2008
Posts: 88

PostPosted: Thu 08 Mar 2012, 15:09    Post subject:    

Premeirtek "Powerlink Speedy2" Is working great! Very Happy
Ralink 3072 chip
Its working in 528 , 528.004 and Racy 522 ( Racy needed the firmware file).

FYI: This is a high power usb b/g/n adapter with duel 5dbi antennas. Its the best $(2Cool you can spend if you want long rang and smooth videos streams.
I had to put my velco "ALFA AWUS036h (1watt 5dbi antenna)" to a window for a stable connection! This adapter sits on my desk working better! Smile
Back to top
View user's profile Send private message 

Joined: 04 Oct 2005
Posts: 133
Location: Italy

PostPosted: Thu 03 May 2012, 12:56    Post subject:
Subject description: ipn2220 inprocomm mini-pci works with ndiswrapper

I ripped a mini-pci ipn2220 wifi card off a broken wifi modem Exclamation . Installed it on my laptop, then tried Puppy 4.3.1 and ndiswrapper, but the connection was slow, high latency, and downloads wouldn't complete (wget stopped after 4-6 MB ). I used i2220ntx.sys version
Then I tried other version of inf and sys win files in Puppy Racy 5.2 and it worked very well, perfect downloads, stable connection etc. The version of i2220ntx.sys file I found to be stable is: Just search "" AND inprocomm in google to find the right Windows driver or try this link:
Back to top
View user's profile Send private message 

Joined: 15 Apr 2011
Posts: 969
Location: El Salvador

PostPosted: Thu 03 May 2012, 19:46    Post subject: pci wireless card ion 300 nexxt  

chip rt3265sta works in lucid 528 puppy 420 and slacko 3.5.1
saluki020 and dpup exprimo 5x14
Back to top
View user's profile Send private message 

Joined: 10 Sep 2011
Posts: 12591
Location: Mer méditerrannée (1 kms°)

PostPosted: Tue 16 Apr 2013, 06:19    Post subject: 2013 : should be updated now.
Subject description: very good job

very good job. 2013 : it would be worth to update it...
Medion P7624 connects the web with driver Atl1c atheros eth0
But IWLWIFI driver iwlagn hardly connect wireless with Puppies 4XXX and 3XXX (hardly means never for my own use)
Back to top
View user's profile Send private message Yahoo Messenger 

Joined: 26 Jun 2013
Posts: 2

PostPosted: Sat 29 Jun 2013, 14:05    Post subject:  Looking for up to date help
Subject description: About setting up wireless network

Hello forum,
This is my first post since I registered.
I've been searching for solutions to set up my PC wireless network.

PC: Everex StepNote NC1510
Ethernet controller: Marvel Technologies Group Ltd. 88w8335 [Libertas] 802.11 b/g Wireless (rev 43)

I don't have Windows Vista installed on the PC nor the Windows installer.

OS: Precise Puppy Linux 5.6.1 installed on Hard Drive.

Has something been developed for the card?
How can I set it up and how can I bring the windows drivers onto linux, if required for it to work?

I've been using the Network Wizard, I've been trying different modules but hardware isn't recognized.
Back to top
View user's profile Send private message 

Joined: 29 Jan 2006
Posts: 4490
Location: Sydney Australia

PostPosted: Sun 30 Jun 2013, 07:09    Post subject:  



Wireless Controller Atheros AR5005G


Supported from 2006

Is the wireless light on after booting.

Maybe try Give Dpup Exprimo a go...

and use Frisbee to connect.

That...the download links... and other Pups to try
are in my post here.


And welcome to Puppy.

Back to top
View user's profile Send private message 

Joined: 01 Jul 2013
Posts: 1458
Location: USA

PostPosted: Thu 02 Jan 2014, 20:04    Post subject:  

Hi all...

I just purchased this USB wireless adapter from ThinkPenguin.com, which, as stated, uses the AR9271 chipset. I can confirm it works out of the box for Precise 5.6.1, perhaps others (that I can test later.) I had no problem getting it connected using Frisbee. Only had one hiccup so far, in which after roughly 15-20 minutes into the session, I could no longer download anything, even though Frisbee showed me as connected. Puppy also wouldn't shut down, I had to manually turn the computer off at the switch. However, I didn't reboot the system after setting up the connection (but I wouldn't think that would be necessary,) so far this session, it's working fine. Smile

UPDATE: I just tried this device with Lucid 5.2.8 and it does not work, I'm assuming because this version does not have the correct driver. Although Puppy sees it under lsusb, it is not recognized by the Network Manager. Sad


Our Lord and Savior Jesus Christ loves and cares about you most of all!

PLEASE READ! You don't have to end up here!
Back to top
View user's profile Send private message 

Joined: 16 Aug 2009
Posts: 1088
Location: Ann Arbor MI USA

PostPosted: Mon 20 Jan 2014, 23:29    Post subject:  Not Working: non-cardbus orinoco_cs manfid 0xd601, 0x0005
Subject description: works in an older linux not in puppy 4.1.2

Card was pulled from a broken D-Link router and saved because it has a big antenna on it.
Zcom XI-325 Wireless B

Works perfectly in 15 year old Basiclinux ,with orinoco_cs as listed in config.

Puppy 4.3.1 does not see the card. The config file lists it as using hostap_cs, whiich like orinoco_cs and prism2_cs did not work loaded manually.

Other linux users have had problems with it being recognized.

Also not seen by Puppy (4.1.2):
GigaFast Wireless 802.11B/G WF729-AEX (tested working in Win7 - did not try ndiswrapper).
Back to top
View user's profile Send private message 

Joined: 05 Feb 2014
Posts: 13

PostPosted: Thu 06 Feb 2014, 12:59    Post subject:  Broadcom BCM4318 [AirForce One 54g] & Dell B120
Subject description: Successful/Stable Wireless Connectivity

Dell B120 (rescue)
Slacko Puppy 5.6.0 (Full-install)
Broadcom BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller
Native b43 driver
Wireless: G

After several days of trying to get this damaged rescue laptop to take and boot an install of anything; this OS has found it’s home. It will also become my new "work" laptop as it is high time I delve deeper into open-source instead of hacking, cracking, blatant mis-use and general disregard of respect for copy-righted material(s).

This Frisbee network manager is the BOMB.
Back to top
View user's profile Send private message 

Joined: 26 Sep 2012
Posts: 551

PostPosted: Fri 07 Feb 2014, 18:48    Post subject:  

you've encouraged me-I've bought a mini PCI-e version of your device, hoping to get top encryption. 2-4 weeks from China via ebay. Can't wait to try it out..

where there's a will, there's a lawyer.

B.O.M.B: Best Ordinary Mixed Black????? [the Goon show:xxxxxx; Eccles and Bluebottle driving a steam train, Eccles pick up piece of coal with BOMB written on it. [reads aloud] "B.O.M.B. [struggles to pronounce it] Says "Strong coal!" Bluebottle says :"Best......., that's what that is, throw it into the fire, Eccles"]
Back to top
View user's profile Send private message 

Joined: 05 Feb 2014
Posts: 13

PostPosted: Fri 07 Feb 2014, 22:38    Post subject:  

Using Linux (other than troubleshooting hardware issues) as a primary OS was always put off for network cofig issues: Got network? Got answers!
I actually look forward to opening this pet up to take it for walks. Or is it the other way around...? Confused
I needed a replacement pet anyway as I took Beast (my rotty) ice-fishing last month. Instead of cutting holes; I stand back and lob grenades to take the strain off my back.
Well, Beast decided to "fetch" the first attempt and jumps back in my new Escalade. BOMB went BOOM!
Moral of the story?
Stay away from guys name "Eccles" and "Bluebottle".
Don't own a dumb pet: Stay with Puppy. lol
Good luck with the networking.

See ya round....

Hope you get your toy sooner than later. I order pieces and parts from China and the Chinese New Year really stalls their system for a bit.
Back to top
View user's profile Send private message 

Joined: 15 Jan 2013
Posts: 14
Location: U.K.

PostPosted: Fri 18 Apr 2014, 14:38    Post subject: WIFI - 3Com 3CRWE154G72 PCMIA card  

Works with Puppy 5.2.8 & 5.7.1
Back to top
View user's profile Send private message 

Joined: 13 Dec 2007
Posts: 5

PostPosted: Fri 11 Jul 2014, 12:48    Post subject: Dell Latitude D600 Intel 2100 wireless
Subject description: One more thing to check

I got one of these in an auction, and loaded Slacko PuPPy 5.7.
The wireless would not work out of the box.
Things to check:
Go into the BIOS (F2 on startup) and make sure the wireless is turned on. It didn't matter if the setting was F2 or Application.
Boot the machine, and use any of the wireless network setup tools (all 3 worked eventually)
They did see the available wireless networks around my neighborhood, but would not connect to mine. All the others were protected/unavailable.

So, seeing the interface was up with the ifconfig eth1 command, but without a DHCP provided IP address, I looked elsewhere.

It dawned on me that this is 10 year old hardware, and may only work at 11Mb/second (802.11b). I had set my wireless router to only connect with 802.11g (54Mb/second). I changed the router to Mixed, and it connected like a charm. DHCP worked fine as well.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 7 of 10 [140 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6, 7, 8, 9, 10 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Networking » Wireless
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0772s ][ Queries: 11 (0.0192s) ][ GZIP on ]