Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 15 Dec 2017, 22:00
All times are UTC - 4
 Forum index » Advanced Topics » Cutting edge
to test: Keyboard-layout-chooser
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 2 of 2 [26 Posts]   Goto page: Previous 1, 2
Author Message
sveitserosten :)

Joined: 27 Oct 2005
Posts: 22
Location: Switzerland

PostPosted: Sat 17 Dec 2005, 16:05    Post subject: to test: Keyboard-layout-chooser  

Four more things:

- I tested this choose-keyboard-layout-pup with both:
- the standard country keyboard layout and
- the older 2-letter method keyboard layout

It worked with both.

Question: Is there a difference when installing this Dotpup ?

- I can only test anything on a laptop - I HOPE it will work with a computer and a USB keyboard as well.


- All changes (exept installing the dotpup itself) took effect if and only if the computer was rebooted.
Restarting JWM only did not change the settings.

- It worked in all applications exept in Beaver. But this is a known bug as I have read above.
Back to top
View user's profile Send private message 
MU


Joined: 24 Aug 2005
Posts: 13648
Location: Karlsruhe, Germany

PostPosted: Sat 17 Dec 2005, 17:17    Post subject:  

Mange tak Sveit, I will add it to the next version Smile

Mark
Back to top
View user's profile Send private message Visit poster's website 
pakt


Joined: 04 Jun 2005
Posts: 1156
Location: Sweden

PostPosted: Sun 18 Dec 2005, 07:11    Post subject:  

Mark, I'm sorry to say that there _are_ differences in the Swedish xmodmap I had before and the one from Ubuntu. The headers are identical, even the dates are the same, but I found for example:

xmodmap from Ubuntu:
keycode 18 = 9 parenright
keycode 19 = 0 equal
keycode 26 = e E currency

xmodmap from internet:
keycode 18 = 9 parenright bracketright
keycode 19 = 0 equal braceright
keycode 26 = e E EuroSign

So this might explain why other users had problems. It might be useful to compare the files with the ones in SuSE. They are supposed to be in /opt/gnome/share/xmodmap/

I don't have SuSE installed, so I can't check.

Update:I've compared the xmodmap files from Ubuntu 5.10 with the ones in SuSE 10.0 - they are exactly the same, i.e. they have the same errors. I would guess they came from the same source.

The Swedish keyboard is the same as the Finnish one, so I compared xmodmap.fi with xmodmap.se. They are not the same. It turns out that the Finnish one has the missing keys definitions.

Paul
Back to top
View user's profile Send private message 
MU


Joined: 24 Aug 2005
Posts: 13648
Location: Karlsruhe, Germany

PostPosted: Tue 31 Jan 2006, 22:02    Post subject:  

I updated the Dotpup with sveitserostens Layouts (Norvegian, swiss-laptop, french-laptop).
Thanks sveit Smile
Mark
Back to top
View user's profile Send private message Visit poster's website 
dewdrop


Joined: 29 Aug 2005
Posts: 298
Location: Texas USA

PostPosted: Sat 11 Feb 2006, 11:59    Post subject: keyboard layouts  

Hi Mark,

I confirm that the xmodmap.es.gz (Spanish) works in OpenOffice 2.0, Opera 8.51, Mozilla 1.8b1.5, Firefox 1.5.1.

I am using Puppy 1.0.7 with the usr.more.sfs and usr.devx.sfs files on the C drive with pup001.

I tried some of the other Spanish versions and they did not work correctly or at all.

I am using xorg, and ICEWM, and while the keyboard switch from default (English) to Spanish works without having to restart X, I cannot switch back to default without restarting X.

There are times when I need the Spanish keyboard, and your efforts here are greatly appreciated.

Thank you!

dewdrop
Back to top
View user's profile Send private message 
pakt


Joined: 04 Jun 2005
Posts: 1156
Location: Sweden

PostPosted: Sat 11 Feb 2006, 14:51    Post subject:  

Mark and others with international keyboards:

Use Xkb instead of .Xmodmap to get the right keys for your keyboard. See the thread http://www.murga.org/~puppy/viewtopic.php?t=5993 for lior2b's "howto" and the necessary file to download. No more fiddling around with defining individual keys. Works perfectly with my Swedish keyboard! Highly recommended... Very Happy

Paul
Back to top
View user's profile Send private message 
pakt


Joined: 04 Jun 2005
Posts: 1156
Location: Sweden

PostPosted: Sat 11 Feb 2006, 14:57    Post subject: Re: keyboard layouts  

dewdrop wrote:

I am using xorg, and ICEWM, and while the keyboard switch from default (English) to Spanish works without having to restart X, I cannot switch back to default without restarting X.

Dewdrop, see the link in my message above for a solution to toggle effortlessly between English & Spanish layouts using Xkb, by pressing Alt-Shift.

Paul
Back to top
View user's profile Send private message 
dewdrop


Joined: 29 Aug 2005
Posts: 298
Location: Texas USA

PostPosted: Mon 13 Feb 2006, 21:20    Post subject: keyboard switching  

Hi Paul,

Quote:

Dewdrop, see the link in my message above for a solution to toggle effortlessly between English & Spanish layouts using Xkb, by pressing Alt-Shift.

Paul


Thanks for the info about the link. I did as you suggested...see below....


Section "ServerLayout"
Identifier "X.org Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us,latam"
Option "XkbOptions"
"grp:alt_shift_toggle,grp_led:scroll,caps:shift,altwin:menu"
EndSection

I tried the latam after the es didnt work....but that didnt work either. In other distos, I can usually get the change to occur by just hitting the Alt key one time....and the keyboard switches back and forth...but that is after changing a key combination - kind of like in a Preferences area of the keyboard setup in those other distros.

However, all is not lost. Although Im not able to use the shift/alt or alt only combination, I have a partial solution by using the dotpup from MU. I have reduced the keyboard selections to what you see in the screenshot, and use that method since I dont have to switch back and forth very often. Usually, if Im doing some work, Ill switch to the keyboard I need and just leave it there until I finish.

Thanks again for the information.

dewdrop

I've edited this post to delete the photo I had attached. It is no longer needed and frees up some space on the server.

dewdrop

Last edited by dewdrop on Tue 14 Feb 2006, 18:04; edited 1 time in total
Back to top
View user's profile Send private message 
pakt


Joined: 04 Jun 2005
Posts: 1156
Location: Sweden

PostPosted: Tue 14 Feb 2006, 04:40    Post subject:  

Dewdrop, I just tested xorg.conf by changing the lines as follows:
Code:
Section "InputDevice"
   Identifier  "Keyboard0"
   Driver      "kbd"
   Option      "XkbRules"   "xorg"
   Option      "XkbModel"   "pc105"
   Option      "XkbLayout"  "us,es"
   Option      "XkbOptions" "grp:alt_shift_toggle,grp_led:scroll,caps:shift,altwin:menu"
EndSection

Worked as far as I can tell:

I am now using the US layout...
I press Alt + Shift, the LED comes on and I get the es (Spanish) layout:

You did install the xkb.tar.gz from the link right?

Don't forget to kill X (Ctrl-Alt-Backspace) after changing xorg.conf. Restart with xwin.

I almost forgot - rename or remove your .Xmodmap file as it overrides the xorg.conf settings...

Paul
Back to top
View user's profile Send private message 
dewdrop


Joined: 29 Aug 2005
Posts: 298
Location: Texas USA

PostPosted: Tue 14 Feb 2006, 12:36    Post subject: International Keyboard settings  

Quote:

Dewdrop, I just tested xorg.conf by changing the lines as follows:
Code:
Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us,es"
Option "XkbOptions" "grp:alt_shift_toggle,grp_led:scroll,caps:shift,altwin:menu"
EndSection

Worked as far as I can tell:

I am now using the US layout...
I press Alt + Shift, the LED comes on and I get the es (Spanish) layout:

You did install the xkb.tar.gz from the link right?

Don't forget to kill X (Ctrl-Alt-Backspace) after changing xorg.conf. Restart with xwin.

I almost forgot - rename or remove your .Xmodmap file as it overrides the xorg.conf settings...

Paul





Hi Paul,

I had accomplished everything you noted above, with the exception of not renaming the Xmodmap file.

Once I renamed that file....I left my "latam" entry rather than changing it to "es"...... the toggle light lights when the keyboard is in Spanish, and my Spanish (espaol) keyboard is up and working.

Thanks a bunch for the information and instructions on what to do to get a needed piece of equipment to function with ease.

Dewdrop
Back to top
View user's profile Send private message 
pakt


Joined: 04 Jun 2005
Posts: 1156
Location: Sweden

PostPosted: Tue 14 Feb 2006, 13:56    Post subject:  

Nice Cool
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 2 of 2 [26 Posts]   Goto page: Previous 1, 2
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Cutting edge
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0674s ][ Queries: 14 (0.0075s) ][ GZIP on ]