Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 23 Aug 2014, 03:43
All times are UTC - 4
 Forum index » House Training » Bugs ( Submit bugs )
Puppy 4.3 Beta2 -- bugs and reports
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 12 of 15 [219 Posts]   Goto page: Previous 1, 2, 3, ..., 10, 11, 12, 13, 14, 15 Next
Author Message
richwa4sxz

Joined: 17 Sep 2007
Posts: 7
Location: Fort Walton Beach, Florida

PostPosted: Wed 09 Sep 2009, 10:30    Post subject: alsaconf 1.0.16 fails
Subject description: no soundcards are detected by this script in 4.3b2
 

BarryK,

I've tried this from console and as part of the setup, on several various computers, and no sound card is ever detected by the script. The sound cards all have been detected at boot and are usable by running the alsamixer from the speaker icon or console. This seems to be something new since changing the alsa version to the newer one.

Have run this beta on a variety of older P3 & P4 computers and have not run into any other setup issues, using a manual frugal installation to HD.

Rich
Back to top
View user's profile Send private message 
panzerpuppy

Joined: 02 Oct 2007
Posts: 632

PostPosted: Wed 09 Sep 2009, 11:12    Post subject:  

@BarryK: Looks like happypuppy found a way to reproduce the JWM theme changing bug. See the post in the dev blog.

I always edit the .jwmrc-tray file first to remove unnecessary stuff.
For example, I don't need asapm (i don't use a laptop), xload (I don't need it) ,the pager (i don't use virtual desktops) and the show desktop icon ,so I edit .jwmrc-tray and remove the stuff.

Then when I use the GUI to change the theme, the taskbar disappears Sad

As happypuppy said in the blog post, this worked perfectly in Puppy 4.1.2.

Last edited by panzerpuppy on Wed 09 Sep 2009, 12:33; edited 1 time in total
Back to top
View user's profile Send private message 
edoc


Joined: 07 Aug 2005
Posts: 4365
Location: Southeast Georgia, USA

PostPosted: Wed 09 Sep 2009, 12:31    Post subject:  

Is the ath9k driver module for the newer "n" wifi devices included?

Also, for my Puppy-newbie friend - is there a driver for the Buffalo wli-u2-g300n?

Or does he have to do the ndiswrapper thing?

Last edited by edoc on Wed 09 Sep 2009, 12:48; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
panzerpuppy

Joined: 02 Oct 2007
Posts: 632

PostPosted: Wed 09 Sep 2009, 12:47    Post subject:  

More bugs:

- In PupX (set properties of X) , unchecking the 'enable screen saver' checkbox has no effect. The screensaver still kicks in after a while.

- Some apps behave strangely when locale is set to anything but en_US:
i.e. ExpenseTracker refuses to save expenses.

- Nathan Wallpaper Setter doesn't work (EDIT: fixed with the .PET patch)

P.S. 'Top' (the process viewer) looks much better / easier on the eyes with a white background.
It's a simple fix: just edit /usr/share/applications/Top-view-running-processes.desktop and change the bg color from #c0c0c0 to #ffffff


------------------
panzerpuppy

Last edited by panzerpuppy on Wed 09 Sep 2009, 14:58; edited 7 times in total
Back to top
View user's profile Send private message 
James C


Joined: 26 Mar 2009
Posts: 5710
Location: Kentucky

PostPosted: Wed 09 Sep 2009, 13:06    Post subject:  

The pet to fix the wallpaper setter is already posted earlier in this thread.
Back to top
View user's profile Send private message 
Kal

Joined: 05 May 2005
Posts: 624
Location: California, High Desert

PostPosted: Wed 09 Sep 2009, 14:13    Post subject:  

panzerpuppy:

Quote:
'Top' (the process viewer) looks much better / easier on the eyes with a white background.
It's a simple fix: just change the bg color from #c0c0c0 to #ffffff in .jwmrc


Any change to .jwmrc is NOT permanent, you need to edit the /usr/share/applications/Top-view-running-processes.desktop and then run fixmenus in terminal and Restart JWM.
Back to top
View user's profile Send private message 
straypup

Joined: 03 Feb 2008
Posts: 47

PostPosted: Wed 09 Sep 2009, 14:27    Post subject: Save  

Reburned live CD using both Puppy 4.2.1 and Windows9 (sorry). Windows burn failed to save but was good otherwise. Pburn saved, but had to retry several times befor it would load due to syncing glitch. Burniso2CDgave best results, but neither would save my wireless connection (the ever problematic rtl8187b. Otherwise , even SCIM is working. Thanks for a great easy to use OS
stray
Back to top
View user's profile Send private message 
edoc


Joined: 07 Aug 2005
Posts: 4365
Location: Southeast Georgia, USA

PostPosted: Wed 09 Sep 2009, 14:40    Post subject:  

He got the Buffalo wli-u2-g300n working via ndiswrapper and the MS-win drivers from the Buffalo site.

Would be better to have a Linux-native driver but please add the Buffalo to the list of ndiswrapper supported devices - if it is not already on that list.

_________________
Thanks! David
Home page: http://nevils-station.com
Don't google Search! http://duckduckgo.com
Puppy upup Raring 3992 & Lighthouse64-b602
Back to top
View user's profile Send private message Visit poster's website 
panzerpuppy

Joined: 02 Oct 2007
Posts: 632

PostPosted: Wed 09 Sep 2009, 14:45    Post subject:  

Another bug:

- Aqualung crashes with a segmentation fault (or doesn't start at all) if you uncheck the 'enable statusbar' option in the preferences for Music Store.
Back to top
View user's profile Send private message 
Kenny-M


Joined: 15 May 2009
Posts: 147
Location: United States

PostPosted: Wed 09 Sep 2009, 15:02    Post subject:  

4.3Beta2 (Sata)

Does not include ActiveX version 10 under SeaMonkey 1.1.7.

How to update? What version of Linux is Puppy based on?

Under Qemu when Puppy 4.3.2 is shutdown rather then closing task returning to originating batch file as it does under 4.2.1 it displays a message "shutdown" then the screen glows blank. Manually keying in Ctrl/Alt/F followed by closing open task windows returns you to where you should be.

4.3Beta2 SCSI

On SCSI machine audio chip cs4236 not handled correctly. ALSA
freezes at cs4326 and never returns.

On SCSI machine can not use Universal Installer. Says not supported.
Desired setup sda Windows XP, sdb1 Puppy, sdb2 Swap, sdb3 FAT32.
Grub on sda with boot menu for Puppy and Windows.
Note: Booting LIVE the SCSI devices are revealed.

-Ken

_________________
Puppy 4.2.1 SeaMonkey on 160GB Ext USB Disk on Dell 745 SFF.
Puppy 4.3.0-SCSI on Dell Precision 610 workstation.
Puppy 4.2.1 running on Windows XP under Qemu.
Back to top
View user's profile Send private message 
mawebb88

Joined: 13 Jul 2008
Posts: 245
Location: France nr Lyon

PostPosted: Wed 09 Sep 2009, 17:04    Post subject: PstreamTV Good  

Works great. But best with Mplayer installed.

Rgds Mike
Back to top
View user's profile Send private message 
mawebb88

Joined: 13 Jul 2008
Posts: 245
Location: France nr Lyon

PostPosted: Wed 09 Sep 2009, 17:41    Post subject: Mplayer installed for use with PstreamTV  

The JWM menu needs fixing for Mplayer as per:

http://www.murga-linux.com/puppy/viewtopic.php?t=26511

Otherwise everything freezes.

Rgds Mike

Sorry I know this is off topic but Mplayer is needed for PStreamTV which is part of this release.
Back to top
View user's profile Send private message 
rerwin


Joined: 24 Aug 2005
Posts: 1512
Location: Maine, USA

PostPosted: Wed 09 Sep 2009, 20:21    Post subject: pupscan shows all driver modules as "unknown"
Subject description: Impacted by removal of the modules.pci/usbmap files
 

Now that the modules.*map files are no longer maintained in /lib/modules/<kernel>/, pupscan no longer displays the modules associated with hardware devices. I have updated it to obtain its information from the modules.alias file and added use of the dialup-modem rules file (for devices not listed in modules.alias).

I also changed it to choose that last-found module instead of the first, to match how pup_event_backend_modprobe makes its choice.

At some point, I hope to refine it so that it accounts for "pci overrides" and "preferred modules" specified in the BootManager. But this is already a little more comprehensive than when it was last working.

UPDATE 9/10/09: Turns out using the modaliases is trickier than I anticipated. I have made further refinements to pupscan (as -2), but more can be done. I may continue refinement, but please (Barry) take whatever version is here at the deadline for the next beta. Thanks,
Richard
pupscan_using_modalias-2.pet
Description  The upgraded pupscan.
pet

 Download 
Filename  pupscan_using_modalias-2.pet 
Filesize  3.44 KB 
Downloaded  267 Time(s) 
pupscan_differences.tar.gz
Description  Difference listing
gz

 Download 
Filename  pupscan_differences.tar.gz 
Filesize  726 Bytes 
Downloaded  244 Time(s) 

Last edited by rerwin on Thu 10 Sep 2009, 18:09; edited 1 time in total
Back to top
View user's profile Send private message 
sfl7fl

Joined: 11 Jun 2009
Posts: 25
Location: tampa bay

PostPosted: Thu 10 Sep 2009, 07:52    Post subject:  sound card not identified
Subject description: no sound
 

puppy version 4.12 recognizes hda-intel 8086:27d8(rev 01)
4.3 b2 does recognize card, so no audio
Back to top
View user's profile Send private message Visit poster's website 
dawg

Joined: 09 Aug 2009
Posts: 113
Location: still here

PostPosted: Thu 10 Sep 2009, 08:33    Post subject:
Subject description: adding sfs packages
 

I apologise if anyone has already pointed this out (long thread), but:
adding SFS packages still messes up (at least) the desktop icons with defaults.


PS: I like the wallpaper, not so much the Marble icons - they all look "the same" and monotonous, they don't "balance" the wallpaper, IMO.
Back to top
View user's profile Send private message 
ICQ Number 
Display posts from previous:   Sort by:   
Page 12 of 15 [219 Posts]   Goto page: Previous 1, 2, 3, ..., 10, 11, 12, 13, 14, 15 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Bugs ( Submit bugs )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.7199s ][ Queries: 12 (0.0152s) ][ GZIP on ]