Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 18 Dec 2014, 06:43
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Video
xserver 1.6.3 upgrade:vesa,ati-6.12.4,intel-2.8.1,mesa-7.5.1
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 2 of 3 Posts_count   Goto page: Previous 1, 2, 3 Next
Author Message
jemimah


Joined: 26 Aug 2009
Posts: 4309
Location: Tampa, FL

PostPosted: Tue 08 Sep 2009, 16:16    Post_subject:  

Thanks a bunch! This allows kernel modesetting to work properly. The native 1024x600 console looks sweet and no more flicker when starting Xorg. All it needs now is the synaptics module!
Back to top
View user's profile Send_private_message Visit_website 
MU


Joined: 24 Aug 2005
Posts: 13644
Location: Karlsruhe, Germany

PostPosted: Tue 08 Sep 2009, 16:55    Post_subject:  

I can confirm the problem with the black background for icons in the JWM menu.
Icewm in Newyearspup looks unasable,; it was compiled with some different options than other icewm around in the forum.
Might be interesting to test, if the icewm from Puppy 4.21 looks correct.

In newyearspup, openbox (LXDE) and xfce display correctly.
So if someone finds out, that this driver is the only one giving correct screen-resolutions, he might search the forum for pets of those windowmanagers, to get a good look.

With the HD4850, the driver is very fast.
Even with xcompmgr (shadows for the windows), windows can be resized very fast. The propriatary catalyst drivers are much slower here.

But this is valid just for my own card, the reports in this thread show, that many other cards may work even worse than with Puppys default drivers.

So we can give no general recommendation to use these new drivers, you must test it on your own.

Concerning Radeonhd:
I had compiled that one, too, but just get a black screen with it, so stopped my experiments with it.

Thanks for all the reports you give us here, they may help others to find out, if this pet might solve their problems, or if it is wasted time for their cards!


Sidenote:
I made a pet of the Catalyst 9.10beta driver mentioned by Panzerpuppy.
It is based on the Ubuntu download, that has only the files for Xorg 7.4.
So this pet currently only works in Ultrapup/Newyearspup (and I think Lighthouse pup that used xorg 7.4, too), but no other puplet.
More info:
http://www.murga-linux.com/puppy/viewtopic.php?p=339440#339440


Mark

_________________
my recommended links
Back to top
View user's profile Send_private_message Visit_website 
zygo

Joined: 08 Apr 2006
Posts: 211
Location: UK

PostPosted: Thu 10 Sep 2009, 07:39    Post_subject: Thanks, thanks and thanks  

Very Happy Very Happy Very Happy
Mu, For the first time my Intel 82946 GZ/GL card and Acer 1440x900 LCD have delivered a perfect picture with Linux (Puppy 4.3b2).

Thanks
Very Happy Very Happy Very Happy
Back to top
View user's profile Send_private_message 
panzerpuppy

Joined: 02 Oct 2007
Posts: 632

PostPosted: Thu 10 Sep 2009, 15:09    Post_subject:  

@MU: Great news:

Quote:
A new major bug-fix release of the xf86-video-ati driver is now available.
The xf86-video-ati 6.12.3 driver brings important bug-fixes ranging from AGP quirks to adding missing PCI IDs to other fixes.

The xf86-video-ati 6.12.3 driver release announcement can be read on the X.Org mailing list.


Now this is what's needed to finally make AGP Radeon HD cards (like that 2600 Pro AGP) work Smile
It should also fix the problems with R200 cards.

MU, could you make an updated Xorg package for 4.3 beta 2 with this driver? Please Wink
Back to top
View user's profile Send_private_message 
MU


Joined: 24 Aug 2005
Posts: 13644
Location: Karlsruhe, Germany

PostPosted: Sat 12 Sep 2009, 12:53    Post_subject:  

added
xorg-1.6.3-upgrade-vesa-ati-6.12.4-intel-2.8.1-mesa-7.5.1-01.pet

So now the pet uses ati-6.12.4 instead of 6.12.2.
(download see first message)

If you had the old one already, simply install this new one over the old one.
Do NOT uninstall the old one.


Mark

_________________
my recommended links
Back to top
View user's profile Send_private_message Visit_website 
MU


Joined: 24 Aug 2005
Posts: 13644
Location: Karlsruhe, Germany

PostPosted: Sat 12 Sep 2009, 14:10    Post_subject:  

I attach the radeonhd driver.
It will need the updated xserver from the first message.
On my system (hd 4850) I just get a black screen.

Maybe panzerpuppy has more luck.

To activate it, I edited my
/etc/X11/xorg.conf
and
/etc/X11/xorg.conf.ATI_ATOMBIOSV223W

The name of the second conf varies on each system.

I simply replaced
driver "radeon"
with:
driver "radeonhd"

You can do it in console like this:
mp /etc/X11/xorg.conf

I can see, that debian packages also have a /usr/share/xserver-xorg/pci/radeonhd.ids
http://packages.debian.org/lenny/xserver-xorg-video-radeonhd

I don't know, where this file comes from, or where it had to be placed in Puppy.
Literature for the driver can be found here:
http://www.radeonhd.org/

Mark
xf86-video-radeonhd-1.2.5-i486.pet
Description 
pet

 Download 
Filename  xf86-video-radeonhd-1.2.5-i486.pet 
Filesize  192.51 KB 
Downloaded  697 Time(s) 

_________________
my recommended links
Back to top
View user's profile Send_private_message Visit_website 
panzerpuppy

Joined: 02 Oct 2007
Posts: 632

PostPosted: Sat 12 Sep 2009, 19:07    Post_subject:  

MU,there's a big problem with your xserver-ati .PET package: the radeon R600 DRI kernel module (r600_dri.so) is missing!

(EE) AIGLX error: dlopen of /usr/X11R7/lib/dri/r600_dri.so failed (/usr/X11R7/lib/dri/r600_dri.so: cannot open shared object file: No such file or directory)
(EE) AIGLX: reverting to software rendering

That's why I don't get any DRI acceleration with this card.
Back to top
View user's profile Send_private_message 
MU


Joined: 24 Aug 2005
Posts: 13644
Location: Karlsruhe, Germany

PostPosted: Sat 12 Sep 2009, 19:43    Post_subject:  

Panzerpuppy, you get this with the radeonhd driver?
I found this via google:

Quote:
Quote:
(EE) AIGLX error: dlopen of /usr/lib/dri/r600_dri.so failed (/usr/lib/dri/r600_dri.so: cannot open shared object file: No such file or directory)
(EE) AIGLX: reverting to software rendering
(II) AIGLX: Loaded and initialized /usr/lib/dri/swrast_dri.so


You can ignore that. There is no 3D driver yet for r6xx/r7xx.


http://www.phoronix.com/forums/showthread.php?t=15227&page=8

The xxx_dri.so drivers are part of Mesa, and Mesa has no such driver r600_dri.so.
Here is an extract from my config.log:
Code:
DRIVER_DIRS='dri'
DRI_DIRS='i810 i915 i965 mach64 mga r128 r200 r300 radeon s3v savage sis tdfx trident unichrome ffb swrast'
DRI_DRIVER_INSTALL_DIR='${libdir}/dri'


Mark

_________________
my recommended links
Back to top
View user's profile Send_private_message Visit_website 
bitzer


Joined: 03 Aug 2009
Posts: 3

PostPosted: Tue 29 Sep 2009, 04:06    Post_subject:  

Hi MU

Sorry to come to this thread late but only just stumbled across it while trying to find a way of running Google Earth. I have an Acer Extensa 5220 laptop with the Intel GL960/X3100 chipset which seems to cause everyone problems; even the ‘buntu boyz are struggling, which is embarrassing for them as Dell laptops with this chipset are shipped with Ubuntu! Heh, heh!

Well it runs slow (24 fps in Antinspect) and obviously only 2D but it’s usable and for the first time I can actually run GE in 4.1.2 from USB install.

Tried twice with 4.3 Final but screen and cursor are locked on reboot?

Many thanks for this great work; I look forward to the next driver release.

Bitzer
Back to top
View user's profile Send_private_message 
charlie6


Joined: 30 Jun 2008
Posts: 1030
Location: South of Belgium

PostPosted: Tue 13 Oct 2009, 14:36    Post_subject:
Sub_title: xorg-1.6.3-upgrade-vesa-intel-2.8.1-mesa-7.5.1-02.pet o, pup4.31candidate
 

Hi,
thanks MU! for this pet !
tested xorg-1.6.3-upgrade-vesa-intel-2.8.1-mesa-7.5.1-02.pet
on puppy4.3.1 candidate (with k2.6.30.5) candidate frugal:
it gave this

1. on HP PIV 2.8GHz + nvidia 6200SE:
Code:
# glxinfo
name of display: :0.0
display: :0  screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
    GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,
    GLX_EXT_import_context, GLX_EXT_texture_from_pixmap, GLX_OML_swap_method,
    GLX_SGI_make_current_read, GLX_SGIS_multisample, GLX_SGIX_hyperpipe,
    GLX_SGIX_swap_barrier, GLX_SGIX_fbconfig, GLX_MESA_copy_sub_buffer
client glx vendor string: SGI
client glx version string: 1.4
client glx extensions:
    GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_allocate_memory,
    GLX_MESA_copy_sub_buffer, GLX_MESA_swap_control,
    GLX_MESA_swap_frame_usage, GLX_OML_swap_method, GLX_OML_sync_control,
    GLX_SGI_make_current_read, GLX_SGI_swap_control, GLX_SGI_video_sync,
    GLX_SGIS_multisample, GLX_SGIX_fbconfig, GLX_SGIX_pbuffer,
    GLX_SGIX_visual_select_group, GLX_EXT_texture_from_pixmap
GLX version: 1.2
GLX extensions:
    GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_OML_swap_method,
    GLX_SGIS_multisample, GLX_SGIX_fbconfig
OpenGL vendor string: Mesa Project
OpenGL renderer string: Software Rasterizer
OpenGL version string: 2.1 Mesa 7.5.1
OpenGL shading language version string: 1.20
OpenGL extensions:

no acceleration then - I do not know what to do yet
I tried gray's nvidia driver which gives OpenGL working + 3D acceleration.

2. on PIV 2.6GHz FujiSiemens (scenic) + intel onboard graphic 845G chip (which support 3D acceleration according to 845G intel data sheet): on a fresh pupsave (thanks for your advices...!)
nothing with Xorg after restarting X! black screen ! I had to restart X on Vesa.
I wonder if I have missed something as that chip is rather common?

I did not try to install the other pets as they are already included in the tested pet.

3. question: is the module for intel 845G already in pup4.3.1 k2.6.30.5?

Thanks for your advices
cheers, charlie
Back to top
View user's profile Send_private_message 
MU


Joined: 24 Aug 2005
Posts: 13644
Location: Karlsruhe, Germany

PostPosted: Tue 13 Oct 2009, 18:33    Post_subject:  

nvidia cards will not work with this pet (just in vesamode maybe), so there is no reason to install this pet.
For nvidia use:
http://www.murga-linux.com/puppy/viewtopic.php?t=46686
But it will not work, if you already installed my xserver 1.6.3.
In that case, you had to start with a new savefile, as my pet (incompatible) overwrote the older xserver that is compatible with the Nvidia-pets.

Intel:

I just had the chance to test a Intel 855gm.
In newyearspup, the pet activated DRI (video-accelleration using xv), but not 3D accelleration.
The log told me, that kernel 2.6.29 or newer is needed (NYP has 2.6.28.5).
So next I tried Puppy 4.3.0, and voila - success.
See attached screenshot.


If the Intel 845 will not work, we would need to look at the log.
If X will not start, and you are dropped back to the prompt (maybe after hitting CTRL-ALT-Backspace), then type:
cp -ax /usr/X11R7/var/log/Xorg.0.log /root/
gzip /root/Xorg.0.log


Then run xorgwizard again to start X, and attach here the file /root/Xorg.0.log.gz.

I often (not always) encountered problems with the intel 855gm, when TWO chips are on the mainboard. This is the case with many notebooks with extra VGA connector.

X refused to start completely without the new pet.


This could be solved by typing:
mp /etc/X11/xorg.conf

Then scroll down and look, if you have such a line:
Code:
   Screen      1  "Screen1" RightOf "Screen0"

Comment it like this:
Code:
#   Screen      1  "Screen1" RightOf "Screen0"


In some cases, this solves it.


general (black icon backgrounds)
Also with the intel chip, the background of the icon in the JWM menu is black.
So I think an extension is missing. The log shows, that some old extensions had to be recompiled to work with the new xserver. I might look at this next week, back at home.
I also will compile the synaptics module, sorry Jemimah, just had forgotten about it Embarassed

Mark
puppy43intel855gm.jpg
Description 
jpg

 Download 
Filename  puppy43intel855gm.jpg 
Filesize  139.55 KB 
Downloaded  719 Time(s) 

_________________
my recommended links
Back to top
View user's profile Send_private_message Visit_website 
MU


Joined: 24 Aug 2005
Posts: 13644
Location: Karlsruhe, Germany

PostPosted: Mon 19 Oct 2009, 18:04    Post_subject:  

I added a pet for synaptics touchpets to the download folder.
#Mark

_________________
my recommended links
Back to top
View user's profile Send_private_message Visit_website 
Q5sys


Joined: 11 Dec 2008
Posts: 1074

PostPosted: Fri 11 Dec 2009, 19:50    Post_subject:  

Took the plunge and tested on an Intel system.

As a base I'm using Gray's BoxPup (4.12).
Graphics in my laptop is the Intel GM965. Screen res = 1280x800

So xorg has always worked for me, it was whatever came with the pupplet, I never messed with upgrading xorg before this.
After installing xorg would goes to a dead black screen. Crtl-Alt-Backspace would do nothing. Xvesa still works fine.
Since you mentioned that an uninstall would be impossible, I went into the package manager and tried to install the full 7.3 xorg package, hoping maybe that would overwrite the files from your .pet.
That didnt fix anything. lol
If I go into the xorg wizard, and go to test, the entire screen will go black and Ctrl-Alt-Backspace fails to do anything, as does Crtl-Alt-Delete, Crtl-X, Ctrl-C, and any other possible escape combo that happened to be running through my head at the time.

I followed the steps you listed for the Intel 845, and will attach the log here, however since the system locks up as soon as I test Xorg and I am forced to reboot, I assume nothing it able to be written to the log. But i'll attach it here in case something is.

If there is anything you'd like me to do, let me know. I noticed that a few days ago you have uploaded:
xorg-1.6.3-upgrade-vesa-ati-6.12.4-intel-2.8.1-mesa-7.5.1-01.pet
I have installed xorg-1.6.3-upgrade-vesa-intel-2.8.1-mesa-7.5.1-02.pet
Is there a reason you downgraded mesa? I didnt grab that package because I dont have an ATI card, If you'd like me to try that newer package on my intel system i'd be happy to test it for you *since it appears the intel stuff is still included).

EDIT:
Im thinking I may be hung up by my kernel. So I'm going to try to figure out how to update it and then see if everything works dandy. Wasnt sure if the kernel update is required for all Intel Cards or just the one tested above. But If I can figure out how to upgrade my kernel then I guess i'll find out.
xorg.conf.gz
Description 
gz

 Download 
Filename  xorg.conf.gz 
Filesize  1.86 KB 
Downloaded  639 Time(s) 
Xorg.0.log.gz
Description 
gz

 Download 
Filename  Xorg.0.log.gz 
Filesize  2.6 KB 
Downloaded  635 Time(s) 
Back to top
View user's profile Send_private_message Visit_website 
battleshooter


Joined: 14 May 2008
Posts: 1161
Location: Australia

PostPosted: Tue 26 Jan 2010, 19:22    Post_subject:  

Very interesting work Mark. Gives me 3D acceleration and perfect resolution in LighthousePup (4.3.1) on my Intel GL40 so thank you! 3D acceleration seems to be something that very often eludes but you've helped in the past with those problems too Smile

Like everyone else, I've also had the problem with the black boxes in the menu using JWM. The black boxes don't show up in Icewm though.

Actually I seem to have a problem others haven't had, after I install this pet, Wine doesn't work anymore. I tried numerous different wine packages but they all fail on attempting to run a OpenGL function. I thought it might be Wine has a problem because it was compiled with a different XOrg. So, I compiled Wine myself but Wine still wouldn't run OpenGL stuff.

Not very a descriptive bug report, but I thought I'd just throw it out and see who would reply.

Battleshooter

_________________
LMMS 1.0.2, Ardour 3.5.389, Kdenlive 0.9.8
Back to top
View user's profile Send_private_message 
Barkingmad

Joined: 21 Nov 2008
Posts: 121

PostPosted: Mon 22 Feb 2010, 13:13    Post_subject: Works with X1600  

Just for information.

I've just tried Mark's Pet with my X1600 card (I think this is an R5xx chipset) in Puppy Stardust (2.6.30.5 kernel) and it gives 2 and 3D acceleration. MPlayer works with "Xv" output and full screen and "glxgears" gives over 2700fps.

I have the icon problem others have reported but I can live with that as I've "been all round the houses" trying to get this card to work fully with this Puppy and this is the only driver I have found that does it.

Thanks again Mark
Will
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 2 of 3 Posts_count   Goto page: Previous 1, 2, 3 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Hardware » Video
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1101s ][ Queries: 12 (0.0059s) ][ GZIP on ]