Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 23 Nov 2014, 21:34
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
Dev-Pup (Released v1.0)
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 2 of 3 [43 Posts]   Goto page: Previous 1, 2, 3 Next
Author Message
alseycolemanmiller


Joined: 25 Aug 2009
Posts: 21
Location: PERU, Lima *Gringo living in Southmerica

PostPosted: Sat 29 Aug 2009, 02:17    Post subject: Re: Trying to BUT!  

Nekroze wrote:
......oh and whats the main difference between BOCHS and QEMU? you see i have already got a perfect working QEMU for Dev-Pup1.0 that can run any OS that is in root as a .iso and it just runs it.

if i am off by much thats ok ill pack both......

.....Thanks again mate,
Nekroze


Gonna test Qemu today but i´m sure BOCHS is having lots of problems right now for Puppy Linux. So stick with Qemu.

here a link to a tread about BOCHS emulator (currently sucks!):

http://www.murga-linux.com/puppy/viewtopic.php?t=42967

Tell me if you want me to upload thoso ICOs (and CUR) files with a nice XP logo, hehe! or else gonna lookup the Wine favicon or 48*48 icon and post that (or U can shut me up say thats lame tooo, haha!) for windows application user-friendly compatibility ROX MIME-type icon set.

_________________
Coleman,




Back to top
View user's profile Send private message MSN Messenger 
Nekroze


Joined: 22 Aug 2009
Posts: 56

PostPosted: Sat 29 Aug 2009, 02:57    Post subject:  

That would be nice however Dev-Pup is to be using xfce that dose not use roxfiler it uses thunar so would that still work...

although i am kind of unsure of what u mean exactly are you saying that you can assist in getting the actual exe files icons to work in rox (hopefully with thunar)

That would be very nice but i would query the size cost of doing such a thing.

also i was thinking about making a fat version with practically everything i can find to accommodate every angle adequately.

Nekroze
Back to top
View user's profile Send private message 
Nekroze


Joined: 22 Aug 2009
Posts: 56

PostPosted: Sat 29 Aug 2009, 10:42    Post subject:  Delays  

i am Currently working through the final bits of Dev-Pup 1.0 however am long behind schedule.

it should be completed by tomorrow. I have been having a few problems with the dotpups im not sure if its cause they are older or what but it seems that mingw after a few attempts would not open after installing however i will continue to work at it (its prolly something simple) and other little tidbits and i am yet to remaster the XFCE menu... it should be done by 24hrs from now. at the moment it is 12:40 here is australia midnight.

although it seems that the delays i mentioned are trivial and not enough to delay by a whole day yet remember i do still have a life and a signifigant other that needs atleast a quater as much time spent with as i do on my PC working on this and other puppy/linux related bits.

thank you all for supporting this project really! and sorry for the delays to expected timing...
Nekroze
Back to top
View user's profile Send private message 
Nekroze


Joined: 22 Aug 2009
Posts: 56

PostPosted: Sun 30 Aug 2009, 05:15    Post subject: GRRRRR!!!!!  

ok the main updates i wanted for Dev-Pup 1.0 was the mingwstudio and gtkbasic however i cannot use them as they will not open no matter what i do after installation. unless i can manage to get a newer version or a good a3ternate to these Dev-Pup 1.0 will not release.

i am very sorry to say such a thing but i will do my best to get the stuff up and running we all want so don't forget to keep updating me on things you think or want or think or anything.

i will still try to keep the release within the new week however i cannot rush it at this point or truly say what day it should be expected, i need some more feedback on the previous version of problems and such and more new software as the new additions are few for 1.0 at this point.

In mourning of a lost release date,
Nekroze
Back to top
View user's profile Send private message 
alseycolemanmiller


Joined: 25 Aug 2009
Posts: 21
Location: PERU, Lima *Gringo living in Southmerica

PostPosted: Sun 30 Aug 2009, 08:14    Post subject:  Wine ease  

Nekroze wrote:
That would be nice however Dev-Pup is to be using xfce that dose not use roxfiler it uses thunar so would that still work...

although i am kind of unsure of what u mean exactly are you saying that you can assist in getting the actual exe files icons to work in rox (hopefully with thunar)

That would be very nice but i would query the size cost of doing such a thing.

also i was thinking about making a fat version with practically everything i can find to accommodate every angle adequately.

Nekroze


I want to assist en the Wine MIME-type, guess I'll have to learn to use thunar now and put it in a PET for you. The Dos-x apps (according to ROX all with .dll, .sys and .exe) should be configurated so its easy to just click on it and it opens with Wine and it has a Windows logo. I also could put a shortcut of winefile with its logo on the taskbar or enhance the Menu. User-friendly. XCE menu is sorta like OpenBox so mostly have to change it manually but its easier. so could locate the Menu.lst (or whatever the configuration file is) and create a folder with all the neccesary icons in root and export it en a PET package. Guess it won´t be in 1.0. No Problem.

PS. A question. Do you recommend me to upgrade my existing Dev-pup 0.9 beta installation (full installation!) or wipe the partition (this is a experimental PC so I do it anyway.) to install your dev-pup 1.0? Wanted to know.

_________________
Coleman,




Back to top
View user's profile Send private message MSN Messenger 
alseycolemanmiller


Joined: 25 Aug 2009
Posts: 21
Location: PERU, Lima *Gringo living in Southmerica

PostPosted: Sun 30 Aug 2009, 08:53    Post subject: Re: GRRRRR!!!!!  

Nekroze wrote:
ok the main updates i wanted for Dev-Pup 1.0 was the mingwstudio and gtkbasic however i cannot use them as they will not open no matter what i do after installation. unless i can manage to get a newer version or a good a3ternate to these Dev-Pup 1.0 will not release...
Nekroze


Glad ya didn't release it yet. MinGWstudio is a PUP file and I installed it on Dev-pup 0.9 beta nad worked fine. Gonna give ya my version.

Also... firefox could replace seamonkey and please fix vlc or put Gxine and VLC. VLC player doesn´t work for me (hope its already fixed in dev-pup 1.0).
gootta go. post alter tody!
MinGWStudio.pup
Description 
pup

 Download 
Filename  MinGWStudio.pup 
Filesize  1.5 MB 
Downloaded  254 Time(s) 

_________________
Coleman,




Back to top
View user's profile Send private message MSN Messenger 
Nekroze


Joined: 22 Aug 2009
Posts: 56

PostPosted: Sun 30 Aug 2009, 09:37    Post subject: semper fi!  

Last thoughts before i pass out for the night.

i think i may scrap xfce if it becomes to much of a problem, will also scrap vlc for gxine but maybe both... will see how sizing goes if i scrap xfce and if i do i may just stick with icewm or jwm the main reluctance to use jwm as the main wm to be packaged over icewm(atleast original thoughts before xfce) was because jwm lack alot of style and although it was basic it felt to basic where as the nicer slick of icewm and the size mad it a nice alternative so the more i think of it i may just as well stick with icewm but perhaps do a slightly more custom theme for Dev-Pup.

also as much as i LOVE Firefox the reason i choose to leave it out of Dev-Pup in favor of SeaMonkey is because SeaMonkey is a full suite of mail, html editor and another i forgot ontop of a browser with most all the major Firefox must have add-ons.

its more that it contains more in one package that i keep with it and it seems the same for the general full puppy over the last while now and i suspect the reasoning is the same.

thanks for the pup aswell mate,
Nekroze
Back to top
View user's profile Send private message 
muggins

Joined: 20 Jan 2006
Posts: 6690
Location: lisbon

PostPosted: Sun 30 Aug 2009, 18:55    Post subject:  

Nekrose,

MinGWStudio probably isn't working for you due to missing gtk1 libraries. Whenever any binary doesn't work, the first thing to check is that all it's library dependencies are met, with ldd:

Code:
ldd /usr/local/MinGWStudio/MinGWStudio


If you are missing gtk1 libs, then you would probably need:

glib12-1.2.10.pet (53k)
gtk+12-1.2.10.pet (522k)
gdk_pixbuf10-0.22.0.pet (121k)
Back to top
View user's profile Send private message 
alseycolemanmiller


Joined: 25 Aug 2009
Posts: 21
Location: PERU, Lima *Gringo living in Southmerica

PostPosted: Sun 30 Aug 2009, 22:50    Post subject:  

Are there anymore bugs? if so please make a list of them so me and other people might help.
_________________
Coleman,




Back to top
View user's profile Send private message MSN Messenger 
Nekroze


Joined: 22 Aug 2009
Posts: 56

PostPosted: Mon 31 Aug 2009, 01:19    Post subject: Bugs...  

Thanks for that will test them soon, much appreciated.

bugs other then the pwidgets thing which is just annoying and has brought me to just remove it in coming versions, apart from that the only other major thing i know of at all at this point is first-

alsey mentioned problems with vlc i have know clue why but am very willing o put that under older hardware as the cause.

apart from that with the current version i was having problems with the next release with xfce in that after using it and remastering it was no longer the WM that it opened in boot and that i could not get the themes or menus to save to the new remastered copy.

Thanks i will add them to the issues list on the second post(atleast the ones to do with the current released version.

Nekroze
Back to top
View user's profile Send private message 
Nekroze


Joined: 22 Aug 2009
Posts: 56

PostPosted: Mon 31 Aug 2009, 06:43    Post subject: more programs?  

Seriously at this point the only major software changes to Dev-Pup 1.0 release will be QEMU and minGWstudio really.... as this is the case i can probably get the new Dev-Pup up and out to you all in a few hours but with such a small amount of actual real additions i don't feel comfortable doing so please anyone with other software that they have found useful for creating software please tell me.

but i think i will begin to just make Dev-Pup 1.0 now with those additions i hope that this will be ok thank you all.
Nekroze
Back to top
View user's profile Send private message 
Nekroze


Joined: 22 Aug 2009
Posts: 56

PostPosted: Mon 31 Aug 2009, 08:19    Post subject: Release  

OK ALL!

Dev-Pup1.0-Devx412.iso is uploading at the moment although slow as hell it says it will be done between 3 and 7 hours from now so its night time here ill leave it overnight then alter the OP in the morning for the new version

Grats all it is not a large amount of change from the Beta but is dose bring it out of a concept and beta kind of stage.

Nekroze
Back to top
View user's profile Send private message 
alseycolemanmiller


Joined: 25 Aug 2009
Posts: 21
Location: PERU, Lima *Gringo living in Southmerica

PostPosted: Mon 31 Aug 2009, 12:55    Post subject:  NICE!!!  

cool, so here in South America it's 11:48 AM so i´ll wait for tomorrow.
About VLC does it work for you??? i don´t think its because of my hardware... it must be missing libraries if it doesn´t work on any PC.

PS. need more people to try this out so its not just U and me.
Plus I homeschool so we need somebody else active here too besides us too test this.

Not worried if nobody wants to contribute to free software but I sure am.

(PLEASE MAKE A FULL CHANGELOG AND A FULL BUGLIST!!!)
Idea

_________________
Coleman,




Back to top
View user's profile Send private message MSN Messenger 
Tui

Joined: 27 Sep 2006
Posts: 380
Location: Wellington New Zealand

PostPosted: Mon 31 Aug 2009, 21:52    Post subject: Blender
Subject description: not working!
 

Hi all, I have d/l this latest version and can't get it to run,
worked ok in version 0.9 - so what has been missed ?

Also can't get the Qemu to work !

Iam still testing other parts of this version
Back to top
View user's profile Send private message 
Nekroze


Joined: 22 Aug 2009
Posts: 56

PostPosted: Mon 31 Aug 2009, 22:06    Post subject:  

what do you mean by cant get it to run...

if you mean you cannot get it to boot i don't see why not it boots on mine fine try puppy pfix=ram just to test that....

but you say you cannot get qemu to work but that indicates you got it to boot. with qemu in Dev-Pup you place any iso of a bootable disc into /root/ and run qemu.

you may have to run in xvesa just to get it to work though as even on my main rig i needed to do that when runing any puppy under qemu.

if you are not running puppy under it you may have to change the launch script as it comes stock at using 256mb's of ram you may need to fiddle with that you can find out where that file is by the icon on the desktop go to its location and edit the launch script as text file.

i need some more details on what you say is and is not working.

thank you for testing it aswell though,
Nekroze
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 2 of 3 [43 Posts]   Goto page: Previous 1, 2, 3 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0894s ][ Queries: 12 (0.0050s) ][ GZIP on ]