Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 25 Oct 2014, 19:59
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
Problems updating firefox
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
Josef K

Joined: 13 Oct 2007
Posts: 16

PostPosted: Fri 14 Aug 2009, 20:01    Post_subject:  Problems updating firefox  

I just updated to firefox 3.5.2 and now firefox won't run in Puppy. Running it in the terminal returns this:

/usr/lib/firefox/firefox-bin: error while loading shared libraries: libdbus-glib-1.so.2: cannot open shared object file: No such file or directory

Any suggestions?
Back to top
View user's profile Send_private_message 
disciple

Joined: 20 May 2006
Posts: 6449
Location: Auckland, New Zealand

PostPosted: Fri 14 Aug 2009, 22:20    Post_subject:  

Puppy doesn't include dbus and dbus-glib but there are various packages around, so have a look.
It is rather annoying that the Firefox people have decided it is now a necessity - Firefox worked fine before without it.

_________________
DEATH TO SPREADSHEETS
- - -
Classic Puppy quotes
- - -
Beware the demented serfers!
Back to top
View user's profile Send_private_message 
tlchost

Joined: 05 Aug 2007
Posts: 1727
Location: Baltimore, Maryland USA

PostPosted: Fri 14 Aug 2009, 23:24    Post_subject:  

disciple wrote:
Puppy doesn't include dbus and dbus-glib but there are various packages around, so have a look.
It is rather annoying that the Firefox people have decided it is now a necessity - Firefox worked fine before without it.


Golly, it works fine here with 4.2.1Retro right out of the box.
Back to top
View user's profile Send_private_message Visit_website 
Josef K

Joined: 13 Oct 2007
Posts: 16

PostPosted: Fri 14 Aug 2009, 23:40    Post_subject:  

Thanks disciple. If anyone else is having a similar problem I was able to get the dotpets from technosaurus's post at http://www.murga-linux.com/puppy/viewtopic.php?p=244781 and it works fine now.
Back to top
View user's profile Send_private_message 
disciple

Joined: 20 May 2006
Posts: 6449
Location: Auckland, New Zealand

PostPosted: Sat 15 Aug 2009, 00:14    Post_subject:  

Quote:
Golly, it works fine here with 4.2.1Retro right out of the box.

Did you install it from a .pet? Maybe it was compiled without dbus for puppy.
4.2.1 doesn't have dbus does it? Maybe you have installed it for something else...

_________________
DEATH TO SPREADSHEETS
- - -
Classic Puppy quotes
- - -
Beware the demented serfers!
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0446s ][ Queries: 11 (0.0039s) ][ GZIP on ]